Stop on singularities

Hey community,

It seems singularities can be display in the output terminal by marking this 2 settings:
Program > Limits
:white_check_mark: Singularity
:white_check_mark: Message panel output

Additionnaly do you have any trick to stop the simulation when a singularity occurs ?

Thank you in advance.

.NET API has this event that should include singularities if those tests are enabled.


If you have also “Stop at Limits” checked then the simulation should stop also when singularity occurs.


1 Like

works! thank you @keke
(cool avatar btw)

1 Like