Blender Addon

THIS IS AN OLD VERSION OF THE ADDON. PLEASE FIND THE NEW VERSION BEHIND THE FOLLOWING LINK:

https://forum.visualcomponents.com/forums/topic/blender-2-80-addon/

 

This addon allows rendering higher quality images and animations. It’s done by converting the simulation scene into a blender scene and then rendering the scene. The Addon utilizes the Cycles ray tracing render engine inside the Blender. Rendering can be done as a backround task, which will output the result automatically into a image file or the scene can be opened in the Blender for further tweaking. Animations can be rendered to a sequence of images.

To use the addon the Blenderer Visual Components plugin needs to be added to the My Commands folder (restart VC) and the Blender 2.79 needs to be installed.

Download the Blender here:
https://www.blender.org/download/

Download the VC plugin from the link provided below (see Attachments): “Blenderer_2018_07_25.zip”

The plugin assumes that the Blender software is installed to a specific path. The path must be:

“C:\Program Files\Blender Foundation\Blender\blender.exe”

If you want to use another installation path, edit the blender_exe_uri variable in the Blenderer.py script on line #13. The file can be found in the Blender plugin after extracting the zip into the My Commands folder.

 

Edit 2018_07_25: bug fix related to texture coordinates; added enabling gpu rendering video

BlenderAddonDocumentation.pdf (194 KB)

Blenderer_2018_06_01.zip (8.07 MB)

3_MaterialsMistFocus.mp4 (12.2 MB)

1_SimpleWorkFlowDemo.mp4 (16.3 MB)

2_RenderingAnimation.mp4 (13 MB)

BlenderAddonExplained.pdf (1.99 MB)

Blenderer_2018_06_11.zip (5.63 MB)

Blenderer_2018_07_09.zip (5.78 MB)

Blenderer_2018_07_25.zip (5.78 MB)

4_Enabling_GPU_rendering.mp4 (1.49 MB)

Woks also with Blender 2.79b

Nice job Eme!

Hi,

Nice work!

I think this will only work with a VC premium license.
I tried it in VC 4.1 Professional and it throws me the error:

for vec in gs.getPointNormals([i for i in range(gs.PointCount)]):
TypeError: ‘NoneType’ object is not iterable

I’ve added a line of code the following line of code to the script:

print gs.getPointNormals(1)

Then I receive the error:

print gs.getPointNormals(1)
RuntimeError: No license for 3D Topology

Is it possible to use this add-on with VC professional as well?

Cheers!

Hi JobW,

Ugh, you are correct, the plugin is using some features of VC Premium. Probably there would be a way to make it VC Professional & Essentials compatible, at the cost of some speed :cry:

 

Hi All,

The vertex normals were not actually fully utilized. So I removed that code completely. It was there - I guess - by accident. Should have tested this more with different versions.

The latest Blenderer_2018_06_11.zip won’t call getPointNormals and that way should work with lower level products. I’ll test it.

Hi,

I’ve just tested it and it works fine in VC pro now!

Thanks, this add-ons is awesome:-) good work!

 

Regards,

 

Hi There

I get a error message with Pro Version :


File “\<my_network_path>\Documents\Visual Components\4.1\My Commands\Blenderer_2018_06_01\export_from_vc.py”, line 72, in export_obj

for vec in gs.getPointNormals([i for i in range(gs.PointCount)]):

TypeError: ‘NoneType’ object is not iterable


Please “eme” could you show me which part of the code i will have to remove in order to make it run properly?

Thanks

Hey eme!

Great AddOn! Works fine for me with 4.1

But we sometimes get this error:

UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xfc in position 25: ordinal not in range(128)

when using 4.0 and trying to use a custom background image which works fine in 4.1.

Any ideas what could be the problem here?

Best regards!

 

EDIT: Okay i just figured it out. You can’t use ä,ü,ö,ß in your picture-title :slight_smile: German Problems

@Dubs3pp, Great you figured it out. Maybe 4.1 has some unicode related fixes causing it to work in 4.1 but not in older versions.

@PatKoono, Please download more recent version of the addon. The original post in this thread has the links to all versions. Please download the most recent one and replace your current version.

The most recent is actually from today …_2018_070_09.

Just added a new version: Blenderer_2018_07_09

Please find it as an attachment to the original post in this thread.

It has a performance improvement for bigger scenes. I tried to render the storage layout from the DemoLayouts and it was way too slow. Found out some ways to optimize the conversion from visual components to blender.

The new version also has one more default floor textures: “ConcreteWhite”

Here’s the video I rendered using the Storage Demo Layout:

https://youtu.be/1vAoqcstXJk

 

Added an update that fixed some texture issues in the renders. Also added a simple video that shows how to enable gpu rendering in blender. The gpu rendering must be enabled inside the blender application. Open the blender.exe and follow the steps shown in the video.

Hello eme,

I have a question.
How much time when you using the Animations to export the sequence of images in Demo layout(https://www.youtube.com/watch?v=1vAoqcstXJk).
Is it spent a lot of time?

 

Hello Jerry,

As shown on the description of the video (visible from Youtube), it took 16 hours to render the full video in a Workstation with a GTX1060 Graphics Card.

Br,

Holms

Hi guys,

The idea of rendering animations and images with Blender is awesome! Unfortunatly I cant make it work, I get the following text in Output:

In other words, looks like the files do not get stored in the TEMPDATA folder. Does anyone have an idea on how to fix this? Would be great to make it work :slight_smile:

@bvriessen looks like a permission issue. Is the add-on installed in your My Commands folder in the Documents library for your Visual Components documents?

C:\Users%username%\Documents\Visual Components\4.1\My Commands

Based on the uri shown in the error message it looks like you have installed the addon under the program files folder and you don’t have write permission to that folder.

Like zesty said, please move the addon folder to My Commands folder:

C:\Users&lt;USERNAME>\Documents\Visual Components\4.1\My Commands

Hope that fixes it.

Thanks for the reply guys, works like a charm!

@ImHolms Thank for your reply.

We want to record a radar detection effect video, but there is no way to transparent and non-reflective effect color in Visual Components 4.1. Does anyone know how to set the color parameters or Blender parameters of the radar effect?
This picture is my setting color.

Hello,

I am trying. to use the Addon within Kuka.Sim 3.0. By adding some lights, i got these errors: