Blender Addon - Blenderer

Hi ,for my side ,The version was VC 4.7 + Blender 3.6
It still can’t work ,It shows this message

i did follow your instructions. and got this dialog when i hit render button under the default tab:


when i hit yes, i got this error:

i don’t know how to solve this. do i need to change some lines in

Blender and Blender Addon are 2 different things.

  1. Blender: Another software, not VC, not VC add-on
  2. Blender Add-on: Download from this post

This dialog indicates 2 possibilities

  1. Blender is not installed on your computer
  2. Blender Add-on’s “Blender Executable” property is not point to correct Blender installed location.

2 questions for you.

  1. Did you install Blender? If yes, where was it installed?
  2. What is your “Blender Executable” property value of Blender Add-on?


i know that they are 2 different applications. i put blenderer add-on here:

here’s my blender:

i hit open.

and still get same dialog and error…

Try 3.6 LTS version, which is recommended by OP

By the way, when this dialog pop-up, click yes to select Blender executable file directly.

i downloaded the version of blender you told me and put it right there:

i choose the blender.exe and hit open.

then i click render button under the Default tab:


then i get this dialog:


i hit yes and get this error:

967 dialog_return_value = app.messageBox(msg, 'Failed to locate Blender executable.', VC_MESSAGE_BUTTONS_YESNO)
968 if dialog_return_value == VC_MESSAGE_RESULT_YES:

I think this is because of the version.
Either dialog_return_value is not integer or VC_MESSAGE_RESULT_YES is not integer.

i use kuka.sim 3.1.
maybe it can cause this

1 Like

Hello dears,
i have issue with the robot movements after rendering, i can’t figure out what’s that wrong that make this issue,
when running normal simulation eveything is fine but when generating the animation i get this messy result


I have encountered your problem before. In my preliminary judgment, I think it is a conflict between the material changes made by the new version of the plug-in and the robot IK rendering. In fact, if you have used an old version of the plug-in (2.2), you will find that this problem does not exist in the old version, and what causes this problem is probably the code that was changed for better material effects.

Why is this??

The primitive geometrical shapes in VC (like cylinder, block, wedge, …) didn’t have any UV coordinates (i.e. texture coordinates). VC 4.7 introduced automatically applied UV coords to the primitives. Unfortunately those coordinates can’t be utilized (yet) in the Blender addon.
To work around this issue, use the texture coordnate mapping tool on Modeling tab > Tools gallery > Material group > Mapping.
Using this tool sets the coordinates to the geometry and then your textures will show up normally in the renders again.

Some lighting scenes have a primary light source. If the view angle is just right it seem to reflect quite directly from even surfaces. Try to use another lighting preset or set up your own lights in the scene. If you are happy with the lighting in general but it’s just a tad too bright or dark, you can use the Exposure value on the Advanced tab to control the overall exposure… eh… brightness of your image.

Do you mean the missing wires in the fences? That layout is using an old version of the fence component. In the fence the wires are not created from geometry mesh (i.e. triangles) but are linesets. Blender doesn’t render anything but triangles.
Take a new fence component from the ecatalog and it works fine. Maybe VC should update that layout to utilize the latest fence component.

Are you using the latest addon version together with the latest 4.8 Visual Components? The latest addon with older than 4.8 version may cause this. It’s related to a change that fixes the issue with a choppy animation/video stream.
I hope this doesn’t anymore happen with latest addon + latest VC version.

Hi please you can send vdo how to create weld scenes . Thank you.

Hello All,
I am first time using Blender Add-On. Every time I try to render any image or animation I get the “file not found- VC_to_Blender_materials.mtl” error. I tried to run the same on another computer and I got the same error. Has any body faced the same problem before?
I am using VC 4.8 and Blender 3.6 (also tried with 4.1).

Hi, This is a hard one to crack as I haven’t been able to repro the issue. May I ask where do you have the Blender application installed? Also, if you run the addon and try to render, what files do you find in the TEMPDATA folder. Open the folder with the file explorer and see if the file actually exists or not. Also what other files do you see in the folder.

Blenderer does not seem to work with 4.9? The menu tab does not appear.

4.9 is a little bit different, put the add-on under this folder
\Documents\Visual Components\4.9\My Commands\Python 2

1 Like