Assembly not forming

Hey, wondering if anyone can help, Its probably a simple thing i have done wrong but i am unsure what it is I have checked my links and they are fine i think in the process steps the issue lies but I’ve tried a few ways and same issue happens. see below:

Anyone have any ideas be a great help.


For each StartTransportIn you must have a corresponding WaitTransport statement. That’s what the error messages tell. Same goes for StartTransportOuts.

I shall try this and let you know thanks for the advice

@TSy Thanks that helped for one of the process still getting error codes on the other one but I think i can figure that out

Added the wait transports and it works however, still having an issue with the assembly not forming as it should any one assist??

The statement Assign counter + 1= <Null> clearly has been set up wrong at least.

Fixed that but didnt fix the issue

I have fixed what I needed I have one more issue. I have no error codes however the robot work pick up the products to create the assembly. Can anyone assist?

From your last screenshot, it seems that your are still missing some WaitTransport statements. Btw, is there a reason why you’re using these StartTransportIn + WaitTransport instead of just TransportIn?

1 Like

Hey @Tilma this is what it looks like now:

The products stop at the conveyor and no error messages come up

I can’t see the names of the variables you used for the StartTransportIn, but I think you might be missing one WaitTransport for the first StartTransportIn.
Check this video from the Academy about the WaitTransport statement : Wait for Transport | Visual Components Academy

You might also want to verify if you used the right Source and Destination parameters for the TransportIn and TransportOut statements : From/To Component Container if it’s being transported on a conveyor.

And it might not be finished, but from what I see, your FromConveyor Process also contains some errors. You should watch the Academy video about Assemblies : How to complete an Assembly or Disassembly Task | Visual Components Academy

1 Like

Still havent got this working, making small progress, removed everything and re done it. Seemed to work however the getAssembly gets step 2 before step 1 does anyone know a solution. I have tried to delay, send signal/wait signal but that stops the sim all together

You’ll need to share a minimal example layout of your problem. Written descriptions and screenshots can only go so far.

In the latest screenshot you still have 2 StartTransportIns and only one WaitTransport, which is wrong.

Hey @TSy Image below shows the issue the issue. A box is meant to be the first item at the process node and then the robot lifts a divider and sets in it. Currently the robot picks the divider and sets it down first before the box. IN the process node I have used getAssembly i have changed them to transportIn however, I have used the other ones before and got the same result. I am also why this process jumps a step and lifts a divider first.

Does it work the same if you use interpolating transport controller instead of a robot?
The robot might just pick wrong thing.

Works the same way divider still appears in the process node first

Update : got the simulation to run while lifting the divider second, however it seems to get stuck on that step and not move.

again, if you watch carefully the Academy video about Assemblies, you’ll see that your first statement should be a TransportIn. If the Assembly is correctly defined, and that you created the box, not as the ProductType Box, but as the first step of your assembly, you can directly transport it and then get the following steps.

You could also use the filter to not accept all product types, but only those you define

1 Like

hey @Tilma I had that in the beginning after removing everything and starting from scratch the divider seems to come in first unless i define the product i only want, however it still stops on the transportIn divider step. Or alternative to this issue is it works but the box stops before the process node and divider in placed ontop of the node

Hey @TSy @Tilma could my issue lay in the previous node? Below shows a picture both the nodes that are linked, I cannot seem to solve this issue any help will be greatly appreciated