Why can't I speed up the simulation


I am building a layout including ASRS,AGV and conveyors. A large number of components, quite complicated control logic and long simulation time (one month).

My problem is that the simulation running speed is quite slow(even slower than real),no matter how I set the speed factor. I tried to set the simulation level, but it seems unchangeable, see figure 2.Why can’t it speed up?

By the way, is it possible to run the simulation without any animation effect in 3D world, but just collecting and showing data I want?

1 Like


at first you should check if all limit checks in the teach context are disabled:

The limit checks and the MessagePanelOutput really slow down the simulation speed.

Regarding your screenshot you are not using the latest release 4.0.4. In this release you can also activate the VirtualTime mode:

The simulation level is only a property in the component that can’t be used in the component logic to execute different logics regading to the level. But as far as I know not many components of the eCat supporting the simulation level.