Strange issues with robots


Ive been trying to learn VC for about 2 weeks now and while im working with robotic arms im experiencing issues with the pose of the arm after making the point-to-point motion statements.

I will try to explain using some pictures from an experiment i did just now:

Here i am making the first statement for the robot. This is the first pose in a series of three.

Here i have made a second statement.

This is the third.

I put these movements into a while-loop and i run the simulation. The movements work as they should, that is that the arm will move from 1-3 without any strange issues like rotating 360 degrees on one or more axis.

I remove the while-loop and i start adding some logic for the movement (sensor signal, gripper signal) and suddenly one of the poses (the last one) is distorted, in lack of a better word…

Ive taken care to include the jogscreen so that we can see the parameters for all axis and i noticed that the “Configuration” field above the axis has changed.

Why does this happen? Is it something im doing wrong or is it a bug in the software?
As i mentioned earlier this is happening fairly often, it seems to happen if one or more joints are close to their limits but im not sure.

Thanks for reading and hopefully i can get an answer from someone… :slight_smile:

send the file to me, i make it correct.

email :

It a configuration naming issue in robot component not the software right?

Hi, i see that the pictures are not clickable, so i guess its hard to see the text.
I will update the post as soon as i have 5 minutes to spare and i will elaborate on what i found later last night.
Thanks :slight_smile:

fymhappy: It would be better if i knew why this happens so i can correct it myself.. :)

I have now updated my first post with links to full res pictures. The “configuration” field changes automatically and that is causing the issue, how to prevent this? :slight_smile:


Refresh your eCatalog and get the latest version of the robot, and then exchange the old one with the new one. Does this issue still happen?

Hello, sorry for the slow response, i havent been working on VC the past week.

The issue still persists, even when switching to new version of robot.

Some additional information:
It will randomly do this wierd behaviour. I have a working simulation that i load. I run it for a while and all is fine. I try resetting and starting it again, everything works as it should. I select the conveyor, open the python script associated with it (i wanted to remove a debug print message i had added there), compile the script and run the simulation again and it will express this strange behaviour.
I then proceed to save the layout. I do a Clear All, then i load the save, and everything is back to normal.

Wait until 4.0.5

Is there any solution for this issue?

The problem seems to be solved in the current robots in the eCat. Thanks!