Simulation keeps pausing

hi, im having issues with my simulation constantly pausing. after i press play it continues normally but it pauses every time at the same few points. it was throwing up an error that the destination of the human transport controller was inside an obstacle. so i added everything around there in to “exclude obstacles”. there is now no error but the simulations still keeps pausing.
workflow.vcmx (8.2 MB)

Hi, can you look in your program tab, if the functions “Stop on collision” and/or “Stop at Limits” are checked?

no they are not checked

The File did not open correctly for me but one thing might be the AR900 you have is not set to “IsLooping” under the Executor tab. That can cause a one time pause since it is not connected to a robot controller. I hope this helps and sorry I couldn’t help more

no that didnt solve it. and the yaskawa is infact connected to a robot controller. the pause occurs 4 times and every time the simulation resumes normally after i press play again

i tried putting Otto on IsLooping and it worked. the simulation no longer pauses. but now the issue is that Otto constantly walks in place even when performing tasks. any idea how to solve this now?


Could you try to put a random (PM) feeder somewhere in the world and then make it invisible and see if this forces the simulation to not pause?


the issue has been solved. i disabled the HumanExecutor and then it worked normaly