Signal Relay wait signal does not execute



I dont understand why wait signal does not trigger even though Signal relay already got signal turn to True. I tried to play with it in many different way but it still does not execute the step. I tried manual trigger it in siugnal relay write and it work but it will stop at this step again…

Did i place it in wrong order?

The WaitSignal statement has options for either waiting a new signal or to also accept current signal value. Maybe verify that those are set correctly for your purpose?

1 Like

I don’t see any error in your screenshots.
In my quick test it works.

Maybe i have to check this. Could you guide me how to verify this?

All others signal work except this one…

Might be as TSy mention that the statement accept only new signal and not current one.

Wonder how to check this.

If “WaitTrigger” is on for the Wait Signal process statement, it will not check the current state, but wait for a new signal to trigger.
If it is not enabled, it will also check the current state,

1 Like

Thank you!

How to enable it?

I saw it now, thank you and it seem it work.

Thank all of you!