I am using Visual Components 4.0 and have imported a layout that was created using 3D Automate 2014 (which was created by someone else).

Some of the robots’ VCIDs are wrong and as a result do not load as robots. They instead appear as invisible component. If I go to modelling and “show” the structure I can see the general structure of a robot, and running the simulation I see it moving around, but the Programming tab doesn’t work on it and I can’t use the Robot Replacement tool since it’s not a robot.

My thought was to find the correct robot model and use “Save As” to save a new version with an ID matching the one used in the original layout, but Save As does not seem to allow me to manually set the VCID.

Is there a way to do this, or some alternative solution that would allow me to tell Visual Components which robot it should be loading when it imports?

An example of the messages I get when I try and import. As you can see the VCIDs it’s looking for clearly don’t match an existing VCID. Is there some way I could maybe alter the old layout file and manually change the VCID?

Reading node: r1 #3 Reading node class Loading geometry: Geometry_2 Reading geometry file: vcid:33c318ff-1cee-46ef-9551-31bc722a97ea#geometry_2 VCID not found. Reading node: VCTrack #4 Reading node: T1 Reading node: R1 #4 Reading node class Loading geometry: M-710iC-50/70 Reading geometry file: vcid:63567ef6-fced-4a20-bc06-5e432736c5c0#70 VCID not found.

Let’s see if we can get this working for you.

Option 1

Long story short, if you still have 2014 then save the layout in 2014 and package the components in the layout, and then try to open the layout in 4.0.

Option 2

If possible, email the person who made the layout and get that person to save the layout in 2014 and package the components in the layout, send the layout to you and then open the layout in 4.0.

Option 3

  1. In your 4.0 product, go to the eCatalog panel.
  2. In the eCatalog panel, Collections view, click + and then click Edit Sources.
  3. In the Sources editor, find the Legacy Library source and make it visible.
  4. Click OK to exit the Sources editor. You should now see the Legacy Library listed in the Collections view.
  5. Point to an empty area of the Collections view, right-click and then enable Show Deprecated Components. The eCatalog panel should now automatically download and index the files in the legacy library.
  6. Wait until indexing is completed.
Now try this:
  1. (Optional) Restart 4.0 product.
  2. Open your layout. Backwards compatibility is not officially supported, so opening VCM files instead of VCMX may or may not work.
  3. Check the Output panel.
    1. If you get the same feedback that VCID not found and the robot geometry is not visible in the 3D world, check if the robot models are available in the eCatalog panel. If they are not then the layout would need to have been saved with the robots packaged to the file.
If the layout loaded correctly, the executors of the robot would need to be upgraded to new executor. That can be done in Program Editor panel when the robot is selected in 3D world. I believe nowadays this is automatically done for you: old executor is not deleted but new one is added to component.

To exchange a robot in 3D world, the component would have to be visible in order to select it.

And in order to use exchange robot command and teach tab with robots with missing geometry, you can add some dummy geometry to the robot links. E.g. add a block into each link of the robot on the modeling tab. This may not solve you original problem straight away, but is sometimes useful trick when you have a layout but you are missing the referenced components.


I’m not sure exactly what happened but suddenly the Robot Exchange option is working. The RSL executor upgrade breaks the simulation (I’ve posted seperately for that issue) but I have been able to at least get the right model in there.

Thank you for the suggestions.