Robot not moving on a track

Hi Everybody,

It is my first post so my excuse if it is not the right place.
I am trying to use a robot on Horizontal track to move one object from WorkProcess 1 to Workprocess 2.

I attached the tracks to WorkRobotController and the robot to the track support.
When I want to execute the move, I have an error because Workprocess 2 location is not reachable by the robot. It is like the robot doen’t He can move along the track.

Kind regards

Example.vcmx (336 KB)


I would give this to the official support. The Gantry has a problem, it’s based on old VC-RobotTrack which also have the same issue…



Hello Remy

It works without flipped joints. I updated your layout.

Example-1.vcmx (1.36 MB)

Hi, remy.
I have the same error like you.
Do you fix that yet?

Hi, ozan
I tried your layout, and it can work correctly.
But I find no difference between yours and remy’s layout.
Could you explain how to fix that?

Hello Littlefishlp,


I had to select good Track axis and uncheck FlippedJoint