RCS module initialization failed

Hello guys,

can anyone explain me this error and how to fix it? When i use any kuka robot and want to use RCS it causes this error. Could be some missing files? (Using KUKA.Sim 4.1)

I didnt find anything on the internet.

I’m a beginner so sorry for a possibly stupid question. Thank you : -)

Juicy topic of conversation. I have seen this. Try clearing “RobotDataGeneration” and then set “RobotDataFolder” to be empty, and then run simulation. It might not work or at least give error that no machine data is in robot.

You might need to reinstall KUKA.Sim or install “EqualizingTech” which KUKA support can help with.

If you want to get down with the sickness, this zip is RobotDataFolder created in VC 4.6 +KUKA OLP with same KR 10 robot, but in VC it has dress pack on it.
zhuhge1q.zip (512.2 KB)

Thank you for the answer. I tried deleted it. It didnt helped. Also i tried to use your zip robot data folder and same problem. ¯ \ _(ツ) _ /¯

Reinstalling might fix this : / But I just activated trial license, when reinstalling the program - license will be deactivated - if i remember right.

There might be something corrupted on the installation, so best to contact Support since they can possibly send you repair package.

Might be related to Engineering Tools installed on your device… is it just KUKA.Sim on your machine or do you also have VC on the machine? Anyway, support most likely has to help or you can try cleaning your machine.

Yea, i will try. Only KUKA.sim installed. VC was never installed on this machine.

Solved. If anyone else facing this problem - it is in windows account special letters like ý,ž,á,… If I move the files RobotDataFolder somewhere else - its working. Lesson learned.