Process stops after one iteration of while loop

Here the first process(left side) runs 14 times and once the first process runs 14 times, with a signal action the second process starts running within which there is a while loop that runs twice before releasing the human resource back to the first process. But the while loop runs fine the first time but gets stuck on the second time without any proper error message related to why the human stops execution.

Any idea what could be the cause when the second process’s loop ran fine the first time but not the second?

Thanks in advance…

You need to reset your product variables Box1 etc. to null or otherwise they will become a list as you reuse the variable on the next loop.

1 Like

Thank you for the response. But how do I do that?
I tried null, Null, None, in both “” and without it. I also tried to remove product and even that didn’t help.

Simply leave the value expression field empty in the Assign statement.

1 Like

Thank you for the response.
I tried the same. But for some reason the human stops at the same statement again. It is not making a difference.

Any idea if anything else can cause such an issue?