Place Ball in spherical hole

Hello, I am having a problem placing a small ball (around 50 mm) on top of a cylinder with a spherical hole inside size (30 mm). The idea was to let the ball lay steady on top of the cylinder after on gripper has put it there. After this I want another gripper to pick up the ball so the ball may not move.

A floating ball

Now it seems as the ball is floating in the air above the hole of the cylinder. How can i make the ball and the cylinder stop ONLY if the physical objects touch each other??

All help is kindly accepted!

Are you using physics? If yes, you should use a collider of precise. There are, of course, known issues with cylindrical objects.

Are you using basic shapes from the eCat?

Hi ,
Does the cylinder below has a component container type behaviour ? If it has no any container : I suggest you to add a container and then check your gripper’s detection container if it covers the area you want to release or not





I have tried with booth CAD-geometries of my own design aswell as basic shapes from the eCat. I have selected physics in all places possible end now I tried to to make the cylinder to a container as suggested but still I am having the same problem.


You say there are known issues with cylindrical objects, is this one of them?


What more can I try, can someone model a simple ball on a cylinder just so that I can see that it is possible to do?


Best regards, J


I have no idea how the Physx engine is implemented in source. It might be bug or issue with entity bound box in respect to colliders. I don’t remember if cylindrical shapes cannot do a precise convex hull. I am also seeing issues with feature selection where the outline of the geometry is not being selected rather the bound box.

I believe this is what we are trying to avoid.

And this is not what I would expect when selecting the hole.

EDIT: Encountering a few bugs and unexpected issues, so I’m done with this. Good luck to rest of you.

Stand.stp (19 KB)

Ball.stp (2.17 KB)

Thanks for trying, I just hope someone can solve this.

I think the “precise” collider option might still create a convex hull of the mesh and use that so any holes get covered over. You would need to split the tube into several individual segments and have the precise collider setting enabled for all of them.

Edit: In the attached layout you can see how the 4 separate box meshes work but the tube doesn’t.

Physics-colliders.vcmx (243 KB)