Machine in Works process


I tried to make a process with Works Library which includes Visual Components Parametric five-axis lathe (checked in Modeling if the machine has task behavior and it does), attached works process to clutch but when I start simulation I get an error:

File “CNC_1::PythonScript”, line 74, in OnRun
AttributeError: ‘NoneType’ object has no attribute ‘ChildComponents’

I would like to know if someone had the same issue and how can it be fixed. Please help :slight_smile:

What version are you using? In 4.3 it seems ok.
Make sure that the works process is connected to the interface. Do this in the Home tab with the PnP-tool.

If it still does not work, check the PythonScript. Does it have the correct interface name.

I didn’t know I have to use PnP-tool because in the tutorial " Simulate Process with Human, Machine and Robot" ( ) only snap and attach were used.

Now it works like a charm. Thank you for your fast response. :slight_smile:

The tutorial was made with VC 4.0.5, so the components in eCat are probably different than the version used with the tutorial or they are modeled differently. According to the Works task reference guide, plug and play should not be required for MachineProcess task, but no idea if the reference guide is up-to-date.

Here are the tutorial files just in case others want to complete the tutorial using the old components.