Grasp Action Wizard (Professional)

Hi Frank,

It is used for detecting components while grasping and is working exactly the same as robot Grasp/Release Action Signals. When GraspSignal is sent, an invisible “DetectionVolume” is created around the TCPframe and is used for detecting collisions with other components. Collision test results are used to identify component(s) (if any) for grasping.

In this case the orientation of the frame is usually not so interesting, only the location.

Hopefully this clarifies the operation!

That’s helps me a lot. Thanks.

Nice, thanks!

I think you have missed to define the setPhysics function in the GraspActionScript, atleast for me the function was missing, it is easy to fix, but I just thought you should know.

Thanks for a great wizard!! :slight_smile:

 

Hi @autohenrik

Thanks for the tip!

It’s now fixed :slight_smile:

Sweet addon jouha!

-Este

1 Like

Hello @jouha ,

thanks a lot for the add-on. It was really helpful.

I have one short issue. I am working with Works Process and I have found that your grasp action wizard is not working when I “Attach” the Works Process to other component. It works only when I “Detach” it.

Could you please let me know if I am doing any mistake here? I have to make the Works Process attached to another link to have clear movements for the entire process in a work station.

Regards.

Hi @davinci ,

How is it not working? It doesn’t grasp or doesn’t release?
Is the grasped component released (attached) to a wrong node?
Something else?

Hello @jouha ,

when the Works Process is attached, both grasping and releasing is not working. I tried the same setup but with ‘Detach’ the Works Process, then both grasp and release is working as usual.

Here you can see my small demo layout. Initially it is attached to Block Geo, so grasp is not working. If you detach the workprocess, then it will work.

Grasping Product with own Geometry.vcmx (575.2 KB)

Hi @davinci ,

This happens because the component (and all in its hierarchy) where the graspaction is, are excluded from the grasping/releasing detection. The intention is to prevent it from picking/detecting itself.

You can fix this by replacing VC_NODELIST_TREE with VC_NODELIST_COMPONENT on lines 213 and 220 in the GraspActionScript, see below:

Hello @jouha ,

it works. Thanks a lot! :smiley:

Hi johua, Nice! I have played with this script a bit and I am trying to control the “GraspSignal” by using the “Write Signal” Works Process task instead of the WP “SensorBooleanSignal”. Is this possible somehow? I am already using the SensorBooleanSignal elsewhere. Thanks!

You can send a signal directly to your “gripper” by:
WriteSignal:GripperComponent:GraspSignal:True

Where “GripperComponent” is the name of the component that has the “GraspSignal”.

To learn more see:
https://forum.visualcomponents.com/t/works-library-tasks-reference-guide/

1 Like

Thanks for sharing such add-on! But I’m meeting trouble using it for modeling a gripper.
I need a gripper attached to a 3 axies moving feeder, and I just finished the feeder moving part. Before using this add-on, I tried End Effector Wizard, similar to modeling a basic gripper for a robot just like in the official tutorial. But it works only when plug the gripper onto a robot.
Then I tried this add-on, as in the screenshot, MyGripper: Action ‘Grasp’ executed (Ok), but gripper does not move close to grasp.
Am I using the wizard wrong? How can I make it work correctly? Thanks!


Grasp Action Wizard doesnt make gripper grasp.vcmx (2.5 MB)

Grasp Action Wizard doesnt make gripper grasp.vcmx (2.4 MB)

Thanks for helping! But I opened the vcmx file you provided, the program in robot is empty, and I can’t find any program. Clicking play button does not make those parts move like in the video you mentioned.
What’s wrong? Looking forward your reply.
PS I’m using Premium version 4.1.

*Just program it like a normal robot

I’m sorry I am new for visual components.
I connected the signal between robot and the carrier part, but I can’t connect the interface between them, because only one panel shows up.
Please cover more detail, thanks a lot!



hi,bro.First of all, thank you very much for your script, it was very helpful to me. But when I make a push rod to push the object, its jog frame and tool frame do not match. How to adjust the match between the jog frame and the tool frame?




Uploading: data simu.vcmx…

data simu.vcmx (5.5 MB)