Geometry Bug

Hey wondreing if anyone had a silmar issue.
when i load my layout geomatry has jumped all over the place and in some cases even changed scaling here is a screen a couple screen shots. I didn’t do anything just close VC and when I tried to re open the layout it came out like this. I tried opening some of the back ups but they are all screwed up in the same way. but different geometry is screwed.
as you can see on the screen shots the geometry is now a jumbled mess.
this is super enfuriating as I lost a ton of work. would be great if I could get it back but like I said even the back ups get screwed up.

any ideas how to fix this would really be appreciated.



Heres another screen shot. you can see geomtry flying around everywher.
so frustrating will be so much work to try to fix this any help is appreciated.


I had before, but not often, this usually happens when there are so many geometry.
But my situation is, geometry is not flying away, it is because geometryA replace with geometryB.

For example, there is a “Screw” geometry and a “ControlPanel” geometry.
“Screw” geometry replaced with “ControlPanel” geometry.
Geometry name are the same, but not the geometry content.

I guess that’s why it looks flying away. If your layout’s component and geometry literally flying away, this is weird for me, never seen before. Because component’s XYZABC is just few numbers, should not go wrong.

What I did is that “Save As” backup layout (don’t forget to check included components), start up 2nd VC, load it, check if it fails.

I think this is the same bug I have had many times. It is known by VC but they do not know why it occurs.

Just read the post, I have the same feeling about it, I think it is about geometry names, when import many CADs, there could be same geometry name, maybe that cause loading the wrong content.

This addon might reduce the problem: VC replaces parts by itself - #3 by andyv
However, I’m still experiencing “replaced/offset geometry” issues so I can’t really tell what to expect with the addon.

For me this bug usually happens with geometry that has been sliced, patterned or mirrored. In the pictures below the press tool ended up offset from the press, while the 2 boxes on each side of the tool remained in place.

Cool, could you share this press’s original CAD? If could reproduce it, it is possible to find the root cause.

Sorry, I can’t share the CAD data. I did however create a support ticket, so I’ll keep you (and others) updated on any progress.

It is very important to find a clear way to reproduce the issue starting from a sample CAD data. Cause the layout might already be corrupted, developers will have difficulties finding the root cause…

Thanks everyone for your input. it’s too bad a lot of people have experienced this.
but I’m glad you all replied hopefully we can get the devs working on a fix. although might be a while untill it’s implemented but at least will be on their radar.

@andyv let us know how the support ticket plays out

1 Like

Layout that has components without VCIDs (that is: components that are not saved as components) can be mixing up the geometries when loading the layout. It seems to only happen when the geometries have the same names.

One workaround, until the bug gets fixed, is to rename each non-unique feature name in the components that has no VCIDs. Here is an add-on (1.2 KB)
that just adds an underscore in the end of the name to avoid the issue. It cannot fix the layout anymore, so you need to do it first. Use the command before saving the layout.

1 Like