Failing to execute subroutines from script


I have tried to call and execute a subroutine from script, in the OnRun-method. This has been tried with both the vcComponent (executor behavior) and vcHelpers.Robot2, where both is giving the same result. The subroutine is found, and the robot moves to the first point within the subroutine, but just stops here with no error.

Is there anyone with the same experience and has figure this out? I have tried to start fresh with a new model, with just simple movements following the course ‘Control Robots’ on academy, but still the robot will not execute the subroutine.

Maybe the robot is stopping because it has reached its limits. Check these settings in the program tab.

My advice is to always have the “Message Panel Output” on when any limit check is enabled. Otherwise, it will just stop without any message.

Thanks for the advice, but “Message Panel Output” is on. The function will execute when it is called from main, but not from the script.

It should work the same way when you use the vcExecutor.callRoutine(routine_name) command.
Maybe you can share an example layout?