Confusing Path Behaviour Breakage

Hi there, using VCP 4.3 here and experienced 2 things just now I can’t comprehend:

  1. When changing python script name, connection to signals get lost after restarting VC - they appear as “.-” for me. Need to add connection again. Is this normal?

  2. I just modified a path with one sensor, containing frames

Path_Frame_1
Path_Frame_2
Path_Frame_3

and a sensor triggered at Path_Frame_2 origin.
I added a new Frame to the path, Path_Frame_2_5 (offset only in z-direction right on top of Path_Frame_2), and moved it in-between Path_Frame_2 and Path_Frame_3 like

Path_Frame_1
Path_Frame_2
Path_Frame_2_5
Path_Frame_3

After rerunning the simulation, parts stopped moving on leading edge for the newly created Path_Frame_2_5, without even reaching the origin for sensor connected to origin trigger at Path_Frame_2.

I don’t understand why. Doesn’t really make sense to me, I just added a new frame to the path, no new sensor or signal.

I also experienced making changes to path frames breaking part transfer between different paths, also don’t get this.

I removed Path_Frame_2_5 again, now the part transits across the component fine, but when touching Path_Frame_3 on leading edge, transfer stops again instead of completely moving the origin to Path_Frame_3 to engage in path transfer.

Anyone experienced this, or am I missing something obvious?

Thanks!

Edit 01:
Things.

Edit 02: When I look at python and print path.Enabled & path.Capacity, the component starts with path.Enabled = False & Path.CapacityAvailable = True.

When I add
path.Enabled = True
path.CapacityAvailable = True
to the start of my script, this swaps path.Enabled = True & Path.CapacityAvailable = True.

Only when I add
while app.Simulation.IsRunning:
path.Enabled = True
path.CapacityAvailable = True
do both stay true & part transists to the new path again.

is there a component setting outside python that toggles this behaviour?

Edit 03:

I re-added both true-statements to my state-machine, now this is working again.
Then again, idk why it didn’t in the first place, feels pretty hard to get a grasp on how things are behaving.

Edit 04:

Another thing I experience, which doesn’t make sense, is having 1 “leading edge” sensor 01 followed by 1 “origin” sensor 02, but components passing trigger the “origin” sensor 02 after leading edge passed “leading edge” sensor 01.
Again order is sensor 01 (leading edge) → sensor 02 (origin).

Is VC possibly sometimes not remembering changes in parameters, or just not executing new changes?

I feel like to have this work properly I have to take note of all changes and then re-create all behaviour with the correct settings right at the beginning for VC to execute properly?

Edit 05:

Just now I lost an entire component after saving and re-opening the layout.
No matter what component behaviour I selected, feature properties didn’t show me anything besides geometry for this single component.
Signals, sensors, path, nothing. But I could open the python script.
So I restarted VC and viola, I could access individual behaviour properties again - only to find every single connection to the python script was gone.

Had to reconnect them to the python script and everything worked as before restarting VC.
Still, order of executing origin sensor before prior leading edge sensor stays and confuses me.

Edit 06:

It seems I missed extending the path exit frame past sensor 02.
Still unsure how this skipps the sensor in nearest proximity, but interesting find nonetheless!

Edit 07:

Removing sensor 02 and changing sensor 01 from leading edge to origin detect has sensor 01 working.
But strangely enough the connected boolean signal triggers at origin and what seems to be the trailing edge again.
Really has me wonder what’s happening there.

Edit 08:

Fixed Edit 07 by deleting the path sensor and replacing it with a new one, with signal reset set to trailing edge.

Also had an issue of path.Enable & path.CapacityAvailable were both set to False but wouldn’t stop part moving.
Was working after restarting VC again.

Have you updated your frames on path?

image

I’ve noticed that when adding or moving frames it’s easier to clear those path and sensor boxes and add them all.

I’ve used those path.Enabled commands and had some issues with it so started just setting the path.Speed=0

1 Like

Sorry for my late reply.

I did update path frames, but as per your suggestion I cleared all boxes or re-did the behaviour entirely upon larger changes. This worked for me.