Component polygon count and file size

Hello. What is affecting to the file size of components? It is not just triangle/polygon count in the component as robot from VC library took 400k triangles and 5,5 MB of space as same geometry imported from STEP took 100k triangles but 15 MB of space. Can I lower the amount of space the geometry takes?

Importing STEP with math data might be the issue. I tested to import a STEP with and without math data. With math the size was 17Mb and without the size was 1Mb. Comp had 89k triangles.


Is the math data defined in the STEP file or in the VC import? Is there anything that I can do if I just have the one STEP, not the original CAD-files?

It’s defined in import tool. If you select “Organize Geometry” option of “Mathematical data” the math data is stored in the imported geometry. And you can use it for topology tools or redefine the tesselation level for the geometry. Selecting any other “Organize Geometry” option will not store mathematical data in the VC model. It’s lower in .vcmx file size but you cannot use those features I mentioned. By default I suggest not to include math data unless you have some particular use case that needs it.


Thanks for the reply, but that was not the issue for me. I solved it though. I saved the model from VC Modeling tab and then brought the saved model again to the layout and now the size is just 1 MB as it was 15 MB. I really do not know why it worked, but somehow there was some geometry in that component that was not saved. Maybe a bug?

Good that it got solved. If the issue is reproduceable you could contact and attach the model on the mail. We could take a look at it in more detail to see if there’s a bug.