Completly deactivate Kuka RCS


is it possible to completly deactivate the Kuka implementations in VC Premium, like this not exists!? → I only want to use the great VC Robot stuff…


Thx & Regards

If you have KUKA OLP disabled then Kuka robots always use VC controller and executor. Robot models still have RCS controller behaviour and some KUKA OLP related properties but those shouldn’t affect the simulation in any way. Only minor effect I can think of is a tiny delay on first sim start after new kuka robot is brought to the scene. I think that relates to the RCS controller behaviour. On next sim starts you don’t see this however.


I think that could be the reason for that the configurations of the robot are empty a short time! → I create the robotprogram over .Net

Do you have an idea to update the robot so that I skip this ugly delay?

Thx & Regards

You could try to delete the rcs controller on .NET to see if it makes a difference. I can’t say when it would be the best time to do that. Maybe immediately when new component is added to scene you could check for the behvaiour and delete it.

PM robot TC has this function ran on Kuka robots when they are connected:

def disable_kuka_functions():
  if not connected_robot:
  change = False
  # Delete Krl executor
  krl_exes = connected_robot.findBehavioursByType('rCustomExecutor')
  for krl_exe in krl_exes:
    change = True
  # Delete Rcs controller
  rcss = connected_robot.findBehavioursByType('rSimRrsRobotController')
  for rcs in rcss:
    change = True
  if change:
    print 'INFO: Modified Kuka robot to use VC controller.'

So that deletes the RCS controller and also the KRL executor. Note that KRL executor exists only when KUKA OLP is enabled. In that case app will recognize kuka robot model based on RCS controller and TrafoName property and then automatically creates KRL executor to the model with a blank program when robot is loaded from eCat.


KUKA OLP is disabled on my computer!

My first approach (set UseRcs-property to false) ends in the message: “INFO: Modified Kuka robot to use VC controller” → Result: Configurations are emtpy for an undefined amount of time. → Very bad for code automation!

My new approach (delete rcs behavior completly) ends in: No message, behavoir is deleted. But the configuration problem is still there.

What should I do, to get my stuff work again before implement the … kuka stuff?!

I do this immediately after load the robot in world!

Thx & Regards

Where exactly is the configuration list empty? I tested the following code snippet on 4.7 with manually triggered action item and to me IRobotController.Configurations shows 8 confs as it should.


In my TeachContext everything is null!?

I get the robotController after successfully create different InterfaceConnections between Robot and stuff like: Gripper, Positioner, … with:
and then the robotController.Configurations.Count() is 0 for a while… → But when I set a breakpoint an extend the robotController the configurations are immediately there, thats sooooooooo strange!

I’m looking for the magic to update everything so that I’m able to use it…

If TeachContext doesn’t have any objects populated then you probably don’t have a robot selected on program tab momentarily. If you see the program editor for selected robot on program tab then you should have teach context properties for that robot.

As for why the conf list appears empty for a moment I can’t think what could be the cause for it. Controller gets configuration count and names from the associated kinematics and if you don’t mess with the kinematics then the conf list shouldn’t be affected. I don’t know, maybe there’s something in your app that affects it but I can’t think what it could be.


I think I solve it, I use the IRobotSelectionService.SetActiveController() with my robotController and the configurations are there after it… hmmm

I think you brought me on right track @keke


Good to hear if you got that solved!


1 Like