Change type from assembly to single product

Hello, I am onto a new project and i am trying to simulate a process that has very small components and would be difficult to simulate in the software to combat this and save time I am trying to bring in all components I need to then change it into a single product (finished product) to move to the next stage of quality checks and packing. below is how i tried to go about my issue and the errors that came up.


Update: I tried a different method to change type into a singular product, using the attach command. It works but doesn’t transport the product out. Any reason why this would happen? Another question also out of the 2 methods which one would be better to use the singular product in an assembly?

I’m not sure if I understand your second approach, could you share how the process looks?

As for the first approach, you could instead of changing type, use ‘Remove’ to remove ‘Assembly #1’ and use ‘Create’ to add ‘Assembled gun’ as ‘ProductOut’. Then TransportOut: ProductOut.

@kreaturen this is what i done for the second attempt, not sure if it is the correct way to go about it but it seems to work for the next step in the process

Alright. I’m quite noob myself, so still not able to understand how your second try works (up until it doesn’t) just by looking at it. But you said it worked, just wouldn’t transport out? Do you get any errors on the ‘ChangeType’?

Your first attempt should work though, if you just replace ‘ChangeType’ with ‘Remove’ the gun assembly and ‘Create’ single gun. Then transport out single gun. The reason you can’t use ‘ChangeType’ here is because it doesn’t support assemblies, only single parts for other single parts. Perhaps that is why it doesn’t work with bundled parts either (Which is what you get when you use attach, then it’s no longer a part, but a list… Which is way too abstract for me :crazy_face:)

In either case, if both processes manage to build the gun and it looks alright, you can use ‘Remove’/‘Create’ before TransportOut in both cases. (It’s my favorite trick, I call it: Delete everything and create it again :wink:)

In the second situation I use the attach 2 components to the one and when I change type I remove the parent and it deletes the child components which are attached to the parent. Found this worked and moved on with the rest of the process. I am not getting any errors with the changetype command