Can't seem to acces the VC IMessageService

I’ve set up my plugin based on this video of your YouTube channel : .NET API - 1 - Add a Background Plugin - YouTube

I still can’t seem to connect to the VC software I’ve tried with IApplication and ISimulationService, etc. The constructor of the initialize never seemed to be called.

I can’t seem to be able to put break points I got this error: c# - How do I remedy "The breakpoint will not currently be hit. No symbols have been loaded for this document." warning? - Stack Overflow

Based on the debug output you are launching and attaching the debugger to the VC launcher, not the visualcomponents.engine.exe which is the main process that will also load your plugin dll.

True, I changed it still nothing…

My guess is that your plugin dll file is not getting built to the VC installation directory, so the VC engine.exe you start and attach the debugger to doesn’t actually load your plugin. So double check the output path and from where you start VC.

If your VC installation is under the Program Files folder you will need to run Visual Studio as admin so it can write the dll there.

Edit: Also your the main dll file of your plugin must be named Plugin.*.dll for VC to load it.

The path is correct, I run VS as admin and I’ve put the prefix for it to run as Plugin.*.dll. Is there something I should do for it to run my plugin correctly?

From your screenshot I can see that there isn’t any dll file with a name that starts with “Plugin.” so clearly you are not building your plugin to that folder or it is not named correctly.

Configuring the output path and assembly name for a library project is just some basic Visual Studio stuff.

1 Like