Can't add Beckhoff ADS server

Dear VC users,

I’m trying to setup TwinCat PLC connection for my simulation model using the Beckhoff ADS interface. However the ADS interface is not available (the plug icon is not yellow) in VC and i’m not able to add server to my project. I have Visual Studio and TwinCat installed on my computer and i have enabled the connectivity features as well. Any thoughts on this?

Thanks in advance,



Hey Toni,

In general the Beckhoff ADS interface should be available if you have at least TwinCat 3.1 ADS (Automation Device Specification) or any version above which includes ADS like XAR (eXtended Automation Runtime) and XAE (eXtended Automation Engineering).

I’ve installed only installed TwinCat 3.1 ADS on my PC and run the PLC in a VM.

I would install one of the below linked ADS versions depending on which version number matches your other TwinCat installation.

TwinCat 3.1 ADS - version 3.1.4020.39

TwinCat 3.1 ADS - version 3.1.4022.2

I hope that fixes your issue!

Greetings Felix :slight_smile:

Hi Felix,

I couldn’t install either one of those packages because another one is older than my current TwinCat installation and the newer one is already installed. I have the newest XAE installed on Visual Studio 2015.

I inspected the log files and there was some errors relating to the ADS. Please, see the attached file.





logfile.txt (1.22 KB)

Hey Toni,

Unfortunately I don’t know how to fix this error.

I have TwinCat 3.1 ADS - version 3.1.4020.28 installed, maybe there is something of with the newer version. I would give the older version a shot.

If this doesn’t help either, I would recommend contacting the support.

Keep us updated & have a nice weekend!

Greeting Felix

Hi Felix!

Installing the older TwinCat version solved the problem. Now everything works like it should. Thanks Felix for your help!



Hey Toni,

Glad we found a workarround! :slight_smile:

But seems like there is an issue with the new TwinCat version then!

Best regards,


I’ve tested both versions. The old version was fine, like expected, but the TwinCat service of the new version didn’t start at all. I think that could’ve caused the problem.

There might be a workaround for the specific dll version requirement.

Find VisualComponents.Engine.exe.config from your VC installation folder and add this to inside the assemblyBinding element near the top of the file:


<assemblyIdentity name=“TwinCAT.Ads” publicKeyToken=“180016cd49e5e8c3” culture=“neutral” />

<bindingRedirect oldVersion=“” newVersion=“” />


This will instruct the CLR to search for version of the TwinCAT.Ads.dll instead of the version our software is built against. You may try targeting other versions of the TwinCAT.Ads.dll available on your GAC as well.

However, if there are functional differences between the dll versions you may get unexpected behavior.

I met the same situation. I installed this one.

Beckhoff ADS interface is not available.

Try Jay’s solution, does not work.


Correction: Jay’s solution actually works! Awesome!

I cannot add variables to link between VC and TwinCAT. After modifying the config file I was able to add the server connection. Clicking “add variables” opens the pop-up where on the left there are the default sensor conveyor variables, but the server (right) side is empty. The connection itself works so starting/pausing the simulation starts/stops the TwinCAT runtime as well. What to do?

The versions I am using are:

  • Visual Components Premium (64-bit)
  • TwinCAT version v3.1.4022

hi felix~~
Have you tried to connect PLC with visual components by Modbus TCP ?
I have a PLC which support Modbus TCP,but don’t support opc TCP.
I can’t connect it by OPC UA server .

Thanks in advance.

Hi juhajunttila,

Check the PLC Control configuration that the ‘Symbol-Download’ under Project / Options / TwinCAT is activated?

Back then I got it working after updating both VC and TwinCAT. I don’t know which one or both was the reason. BUT, now I’m having newer versions again and the feature doesn’t work anymore. Same as previously that it does have the connection between TwinCAT and VC and by pressing play on simulation it starts the runtime on TwinCAT. The button “Add variable pairs…” seen on instruction video is missing.
Current versions are:

  • VC Premium 4.3.1
  • TwinCAT build 4024.17
    I wonder and by which update I get it going again… I’ll inform as I get it.

I would first check the symbol download settings on your TwinCAT project like ahven pointed out.

The Connectivity UI might have changed a bit since the video was recorded, but whether the connection works shouldn’t have any effect on “Add variable pairs” button being shown in the UI or not, only whether you can see any server side variables in the dialog.

Also note that uninstalling TwinCAT doesn’t necessarily uninstall all the ADS dlls from your computer, so if you have had old TwinCAT versions installed they could have left incompatible versions of the dlls behind.

I have a new laptop and only the latest software installed so not any residues from obsolete versions. With previous laptop and a bit older versions it already did work. I cannot see any variables neither add them. The connection between VC and TC works. I can’t find the setting @ahven is pointing out. Could you be more specific, thx!

Try enabling both TMC and TPY files from the “Target Files” settings group here:

It works now. Actually no need to tick TMC nor TPY. I must just had wrong order or something.
So anyways this is how it works:
First on TwinCAT side: Build project; Activate configuration; Login
Then on Visual Components side: (Connectivity Configuration:) Beckhoff ADS Connect; (select) simulation to server (or the other); (after the previous is selected adding variables is now available) Add Variables.

Now I need to play around a while. There’s some aberration compared to instructional video regarding acting as event based or cyclic… but I’ll might get into that in different thread.

Thank you guys for support!

hello TwinCAT3.1.4020 Where to download You can’t open this link

hello You can send me an old version of the code

If you have decently recent version of VC (like 4.3 or maybe even older) it should work fine with up to date versions of TwinCAT.