Cannot select components for Report Statistics


I am following the Report Statistics lesson, and I downloaded the example in the lesson to try out.

I am encountering a problem when selecting the components for the data series.

When I try to ‘Pick Property Value from 3D world’, the red highighted box appears around the conveyor belts but when I click on them, nothing is added to the components. When I try to add/remove items via the list, clicking on the conveyors highlights them in the menu but otherwise does nothing as well. I have tried to restart the program and my computer but neither changed the result.


Please advise.



I was able to do what is shown in the video, for example pick the components from list and 3D world. I used 4.1.2 and perspective mode.

Are you using 4.1.2? What about orthographic mode?

Just to be on the safe side, I am attaching the same layout made with 4.1.2 components and new conveyors from eCat.

Reporting-Statistics.vcmx (459 KB)

I am using 4.1.2. I downloaded your layout and tried again but once again it did not work. Using orthographic did not help either.

I am able to open up this dialogue and select the conveyor belts, but I cannot do anything to ‘confirm’ the selection, I can only close the window which does nothing.

Closing the dialog should confirm the selected items.

Are you using a normal PC? Which operating system? Have you noticed any other issues in the 3d scene. I’m starting to suspect that it might be some sort of a 3d graphics issue.


I am using the program on my laptop, on Windows 10. I am fairly new to this program so I haven’t encountered any other issues.