Application crash on run

Im having problems with the application crashing upon execution.

Im using Visual Components Premium 4.0.4.0 on a trial license and after installation and activation of license, when i try to launch the application it will crash going through the License box and showing the splash screen for the application with the text “Initializing…” shown in the lower left hand corner.

I have attached the log from the application, might be related to .NET 4.0… Below is the top line in the error log.

System.Windows.Markup.XamlParseException: The invocation of the constructor on type 'VisualComponents.UX.Shell.AppBootstrapper' that matches the specified binding constraints threw an exception. ---> System.IO.FileNotFoundException: Could not load file or assembly 'VisualComponents.Revolution.dll' or one of its dependencies. The specified module could not be found.
The file in question is located at C:\Program Files\Visual Components\Visual Components Premium 4.0\

 

And from event viewer:

---------------------------------------------------------------------------------
.NET RUNTIME

Application: VisualComponents.Engine.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.InvalidOperationException
at Caliburn.Micro.IoC.<.cctor>b__0(System.Type, System.String)
at Caliburn.Micro.IoC.Get[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]
at VisualComponents.UX.Shared.VcMessageBox.Show(System.Windows.Window, System.String, System.String, System.Windows.MessageBoxButton, System.Windows.MessageBoxImage, VisualComponents.UX.Shared.MessageBoxResultEx, System.String, System.String, System.String, Boolean, Boolean)
at VisualComponents.UX.Shell.AppBootstrapper+<>c__DisplayClass1b.<OnUnhandledException>b__1a()
at Caliburn.Micro.Execute.OnUIThread(System.Action)
at VisualComponents.UX.Shell.AppBootstrapper.OnUnhandledException(System.Object, System.Windows.Threading.DispatcherUnhandledExceptionEventArgs)
at System.Windows.Threading.Dispatcher.CatchException(System.Exception)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)
at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)
at MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)
at System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)
at System.Windows.Application.RunDispatcher(System.Object)
at System.Windows.Application.RunInternal(System.Windows.Window)
at VisualComponents.UX.Shell.App.Main()


APPLICATION ERROR

Faulting application name: VisualComponents.Engine.exe, version: 4.0.4.0, time stamp: 0x594bacb2
Faulting module name: KERNELBASE.dll, version: 10.0.15063.608, time stamp: 0x943cbf8b
Exception code: 0xe0434352
Fault offset: 0x0000000000069e08
Faulting process id: 0x2590
Faulting application start time: 0x01d340edc4728149
Faulting application path: C:\Program Files\Visual Components\Visual Components Premium 4.0\VisualComponents.Engine.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: c07b7c3a-fad3-4311-8e91-d2dcbfd1e833
Faulting package full name:
Faulting package-relative application ID:

log-file-VisualComponents.Engine.txt (17.7 KB)

This is a .NET runtime error. Suggested solutions from Microsoft community forum ranges from performing an SFC scan to doing a clean install of the OS. Here is the link to Microsoft forum

https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/kernelbasedll-version-100105860-and-net-runtime/e1b5a9e8-a377-4de7-9a1a-df0bd205a963

 

Hello Jay,

I was in touch with tech support through a sales agent and they concluded the issue was on my side and related to kernelbase.dll.
I did some preliminary google searches concerning this and there was no immediate fix for it. It seems to be caused by different stuff including windows user account and i decided i didnt want to spend time on this.
I was able to get a new trial license and i installed it on my desktop instead which works nicely.
Sorry i cant give a better update on how to fix it :frowning: