3D PDF issues in Adobe Reader and Acrobat

If you are experiencing issues with 3D PDF files, for example slow rendering in either Adobe Reader or Acrobat, try the following steps:

  1. Right-click the executable of Acrobat/Reader, and then point at Run with graphics processor and click Integrated graphics.

    If this works, consider modifying the program settings of Acrobat/Reader to use integrated graphics by default. For example, if you are using a NVIDIA graphics card, the NVIDIA control panel allows you to manage 3D settings. From there you can set the preferred GPU of Acrobat (acrobat.exe) and Reader (acrord32.exe). Afterward, reopen Acrobat/Reader and test with your 3D PDF.

    On 2018-03-26, this problem was solved on a Lenovo ThinkPad T470p with Intel(R) HD Graphics 630 with Shader version 5.1 and DirectX 12.
  2. If step 1 did not work or you prefer to use your high-performance GPU, reinstall the drivers for that graphics card. It is recommended to research online beforehand to see if you should rollback the drivers to an earlier version instead of the latest version.
    On 2018-03-26, this problem was solved on a Dell Precision 7510 by re-installing the drivers of the graphical board Nvideo M1000M (Nvidea Driver 375.86 from Download section of Dell)
    On 2018-03-26, this problem was solved on a Dell Precision 7710 by downgrade the driver to an older version (Nvidea Driver 375.92 from Download section of NVidea). It seems that newer drivers did not work.
  3. If step 1 or 2 did not work, you can try editing the 3D & Multimedia options in Acrobat/Reader. For example, under Render Options you can deactivate Enable hardware rendering for legacy video cards and then under Auto-Degrade Options you can set Optimization Scheme for Low Framerate to None. If you do not observe any notable improvement, undo these changes.
  4. As a last resort, reinstall Acrobat/Reader as well as consider remaking the 3D PDF with a different frame rate.
Note: 4.0 product uses DirectX9.

I had the same issue and I could resolve it without changing the graphics card properties to CPU (wasn’t an option in my NVIDIA settings) using the recommended setup from Adobe Forum Post #10427718:

Preferences -> Security (Enhanged) -> unbox “Enable Protected Mode at startup”

Hardware-/Softwaresetup: HP ZBook 17 G3 (i7-6700HQ, NVIDIA M3000M, Driver Version: 385.73)

 

I resolved installing 32 bit version of Acrobat Reader

Yes I would recommend this instead of the solution from OP.

Uncheck protected mode will let you use your dedicated graphic card instead of a ‘crappy’ integrated graphic card.

I agree. If I recall back in 2018 there was an issue with Nvidia or AMD and Adobe, so switching to integrated was a workaround.