TransportLinkView Class

Interaction logic for TransportLinkView.xaml
TransportLinkView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedUserControlOptimizedView
VisualComponents.UX.SharedTransportLinkView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TransportLinkView : UserControlOptimizedView,
    IComponentConnector
public ref class TransportLinkView : public UserControlOptimizedView,
    IComponentConnector

The TransportLinkView type exposes the following members.

Constructors
 | Name | Description
Public method | TransportLinkView | Initializes a new instance of the TransportLinkView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


TransportLinkView Constructor

Initializes a new instance of the TransportLinkView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TransportLinkView()
public:
TransportLinkView()
See Also

Reference

TransportLinkView Class


TransportLinkView Properties

The TransportLinkView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TransportLinkView Class


TransportLinkView Methods

The TransportLinkView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TransportLinkView Class


TransportLinkView.InitializeComponent Method

Visual Components Public API Reference

TransportLinkViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

TransportLinkView Class


TransportLinkView Events

The TransportLinkView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

TransportLinkView Class


TreeFlattener Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedTreeFlattener

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TreeFlattener : IList,
    ICollection, IEnumerable, INotifyCollectionChanged
public ref class TreeFlattener : IList,
    ICollection, IEnumerable, INotifyCollectionChanged

The TreeFlattener type exposes the following members.

Constructors
 | Name | Description
Public method | TreeFlattener | Initializes a new instance of the TreeFlattener class
Top
Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NodesInserted |
Public method | NodesRemoved |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | SortNaturally | Overloaded. Sorts the list naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | SortNaturally(Int32, Int32) | Overloaded. Sorts the list naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


TreeFlattener Constructor

Initializes a new instance of the TreeFlattener class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeFlattener(
    TreeViewEx treeView,
    TreeNodeEx modelRoot,
    bool includeRoot
)
public:
TreeFlattener(
    TreeViewEx^ treeView,
    TreeNodeEx^ modelRoot,
    bool includeRoot
)

Parameters

treeView
Type: VisualComponents.UX.SharedTreeViewEx
modelRoot
Type: VisualComponents.UX.SharedTreeNodeEx
includeRoot
Type: SystemBoolean
See Also

Reference

TreeFlattener Class


TreeFlattener Properties

The TreeFlattener type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

TreeFlattener Class


TreeFlattener.Count Property

TreeFlattenerCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Count { get; }
public:
virtual property int Count {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ICollectionCount
See Also

Reference

TreeFlattener Class


TreeFlattener.Item Property

TreeFlattenerItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object this[
    int index
] { get; set; }
public:
virtual property Object^ default[int index] {
    Object^ get (int index) sealed;
    void set (int index, Object^ value) sealed;
}

Parameters

index
Type: SystemInt32

Property Value

Type: Object

Implements

IListItemInt32
See Also

Reference

TreeFlattener Class


TreeFlattener Methods

The TreeFlattener type exposes the following members.

Methods
 | Name | Description
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NodesInserted |
Public method | NodesRemoved |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | SortNaturally | Overloaded. Sorts the list naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | SortNaturally(Int32, Int32) | Overloaded. Sorts the list naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TreeFlattener Class


TreeFlattener.Contains Method

TreeFlattenerContains Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    Object item
)
public:
virtual bool Contains(
    Object^ item
) sealed

Parameters

item
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeFlattener.Contains(System.Object)"]

Implements

IListContains(Object)
See Also

Reference

TreeFlattener Class


TreeFlattener.CopyTo Method

TreeFlattenerCopyTo Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CopyTo(
    Array array,
    int arrayIndex
)
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
) sealed

Parameters

array
Type: SystemArray
arrayIndex
Type: SystemInt32

Implements

ICollectionCopyTo(Array, Int32)
See Also

Reference

TreeFlattener Class


TreeFlattener.GetEnumerator Method

TreeFlattenerGetEnumerator Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerator GetEnumerator()
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

Type: IEnumerator

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeFlattener.GetEnumerator"]

Implements

IEnumerableGetEnumerator
See Also

Reference

TreeFlattener Class


TreeFlattener.IndexOf Method

TreeFlattenerIndexOf Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    Object item
)
public:
virtual int IndexOf(
    Object^ item
) sealed

Parameters

item
Type: SystemObject

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeFlattener.IndexOf(System.Object)"]

Implements

IListIndexOf(Object)
See Also

Reference

TreeFlattener Class


TreeFlattener.NodesInserted Method

TreeFlattenerNodesInserted Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NodesInserted(
    int index,
    IEnumerable<TreeNodeEx> nodes
)
public:
void NodesInserted(
    int index,
    IEnumerable<TreeNodeEx^>^ nodes
)

Parameters

index
Type: SystemInt32
nodes
Type: System.Collections.GenericIEnumerableTreeNodeEx
See Also

Reference

TreeFlattener Class


TreeFlattener.NodesRemoved Method

TreeFlattenerNodesRemoved Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NodesRemoved(
    int index,
    IEnumerable<TreeNodeEx> nodes
)
public:
void NodesRemoved(
    int index,
    IEnumerable<TreeNodeEx^>^ nodes
)

Parameters

index
Type: SystemInt32
nodes
Type: System.Collections.GenericIEnumerableTreeNodeEx
See Also

Reference

TreeFlattener Class


TreeFlattener Events

The TreeFlattener type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged |
Top
See Also

Reference

TreeFlattener Class


TreeFlattener.CollectionChanged Event

TreeFlattenerCollectionChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
public:
virtual  event NotifyCollectionChangedEventHandler^ CollectionChanged {
    void add (NotifyCollectionChangedEventHandler^ value);
    void remove (NotifyCollectionChangedEventHandler^ value);
}

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

TreeFlattener Class


TreeGridView Class

Adds the ability to present data in columns for TreeViewEx.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsViewBase
System.Windows.ControlsGridView
VisualComponents.UX.SharedTreeGridView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TreeGridView : GridView
public ref class TreeGridView : public GridView

The TreeGridView type exposes the following members.

Constructors
 | Name | Description
Public method | TreeGridView | Initializes a new instance of the TreeGridView class
Top
Properties
 | Name | Description
Public property | AllowsColumnReorder | Gets or sets whether columns in a GridView can be reordered by a drag-and-drop operation. (Inherited from GridView.)
Public property | ColumnHeaderContainerStyle | Gets or sets the style to apply to column headers. (Inherited from GridView.)
Public property | ColumnHeaderContextMenu | Gets or sets a ContextMenu for the GridView. (Inherited from GridView.)
Public property | ColumnHeaderStringFormat | Gets or sets a composite string that specifies how to format the column headers of the GridView if they are displayed as strings. (Inherited from GridView.)
Public property | ColumnHeaderTemplate | Gets or sets a template to use to display the column headers. (Inherited from GridView.)
Public property | ColumnHeaderTemplateSelector | Gets or sets the selector object that provides logic for selecting a template to use for each column header. (Inherited from GridView.)
Public property | ColumnHeaderToolTip | Gets or sets the content of a tooltip that appears when the mouse pointer pauses over one of the column headers. (Inherited from GridView.)
Public property | Columns | Gets the collection of GridViewColumn objects that is defined for this GridView. (Inherited from GridView.)
Protected property | DefaultStyleKey | Gets the reference for the default style for the GridView. (Inherited from GridView.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Protected property | ItemContainerDefaultStyleKey | (Overrides GridViewItemContainerDefaultStyleKey.)
 | ItemContainerStyleKey |
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a GridViewColumn object to a GridView. (Inherited from GridView.)
Protected method | AddText | Not supported. (Inherited from GridView.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearItem | Removes all settings, bindings, and styling from a ListViewItem. (Inherited from GridView.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutomationPeer | Gets the AutomationPeer implementation for this GridView object. (Inherited from GridView.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Protected method | PrepareItem | Prepares a ListViewItem for display according to the definition of this GridView object. (Inherited from GridView.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of the GridView object. (Inherited from GridView.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


TreeGridView Constructor

Initializes a new instance of the TreeGridView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeGridView()
public:
TreeGridView()
See Also

Reference

TreeGridView Class


TreeGridView Properties

The TreeGridView type exposes the following members.

Properties
 | Name | Description
Public property | AllowsColumnReorder | Gets or sets whether columns in a GridView can be reordered by a drag-and-drop operation. (Inherited from GridView.)
Public property | ColumnHeaderContainerStyle | Gets or sets the style to apply to column headers. (Inherited from GridView.)
Public property | ColumnHeaderContextMenu | Gets or sets a ContextMenu for the GridView. (Inherited from GridView.)
Public property | ColumnHeaderStringFormat | Gets or sets a composite string that specifies how to format the column headers of the GridView if they are displayed as strings. (Inherited from GridView.)
Public property | ColumnHeaderTemplate | Gets or sets a template to use to display the column headers. (Inherited from GridView.)
Public property | ColumnHeaderTemplateSelector | Gets or sets the selector object that provides logic for selecting a template to use for each column header. (Inherited from GridView.)
Public property | ColumnHeaderToolTip | Gets or sets the content of a tooltip that appears when the mouse pointer pauses over one of the column headers. (Inherited from GridView.)
Public property | Columns | Gets the collection of GridViewColumn objects that is defined for this GridView. (Inherited from GridView.)
Protected property | DefaultStyleKey | Gets the reference for the default style for the GridView. (Inherited from GridView.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Protected property | ItemContainerDefaultStyleKey | (Overrides GridViewItemContainerDefaultStyleKey.)
 | ItemContainerStyleKey |
Top
See Also

Reference

TreeGridView Class


TreeGridView.ItemContainerDefaultStyleKey Property

TreeGridViewItemContainerDefaultStyleKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Object ItemContainerDefaultStyleKey { get; }
protected:
virtual property Object^ ItemContainerDefaultStyleKey {
    Object^ get () override;
}

Property Value

Type: Object
See Also

Reference

TreeGridView Class


TreeGridView.ItemContainerStyleKey Property

TreeGridViewItemContainerStyleKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ResourceKey ItemContainerStyleKey { get; }
public:
static property ResourceKey^ ItemContainerStyleKey {
    ResourceKey^ get ();
}

Property Value

Type: ResourceKey
See Also

Reference

TreeGridView Class


TreeGridView Methods

The TreeGridView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a GridViewColumn object to a GridView. (Inherited from GridView.)
Protected method | AddText | Not supported. (Inherited from GridView.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearItem | Removes all settings, bindings, and styling from a ListViewItem. (Inherited from GridView.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutomationPeer | Gets the AutomationPeer implementation for this GridView object. (Inherited from GridView.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Protected method | PrepareItem | Prepares a ListViewItem for display according to the definition of this GridView object. (Inherited from GridView.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of the GridView object. (Inherited from GridView.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TreeGridView Class


TreeMode Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TreeMode
public enum class TreeMode
Members
Member name | Value | Description
Combined | 0 |
FeaturesOnly | 1 |
ComponentOnly | 2 |
See Also

Reference


TreeNodeCollectionEx Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedTreeNodeCollectionEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class TreeNodeCollectionEx : IList,
    ICollection, IEnumerable, IList<TreeNodeEx>, ICollection<TreeNodeEx>,
    IEnumerable<TreeNodeEx>, INotifyCollectionChanged, INotifyPropertyChanged
public ref class TreeNodeCollectionEx sealed : IList,
    ICollection, IEnumerable, IList<TreeNodeEx^>, ICollection<TreeNodeEx^>,
    IEnumerable<TreeNodeEx^>, INotifyCollectionChanged, INotifyPropertyChanged

The TreeNodeCollectionEx type exposes the following members.

Constructors
 | Name | Description
Public method | TreeNodeCollectionEx | Initializes a new instance of the TreeNodeCollectionEx class
Top
Properties
 | Name | Description
Public property | Count |
Public property | IsFixedSize |
Public property | IsReadOnly |
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |
Top
Methods
 | Name | Description
Public method | Add(Object) |
Public method | Add(TreeNodeEx) |
Public method | AddRange |
Public method | Clear |
Public method | Contains(Object) |
Public method | Contains(TreeNodeEx) |
Public method | CopyTo(Array, Int32) |
Public method | CopyTo(TreeNodeEx, Int32) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Object) |
Public method | IndexOf(TreeNodeEx) |
Public method | Insert(Int32, Object) |
Public method | Insert(Int32, TreeNodeEx) |
Public method | InsertRange |
Public method | Move |
Public method | Remove(Object) |
Public method | Remove(TreeNodeEx) |
Public method | RemoveAt |
Public method | Swap |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged |
Public event | PropertyChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachTreeNodeEx | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanTreeNodeEx | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | SortNaturally | Overloaded. Sorts the list naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | SortNaturally(Int32, Int32) | Overloaded. Sorts the list naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | ToObservableCollectionTreeNodeEx | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExTreeNodeEx | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


TreeNodeCollectionEx Constructor

Initializes a new instance of the TreeNodeCollectionEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeCollectionEx(
    TreeNodeEx node
)
public:
TreeNodeCollectionEx(
    TreeNodeEx^ node
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx Properties

The TreeNodeCollectionEx type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | IsFixedSize |
Public property | IsReadOnly |
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |
Top
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Count Property

TreeNodeCollectionExCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Count { get; }
public:
virtual property int Count {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ICollectionCount
ICollectionTCount
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.IsFixedSize Property

TreeNodeCollectionExIsFixedSize Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsFixedSize { get; }
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IListIsFixedSize
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.IsReadOnly Property

TreeNodeCollectionExIsReadOnly Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsReadOnly { get; }
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IListIsReadOnly
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.IsSynchronized Property

TreeNodeCollectionExIsSynchronized Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSynchronized { get; }
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICollectionIsSynchronized
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Item Property

TreeNodeCollectionExItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx this[
    int index
] { get; set; }
public:
virtual property TreeNodeEx^ default[int index] {
    TreeNodeEx^ get (int index) sealed;
    void set (int index, TreeNodeEx^ value) sealed;
}

Parameters

index
Type: SystemInt32

Property Value

Type: TreeNodeEx

Implements

IListTItemInt32
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.SyncRoot Property

TreeNodeCollectionExSyncRoot Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object SyncRoot { get; }
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Property Value

Type: Object

Implements

ICollectionSyncRoot
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx Methods

The TreeNodeCollectionEx type exposes the following members.

Methods
 | Name | Description
Public method | Add(Object) |
Public method | Add(TreeNodeEx) |
Public method | AddRange |
Public method | Clear |
Public method | Contains(Object) |
Public method | Contains(TreeNodeEx) |
Public method | CopyTo(Array, Int32) |
Public method | CopyTo(TreeNodeEx, Int32) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Object) |
Public method | IndexOf(TreeNodeEx) |
Public method | Insert(Int32, Object) |
Public method | Insert(Int32, TreeNodeEx) |
Public method | InsertRange |
Public method | Move |
Public method | Remove(Object) |
Public method | Remove(TreeNodeEx) |
Public method | RemoveAt |
Public method | Swap |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachTreeNodeEx | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanTreeNodeEx | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | SortNaturally | Overloaded. Sorts the list naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | SortNaturally(Int32, Int32) | Overloaded. Sorts the list naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | ToObservableCollectionTreeNodeEx | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExTreeNodeEx | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Add Method

TreeNodeCollectionExAdd Method

Overload List
 | Name | Description
Public method | Add(Object) |
Public method | Add(TreeNodeEx) |
Top
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Add Method (Object)

TreeNodeCollectionExAdd Method (Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Add(
    Object value
)
public:
virtual int Add(
    Object^ value
) sealed

Parameters

value
Type: SystemObject

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeCollectionEx.Add(System.Object)"]

Implements

IListAdd(Object)
See Also

Reference

TreeNodeCollectionEx Class
Add Overload


TreeNodeCollectionEx.Add Method (TreeNodeEx)

TreeNodeCollectionExAdd Method (TreeNodeEx)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    TreeNodeEx node
)
public:
virtual void Add(
    TreeNodeEx^ node
) sealed

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx

Implements

ICollectionTAdd(T)
See Also

Reference

TreeNodeCollectionEx Class
Add Overload


TreeNodeCollectionEx.AddRange Method

TreeNodeCollectionExAddRange Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddRange(
    IEnumerable<TreeNodeEx> nodes
)
public:
void AddRange(
    IEnumerable<TreeNodeEx^>^ nodes
)

Parameters

nodes
Type: System.Collections.GenericIEnumerableTreeNodeEx
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Clear Method

TreeNodeCollectionExClear Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
virtual void Clear() sealed

Implements

IListClear
ICollectionTClear
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Contains Method

TreeNodeCollectionExContains Method

Overload List
 | Name | Description
Public method | Contains(Object) |
Public method | Contains(TreeNodeEx) |
Top
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Contains Method (Object)

TreeNodeCollectionExContains Method (Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    Object value
)
public:
virtual bool Contains(
    Object^ value
) sealed

Parameters

value
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeCollectionEx.Contains(System.Object)"]

Implements

IListContains(Object)
See Also

Reference

TreeNodeCollectionEx Class
Contains Overload


TreeNodeCollectionEx.Contains Method (TreeNodeEx)

TreeNodeCollectionExContains Method (TreeNodeEx)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    TreeNodeEx node
)
public:
virtual bool Contains(
    TreeNodeEx^ node
) sealed

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeCollectionEx.Contains(VisualComponents.UX.Shared.TreeNodeEx)"]

Implements

ICollectionTContains(T)
See Also

Reference

TreeNodeCollectionEx Class
Contains Overload


TreeNodeCollectionEx.CopyTo Method

TreeNodeCollectionExCopyTo Method

Overload List
 | Name | Description
Public method | CopyTo(Array, Int32) |
Public method | CopyTo(TreeNodeEx, Int32) |
Top
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.CopyTo Method (Array, Int32)

TreeNodeCollectionExCopyTo Method (Array, Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CopyTo(
    Array array,
    int index
)
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: SystemArray
index
Type: SystemInt32

Implements

ICollectionCopyTo(Array, Int32)
See Also

Reference

TreeNodeCollectionEx Class
CopyTo Overload


TreeNodeCollectionEx.CopyTo Method (TreeNodeEx[], Int32)

TreeNodeCollectionExCopyTo Method (TreeNodeEx, Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CopyTo(
    TreeNodeEx[] array,
    int arrayIndex
)
public:
virtual void CopyTo(
    array<TreeNodeEx^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: VisualComponents.UX.SharedTreeNodeEx
arrayIndex
Type: SystemInt32

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

TreeNodeCollectionEx Class
CopyTo Overload


TreeNodeCollectionEx.GetEnumerator Method

TreeNodeCollectionExGetEnumerator Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerator<TreeNodeEx> GetEnumerator()
public:
virtual IEnumerator<TreeNodeEx^>^ GetEnumerator() sealed

Return Value

Type: IEnumeratorTreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeCollectionEx.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.IndexOf Method

TreeNodeCollectionExIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(Object) |
Public method | IndexOf(TreeNodeEx) |
Top
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.IndexOf Method (Object)

TreeNodeCollectionExIndexOf Method (Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    Object value
)
public:
virtual int IndexOf(
    Object^ value
) sealed

Parameters

value
Type: SystemObject

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeCollectionEx.IndexOf(System.Object)"]

Implements

IListIndexOf(Object)
See Also

Reference

TreeNodeCollectionEx Class
IndexOf Overload


TreeNodeCollectionEx.IndexOf Method (TreeNodeEx)

TreeNodeCollectionExIndexOf Method (TreeNodeEx)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    TreeNodeEx node
)
public:
virtual int IndexOf(
    TreeNodeEx^ node
) sealed

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeCollectionEx.IndexOf(VisualComponents.UX.Shared.TreeNodeEx)"]

Implements

IListTIndexOf(T)
See Also

Reference

TreeNodeCollectionEx Class
IndexOf Overload


TreeNodeCollectionEx.Insert Method

TreeNodeCollectionExInsert Method

Overload List
 | Name | Description
Public method | Insert(Int32, Object) |
Public method | Insert(Int32, TreeNodeEx) |
Top
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Insert Method (Int32, Object)

TreeNodeCollectionExInsert Method (Int32, Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Insert(
    int index,
    Object value
)
public:
virtual void Insert(
    int index,
    Object^ value
) sealed

Parameters

index
Type: SystemInt32
value
Type: SystemObject

Implements

IListInsert(Int32, Object)
See Also

Reference

TreeNodeCollectionEx Class
Insert Overload


TreeNodeCollectionEx.Insert Method (Int32, TreeNodeEx)

TreeNodeCollectionExInsert Method (Int32, TreeNodeEx)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Insert(
    int index,
    TreeNodeEx node
)
public:
virtual void Insert(
    int index,
    TreeNodeEx^ node
) sealed

Parameters

index
Type: SystemInt32
node
Type: VisualComponents.UX.SharedTreeNodeEx

Implements

IListTInsert(Int32, T)
See Also

Reference

TreeNodeCollectionEx Class
Insert Overload


TreeNodeCollectionEx.InsertRange Method

TreeNodeCollectionExInsertRange Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InsertRange(
    int index,
    IEnumerable<TreeNodeEx> nodes
)
public:
void InsertRange(
    int index,
    IEnumerable<TreeNodeEx^>^ nodes
)

Parameters

index
Type: SystemInt32
nodes
Type: System.Collections.GenericIEnumerableTreeNodeEx
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Move Method

TreeNodeCollectionExMove Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Move(
    int sourceIndex,
    int targetIndex
)
public:
void Move(
    int sourceIndex,
    int targetIndex
)

Parameters

sourceIndex
Type: SystemInt32
targetIndex
Type: SystemInt32
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Remove Method

TreeNodeCollectionExRemove Method

Overload List
 | Name | Description
Public method | Remove(Object) |
Public method | Remove(TreeNodeEx) |
Top
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Remove Method (Object)

TreeNodeCollectionExRemove Method (Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Remove(
    Object value
)
public:
virtual void Remove(
    Object^ value
) sealed

Parameters

value
Type: SystemObject

Implements

IListRemove(Object)
See Also

Reference

TreeNodeCollectionEx Class
Remove Overload


TreeNodeCollectionEx.Remove Method (TreeNodeEx)

TreeNodeCollectionExRemove Method (TreeNodeEx)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Remove(
    TreeNodeEx item
)
public:
virtual bool Remove(
    TreeNodeEx^ item
) sealed

Parameters

item
Type: VisualComponents.UX.SharedTreeNodeEx

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeCollectionEx.Remove(VisualComponents.UX.Shared.TreeNodeEx)"]

Implements

ICollectionTRemove(T)
See Also

Reference

TreeNodeCollectionEx Class
Remove Overload


TreeNodeCollectionEx.RemoveAt Method

TreeNodeCollectionExRemoveAt Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveAt(
    int index
)
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: SystemInt32

Implements

IListRemoveAt(Int32)
IListTRemoveAt(Int32)
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.Swap Method

TreeNodeCollectionExSwap Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Swap(
    int sourceIndex,
    int targetIndex
)
public:
void Swap(
    int sourceIndex,
    int targetIndex
)

Parameters

sourceIndex
Type: SystemInt32
targetIndex
Type: SystemInt32
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx Events

The TreeNodeCollectionEx type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged |
Public event | PropertyChanged |
Top
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.CollectionChanged Event

TreeNodeCollectionExCollectionChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
public:
virtual  event NotifyCollectionChangedEventHandler^ CollectionChanged {
    void add (NotifyCollectionChangedEventHandler^ value);
    void remove (NotifyCollectionChangedEventHandler^ value);
}

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeCollectionEx.PropertyChanged Event

TreeNodeCollectionExPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

TreeNodeCollectionEx Class


TreeNodeEx Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedTreeNodeEx
VisualComponents.UX.SharedPlaceholderNode

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TreeNodeEx : INotifyPropertyChanged, IListViewExItem,
    ICloneable
public ref class TreeNodeEx : INotifyPropertyChanged,
    IListViewExItem, ICloneable

The TreeNodeEx type exposes the following members.

Constructors
 | Name | Description
Public method | TreeNodeEx | Initializes a new instance of the TreeNodeEx class
Top
Properties
 | Name | Description
Public property | AllowsNodeReorder |
Public property | CanExpandRecursively |
Public property | CanHostPlaceholder |
Public property | CheckBoxToolTip |
Public property | ChildCollection |
Public property | Children |
Public property | Content |
Public property | ContextMenu |
Public property | DropIndicatorBottom |
Public property | DropIndicatorLeft |
Public property | DropIndicatorRight |
Public property | DropIndicatorTop |
Public property | ExpandedIcon |
Public property | FixedArea |
Public property | FixedAreaToolTip |
Public property | Foreground |
Public property | HasDropLocationChanged |
Public property | Icon |
Public property | IconResolved |
Public property | IconToolTip |
Public property | Indent |
Public property | IsAcceptable |
Public property | IsAncestorBeingCopied |
Public property | IsAncestorBeingDragged |
Public property | IsAnchor |
Public property | IsBeingCopied |
Public property | IsBeingDragged |
Public property | IsCheckable |
Public property | IsChecked |
Public property | IsCloneable |
Public property | IsDropTargetItem |
Public property | IsEditable |
Public property | IsEditing |
Public property | IsExpandable |
Public property | IsExpanded |
Public property | IsFirst |
Public property | IsLast |
Public property | IsLazy |
Public property | IsPlaceholder |
Public property | IsRemovable |
Public property | IsSelectable |
Public property | IsSelected |
Public property | IsTabStop |
Public property | IsVisible |
Public property | IsVisibleInTree |
Public property | ItemDropSide |
Public property | ItemsSource |
Public property | Level |
Public property | Parent |
Public property | Placeholder |
Public property | PlaceholderIndex |
Public property | RemoveButtonToolTip |
Public property | RemoveNodeCommand |
Public property | ShowIcon |
Public property | ShowLines |
Public property | Source |
Public property | ToolTip |
Public property | TreeView |
Public property | WasAncestorCut |
Public property | WasCut |
Top
Methods
 | Name | Description
Public method | AcceptData |
 | AddPlaceholder |
Public method | Ancestors |
Public method | AncestorsAndSelf |
Public method | CanAcceptData |
Public method | Clone |
Public method | Descendants |
Public method | DescendantsAndSelf |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExpandRecursively |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlattenTreeNodeEx(IEnumerableTreeNodeEx, FuncTreeNodeEx, IEnumerableTreeNodeEx) |
 | FlattenTreeNodeEx(TreeNodeEx, FuncTreeNodeEx, IEnumerableTreeNodeEx) |
Protected method | GetCanExpandRecursively |
Protected method | GetCanHostPlaceholder |
Protected method | GetChildren |
Public method | GetData |
Protected method | GetExpandedIcon |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIcon |
Protected method | GetIsChecked |
Protected method | GetIsExpandable |
Protected method | GetIsExpanded |
Protected method | GetIsFirst |
Protected method | GetIsLast |
Protected method | GetIsLazy |
Protected method | GetIsPlaceholder |
Protected method | GetIsVisible |
Protected method | GetIsVisibleInTree |
Protected method | GetParent |
Protected method | GetPlaceholder |
Protected method | GetPlaceholderIndex |
Protected method | GetShowIcon |
Protected method | GetShowLines |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadEditText |
Public method | LoadLazyChildren |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnChecked |
Public method | OnCheckReset |
Public method | OnCollapsed |
Public method | OnContextMenuOpening |
Public method | OnDoubleClick |
Public method | OnEnterPress |
Public method | OnExpanded |
Protected method | OnLazyLoading |
Public method | OnMinusPress |
Public method | OnMouseEnter |
Public method | OnMouseLeave |
Public method | OnMouseMove |
Public method | OnPlusPress |
Public method | OnPropertyChanged |
Public method | OnRemoveButtonClick |
Public method | OnSlashPress |
Public method | OnSpacePress |
Public method | OnStarPress |
Public method | OnUnchecked |
Public method | RaisePropertyChanged |
 | RemovePlaceholder |
Public method | SaveEditText |
Public method | ToString | (Overrides ObjectToString.)
 | UpdatePlaceholder |
Public method | VisibleDescendants |
Public method | VisibleDescendantsAndSelf |
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Protected field | _clone |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


TreeNodeEx Constructor

Initializes a new instance of the TreeNodeEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx()
public:
TreeNodeEx()
See Also

Reference

TreeNodeEx Class


TreeNodeEx Properties

The TreeNodeEx type exposes the following members.

Properties
 | Name | Description
Public property | AllowsNodeReorder |
Public property | CanExpandRecursively |
Public property | CanHostPlaceholder |
Public property | CheckBoxToolTip |
Public property | ChildCollection |
Public property | Children |
Public property | Content |
Public property | ContextMenu |
Public property | DropIndicatorBottom |
Public property | DropIndicatorLeft |
Public property | DropIndicatorRight |
Public property | DropIndicatorTop |
Public property | ExpandedIcon |
Public property | FixedArea |
Public property | FixedAreaToolTip |
Public property | Foreground |
Public property | HasDropLocationChanged |
Public property | Icon |
Public property | IconResolved |
Public property | IconToolTip |
Public property | Indent |
Public property | IsAcceptable |
Public property | IsAncestorBeingCopied |
Public property | IsAncestorBeingDragged |
Public property | IsAnchor |
Public property | IsBeingCopied |
Public property | IsBeingDragged |
Public property | IsCheckable |
Public property | IsChecked |
Public property | IsCloneable |
Public property | IsDropTargetItem |
Public property | IsEditable |
Public property | IsEditing |
Public property | IsExpandable |
Public property | IsExpanded |
Public property | IsFirst |
Public property | IsLast |
Public property | IsLazy |
Public property | IsPlaceholder |
Public property | IsRemovable |
Public property | IsSelectable |
Public property | IsSelected |
Public property | IsTabStop |
Public property | IsVisible |
Public property | IsVisibleInTree |
Public property | ItemDropSide |
Public property | ItemsSource |
Public property | Level |
Public property | Parent |
Public property | Placeholder |
Public property | PlaceholderIndex |
Public property | RemoveButtonToolTip |
Public property | RemoveNodeCommand |
Public property | ShowIcon |
Public property | ShowLines |
Public property | Source |
Public property | ToolTip |
Public property | TreeView |
Public property | WasAncestorCut |
Public property | WasCut |
Top
See Also

Reference

TreeNodeEx Class


TreeNodeEx.AllowsNodeReorder Property

TreeNodeExAllowsNodeReorder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool AllowsNodeReorder { get; set; }
public:
virtual property bool AllowsNodeReorder {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.CanExpandRecursively Property

TreeNodeExCanExpandRecursively Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanExpandRecursively { get; set; }
public:
property bool CanExpandRecursively {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.CanHostPlaceholder Property

TreeNodeExCanHostPlaceholder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanHostPlaceholder { get; set; }
public:
property bool CanHostPlaceholder {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.CheckBoxToolTip Property

TreeNodeExCheckBoxToolTip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object CheckBoxToolTip { get; set; }
public:
virtual property Object^ CheckBoxToolTip {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.ChildCollection Property

TreeNodeExChildCollection Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeCollectionEx ChildCollection { get; }
public:
property TreeNodeCollectionEx^ ChildCollection {
    TreeNodeCollectionEx^ get ();
}

Property Value

Type: TreeNodeCollectionEx
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Children Property

TreeNodeExChildren Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<TreeNodeEx> Children { get; set; }
public:
property IList<TreeNodeEx^>^ Children {
    IList<TreeNodeEx^>^ get ();
    void set (IList<TreeNodeEx^>^ value);
}

Property Value

Type: IListTreeNodeEx
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Content Property

TreeNodeExContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object Content { get; set; }
public:
virtual property Object^ Content {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.ContextMenu Property

TreeNodeExContextMenu Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual IList ContextMenu { get; set; }
public:
virtual property IList^ ContextMenu {
    IList^ get ();
    void set (IList^ value);
}

Property Value

Type: IList
See Also

Reference

TreeNodeEx Class


TreeNodeEx.DropIndicatorBottom Property

TreeNodeExDropIndicatorBottom Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual FrameworkElement DropIndicatorBottom { get; set; }
public:
virtual property FrameworkElement^ DropIndicatorBottom {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement

Implements

IListViewExItemDropIndicatorBottom
See Also

Reference

TreeNodeEx Class


TreeNodeEx.DropIndicatorLeft Property

TreeNodeExDropIndicatorLeft Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual FrameworkElement DropIndicatorLeft { get; set; }
public:
virtual property FrameworkElement^ DropIndicatorLeft {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement

Implements

IListViewExItemDropIndicatorLeft
See Also

Reference

TreeNodeEx Class


TreeNodeEx.DropIndicatorRight Property

TreeNodeExDropIndicatorRight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual FrameworkElement DropIndicatorRight { get; set; }
public:
virtual property FrameworkElement^ DropIndicatorRight {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement

Implements

IListViewExItemDropIndicatorRight
See Also

Reference

TreeNodeEx Class


TreeNodeEx.DropIndicatorTop Property

TreeNodeExDropIndicatorTop Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual FrameworkElement DropIndicatorTop { get; set; }
public:
virtual property FrameworkElement^ DropIndicatorTop {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement

Implements

IListViewExItemDropIndicatorTop
See Also

Reference

TreeNodeEx Class


TreeNodeEx.ExpandedIcon Property

TreeNodeExExpandedIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ExpandedIcon { get; set; }
public:
property Object^ ExpandedIcon {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.FixedArea Property

TreeNodeExFixedArea Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object FixedArea { get; set; }
public:
virtual property Object^ FixedArea {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.FixedAreaToolTip Property

TreeNodeExFixedAreaToolTip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object FixedAreaToolTip { get; set; }
public:
virtual property Object^ FixedAreaToolTip {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Foreground Property

TreeNodeExForeground Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Brush Foreground { get; set; }
public:
virtual property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeNodeEx Class


TreeNodeEx.HasDropLocationChanged Property

TreeNodeExHasDropLocationChanged Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool HasDropLocationChanged { get; set; }
public:
virtual property bool HasDropLocationChanged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IListViewExItemHasDropLocationChanged
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Icon Property

TreeNodeExIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Icon { get; set; }
public:
property Object^ Icon {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IconResolved Property

TreeNodeExIconResolved Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object IconResolved { get; }
public:
virtual property Object^ IconResolved {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IconToolTip Property

TreeNodeExIconToolTip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object IconToolTip { get; set; }
public:
virtual property Object^ IconToolTip {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Indent Property

TreeNodeExIndent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Indent { get; }
public:
property double Indent {
    double get ();
}

Property Value

Type: Double
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsAcceptable Property

TreeNodeExIsAcceptable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsAcceptable { get; }
public:
virtual property bool IsAcceptable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsAncestorBeingCopied Property

TreeNodeExIsAncestorBeingCopied Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsAncestorBeingCopied { get; }
public:
virtual property bool IsAncestorBeingCopied {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsAncestorBeingDragged Property

TreeNodeExIsAncestorBeingDragged Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsAncestorBeingDragged { get; }
public:
virtual property bool IsAncestorBeingDragged {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsAnchor Property

TreeNodeExIsAnchor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsAnchor { get; set; }
public:
virtual property bool IsAnchor {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IListViewExItemIsAnchor
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsBeingCopied Property

TreeNodeExIsBeingCopied Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsBeingCopied { get; set; }
public:
virtual property bool IsBeingCopied {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IListViewExItemIsBeingCopied
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsBeingDragged Property

TreeNodeExIsBeingDragged Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsBeingDragged { get; set; }
public:
virtual property bool IsBeingDragged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IListViewExItemIsBeingDragged
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsCheckable Property

TreeNodeExIsCheckable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsCheckable { get; set; }
public:
virtual property bool IsCheckable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsChecked Property

TreeNodeExIsChecked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> IsChecked { get; set; }
public:
property Nullable<bool> IsChecked {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsCloneable Property

TreeNodeExIsCloneable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsCloneable { get; set; }
public:
virtual property bool IsCloneable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IListViewExItemIsCloneable
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsDropTargetItem Property

TreeNodeExIsDropTargetItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsDropTargetItem { get; set; }
public:
virtual property bool IsDropTargetItem {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IListViewExItemIsDropTargetItem
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsEditable Property

TreeNodeExIsEditable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsEditable { get; }
public:
virtual property bool IsEditable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsEditing Property

TreeNodeExIsEditing Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEditing { get; set; }
public:
property bool IsEditing {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsExpandable Property

TreeNodeExIsExpandable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsExpandable { get; set; }
public:
property bool IsExpandable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsExpanded Property

TreeNodeExIsExpanded Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsExpanded { get; set; }
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsFirst Property

TreeNodeExIsFirst Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsFirst { get; }
public:
property bool IsFirst {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsLast Property

TreeNodeExIsLast Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLast { get; }
public:
property bool IsLast {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsLazy Property

TreeNodeExIsLazy Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLazy { get; set; }
public:
property bool IsLazy {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsPlaceholder Property

TreeNodeExIsPlaceholder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPlaceholder { get; }
public:
property bool IsPlaceholder {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsRemovable Property

TreeNodeExIsRemovable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsRemovable { get; set; }
public:
virtual property bool IsRemovable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IListViewExItemIsRemovable
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsSelectable Property

TreeNodeExIsSelectable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsSelectable { get; set; }
public:
virtual property bool IsSelectable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsSelected Property

TreeNodeExIsSelected Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsSelected { get; set; }
public:
virtual property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IListViewExItemIsSelected
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsTabStop Property

TreeNodeExIsTabStop Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsTabStop { get; set; }
public:
virtual property bool IsTabStop {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsVisible Property

TreeNodeExIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.IsVisibleInTree Property

TreeNodeExIsVisibleInTree Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisibleInTree { get; }
public:
property bool IsVisibleInTree {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.ItemDropSide Property

TreeNodeExItemDropSide Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual ItemDropSide ItemDropSide { get; set; }
public:
virtual property ItemDropSide ItemDropSide {
    ItemDropSide get ();
    void set (ItemDropSide value);
}

Property Value

Type: ItemDropSide

Implements

IListViewExItemItemDropSide
See Also

Reference

TreeNodeEx Class


TreeNodeEx.ItemsSource Property

TreeNodeExItemsSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList ItemsSource { get; set; }
public:
virtual property IList^ ItemsSource {
    IList^ get () sealed;
    void set (IList^ value) sealed;
}

Property Value

Type: IList

Implements

IListViewExItemItemsSource
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Level Property

TreeNodeExLevel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Level { get; }
public:
property int Level {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Parent Property

TreeNodeExParent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Parent { get; set; }
public:
property TreeNodeEx^ Parent {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Placeholder Property

TreeNodeExPlaceholder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Placeholder { get; set; }
public:
property TreeNodeEx^ Placeholder {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

TreeNodeEx Class


TreeNodeEx.PlaceholderIndex Property

TreeNodeExPlaceholderIndex Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int PlaceholderIndex { get; set; }
public:
property int PlaceholderIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TreeNodeEx Class


TreeNodeEx.RemoveButtonToolTip Property

TreeNodeExRemoveButtonToolTip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object RemoveButtonToolTip { get; set; }
public:
virtual property Object^ RemoveButtonToolTip {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.RemoveNodeCommand Property

TreeNodeExRemoveNodeCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommand RemoveNodeCommand { get; }
public:
property ICommand^ RemoveNodeCommand {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

TreeNodeEx Class


TreeNodeEx.ShowIcon Property

TreeNodeExShowIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowIcon { get; set; }
public:
property bool ShowIcon {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.ShowLines Property

TreeNodeExShowLines Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool ShowLines { get; set; }
public:
virtual property bool ShowLines {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Source Property

TreeNodeExSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object Source { get; set; }
public:
virtual property Object^ Source {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.ToolTip Property

TreeNodeExToolTip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object ToolTip { get; set; }
public:
virtual property Object^ ToolTip {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeEx Class


TreeNodeEx.TreeView Property

TreeNodeExTreeView Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewEx TreeView { get; }
public:
property TreeViewEx^ TreeView {
    TreeViewEx^ get ();
}

Property Value

Type: TreeViewEx
See Also

Reference

TreeNodeEx Class


TreeNodeEx.WasAncestorCut Property

TreeNodeExWasAncestorCut Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool WasAncestorCut { get; }
public:
virtual property bool WasAncestorCut {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.WasCut Property

TreeNodeExWasCut Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool WasCut { get; set; }
public:
virtual property bool WasCut {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IListViewExItemWasCut
See Also

Reference

TreeNodeEx Class


TreeNodeEx Methods

The TreeNodeEx type exposes the following members.

Methods
 | Name | Description
Public method | AcceptData |
 | AddPlaceholder |
Public method | Ancestors |
Public method | AncestorsAndSelf |
Public method | CanAcceptData |
Public method | Clone |
Public method | Descendants |
Public method | DescendantsAndSelf |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExpandRecursively |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlattenTreeNodeEx(IEnumerableTreeNodeEx, FuncTreeNodeEx, IEnumerableTreeNodeEx) |
 | FlattenTreeNodeEx(TreeNodeEx, FuncTreeNodeEx, IEnumerableTreeNodeEx) |
Protected method | GetCanExpandRecursively |
Protected method | GetCanHostPlaceholder |
Protected method | GetChildren |
Public method | GetData |
Protected method | GetExpandedIcon |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIcon |
Protected method | GetIsChecked |
Protected method | GetIsExpandable |
Protected method | GetIsExpanded |
Protected method | GetIsFirst |
Protected method | GetIsLast |
Protected method | GetIsLazy |
Protected method | GetIsPlaceholder |
Protected method | GetIsVisible |
Protected method | GetIsVisibleInTree |
Protected method | GetParent |
Protected method | GetPlaceholder |
Protected method | GetPlaceholderIndex |
Protected method | GetShowIcon |
Protected method | GetShowLines |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadEditText |
Public method | LoadLazyChildren |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnChecked |
Public method | OnCheckReset |
Public method | OnCollapsed |
Public method | OnContextMenuOpening |
Public method | OnDoubleClick |
Public method | OnEnterPress |
Public method | OnExpanded |
Protected method | OnLazyLoading |
Public method | OnMinusPress |
Public method | OnMouseEnter |
Public method | OnMouseLeave |
Public method | OnMouseMove |
Public method | OnPlusPress |
Public method | OnPropertyChanged |
Public method | OnRemoveButtonClick |
Public method | OnSlashPress |
Public method | OnSpacePress |
Public method | OnStarPress |
Public method | OnUnchecked |
Public method | RaisePropertyChanged |
 | RemovePlaceholder |
Public method | SaveEditText |
Public method | ToString | (Overrides ObjectToString.)
 | UpdatePlaceholder |
Public method | VisibleDescendants |
Public method | VisibleDescendantsAndSelf |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TreeNodeEx Class


TreeNodeEx.AcceptData Method

TreeNodeExAcceptData Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual DragDropEffects AcceptData(
    IDataObject dataObject,
    int position = -1
)
public:
virtual DragDropEffects AcceptData(
    IDataObject^ dataObject,
    int position = -1
)

Parameters

dataObject
Type: System.WindowsIDataObject
position (Optional)
Type: SystemInt32

Return Value

Type: DragDropEffects

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.AcceptData(System.Windows.IDataObject,System.Int32)"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.AddPlaceholder Method

TreeNodeExAddPlaceholder Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void AddPlaceholder(
    TreeNodeEx node
)
public:
static void AddPlaceholder(
    TreeNodeEx^ node
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Ancestors Method

TreeNodeExAncestors Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<TreeNodeEx> Ancestors()
public:
IEnumerable<TreeNodeEx^>^ Ancestors()

Return Value

Type: IEnumerableTreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.Ancestors"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.AncestorsAndSelf Method

TreeNodeExAncestorsAndSelf Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<TreeNodeEx> AncestorsAndSelf()
public:
IEnumerable<TreeNodeEx^>^ AncestorsAndSelf()

Return Value

Type: IEnumerableTreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.AncestorsAndSelf"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.CanAcceptData Method

TreeNodeExCanAcceptData Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool CanAcceptData(
    IDataObject dataObject,
    int position = -1
)
public:
virtual bool CanAcceptData(
    IDataObject^ dataObject,
    int position = -1
)

Parameters

dataObject
Type: System.WindowsIDataObject
position (Optional)
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.CanAcceptData(System.Windows.IDataObject,System.Int32)"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.Clone Method

TreeNodeExClone Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object Clone()
public:
virtual Object^ Clone()

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.Clone"]

Implements

ICloneableClone
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Descendants Method

TreeNodeExDescendants Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<TreeNodeEx> Descendants()
public:
IEnumerable<TreeNodeEx^>^ Descendants()

Return Value

Type: IEnumerableTreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.Descendants"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.DescendantsAndSelf Method

TreeNodeExDescendantsAndSelf Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<TreeNodeEx> DescendantsAndSelf()
public:
IEnumerable<TreeNodeEx^>^ DescendantsAndSelf()

Return Value

Type: IEnumerableTreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.DescendantsAndSelf"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.ExpandRecursively Method

TreeNodeExExpandRecursively Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void ExpandRecursively(
    TreeNodeEx node
)
public:
static void ExpandRecursively(
    TreeNodeEx^ node
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Flatten Method

TreeNodeExFlatten Method

Overload List
Name | Description
FlattenTreeNodeEx(IEnumerableTreeNodeEx, FuncTreeNodeEx, IEnumerableTreeNodeEx) |
FlattenTreeNodeEx(TreeNodeEx, FuncTreeNodeEx, IEnumerableTreeNodeEx) |
Top
See Also

Reference

TreeNodeEx Class


TreeNodeEx.Flatten(TreeNodeEx) Method (IEnumerable(TreeNodeEx), Func(TreeNodeEx, IEnumerable(TreeNodeEx)))

TreeNodeExFlattenTreeNodeEx Method (IEnumerableTreeNodeEx, FuncTreeNodeEx, IEnumerableTreeNodeEx)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<TreeNodeEx> Flatten<TreeNodeEx>(
    IEnumerable<TreeNodeEx> nodes,
    Func<TreeNodeEx, IEnumerable<TreeNodeEx>> function
)

public:
generic<typename TreeNodeEx>
static IEnumerable<TreeNodeEx>^ Flatten(
    IEnumerable<TreeNodeEx>^ nodes,
    Func<TreeNodeEx, IEnumerable<TreeNodeEx>^>^ function
)

Parameters

nodes
Type: System.Collections.GenericIEnumerableTreeNodeEx
function
Type: SystemFuncTreeNodeEx, IEnumerableTreeNodeEx

Type Parameters

TreeNodeEx

Return Value

Type: IEnumerableTreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.Flatten``1(System.Collections.Generic.IEnumerable{``0},System.Func{``0,System.Collections.Generic.IEnumerable{``0}})"]

See Also

Reference

TreeNodeEx Class
Flatten Overload


TreeNodeEx.Flatten(TreeNodeEx) Method (TreeNodeEx, Func(TreeNodeEx, IEnumerable(TreeNodeEx)))

TreeNodeExFlattenTreeNodeEx Method (TreeNodeEx, FuncTreeNodeEx, IEnumerableTreeNodeEx)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<TreeNodeEx> Flatten<TreeNodeEx>(
    TreeNodeEx node,
    Func<TreeNodeEx, IEnumerable<TreeNodeEx>> function
)

public:
generic<typename TreeNodeEx>
static IEnumerable<TreeNodeEx>^ Flatten(
    TreeNodeEx node,
    Func<TreeNodeEx, IEnumerable<TreeNodeEx>^>^ function
)

Parameters

node
Type: TreeNodeEx
function
Type: SystemFuncTreeNodeEx, IEnumerableTreeNodeEx

Type Parameters

TreeNodeEx

Return Value

Type: IEnumerableTreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.Flatten``1(``0,System.Func{``0,System.Collections.Generic.IEnumerable{``0}})"]

See Also

Reference

TreeNodeEx Class
Flatten Overload


TreeNodeEx.GetCanExpandRecursively Method

TreeNodeExGetCanExpandRecursively Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetCanExpandRecursively()
protected:
virtual bool GetCanExpandRecursively()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetCanExpandRecursively"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetCanHostPlaceholder Method

TreeNodeExGetCanHostPlaceholder Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetCanHostPlaceholder()
protected:
virtual bool GetCanHostPlaceholder()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetCanHostPlaceholder"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetChildren Method

TreeNodeExGetChildren Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual TreeNodeCollectionEx GetChildren()
protected:
virtual TreeNodeCollectionEx^ GetChildren()

Return Value

Type: TreeNodeCollectionEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetChildren"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetData Method

TreeNodeExGetData Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object GetData(
    Object caller
)
public:
virtual Object^ GetData(
    Object^ caller
)

Parameters

caller
Type: SystemObject

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetData(System.Object)"]

Implements

IListViewExItemGetData(Object)
See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetExpandedIcon Method

TreeNodeExGetExpandedIcon Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual Object GetExpandedIcon()
protected:
virtual Object^ GetExpandedIcon()

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetExpandedIcon"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetIcon Method

TreeNodeExGetIcon Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual Object GetIcon()
protected:
virtual Object^ GetIcon()

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetIcon"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetIsChecked Method

TreeNodeExGetIsChecked Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual Nullable<bool> GetIsChecked()
protected:
virtual Nullable<bool> GetIsChecked()

Return Value

Type: NullableBoolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetIsChecked"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetIsExpandable Method

TreeNodeExGetIsExpandable Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetIsExpandable()
protected:
virtual bool GetIsExpandable()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetIsExpandable"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetIsExpanded Method

TreeNodeExGetIsExpanded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetIsExpanded()
protected:
virtual bool GetIsExpanded()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetIsExpanded"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetIsFirst Method

TreeNodeExGetIsFirst Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetIsFirst()
protected:
virtual bool GetIsFirst()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetIsFirst"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetIsLast Method

TreeNodeExGetIsLast Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetIsLast()
protected:
virtual bool GetIsLast()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetIsLast"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetIsLazy Method

TreeNodeExGetIsLazy Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetIsLazy()
protected:
virtual bool GetIsLazy()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetIsLazy"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetIsPlaceholder Method

TreeNodeExGetIsPlaceholder Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetIsPlaceholder()
protected:
virtual bool GetIsPlaceholder()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetIsPlaceholder"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetIsVisible Method

TreeNodeExGetIsVisible Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetIsVisible()
protected:
virtual bool GetIsVisible()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetIsVisible"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetIsVisibleInTree Method

TreeNodeExGetIsVisibleInTree Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetIsVisibleInTree()
protected:
virtual bool GetIsVisibleInTree()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetIsVisibleInTree"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetParent Method

TreeNodeExGetParent Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual TreeNodeEx GetParent()
protected:
virtual TreeNodeEx^ GetParent()

Return Value

Type: TreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetParent"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetPlaceholder Method

TreeNodeExGetPlaceholder Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual TreeNodeEx GetPlaceholder()
protected:
virtual TreeNodeEx^ GetPlaceholder()

Return Value

Type: TreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetPlaceholder"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetPlaceholderIndex Method

TreeNodeExGetPlaceholderIndex Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual int GetPlaceholderIndex()
protected:
virtual int GetPlaceholderIndex()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetPlaceholderIndex"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetShowIcon Method

TreeNodeExGetShowIcon Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetShowIcon()
protected:
virtual bool GetShowIcon()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetShowIcon"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.GetShowLines Method

TreeNodeExGetShowLines Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool GetShowLines()
protected:
virtual bool GetShowLines()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.GetShowLines"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.LoadEditText Method

TreeNodeExLoadEditText Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual string LoadEditText()
public:
virtual String^ LoadEditText()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.LoadEditText"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.LoadLazyChildren Method

TreeNodeExLoadLazyChildren Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void LoadLazyChildren()
public:
void LoadLazyChildren()
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnChecked Method

TreeNodeExOnChecked Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnChecked()
public:
virtual void OnChecked()
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnCheckReset Method

TreeNodeExOnCheckReset Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnCheckReset()
public:
virtual void OnCheckReset()
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnCollapsed Method

TreeNodeExOnCollapsed Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnCollapsed()
public:
virtual void OnCollapsed()
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnContextMenuOpening Method

TreeNodeExOnContextMenuOpening Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnContextMenuOpening(
    ContextMenuEventArgs e
)
public:
virtual void OnContextMenuOpening(
    ContextMenuEventArgs^ e
)

Parameters

e
Type: System.Windows.ControlsContextMenuEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnDoubleClick Method

TreeNodeExOnDoubleClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnDoubleClick(
    MouseButtonEventArgs e
)
public:
virtual void OnDoubleClick(
    MouseButtonEventArgs^ e
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnEnterPress Method

TreeNodeExOnEnterPress Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnEnterPress(
    KeyEventArgs e
)
public:
virtual void OnEnterPress(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnExpanded Method

TreeNodeExOnExpanded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnExpanded()
public:
virtual void OnExpanded()
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnLazyLoading Method

TreeNodeExOnLazyLoading Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnLazyLoading(
    ActionRequestedEventArgs e
)
protected:
virtual void OnLazyLoading(
    ActionRequestedEventArgs^ e
)

Parameters

e
Type: VisualComponents.UX.SharedActionRequestedEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnMinusPress Method

TreeNodeExOnMinusPress Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnMinusPress(
    KeyEventArgs e
)
public:
virtual void OnMinusPress(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnMouseEnter Method

TreeNodeExOnMouseEnter Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnMouseEnter(
    MouseEventArgs e
)
public:
virtual void OnMouseEnter(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnMouseLeave Method

TreeNodeExOnMouseLeave Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnMouseLeave(
    MouseEventArgs e
)
public:
virtual void OnMouseLeave(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnMouseMove Method

TreeNodeExOnMouseMove Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnMouseMove(
    MouseEventArgs e
)
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnPlusPress Method

TreeNodeExOnPlusPress Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnPlusPress(
    KeyEventArgs e
)
public:
virtual void OnPlusPress(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnPropertyChanged Method

TreeNodeExOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
public:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ e
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnRemoveButtonClick Method

TreeNodeExOnRemoveButtonClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnRemoveButtonClick(
    MouseButtonEventArgs e
)
public:
virtual void OnRemoveButtonClick(
    MouseButtonEventArgs^ e
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnSlashPress Method

TreeNodeExOnSlashPress Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnSlashPress(
    KeyEventArgs e
)
public:
virtual void OnSlashPress(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnSpacePress Method

TreeNodeExOnSpacePress Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnSpacePress(
    KeyEventArgs e
)
public:
virtual void OnSpacePress(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnStarPress Method

TreeNodeExOnStarPress Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnStarPress(
    KeyEventArgs e
)
public:
virtual void OnStarPress(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

TreeNodeEx Class


TreeNodeEx.OnUnchecked Method

TreeNodeExOnUnchecked Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnUnchecked()
public:
virtual void OnUnchecked()
See Also

Reference

TreeNodeEx Class


TreeNodeEx.RaisePropertyChanged Method

TreeNodeExRaisePropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaisePropertyChanged(
    string name = null
)
public:
void RaisePropertyChanged(
    String^ name = nullptr
)

Parameters

name (Optional)
Type: SystemString
See Also

Reference

TreeNodeEx Class


TreeNodeEx.RemovePlaceholder Method

TreeNodeExRemovePlaceholder Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void RemovePlaceholder(
    TreeNodeEx node,
    int index = -1
)
public:
static void RemovePlaceholder(
    TreeNodeEx^ node,
    int index = -1
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
index (Optional)
Type: SystemInt32
See Also

Reference

TreeNodeEx Class


TreeNodeEx.SaveEditText Method

TreeNodeExSaveEditText Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool SaveEditText(
    string value
)
public:
virtual bool SaveEditText(
    String^ value
)

Parameters

value
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.SaveEditText(System.String)"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.ToString Method

TreeNodeExToString Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.ToString"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.UpdatePlaceholder Method

TreeNodeExUpdatePlaceholder Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void UpdatePlaceholder(
    TreeNodeEx node,
    bool cleanup = false
)
public:
static void UpdatePlaceholder(
    TreeNodeEx^ node,
    bool cleanup = false
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
cleanup (Optional)
Type: SystemBoolean
See Also

Reference

TreeNodeEx Class


TreeNodeEx.VisibleDescendants Method

TreeNodeExVisibleDescendants Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<TreeNodeEx> VisibleDescendants()
public:
IEnumerable<TreeNodeEx^>^ VisibleDescendants()

Return Value

Type: IEnumerableTreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.VisibleDescendants"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx.VisibleDescendantsAndSelf Method

TreeNodeExVisibleDescendantsAndSelf Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<TreeNodeEx> VisibleDescendantsAndSelf()
public:
IEnumerable<TreeNodeEx^>^ VisibleDescendantsAndSelf()

Return Value

Type: IEnumerableTreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeEx.VisibleDescendantsAndSelf"]

See Also

Reference

TreeNodeEx Class


TreeNodeEx Events

The TreeNodeEx type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

TreeNodeEx Class


TreeNodeEx.PropertyChanged Event

TreeNodeExPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

TreeNodeEx Class


TreeNodeEx Fields

The TreeNodeEx type exposes the following members.

Fields
 | Name | Description
Protected field | _clone |
Top
See Also

Reference

TreeNodeEx Class


TreeNodeEx._clone Field

TreeNodeEx_clone Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected TreeNodeEx _clone
protected:
TreeNodeEx^ _clone

Field Value

Type: TreeNodeEx
See Also

Reference

TreeNodeEx Class


TreeNodeSelectionMode Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TreeNodeSelectionMode
public enum class TreeNodeSelectionMode
Members
Member name | Value | Description
Row | 0 |
Node | 1 |
Custom | 2 |
See Also

Reference


TreeNodeType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TreeNodeType
public enum class TreeNodeType
Members
Member name | Value | Description
Invalid | 0 |
Component | 1 |
Node | 2 |
Behavior | 3 |
Feature | 4 |
Property | 5 |
Folder | 6 |
Connector | 7 |
Robot | 8 |
RootFeature | 9 |
Dof | 10 |
RobotFrame | 11 |
Tool | 12 |
Base | 13 |
Statement | 14 |
See Also

Reference


TreeNodeViewEx Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
VisualComponents.UX.SharedTreeNodeViewEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TreeNodeViewEx : ContentControl
public ref class TreeNodeViewEx : public ContentControl

The TreeNodeViewEx type exposes the following members.

Constructors
 | Name | Description
Public method | TreeNodeViewEx | Initializes a new instance of the TreeNodeViewEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationBrush |
Public property | AnchorBrush |
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CheckBox |
Public property | CheckBoxToolTipContent |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CornerRadius |
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropIndicatorBrush |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Expander |
Public property | FixedArea |
Public property | FixedAreaToolTipContent |
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusedBrush |
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GrayOutOnDisabled |
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HoverHighlight |
Public property | Icon |
Public property | IconToolTipContent |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsContextMenuOpen |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsPressed |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabFocused |
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Item |
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Node |
Public property | NodeSelectionArea |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PressedBrush |
Public property | RemoveButton |
Public property | RemoveButtonBrush |
Public property | RemoveButtonToolTipContent |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RowBackground |
Public property | SelectedBrush |
Public property | SelectionMode |
Public property | ShowContextMenu |
Public property | ShowExpander |
Public property | ShowExpanderInDragVisual |
Public property | ShowLinesExpandable |
Public property | ShowLinesRow |
Public property | ShowRemoveButtonOnMouseHoverOnly |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | ToolTipContent |
Public property | ToolTipResolved |
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TreeView |
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ControlMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Overrides FrameworkElementOnVisualParentChanged(DependencyObject).)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AlternationBrushProperty |
AnchorBrushProperty |
CheckBoxProperty |
CheckBoxToolTipContentProperty |
CornerRadiusProperty |
DropIndicatorBrushProperty |
ExpanderProperty |
FixedAreaProperty |
FixedAreaToolTipContentProperty |
FocusedBrushProperty |
GrayOutOnDisabledProperty |
HoverHighlightProperty |
IconProperty |
IconToolTipContentProperty |
IsContextMenuOpenProperty |
IsContextMenuOpenPropertyKey |
IsPressedProperty |
IsPressedPropertyKey |
IsTabFocusedProperty |
IsTabFocusedPropertyKey |
PressedBrushProperty |
RemoveButtonBrushProperty |
RemoveButtonProperty |
RemoveButtonToolTipContentProperty |
RowBackgroundProperty |
SelectedBrushProperty |
SelectionModeProperty |
ShowContextMenuProperty |
ShowExpanderInDragVisualProperty |
ShowExpanderProperty |
ShowLinesExpandableProperty |
ShowLinesRowProperty |
ShowRemoveButtonOnMouseHoverOnlyProperty |
ToolTipContentProperty |
ToolTipResolvedProperty |
ToolTipResolvedPropertyKey |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


TreeNodeViewEx Constructor

Initializes a new instance of the TreeNodeViewEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeViewEx()
public:
TreeNodeViewEx()
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx Properties

The TreeNodeViewEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationBrush |
Public property | AnchorBrush |
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CheckBox |
Public property | CheckBoxToolTipContent |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CornerRadius |
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropIndicatorBrush |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Expander |
Public property | FixedArea |
Public property | FixedAreaToolTipContent |
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusedBrush |
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GrayOutOnDisabled |
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HoverHighlight |
Public property | Icon |
Public property | IconToolTipContent |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsContextMenuOpen |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsPressed |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabFocused |
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Item |
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Node |
Public property | NodeSelectionArea |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PressedBrush |
Public property | RemoveButton |
Public property | RemoveButtonBrush |
Public property | RemoveButtonToolTipContent |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RowBackground |
Public property | SelectedBrush |
Public property | SelectionMode |
Public property | ShowContextMenu |
Public property | ShowExpander |
Public property | ShowExpanderInDragVisual |
Public property | ShowLinesExpandable |
Public property | ShowLinesRow |
Public property | ShowRemoveButtonOnMouseHoverOnly |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | ToolTipContent |
Public property | ToolTipResolved |
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TreeView |
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.AlternationBrush Property

TreeNodeViewExAlternationBrush Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush AlternationBrush { get; set; }
public:
property Brush^ AlternationBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.AnchorBrush Property

TreeNodeViewExAnchorBrush Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush AnchorBrush { get; set; }
public:
property Brush^ AnchorBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.CheckBox Property

TreeNodeViewExCheckBox Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object CheckBox { get; set; }
public:
property Object^ CheckBox {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.CheckBoxToolTipContent Property

TreeNodeViewExCheckBoxToolTipContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object CheckBoxToolTipContent { get; set; }
public:
property Object^ CheckBoxToolTipContent {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.CornerRadius Property

TreeNodeViewExCornerRadius Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CornerRadius CornerRadius { get; set; }
public:
property CornerRadius CornerRadius {
    CornerRadius get ();
    void set (CornerRadius value);
}

Property Value

Type: CornerRadius
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.DropIndicatorBrush Property

TreeNodeViewExDropIndicatorBrush Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush DropIndicatorBrush { get; set; }
public:
property Brush^ DropIndicatorBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.Expander Property

TreeNodeViewExExpander Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Expander { get; set; }
public:
property Object^ Expander {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.FixedArea Property

TreeNodeViewExFixedArea Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object FixedArea { get; set; }
public:
property Object^ FixedArea {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.FixedAreaToolTipContent Property

TreeNodeViewExFixedAreaToolTipContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object FixedAreaToolTipContent { get; set; }
public:
property Object^ FixedAreaToolTipContent {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.FocusedBrush Property

TreeNodeViewExFocusedBrush Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush FocusedBrush { get; set; }
public:
property Brush^ FocusedBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.GrayOutOnDisabled Property

TreeNodeViewExGrayOutOnDisabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GrayOutOnDisabled { get; set; }
public:
property bool GrayOutOnDisabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.HoverHighlight Property

TreeNodeViewExHoverHighlight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HoverHighlightType HoverHighlight { get; set; }
public:
property HoverHighlightType HoverHighlight {
    HoverHighlightType get ();
    void set (HoverHighlightType value);
}

Property Value

Type: HoverHighlightType
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.Icon Property

TreeNodeViewExIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Icon { get; set; }
public:
property Object^ Icon {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IconToolTipContent Property

TreeNodeViewExIconToolTipContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object IconToolTipContent { get; set; }
public:
property Object^ IconToolTipContent {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IsContextMenuOpen Property

TreeNodeViewExIsContextMenuOpen Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsContextMenuOpen { get; }
public:
property bool IsContextMenuOpen {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IsPressed Property

TreeNodeViewExIsPressed Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPressed { get; }
public:
property bool IsPressed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IsTabFocused Property

TreeNodeViewExIsTabFocused Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsTabFocused { get; }
public:
property bool IsTabFocused {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.Item Property

TreeNodeViewExItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewItemEx Item { get; }
public:
property TreeViewItemEx^ Item {
    TreeViewItemEx^ get ();
}

Property Value

Type: TreeViewItemEx
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.Node Property

TreeNodeViewExNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Node { get; }
public:
property TreeNodeEx^ Node {
    TreeNodeEx^ get ();
}

Property Value

Type: TreeNodeEx
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.NodeSelectionArea Property

TreeNodeViewExNodeSelectionArea Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameworkElement NodeSelectionArea { get; }
public:
property FrameworkElement^ NodeSelectionArea {
    FrameworkElement^ get ();
}

Property Value

Type: FrameworkElement
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.PressedBrush Property

TreeNodeViewExPressedBrush Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush PressedBrush { get; set; }
public:
property Brush^ PressedBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.RemoveButton Property

TreeNodeViewExRemoveButton Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object RemoveButton { get; set; }
public:
property Object^ RemoveButton {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.RemoveButtonBrush Property

TreeNodeViewExRemoveButtonBrush Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush RemoveButtonBrush { get; set; }
public:
property Brush^ RemoveButtonBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.RemoveButtonToolTipContent Property

TreeNodeViewExRemoveButtonToolTipContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object RemoveButtonToolTipContent { get; set; }
public:
property Object^ RemoveButtonToolTipContent {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.RowBackground Property

TreeNodeViewExRowBackground Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush RowBackground { get; set; }
public:
property Brush^ RowBackground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.SelectedBrush Property

TreeNodeViewExSelectedBrush Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush SelectedBrush { get; set; }
public:
property Brush^ SelectedBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.SelectionMode Property

TreeNodeViewExSelectionMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeSelectionMode SelectionMode { get; set; }
public:
property TreeNodeSelectionMode SelectionMode {
    TreeNodeSelectionMode get ();
    void set (TreeNodeSelectionMode value);
}

Property Value

Type: TreeNodeSelectionMode
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowContextMenu Property

TreeNodeViewExShowContextMenu Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowContextMenu { get; set; }
public:
property bool ShowContextMenu {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowExpander Property

TreeNodeViewExShowExpander Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowExpander { get; set; }
public:
property bool ShowExpander {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowExpanderInDragVisual Property

TreeNodeViewExShowExpanderInDragVisual Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowExpanderInDragVisual { get; set; }
public:
property bool ShowExpanderInDragVisual {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowLinesExpandable Property

TreeNodeViewExShowLinesExpandable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowLinesExpandable { get; set; }
public:
property bool ShowLinesExpandable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowLinesRow Property

TreeNodeViewExShowLinesRow Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowLinesRow { get; set; }
public:
property bool ShowLinesRow {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowRemoveButtonOnMouseHoverOnly Property

TreeNodeViewExShowRemoveButtonOnMouseHoverOnly Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowRemoveButtonOnMouseHoverOnly { get; set; }
public:
property bool ShowRemoveButtonOnMouseHoverOnly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ToolTipContent Property

TreeNodeViewExToolTipContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ToolTipContent { get; set; }
public:
property Object^ ToolTipContent {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ToolTipResolved Property

TreeNodeViewExToolTipResolved Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ToolTipResolved { get; }
public:
property Object^ ToolTipResolved {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.TreeView Property

TreeNodeViewExTreeView Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewEx TreeView { get; }
public:
property TreeViewEx^ TreeView {
    TreeViewEx^ get ();
}

Property Value

Type: TreeViewEx
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx Methods

The TreeNodeViewEx type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ControlMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Overrides FrameworkElementOnVisualParentChanged(DependencyObject).)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.MeasureOverride Method

TreeNodeViewExMeasureOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size MeasureOverride(
    Size constraint
)
protected:
virtual Size MeasureOverride(
    Size constraint
) override

Parameters

constraint
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeNodeViewEx.MeasureOverride(System.Windows.Size)"]

See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.OnApplyTemplate Method

TreeNodeViewExOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.OnPropertyChanged Method

TreeNodeViewExOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.OnVisualParentChanged Method

TreeNodeViewExOnVisualParentChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnVisualParentChanged(
    DependencyObject oldParent
)
protected:
virtual void OnVisualParentChanged(
    DependencyObject^ oldParent
) override

Parameters

oldParent
Type: System.WindowsDependencyObject
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx Events

The TreeNodeViewEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx Fields

The TreeNodeViewEx type exposes the following members.

Fields
Name | Description
AlternationBrushProperty |
AnchorBrushProperty |
CheckBoxProperty |
CheckBoxToolTipContentProperty |
CornerRadiusProperty |
DropIndicatorBrushProperty |
ExpanderProperty |
FixedAreaProperty |
FixedAreaToolTipContentProperty |
FocusedBrushProperty |
GrayOutOnDisabledProperty |
HoverHighlightProperty |
IconProperty |
IconToolTipContentProperty |
IsContextMenuOpenProperty |
IsContextMenuOpenPropertyKey |
IsPressedProperty |
IsPressedPropertyKey |
IsTabFocusedProperty |
IsTabFocusedPropertyKey |
PressedBrushProperty |
RemoveButtonBrushProperty |
RemoveButtonProperty |
RemoveButtonToolTipContentProperty |
RowBackgroundProperty |
SelectedBrushProperty |
SelectionModeProperty |
ShowContextMenuProperty |
ShowExpanderInDragVisualProperty |
ShowExpanderProperty |
ShowLinesExpandableProperty |
ShowLinesRowProperty |
ShowRemoveButtonOnMouseHoverOnlyProperty |
ToolTipContentProperty |
ToolTipResolvedProperty |
ToolTipResolvedPropertyKey |
Top
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.AlternationBrushProperty Field

TreeNodeViewExAlternationBrushProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AlternationBrushProperty
public:
static initonly DependencyProperty^ AlternationBrushProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.AnchorBrushProperty Field

TreeNodeViewExAnchorBrushProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AnchorBrushProperty
public:
static initonly DependencyProperty^ AnchorBrushProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.CheckBoxProperty Field

TreeNodeViewExCheckBoxProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CheckBoxProperty
public:
static initonly DependencyProperty^ CheckBoxProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.CheckBoxToolTipContentProperty Field

TreeNodeViewExCheckBoxToolTipContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CheckBoxToolTipContentProperty
public:
static initonly DependencyProperty^ CheckBoxToolTipContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.CornerRadiusProperty Field

TreeNodeViewExCornerRadiusProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CornerRadiusProperty
public:
static initonly DependencyProperty^ CornerRadiusProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.DropIndicatorBrushProperty Field

TreeNodeViewExDropIndicatorBrushProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DropIndicatorBrushProperty
public:
static initonly DependencyProperty^ DropIndicatorBrushProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ExpanderProperty Field

TreeNodeViewExExpanderProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ExpanderProperty
public:
static initonly DependencyProperty^ ExpanderProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.FixedAreaProperty Field

TreeNodeViewExFixedAreaProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FixedAreaProperty
public:
static initonly DependencyProperty^ FixedAreaProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.FixedAreaToolTipContentProperty Field

TreeNodeViewExFixedAreaToolTipContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FixedAreaToolTipContentProperty
public:
static initonly DependencyProperty^ FixedAreaToolTipContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.FocusedBrushProperty Field

TreeNodeViewExFocusedBrushProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FocusedBrushProperty
public:
static initonly DependencyProperty^ FocusedBrushProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.GrayOutOnDisabledProperty Field

TreeNodeViewExGrayOutOnDisabledProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty GrayOutOnDisabledProperty
public:
static initonly DependencyProperty^ GrayOutOnDisabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.HoverHighlightProperty Field

TreeNodeViewExHoverHighlightProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HoverHighlightProperty
public:
static initonly DependencyProperty^ HoverHighlightProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IconProperty Field

TreeNodeViewExIconProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IconProperty
public:
static initonly DependencyProperty^ IconProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IconToolTipContentProperty Field

TreeNodeViewExIconToolTipContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IconToolTipContentProperty
public:
static initonly DependencyProperty^ IconToolTipContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IsContextMenuOpenProperty Field

TreeNodeViewExIsContextMenuOpenProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsContextMenuOpenProperty
public:
static initonly DependencyProperty^ IsContextMenuOpenProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IsContextMenuOpenPropertyKey Field

TreeNodeViewExIsContextMenuOpenPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey IsContextMenuOpenPropertyKey
public:
static initonly DependencyPropertyKey^ IsContextMenuOpenPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IsPressedProperty Field

TreeNodeViewExIsPressedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsPressedProperty
public:
static initonly DependencyProperty^ IsPressedProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IsPressedPropertyKey Field

TreeNodeViewExIsPressedPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey IsPressedPropertyKey
public:
static initonly DependencyPropertyKey^ IsPressedPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IsTabFocusedProperty Field

TreeNodeViewExIsTabFocusedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsTabFocusedProperty
public:
static initonly DependencyProperty^ IsTabFocusedProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.IsTabFocusedPropertyKey Field

TreeNodeViewExIsTabFocusedPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey IsTabFocusedPropertyKey
public:
static initonly DependencyPropertyKey^ IsTabFocusedPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.PressedBrushProperty Field

TreeNodeViewExPressedBrushProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PressedBrushProperty
public:
static initonly DependencyProperty^ PressedBrushProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.RemoveButtonBrushProperty Field

TreeNodeViewExRemoveButtonBrushProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RemoveButtonBrushProperty
public:
static initonly DependencyProperty^ RemoveButtonBrushProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.RemoveButtonProperty Field

TreeNodeViewExRemoveButtonProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RemoveButtonProperty
public:
static initonly DependencyProperty^ RemoveButtonProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.RemoveButtonToolTipContentProperty Field

TreeNodeViewExRemoveButtonToolTipContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RemoveButtonToolTipContentProperty
public:
static initonly DependencyProperty^ RemoveButtonToolTipContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.RowBackgroundProperty Field

TreeNodeViewExRowBackgroundProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RowBackgroundProperty
public:
static initonly DependencyProperty^ RowBackgroundProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.SelectedBrushProperty Field

TreeNodeViewExSelectedBrushProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SelectedBrushProperty
public:
static initonly DependencyProperty^ SelectedBrushProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.SelectionModeProperty Field

TreeNodeViewExSelectionModeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SelectionModeProperty
public:
static initonly DependencyProperty^ SelectionModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowContextMenuProperty Field

TreeNodeViewExShowContextMenuProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowContextMenuProperty
public:
static initonly DependencyProperty^ ShowContextMenuProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowExpanderInDragVisualProperty Field

TreeNodeViewExShowExpanderInDragVisualProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowExpanderInDragVisualProperty
public:
static initonly DependencyProperty^ ShowExpanderInDragVisualProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowExpanderProperty Field

TreeNodeViewExShowExpanderProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowExpanderProperty
public:
static initonly DependencyProperty^ ShowExpanderProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowLinesExpandableProperty Field

TreeNodeViewExShowLinesExpandableProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowLinesExpandableProperty
public:
static initonly DependencyProperty^ ShowLinesExpandableProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowLinesRowProperty Field

TreeNodeViewExShowLinesRowProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowLinesRowProperty
public:
static initonly DependencyProperty^ ShowLinesRowProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ShowRemoveButtonOnMouseHoverOnlyProperty Field

TreeNodeViewExShowRemoveButtonOnMouseHoverOnlyProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowRemoveButtonOnMouseHoverOnlyProperty
public:
static initonly DependencyProperty^ ShowRemoveButtonOnMouseHoverOnlyProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ToolTipContentProperty Field

TreeNodeViewExToolTipContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ToolTipContentProperty
public:
static initonly DependencyProperty^ ToolTipContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ToolTipResolvedProperty Field

TreeNodeViewExToolTipResolvedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ToolTipResolvedProperty
public:
static initonly DependencyProperty^ ToolTipResolvedProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeNodeViewEx Class


TreeNodeViewEx.ToolTipResolvedPropertyKey Field

TreeNodeViewExToolTipResolvedPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey ToolTipResolvedPropertyKey
public:
static initonly DependencyPropertyKey^ ToolTipResolvedPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

TreeNodeViewEx Class


TreeViewCell Class

Convenient ContentControl implementing GridView hacks found in TreeNodeViewEx. Use it as a first element in GridViewColumn's (or TreeViewColumn's) cell template.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
VisualComponents.UX.SharedTreeViewCell

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TreeViewCell : ContentControl
public ref class TreeViewCell : public ContentControl

The TreeViewCell type exposes the following members.

Constructors
 | Name | Description
Public method | TreeViewCell | Initializes a new instance of the TreeViewCell class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ControlMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Overrides FrameworkElementOnVisualParentChanged(DependencyObject).)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
This is a helper class. It's not required for correct operation of the TreeViewEx or any of its components.
See Also

Reference


TreeViewCell Constructor

Initializes a new instance of the TreeViewCell class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewCell()
public:
TreeViewCell()
See Also

Reference

TreeViewCell Class


TreeViewCell Properties

The TreeViewCell type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeViewCell Class


TreeViewCell Methods

The TreeViewCell type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ControlMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Overrides FrameworkElementOnVisualParentChanged(DependencyObject).)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TreeViewCell Class


TreeViewCell.MeasureOverride Method

TreeViewCellMeasureOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size MeasureOverride(
    Size constraint
)
protected:
virtual Size MeasureOverride(
    Size constraint
) override

Parameters

constraint
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeViewCell.MeasureOverride(System.Windows.Size)"]

See Also

Reference

TreeViewCell Class


TreeViewCell.OnVisualParentChanged Method

TreeViewCellOnVisualParentChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnVisualParentChanged(
    DependencyObject oldParent
)
protected:
virtual void OnVisualParentChanged(
    DependencyObject^ oldParent
) override

Parameters

oldParent
Type: System.WindowsDependencyObject
See Also

Reference

TreeViewCell Class


TreeViewCell Events

The TreeViewCell type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeViewCell Class


TreeViewColumn Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsGridViewColumn
VisualComponents.UX.SharedTreeViewColumn

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TreeViewColumn : GridViewColumn
public ref class TreeViewColumn : public GridViewColumn

The TreeViewColumn type exposes the following members.

Constructors
 | Name | Description
Public method | TreeViewColumn | Initializes a new instance of the TreeViewColumn class
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the actual width of a GridViewColumn. (Inherited from GridViewColumn.)
Public property | CellTemplate | Gets or sets the template to use to display the contents of a column cell. (Inherited from GridViewColumn.)
Public property | CellTemplateSelector | Gets or sets a DataTemplateSelector that determines the template to use to display cells in a column. (Inherited from GridViewColumn.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberBinding | Gets or sets the data item to bind to for this column. (Inherited from GridViewColumn.)
Public property | Header | Gets or sets the content of the header of a GridViewColumn. (Inherited from GridViewColumn.)
Public property | HeaderContainerStyle | Gets or sets the style to use for the header of the GridViewColumn. (Inherited from GridViewColumn.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from GridViewColumn.)
Public property | HeaderTemplate | Gets or sets the template to use to display the content of the column header. (Inherited from GridViewColumn.)
Public property | HeaderTemplateSelector | Gets or sets the DataTemplateSelector that provides logic to select the template to use to display the column header. (Inherited from GridViewColumn.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | MaxWidth |
Public property | MinWidth |
Public property | ShowSplitter |
Public property | SplitterFill |
Public property | SplitterOpacity |
Public property | SplitterWidth |
Public property | Type |
Public property | Width |
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnHeaderStringFormatChanged | Occurs when the HeaderStringFormat property changes. (Inherited from GridViewColumn.)
Protected method | OnPropertyChanged(PropertyChangedEventArgs) | Raises the INotifyPropertyChangedPropertyChanged event. (Inherited from GridViewColumn.)
Protected method | OnPropertyChanged(DependencyPropertyChangedEventArgs) | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Creates a string representation of the GridViewColumn. (Inherited from GridViewColumn.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
MaxWidthProperty |
MinWidthProperty |
ShowSplitterProperty |
SplitteFillProperty |
SplitterOpacityProperty |
SplitterWidthProperty |
TypeProperty |
WidthProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


TreeViewColumn Constructor

Initializes a new instance of the TreeViewColumn class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewColumn()
public:
TreeViewColumn()
See Also

Reference

TreeViewColumn Class


TreeViewColumn Properties

The TreeViewColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the actual width of a GridViewColumn. (Inherited from GridViewColumn.)
Public property | CellTemplate | Gets or sets the template to use to display the contents of a column cell. (Inherited from GridViewColumn.)
Public property | CellTemplateSelector | Gets or sets a DataTemplateSelector that determines the template to use to display cells in a column. (Inherited from GridViewColumn.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberBinding | Gets or sets the data item to bind to for this column. (Inherited from GridViewColumn.)
Public property | Header | Gets or sets the content of the header of a GridViewColumn. (Inherited from GridViewColumn.)
Public property | HeaderContainerStyle | Gets or sets the style to use for the header of the GridViewColumn. (Inherited from GridViewColumn.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from GridViewColumn.)
Public property | HeaderTemplate | Gets or sets the template to use to display the content of the column header. (Inherited from GridViewColumn.)
Public property | HeaderTemplateSelector | Gets or sets the DataTemplateSelector that provides logic to select the template to use to display the column header. (Inherited from GridViewColumn.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | MaxWidth |
Public property | MinWidth |
Public property | ShowSplitter |
Public property | SplitterFill |
Public property | SplitterOpacity |
Public property | SplitterWidth |
Public property | Type |
Public property | Width |
Top
See Also

Reference

TreeViewColumn Class


TreeViewColumn.MaxWidth Property

TreeViewColumnMaxWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<double> MaxWidth { get; set; }
public:
property Nullable<double> MaxWidth {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: NullableDouble
See Also

Reference

TreeViewColumn Class


TreeViewColumn.MinWidth Property

TreeViewColumnMinWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<double> MinWidth { get; set; }
public:
property Nullable<double> MinWidth {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: NullableDouble
See Also

Reference

TreeViewColumn Class


TreeViewColumn.ShowSplitter Property

TreeViewColumnShowSplitter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowSplitter { get; set; }
public:
property bool ShowSplitter {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewColumn Class


TreeViewColumn.SplitterFill Property

TreeViewColumnSplitterFill Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush SplitterFill { get; set; }
public:
property Brush^ SplitterFill {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeViewColumn Class


TreeViewColumn.SplitterOpacity Property

TreeViewColumnSplitterOpacity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SplitterOpacity { get; set; }
public:
property double SplitterOpacity {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TreeViewColumn Class


TreeViewColumn.SplitterWidth Property

TreeViewColumnSplitterWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SplitterWidth { get; set; }
public:
property double SplitterWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TreeViewColumn Class


TreeViewColumn.Type Property

TreeViewColumnType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewColumnType Type { get; set; }
public:
property TreeViewColumnType Type {
    TreeViewColumnType get ();
    void set (TreeViewColumnType value);
}

Property Value

Type: TreeViewColumnType
See Also

Reference

TreeViewColumn Class


TreeViewColumn.Width Property

TreeViewColumnWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<double> Width { get; set; }
public:
property Nullable<double> Width {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: NullableDouble
See Also

Reference

TreeViewColumn Class


TreeViewColumn Methods

The TreeViewColumn type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnHeaderStringFormatChanged | Occurs when the HeaderStringFormat property changes. (Inherited from GridViewColumn.)
Protected method | OnPropertyChanged(PropertyChangedEventArgs) | Raises the INotifyPropertyChangedPropertyChanged event. (Inherited from GridViewColumn.)
Protected method | OnPropertyChanged(DependencyPropertyChangedEventArgs) | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Creates a string representation of the GridViewColumn. (Inherited from GridViewColumn.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TreeViewColumn Class


TreeViewColumn Fields

The TreeViewColumn type exposes the following members.

Fields
Name | Description
MaxWidthProperty |
MinWidthProperty |
ShowSplitterProperty |
SplitteFillProperty |
SplitterOpacityProperty |
SplitterWidthProperty |
TypeProperty |
WidthProperty |
Top
See Also

Reference

TreeViewColumn Class


TreeViewColumn.MaxWidthProperty Field

TreeViewColumnMaxWidthProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty MaxWidthProperty
public:
static initonly DependencyProperty^ MaxWidthProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewColumn Class


TreeViewColumn.MinWidthProperty Field

TreeViewColumnMinWidthProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty MinWidthProperty
public:
static initonly DependencyProperty^ MinWidthProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewColumn Class


TreeViewColumn.ShowSplitterProperty Field

TreeViewColumnShowSplitterProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowSplitterProperty
public:
static initonly DependencyProperty^ ShowSplitterProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewColumn Class


TreeViewColumn.SplitteFillProperty Field

TreeViewColumnSplitteFillProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SplitteFillProperty
public:
static initonly DependencyProperty^ SplitteFillProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewColumn Class


TreeViewColumn.SplitterOpacityProperty Field

TreeViewColumnSplitterOpacityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SplitterOpacityProperty
public:
static initonly DependencyProperty^ SplitterOpacityProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewColumn Class


TreeViewColumn.SplitterWidthProperty Field

TreeViewColumnSplitterWidthProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SplitterWidthProperty
public:
static initonly DependencyProperty^ SplitterWidthProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewColumn Class


TreeViewColumn.TypeProperty Field

TreeViewColumnTypeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TypeProperty
public:
static initonly DependencyProperty^ TypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewColumn Class


TreeViewColumn.WidthProperty Field

TreeViewColumnWidthProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty WidthProperty
public:
static initonly DependencyProperty^ WidthProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewColumn Class


TreeViewColumnType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TreeViewColumnType
public enum class TreeViewColumnType
Members
Member name | Value | Description
Auto | 0 |
Fixed | 1 |
Fill | 2 |
Range | 3 |
Proportional | 4 |
See Also

Reference


TreeViewEx Class

Extended TreeView with built-in support for Columns and Drag-and-Drop functionality.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsListBox
System.Windows.ControlsListView
VisualComponents.UX.SharedListViewEx
VisualComponents.UX.SharedTreeViewEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TreeViewEx : ListViewEx
public ref class TreeViewEx : public ListViewEx

The TreeViewEx type exposes the following members.

Constructors
 | Name | Description
Public method | TreeViewEx | Initializes a new instance of the TreeViewEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdjacentDropArea | (Inherited from ListViewEx.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowDropToEmptySpace | (Inherited from ListViewEx.)
Public property | AllowsNodeReorder |
Public property | AlternateRows |
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Protected property | AnchorItem | Gets or sets the item that is initially selected when SelectionMode is Extended. (Inherited from ListBox.)
Public property | AnchorLastOnCopy |
Public property | AnchorNode |
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreColumnSplittersHitTestVisible |
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Bounds | (Inherited from ListViewEx.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanCopy |
Public property | CanCut |
Public property | CanDelete |
Public property | CanDragExpand |
Public property | CanPaste |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CollectionView | (Inherited from ListViewEx.)
Public property | Columns |
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ComputedHeaderContentOffset |
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CopiedCutNodes |
 | CopyCommand |
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
 | CutCommand |
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
 | DefaultItemContainerStyleKey |
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DeferFilterRefresh | (Inherited from ListViewEx.)
 | DeleteCommand |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | DragAdornerClipsToBounds | (Inherited from ListViewEx.)
Public property | DragAdornerCounterBackground | (Inherited from ListViewEx.)
Public property | DragAdornerCounterForeground | (Inherited from ListViewEx.)
Public property | DragAdornerLayer | (Inherited from ListViewEx.)
Public property | DragAdornerOpacity | (Inherited from ListViewEx.)
Public property | DragAdornerPlacementTarget | (Inherited from ListViewEx.)
Public property | DragAdornerReflectsVisual | (Inherited from ListViewEx.)
Public property | DragExpandingDelay |
Public property | DragExpandInvalidNodes |
Public property | DragScrollingDelay | (Inherited from ListViewEx.)
Public property | DropIndicatorOffset | (Inherited from ListViewEx.)
Protected property | DropTargetItem | (Inherited from ListViewEx.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | EnableColumnSplittersInteraction |
Public property | FilterBy | (Inherited from ListViewEx.)
Public property | FilterOptions | (Inherited from ListViewEx.)
Public property | FilterOptionsCommand |
Public property | FilterOptionsContent |
Public property | FilterSettingsCommand |
Public property | FilterText | (Inherited from ListViewEx.)
Public property | FilterType | (Inherited from ListViewEx.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HeaderBackground |
Public property | HeaderBorderBrush |
Public property | HeaderBorderThickness |
Public property | HeaderForeground |
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalDragScrollingMargin | (Inherited from ListViewEx.)
Public property | IgnoreFilterTextCase | (Inherited from ListViewEx.)
Public property | Indent |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDataOperationInProgress |
Public property | IsDefaultSearchBoxInUse |
Public property | IsDragAreaRestricted | (Inherited from ListViewEx.)
Public property | IsDragInProgress | (Inherited from ListViewEx.)
Public property | IsDragOver | (Inherited from ListViewEx.)
Public property | IsDragScrolling | (Inherited from ListViewEx.)
Public property | IsDragSource | (Inherited from ListViewEx.)
Public property | IsDropTarget | (Inherited from ListViewEx.)
Public property | IsEditing |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGeneratingDragVisual |
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsNodeCollapsing |
Public property | IsNodeExpanding |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionInProgress |
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerHelperFocusable | (Inherited from ListViewEx.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsToDrag | (Inherited from ListViewEx.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineFill |
Public property | LineThickness |
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NodeExpansionMode |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from ListViewEx.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
 | PasteCommand |
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Placeholder |
Public property | PlaceholderPlacement |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RightClickPerformsExtendedNodeSelection |
Public property | Root |
Public property | ScrollableContentArea | (Inherited from ListViewEx.)
Public property | ScrollViewer | (Inherited from ListViewEx.)
Public property | SearchBox |
Public property | SearchBoxBackground |
Public property | SearchBoxCornerRadius |
Public property | SearchBoxMargin |
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedNodes |
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | ShowColumnHeaders |
Public property | ShowColumnSplitters |
Public property | ShowFilterOptions |
Public property | ShowLines |
Public property | ShowRoot |
Public property | ShowRootExpander |
Public property | ShowRootLines |
Public property | ShowSearchBox |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SortBy | (Inherited from ListViewEx.)
Public property | SortDirection | (Inherited from ListViewEx.)
Public property | SortNaturally | (Inherited from ListViewEx.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TopDownSelectionOrder |
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalDragScrollingMargin | (Inherited from ListViewEx.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | View | Gets or sets an object that defines how the data is styled and organized in a ListView control. (Inherited from ListView.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Protected method | BelongToSameView | (Overrides ListViewExBelongToSameView(KeyValuePairObject, IList, KeyValuePairObject, IList).)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CanStartDragOperation | (Overrides ListViewExCanStartDragOperation(ListViewItem).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes all templates, styles, and bindings for the object that is displayed as a ListViewItem. (Inherited from ListView.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
 | CompareNodesByFlatIndex |
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | FilterPredicate | (Overrides ListViewExFilterPredicate(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | FocusNode |
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | (Overrides ListViewGetContainerForItemOverride.)
Protected method | GetEmptyAreaDropTargetIndex | (Inherited from ListViewEx.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetListViewItem(Int32) | (Inherited from ListViewEx.)
Public method | GetListViewItem(Object) | (Inherited from ListViewEx.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetTopLevelSelection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | (Overrides ListViewIsItemItsOwnContainerOverride(Object).)
Public method | IsLastNodeInView |
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Inherited from ListViewEx.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnCollectionViewCurrentChanged | (Overrides ListViewExOnCollectionViewCurrentChanged.)
Protected method | OnCollectionViewCurrentChanging | (Inherited from ListViewEx.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Defines an AutomationPeer for the ListView control. (Inherited from ListView.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Responds to an OnItemsChanged(NotifyCollectionChangedEventArgs). (Inherited from ListView.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | (Inherited from ListViewEx.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | (Overrides ListBoxOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | (Overrides UIElementOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | (Overrides ListBoxOnSelectionChanged(SelectionChangedEventArgs).)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | (Overrides ListViewPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetFilter | (Inherited from ListViewEx.)
Public method | ScrollIntoView(Object) | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | ScrollIntoView(TreeNodeEx) |
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Public method | SelectItem | (Inherited from ListViewEx.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | Copy |
Public event | Cut |
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Delete |
Public event | DesiredSizeChanged | (Inherited from ListViewEx.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragEntering | (Inherited from ListViewEx.)
Public event | DragFinished | (Inherited from ListViewEx.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarted | (Inherited from ListViewEx.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropHandled | (Inherited from ListViewEx.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | HandleDragEnter | (Inherited from ListViewEx.)
Public event | HandleDragFeedback | (Inherited from ListViewEx.)
Public event | HandleDragLeave | (Inherited from ListViewEx.)
Public event | HandleDragOver | (Inherited from ListViewEx.)
Public event | HandleDrop | (Inherited from ListViewEx.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | NodeCheckedChanged |
Public event | NodeCollapsed |
Public event | NodeContextMenuOpening |
Public event | NodeDoubleClicked |
Public event | NodeEnterPressed |
Public event | NodeExpanded |
Public event | NodeMinusPressed |
Public event | NodeMouseEntered |
Public event | NodeMouseLeft |
Public event | NodeMouseMoved |
Public event | NodePlusPressed |
Public event | NodePropertyChanged |
Public event | NodeRemoveButtonClicked |
Public event | NodeReselected |
Public event | NodeSlashPressed |
Public event | NodeSpacePressed |
Public event | NodeStarPressed |
Public event | NodeVisibilityChanged |
Public event | Paste |
Public event | PrepareDragAdornerVisual | (Inherited from ListViewEx.)
Public event | PrepareItemsToDrag | (Inherited from ListViewEx.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectedNodesChanged |
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
 | Name | Description
Protected field | _dragDropEffects | (Inherited from ListViewEx.)
Protected field | _scrollableContentArea | (Inherited from ListViewEx.)
 | AllowsNodeReorderProperty |
 | AlternateRowsProperty |
 | AnchorLastOnCopyProperty |
 | AnchorNodeProperty |
 | AreColumnSplittersHitTestVisibleProperty |
 | AreColumnSplittersHitTestVisiblePropertyKey |
 | CanCopyProperty |
 | CanCutProperty |
 | CanDeleteProperty |
 | CanDragExpandProperty |
 | CanPasteProperty |
 | ColumnsProperty |
 | ComputedHeaderContentOffsetProperty |
 | ComputedHeaderContentOffsetPropertyKey |
 | DragExpandingDelayProperty |
 | DragExpandInvalidNodesProperty |
 | EnableColumnSplittersInteractionProperty |
 | FilterOptionsContentProperty |
 | HeaderBackgroundProperty |
 | HeaderBorderBrushProperty |
 | HeaderBorderThicknessProperty |
 | HeaderForegroundProperty |
 | IndentProperty |
 | IsDataOperationInProgressProperty |
 | IsDefaultSearchBoxInUseProperty |
 | IsDefaultSearchBoxInUsePropertyKey |
 | IsEditingProperty |
 | IsEditingPropertyKey |
 | IsGeneratingDragVisualProperty |
 | IsGeneratingDragVisualPropertyKey |
 | LineFillProperty |
 | LineThicknessProperty |
 | NodeExpansionModeProperty |
 | PlaceholderPlacementProperty |
 | PlaceholderProperty |
 | RightClickPerformsExtendedNodeSelectionProperty |
 | RootProperty |
 | SearchBoxBackgroundProperty |
 | SearchBoxCornerRadiusProperty |
 | SearchBoxMarginProperty |
 | SearchBoxProperty |
 | ShowColumnHeadersProperty |
 | ShowColumnSplittersProperty |
 | ShowFilterOptionsProperty |
 | ShowLinesProperty |
 | ShowRootExpanderProperty |
 | ShowRootLinesProperty |
 | ShowRootProperty |
 | ShowSearchBoxProperty |
 | TopDownSelectionOrderProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


TreeViewEx Constructor

Initializes a new instance of the TreeViewEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewEx()
public:
TreeViewEx()
See Also

Reference

TreeViewEx Class


TreeViewEx Properties

The TreeViewEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdjacentDropArea | (Inherited from ListViewEx.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowDropToEmptySpace | (Inherited from ListViewEx.)
Public property | AllowsNodeReorder |
Public property | AlternateRows |
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Protected property | AnchorItem | Gets or sets the item that is initially selected when SelectionMode is Extended. (Inherited from ListBox.)
Public property | AnchorLastOnCopy |
Public property | AnchorNode |
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreColumnSplittersHitTestVisible |
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Bounds | (Inherited from ListViewEx.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanCopy |
Public property | CanCut |
Public property | CanDelete |
Public property | CanDragExpand |
Public property | CanPaste |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CollectionView | (Inherited from ListViewEx.)
Public property | Columns |
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ComputedHeaderContentOffset |
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CopiedCutNodes |
 | CopyCommand |
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
 | CutCommand |
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
 | DefaultItemContainerStyleKey |
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DeferFilterRefresh | (Inherited from ListViewEx.)
 | DeleteCommand |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | DragAdornerClipsToBounds | (Inherited from ListViewEx.)
Public property | DragAdornerCounterBackground | (Inherited from ListViewEx.)
Public property | DragAdornerCounterForeground | (Inherited from ListViewEx.)
Public property | DragAdornerLayer | (Inherited from ListViewEx.)
Public property | DragAdornerOpacity | (Inherited from ListViewEx.)
Public property | DragAdornerPlacementTarget | (Inherited from ListViewEx.)
Public property | DragAdornerReflectsVisual | (Inherited from ListViewEx.)
Public property | DragExpandingDelay |
Public property | DragExpandInvalidNodes |
Public property | DragScrollingDelay | (Inherited from ListViewEx.)
Public property | DropIndicatorOffset | (Inherited from ListViewEx.)
Protected property | DropTargetItem | (Inherited from ListViewEx.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | EnableColumnSplittersInteraction |
Public property | FilterBy | (Inherited from ListViewEx.)
Public property | FilterOptions | (Inherited from ListViewEx.)
Public property | FilterOptionsCommand |
Public property | FilterOptionsContent |
Public property | FilterSettingsCommand |
Public property | FilterText | (Inherited from ListViewEx.)
Public property | FilterType | (Inherited from ListViewEx.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HeaderBackground |
Public property | HeaderBorderBrush |
Public property | HeaderBorderThickness |
Public property | HeaderForeground |
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalDragScrollingMargin | (Inherited from ListViewEx.)
Public property | IgnoreFilterTextCase | (Inherited from ListViewEx.)
Public property | Indent |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDataOperationInProgress |
Public property | IsDefaultSearchBoxInUse |
Public property | IsDragAreaRestricted | (Inherited from ListViewEx.)
Public property | IsDragInProgress | (Inherited from ListViewEx.)
Public property | IsDragOver | (Inherited from ListViewEx.)
Public property | IsDragScrolling | (Inherited from ListViewEx.)
Public property | IsDragSource | (Inherited from ListViewEx.)
Public property | IsDropTarget | (Inherited from ListViewEx.)
Public property | IsEditing |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGeneratingDragVisual |
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsNodeCollapsing |
Public property | IsNodeExpanding |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionInProgress |
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerHelperFocusable | (Inherited from ListViewEx.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsToDrag | (Inherited from ListViewEx.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineFill |
Public property | LineThickness |
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NodeExpansionMode |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from ListViewEx.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
 | PasteCommand |
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Placeholder |
Public property | PlaceholderPlacement |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RightClickPerformsExtendedNodeSelection |
Public property | Root |
Public property | ScrollableContentArea | (Inherited from ListViewEx.)
Public property | ScrollViewer | (Inherited from ListViewEx.)
Public property | SearchBox |
Public property | SearchBoxBackground |
Public property | SearchBoxCornerRadius |
Public property | SearchBoxMargin |
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedNodes |
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | ShowColumnHeaders |
Public property | ShowColumnSplitters |
Public property | ShowFilterOptions |
Public property | ShowLines |
Public property | ShowRoot |
Public property | ShowRootExpander |
Public property | ShowRootLines |
Public property | ShowSearchBox |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SortBy | (Inherited from ListViewEx.)
Public property | SortDirection | (Inherited from ListViewEx.)
Public property | SortNaturally | (Inherited from ListViewEx.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TopDownSelectionOrder |
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalDragScrollingMargin | (Inherited from ListViewEx.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | View | Gets or sets an object that defines how the data is styled and organized in a ListView control. (Inherited from ListView.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeViewEx Class


TreeViewEx.AllowsNodeReorder Property

TreeViewExAllowsNodeReorder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AllowsNodeReorder { get; set; }
public:
property bool AllowsNodeReorder {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.AlternateRows Property

TreeViewExAlternateRows Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AlternateRows { get; set; }
public:
property bool AlternateRows {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.AnchorLastOnCopy Property

TreeViewExAnchorLastOnCopy Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AnchorLastOnCopy { get; set; }
public:
property bool AnchorLastOnCopy {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.AnchorNode Property

TreeViewExAnchorNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx AnchorNode { get; set; }
public:
property TreeNodeEx^ AnchorNode {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

TreeViewEx Class


TreeViewEx.AreColumnSplittersHitTestVisible Property

TreeViewExAreColumnSplittersHitTestVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AreColumnSplittersHitTestVisible { get; }
public:
property bool AreColumnSplittersHitTestVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.CanCopy Property

TreeViewExCanCopy Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanCopy { get; set; }
public:
property bool CanCopy {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.CanCut Property

TreeViewExCanCut Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanCut { get; set; }
public:
property bool CanCut {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.CanDelete Property

TreeViewExCanDelete Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanDelete { get; set; }
public:
property bool CanDelete {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.CanDragExpand Property

TreeViewExCanDragExpand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanDragExpand { get; set; }
public:
property bool CanDragExpand {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.CanPaste Property

TreeViewExCanPaste Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanPaste { get; set; }
public:
property bool CanPaste {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.Columns Property

TreeViewExColumns Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GridViewColumnCollection Columns { get; set; }
public:
property GridViewColumnCollection^ Columns {
    GridViewColumnCollection^ get ();
    void set (GridViewColumnCollection^ value);
}

Property Value

Type: GridViewColumnCollection
See Also

Reference

TreeViewEx Class


TreeViewEx.ComputedHeaderContentOffset Property

TreeViewExComputedHeaderContentOffset Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness ComputedHeaderContentOffset { get; }
public:
property Thickness ComputedHeaderContentOffset {
    Thickness get ();
}

Property Value

Type: Thickness
See Also

Reference

TreeViewEx Class


TreeViewEx.CopiedCutNodes Property

TreeViewExCopiedCutNodes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyDictionary<Object, IList> CopiedCutNodes { get; }
public:
property ReadOnlyDictionary<Object^, IList^>^ CopiedCutNodes {
    ReadOnlyDictionary<Object^, IList^>^ get ();
}

Property Value

Type: ReadOnlyDictionaryObject, IList
See Also

Reference

TreeViewEx Class


TreeViewEx.CopyCommand Property

TreeViewExCopyCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ICommand CopyCommand { get; }
public:
static property ICommand^ CopyCommand {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

TreeViewEx Class


TreeViewEx.CutCommand Property

TreeViewExCutCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ICommand CutCommand { get; }
public:
static property ICommand^ CutCommand {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

TreeViewEx Class


TreeViewEx.DefaultItemContainerStyleKey Property

TreeViewExDefaultItemContainerStyleKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ResourceKey DefaultItemContainerStyleKey { get; }
public:
static property ResourceKey^ DefaultItemContainerStyleKey {
    ResourceKey^ get ();
}

Property Value

Type: ResourceKey
See Also

Reference

TreeViewEx Class


TreeViewEx.DeleteCommand Property

TreeViewExDeleteCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ICommand DeleteCommand { get; }
public:
static property ICommand^ DeleteCommand {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

TreeViewEx Class


TreeViewEx.DragExpandingDelay Property

TreeViewExDragExpandingDelay Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double DragExpandingDelay { get; set; }
public:
property double DragExpandingDelay {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TreeViewEx Class


TreeViewEx.DragExpandInvalidNodes Property

TreeViewExDragExpandInvalidNodes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DragExpandInvalidNodes { get; set; }
public:
property bool DragExpandInvalidNodes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.EnableColumnSplittersInteraction Property

TreeViewExEnableColumnSplittersInteraction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool EnableColumnSplittersInteraction { get; set; }
public:
property bool EnableColumnSplittersInteraction {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.FilterOptionsCommand Property

TreeViewExFilterOptionsCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommand FilterOptionsCommand { get; }
public:
property ICommand^ FilterOptionsCommand {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

TreeViewEx Class


TreeViewEx.FilterOptionsContent Property

TreeViewExFilterOptionsContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object FilterOptionsContent { get; set; }
public:
property Object^ FilterOptionsContent {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

TreeViewEx Class


TreeViewEx.FilterSettingsCommand Property

TreeViewExFilterSettingsCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommand FilterSettingsCommand { get; }
public:
property ICommand^ FilterSettingsCommand {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

TreeViewEx Class


TreeViewEx.HeaderBackground Property

TreeViewExHeaderBackground Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush HeaderBackground { get; set; }
public:
property Brush^ HeaderBackground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeViewEx Class


TreeViewEx.HeaderBorderBrush Property

TreeViewExHeaderBorderBrush Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush HeaderBorderBrush { get; set; }
public:
property Brush^ HeaderBorderBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeViewEx Class


TreeViewEx.HeaderBorderThickness Property

TreeViewExHeaderBorderThickness Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness HeaderBorderThickness { get; set; }
public:
property Thickness HeaderBorderThickness {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
See Also

Reference

TreeViewEx Class


TreeViewEx.HeaderForeground Property

TreeViewExHeaderForeground Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush HeaderForeground { get; set; }
public:
property Brush^ HeaderForeground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeViewEx Class


TreeViewEx.Indent Property

TreeViewExIndent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Indent { get; set; }
public:
property double Indent {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TreeViewEx Class


TreeViewEx.IsDataOperationInProgress Property

TreeViewExIsDataOperationInProgress Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDataOperationInProgress { get; set; }
public:
property bool IsDataOperationInProgress {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.IsDefaultSearchBoxInUse Property

TreeViewExIsDefaultSearchBoxInUse Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDefaultSearchBoxInUse { get; }
public:
property bool IsDefaultSearchBoxInUse {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.IsEditing Property

TreeViewExIsEditing Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEditing { get; }
public:
property bool IsEditing {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.IsGeneratingDragVisual Property

TreeViewExIsGeneratingDragVisual Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsGeneratingDragVisual { get; }
public:
property bool IsGeneratingDragVisual {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.IsNodeCollapsing Property

TreeViewExIsNodeCollapsing Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsNodeCollapsing { get; }
public:
property bool IsNodeCollapsing {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.IsNodeExpanding Property

TreeViewExIsNodeExpanding Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsNodeExpanding { get; }
public:
property bool IsNodeExpanding {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.IsSelectionInProgress Property

TreeViewExIsSelectionInProgress Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSelectionInProgress { get; }
public:
property bool IsSelectionInProgress {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.LineFill Property

TreeViewExLineFill Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush LineFill { get; set; }
public:
property Brush^ LineFill {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeViewEx Class


TreeViewEx.LineThickness Property

TreeViewExLineThickness Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double LineThickness { get; set; }
public:
property double LineThickness {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeExpansionMode Property

TreeViewExNodeExpansionMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ClickMode NodeExpansionMode { get; set; }
public:
property ClickMode NodeExpansionMode {
    ClickMode get ();
    void set (ClickMode value);
}

Property Value

Type: ClickMode
See Also

Reference

TreeViewEx Class


TreeViewEx.PasteCommand Property

TreeViewExPasteCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ICommand PasteCommand { get; }
public:
static property ICommand^ PasteCommand {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

TreeViewEx Class


TreeViewEx.Placeholder Property

TreeViewExPlaceholder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Placeholder { get; set; }
public:
property TreeNodeEx^ Placeholder {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

TreeViewEx Class


TreeViewEx.PlaceholderPlacement Property

TreeViewExPlaceholderPlacement Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PlaceholderNodePlacement PlaceholderPlacement { get; set; }
public:
property PlaceholderNodePlacement PlaceholderPlacement {
    PlaceholderNodePlacement get ();
    void set (PlaceholderNodePlacement value);
}

Property Value

Type: PlaceholderNodePlacement
See Also

Reference

TreeViewEx Class


TreeViewEx.RightClickPerformsExtendedNodeSelection Property

TreeViewExRightClickPerformsExtendedNodeSelection Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool RightClickPerformsExtendedNodeSelection { get; set; }
public:
property bool RightClickPerformsExtendedNodeSelection {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.Root Property

TreeViewExRoot Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Root { get; set; }
public:
property TreeNodeEx^ Root {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

TreeViewEx Class


TreeViewEx.SearchBox Property

TreeViewExSearchBox Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TextBox SearchBox { get; set; }
public:
property TextBox^ SearchBox {
    TextBox^ get ();
    void set (TextBox^ value);
}

Property Value

Type: TextBox
See Also

Reference

TreeViewEx Class


TreeViewEx.SearchBoxBackground Property

TreeViewExSearchBoxBackground Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush SearchBoxBackground { get; set; }
public:
property Brush^ SearchBoxBackground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

TreeViewEx Class


TreeViewEx.SearchBoxCornerRadius Property

TreeViewExSearchBoxCornerRadius Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CornerRadius SearchBoxCornerRadius { get; set; }
public:
property CornerRadius SearchBoxCornerRadius {
    CornerRadius get ();
    void set (CornerRadius value);
}

Property Value

Type: CornerRadius
See Also

Reference

TreeViewEx Class


TreeViewEx.SearchBoxMargin Property

TreeViewExSearchBoxMargin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness SearchBoxMargin { get; set; }
public:
property Thickness SearchBoxMargin {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
See Also

Reference

TreeViewEx Class


TreeViewEx.SelectedNodes Property

TreeViewExSelectedNodes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<TreeNodeEx> SelectedNodes { get; set; }
public:
property IList<TreeNodeEx^>^ SelectedNodes {
    IList<TreeNodeEx^>^ get ();
    void set (IList<TreeNodeEx^>^ value);
}

Property Value

Type: IListTreeNodeEx
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowColumnHeaders Property

TreeViewExShowColumnHeaders Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowColumnHeaders { get; set; }
public:
property bool ShowColumnHeaders {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowColumnSplitters Property

TreeViewExShowColumnSplitters Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowColumnSplitters { get; set; }
public:
property bool ShowColumnSplitters {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowFilterOptions Property

TreeViewExShowFilterOptions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowFilterOptions { get; set; }
public:
property bool ShowFilterOptions {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowLines Property

TreeViewExShowLines Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowLines { get; set; }
public:
property bool ShowLines {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowRoot Property

TreeViewExShowRoot Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowRoot { get; set; }
public:
property bool ShowRoot {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowRootExpander Property

TreeViewExShowRootExpander Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowRootExpander { get; set; }
public:
property bool ShowRootExpander {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowRootLines Property

TreeViewExShowRootLines Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowRootLines { get; set; }
public:
property bool ShowRootLines {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowSearchBox Property

TreeViewExShowSearchBox Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowSearchBox { get; set; }
public:
property bool ShowSearchBox {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx.TopDownSelectionOrder Property

TreeViewExTopDownSelectionOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool TopDownSelectionOrder { get; set; }
public:
property bool TopDownSelectionOrder {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TreeViewEx Class


TreeViewEx Methods

The TreeViewEx type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Protected method | BelongToSameView | (Overrides ListViewExBelongToSameView(KeyValuePairObject, IList, KeyValuePairObject, IList).)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CanStartDragOperation | (Overrides ListViewExCanStartDragOperation(ListViewItem).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes all templates, styles, and bindings for the object that is displayed as a ListViewItem. (Inherited from ListView.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
 | CompareNodesByFlatIndex |
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | FilterPredicate | (Overrides ListViewExFilterPredicate(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | FocusNode |
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | (Overrides ListViewGetContainerForItemOverride.)
Protected method | GetEmptyAreaDropTargetIndex | (Inherited from ListViewEx.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetListViewItem(Int32) | (Inherited from ListViewEx.)
Public method | GetListViewItem(Object) | (Inherited from ListViewEx.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetTopLevelSelection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | (Overrides ListViewIsItemItsOwnContainerOverride(Object).)
Public method | IsLastNodeInView |
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Inherited from ListViewEx.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnCollectionViewCurrentChanged | (Overrides ListViewExOnCollectionViewCurrentChanged.)
Protected method | OnCollectionViewCurrentChanging | (Inherited from ListViewEx.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Defines an AutomationPeer for the ListView control. (Inherited from ListView.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Responds to an OnItemsChanged(NotifyCollectionChangedEventArgs). (Inherited from ListView.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | (Inherited from ListViewEx.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | (Overrides ListBoxOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | (Overrides UIElementOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | (Overrides ListBoxOnSelectionChanged(SelectionChangedEventArgs).)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | (Overrides ListViewPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetFilter | (Inherited from ListViewEx.)
Public method | ScrollIntoView(Object) | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | ScrollIntoView(TreeNodeEx) |
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Public method | SelectItem | (Inherited from ListViewEx.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TreeViewEx Class


TreeViewEx.BelongToSameView Method

TreeViewExBelongToSameView Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override bool BelongToSameView(
    KeyValuePair<Object, IList> source,
    KeyValuePair<Object, IList> target
)
protected:
virtual bool BelongToSameView(
    KeyValuePair<Object^, IList^> source,
    KeyValuePair<Object^, IList^> target
) override

Parameters

source
Type: System.Collections.GenericKeyValuePairObject, IList
target
Type: System.Collections.GenericKeyValuePairObject, IList

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeViewEx.BelongToSameView(System.Collections.Generic.KeyValuePair{System.Object,System.Collections.IList},System.Collections.Generic.KeyValuePair{System.Object,System.Collections.IList})"]

See Also

Reference

TreeViewEx Class


TreeViewEx.CanStartDragOperation Method

TreeViewExCanStartDragOperation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override bool CanStartDragOperation(
    ListViewItem item
)
protected:
virtual bool CanStartDragOperation(
    ListViewItem^ item
) override

Parameters

item
Type: System.Windows.ControlsListViewItem

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeViewEx.CanStartDragOperation(System.Windows.Controls.ListViewItem)"]

See Also

Reference

TreeViewEx Class


TreeViewEx.CompareNodesByFlatIndex Method

TreeViewExCompareNodesByFlatIndex Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int CompareNodesByFlatIndex(
    TreeNodeEx source,
    TreeNodeEx target
)
public:
static int CompareNodesByFlatIndex(
    TreeNodeEx^ source,
    TreeNodeEx^ target
)

Parameters

source
Type: VisualComponents.UX.SharedTreeNodeEx
target
Type: VisualComponents.UX.SharedTreeNodeEx

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeViewEx.CompareNodesByFlatIndex(VisualComponents.UX.Shared.TreeNodeEx,VisualComponents.UX.Shared.TreeNodeEx)"]

See Also

Reference

TreeViewEx Class


TreeViewEx.FilterPredicate Method

TreeViewExFilterPredicate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override bool FilterPredicate(
    Object source
)
protected:
virtual bool FilterPredicate(
    Object^ source
) override

Parameters

source
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeViewEx.FilterPredicate(System.Object)"]

See Also

Reference

TreeViewEx Class


TreeViewEx.FocusNode Method

TreeViewExFocusNode Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void FocusNode(
    TreeNodeEx node
)
public:
void FocusNode(
    TreeNodeEx^ node
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
See Also

Reference

TreeViewEx Class


TreeViewEx.GetContainerForItemOverride Method

TreeViewExGetContainerForItemOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override DependencyObject GetContainerForItemOverride()
protected:
virtual DependencyObject^ GetContainerForItemOverride() override

Return Value

Type: DependencyObject

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeViewEx.GetContainerForItemOverride"]

See Also

Reference

TreeViewEx Class


TreeViewEx.GetTopLevelSelection Method

TreeViewExGetTopLevelSelection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<TreeNodeEx> GetTopLevelSelection()
public:
IList<TreeNodeEx^>^ GetTopLevelSelection()

Return Value

Type: IListTreeNodeEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeViewEx.GetTopLevelSelection"]

See Also

Reference

TreeViewEx Class


TreeViewEx.IsItemItsOwnContainerOverride Method

TreeViewExIsItemItsOwnContainerOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
protected:
virtual bool IsItemItsOwnContainerOverride(
    Object^ item
) override

Parameters

item
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeViewEx.IsItemItsOwnContainerOverride(System.Object)"]

See Also

Reference

TreeViewEx Class


TreeViewEx.IsLastNodeInView Method

TreeViewExIsLastNodeInView Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLastNodeInView(
    TreeNodeEx node
)
public:
bool IsLastNodeInView(
    TreeNodeEx^ node
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeViewEx.IsLastNodeInView(VisualComponents.UX.Shared.TreeNodeEx)"]

See Also

Reference

TreeViewEx Class


TreeViewEx.OnApplyTemplate Method

TreeViewExOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

TreeViewEx Class


TreeViewEx.OnCollectionViewCurrentChanged Method

TreeViewExOnCollectionViewCurrentChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnCollectionViewCurrentChanged()
protected:
virtual void OnCollectionViewCurrentChanged() override
See Also

Reference

TreeViewEx Class


TreeViewEx.OnGotKeyboardFocus Method

TreeViewExOnGotKeyboardFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
protected:
virtual void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.OnKeyDown Method

TreeViewExOnKeyDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.OnPreviewKeyDown Method

TreeViewExOnPreviewKeyDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewKeyDown(
    KeyEventArgs e
)
protected:
virtual void OnPreviewKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.OnPropertyChanged Method

TreeViewExOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.OnSelectionChanged Method

TreeViewExOnSelectionChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnSelectionChanged(
    SelectionChangedEventArgs e
)
protected:
virtual void OnSelectionChanged(
    SelectionChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.ControlsSelectionChangedEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.PrepareContainerForItemOverride Method

TreeViewExPrepareContainerForItemOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
protected:
virtual void PrepareContainerForItemOverride(
    DependencyObject^ element,
    Object^ item
) override

Parameters

element
Type: System.WindowsDependencyObject
item
Type: SystemObject
See Also

Reference

TreeViewEx Class


TreeViewEx.ScrollIntoView Method

TreeViewExScrollIntoView Method

Overload List
 | Name | Description
Public method | ScrollIntoView(Object) | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | ScrollIntoView(TreeNodeEx) |
Top
See Also

Reference

TreeViewEx Class


TreeViewEx.ScrollIntoView Method (TreeNodeEx)

TreeViewExScrollIntoView Method (TreeNodeEx)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ScrollIntoView(
    TreeNodeEx node
)
public:
void ScrollIntoView(
    TreeNodeEx^ node
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
See Also

Reference

TreeViewEx Class
ScrollIntoView Overload


TreeViewEx Events

The TreeViewEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | Copy |
Public event | Cut |
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Delete |
Public event | DesiredSizeChanged | (Inherited from ListViewEx.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragEntering | (Inherited from ListViewEx.)
Public event | DragFinished | (Inherited from ListViewEx.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarted | (Inherited from ListViewEx.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropHandled | (Inherited from ListViewEx.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | HandleDragEnter | (Inherited from ListViewEx.)
Public event | HandleDragFeedback | (Inherited from ListViewEx.)
Public event | HandleDragLeave | (Inherited from ListViewEx.)
Public event | HandleDragOver | (Inherited from ListViewEx.)
Public event | HandleDrop | (Inherited from ListViewEx.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | NodeCheckedChanged |
Public event | NodeCollapsed |
Public event | NodeContextMenuOpening |
Public event | NodeDoubleClicked |
Public event | NodeEnterPressed |
Public event | NodeExpanded |
Public event | NodeMinusPressed |
Public event | NodeMouseEntered |
Public event | NodeMouseLeft |
Public event | NodeMouseMoved |
Public event | NodePlusPressed |
Public event | NodePropertyChanged |
Public event | NodeRemoveButtonClicked |
Public event | NodeReselected |
Public event | NodeSlashPressed |
Public event | NodeSpacePressed |
Public event | NodeStarPressed |
Public event | NodeVisibilityChanged |
Public event | Paste |
Public event | PrepareDragAdornerVisual | (Inherited from ListViewEx.)
Public event | PrepareItemsToDrag | (Inherited from ListViewEx.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectedNodesChanged |
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeViewEx Class


TreeViewEx.Copy Event

TreeViewExCopy Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ActionRequestedEventArgs> Copy
public:
 event EventHandler<ActionRequestedEventArgs^>^ Copy {
    void add (EventHandler<ActionRequestedEventArgs^>^ value);
    void remove (EventHandler<ActionRequestedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActionRequestedEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.Cut Event

TreeViewExCut Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ActionRequestedEventArgs> Cut
public:
 event EventHandler<ActionRequestedEventArgs^>^ Cut {
    void add (EventHandler<ActionRequestedEventArgs^>^ value);
    void remove (EventHandler<ActionRequestedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActionRequestedEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.Delete Event

TreeViewExDelete Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ActionRequestedEventArgs> Delete
public:
 event EventHandler<ActionRequestedEventArgs^>^ Delete {
    void add (EventHandler<ActionRequestedEventArgs^>^ value);
    void remove (EventHandler<ActionRequestedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActionRequestedEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeCheckedChanged Event

TreeViewExNodeCheckedChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeEventArgs> NodeCheckedChanged
public:
 event EventHandler<NodeEventArgs^>^ NodeCheckedChanged {
    void add (EventHandler<NodeEventArgs^>^ value);
    void remove (EventHandler<NodeEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeCollapsed Event

TreeViewExNodeCollapsed Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeEventArgs> NodeCollapsed
public:
 event EventHandler<NodeEventArgs^>^ NodeCollapsed {
    void add (EventHandler<NodeEventArgs^>^ value);
    void remove (EventHandler<NodeEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeContextMenuOpening Event

TreeViewExNodeContextMenuOpening Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeContextMenuEventArgs> NodeContextMenuOpening
public:
 event EventHandler<NodeContextMenuEventArgs^>^ NodeContextMenuOpening {
    void add (EventHandler<NodeContextMenuEventArgs^>^ value);
    void remove (EventHandler<NodeContextMenuEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeContextMenuEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeDoubleClicked Event

TreeViewExNodeDoubleClicked Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeMouseButtonEventArgs> NodeDoubleClicked
public:
 event EventHandler<NodeMouseButtonEventArgs^>^ NodeDoubleClicked {
    void add (EventHandler<NodeMouseButtonEventArgs^>^ value);
    void remove (EventHandler<NodeMouseButtonEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeMouseButtonEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeEnterPressed Event

TreeViewExNodeEnterPressed Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeKeyEventArgs> NodeEnterPressed
public:
 event EventHandler<NodeKeyEventArgs^>^ NodeEnterPressed {
    void add (EventHandler<NodeKeyEventArgs^>^ value);
    void remove (EventHandler<NodeKeyEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeKeyEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeExpanded Event

TreeViewExNodeExpanded Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeEventArgs> NodeExpanded
public:
 event EventHandler<NodeEventArgs^>^ NodeExpanded {
    void add (EventHandler<NodeEventArgs^>^ value);
    void remove (EventHandler<NodeEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeMinusPressed Event

TreeViewExNodeMinusPressed Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeKeyEventArgs> NodeMinusPressed
public:
 event EventHandler<NodeKeyEventArgs^>^ NodeMinusPressed {
    void add (EventHandler<NodeKeyEventArgs^>^ value);
    void remove (EventHandler<NodeKeyEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeKeyEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeMouseEntered Event

TreeViewExNodeMouseEntered Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeMouseEventArgs> NodeMouseEntered
public:
 event EventHandler<NodeMouseEventArgs^>^ NodeMouseEntered {
    void add (EventHandler<NodeMouseEventArgs^>^ value);
    void remove (EventHandler<NodeMouseEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeMouseEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeMouseLeft Event

TreeViewExNodeMouseLeft Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeMouseEventArgs> NodeMouseLeft
public:
 event EventHandler<NodeMouseEventArgs^>^ NodeMouseLeft {
    void add (EventHandler<NodeMouseEventArgs^>^ value);
    void remove (EventHandler<NodeMouseEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeMouseEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeMouseMoved Event

TreeViewExNodeMouseMoved Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeMouseEventArgs> NodeMouseMoved
public:
 event EventHandler<NodeMouseEventArgs^>^ NodeMouseMoved {
    void add (EventHandler<NodeMouseEventArgs^>^ value);
    void remove (EventHandler<NodeMouseEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeMouseEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodePlusPressed Event

TreeViewExNodePlusPressed Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeKeyEventArgs> NodePlusPressed
public:
 event EventHandler<NodeKeyEventArgs^>^ NodePlusPressed {
    void add (EventHandler<NodeKeyEventArgs^>^ value);
    void remove (EventHandler<NodeKeyEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeKeyEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodePropertyChanged Event

TreeViewExNodePropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodePropertyChangedEventArgs> NodePropertyChanged
public:
 event EventHandler<NodePropertyChangedEventArgs^>^ NodePropertyChanged {
    void add (EventHandler<NodePropertyChangedEventArgs^>^ value);
    void remove (EventHandler<NodePropertyChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodePropertyChangedEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeRemoveButtonClicked Event

TreeViewExNodeRemoveButtonClicked Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeMouseButtonEventArgs> NodeRemoveButtonClicked
public:
 event EventHandler<NodeMouseButtonEventArgs^>^ NodeRemoveButtonClicked {
    void add (EventHandler<NodeMouseButtonEventArgs^>^ value);
    void remove (EventHandler<NodeMouseButtonEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeMouseButtonEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeReselected Event

TreeViewExNodeReselected Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeEventArgs> NodeReselected
public:
 event EventHandler<NodeEventArgs^>^ NodeReselected {
    void add (EventHandler<NodeEventArgs^>^ value);
    void remove (EventHandler<NodeEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeSlashPressed Event

TreeViewExNodeSlashPressed Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeKeyEventArgs> NodeSlashPressed
public:
 event EventHandler<NodeKeyEventArgs^>^ NodeSlashPressed {
    void add (EventHandler<NodeKeyEventArgs^>^ value);
    void remove (EventHandler<NodeKeyEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeKeyEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeSpacePressed Event

TreeViewExNodeSpacePressed Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeKeyEventArgs> NodeSpacePressed
public:
 event EventHandler<NodeKeyEventArgs^>^ NodeSpacePressed {
    void add (EventHandler<NodeKeyEventArgs^>^ value);
    void remove (EventHandler<NodeKeyEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeKeyEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeStarPressed Event

TreeViewExNodeStarPressed Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeKeyEventArgs> NodeStarPressed
public:
 event EventHandler<NodeKeyEventArgs^>^ NodeStarPressed {
    void add (EventHandler<NodeKeyEventArgs^>^ value);
    void remove (EventHandler<NodeKeyEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeKeyEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeVisibilityChanged Event

TreeViewExNodeVisibilityChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<NodeEventArgs> NodeVisibilityChanged
public:
 event EventHandler<NodeEventArgs^>^ NodeVisibilityChanged {
    void add (EventHandler<NodeEventArgs^>^ value);
    void remove (EventHandler<NodeEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.Paste Event

TreeViewExPaste Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ActionRequestedEventArgs> Paste
public:
 event EventHandler<ActionRequestedEventArgs^>^ Paste {
    void add (EventHandler<ActionRequestedEventArgs^>^ value);
    void remove (EventHandler<ActionRequestedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActionRequestedEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx.SelectedNodesChanged Event

TreeViewExSelectedNodesChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<SelectedNodesChangedEventArgs> SelectedNodesChanged
public:
 event EventHandler<SelectedNodesChangedEventArgs^>^ SelectedNodesChanged {
    void add (EventHandler<SelectedNodesChangedEventArgs^>^ value);
    void remove (EventHandler<SelectedNodesChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSelectedNodesChangedEventArgs
See Also

Reference

TreeViewEx Class


TreeViewEx Fields

The TreeViewEx type exposes the following members.

Fields
 | Name | Description
Protected field | _dragDropEffects | (Inherited from ListViewEx.)
Protected field | _scrollableContentArea | (Inherited from ListViewEx.)
 | AllowsNodeReorderProperty |
 | AlternateRowsProperty |
 | AnchorLastOnCopyProperty |
 | AnchorNodeProperty |
 | AreColumnSplittersHitTestVisibleProperty |
 | AreColumnSplittersHitTestVisiblePropertyKey |
 | CanCopyProperty |
 | CanCutProperty |
 | CanDeleteProperty |
 | CanDragExpandProperty |
 | CanPasteProperty |
 | ColumnsProperty |
 | ComputedHeaderContentOffsetProperty |
 | ComputedHeaderContentOffsetPropertyKey |
 | DragExpandingDelayProperty |
 | DragExpandInvalidNodesProperty |
 | EnableColumnSplittersInteractionProperty |
 | FilterOptionsContentProperty |
 | HeaderBackgroundProperty |
 | HeaderBorderBrushProperty |
 | HeaderBorderThicknessProperty |
 | HeaderForegroundProperty |
 | IndentProperty |
 | IsDataOperationInProgressProperty |
 | IsDefaultSearchBoxInUseProperty |
 | IsDefaultSearchBoxInUsePropertyKey |
 | IsEditingProperty |
 | IsEditingPropertyKey |
 | IsGeneratingDragVisualProperty |
 | IsGeneratingDragVisualPropertyKey |
 | LineFillProperty |
 | LineThicknessProperty |
 | NodeExpansionModeProperty |
 | PlaceholderPlacementProperty |
 | PlaceholderProperty |
 | RightClickPerformsExtendedNodeSelectionProperty |
 | RootProperty |
 | SearchBoxBackgroundProperty |
 | SearchBoxCornerRadiusProperty |
 | SearchBoxMarginProperty |
 | SearchBoxProperty |
 | ShowColumnHeadersProperty |
 | ShowColumnSplittersProperty |
 | ShowFilterOptionsProperty |
 | ShowLinesProperty |
 | ShowRootExpanderProperty |
 | ShowRootLinesProperty |
 | ShowRootProperty |
 | ShowSearchBoxProperty |
 | TopDownSelectionOrderProperty |
Top
See Also

Reference

TreeViewEx Class


TreeViewEx.AllowsNodeReorderProperty Field

TreeViewExAllowsNodeReorderProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AllowsNodeReorderProperty
public:
static initonly DependencyProperty^ AllowsNodeReorderProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.AlternateRowsProperty Field

TreeViewExAlternateRowsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AlternateRowsProperty
public:
static initonly DependencyProperty^ AlternateRowsProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.AnchorLastOnCopyProperty Field

TreeViewExAnchorLastOnCopyProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AnchorLastOnCopyProperty
public:
static initonly DependencyProperty^ AnchorLastOnCopyProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.AnchorNodeProperty Field

TreeViewExAnchorNodeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AnchorNodeProperty
public:
static initonly DependencyProperty^ AnchorNodeProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.AreColumnSplittersHitTestVisibleProperty Field

TreeViewExAreColumnSplittersHitTestVisibleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AreColumnSplittersHitTestVisibleProperty
public:
static initonly DependencyProperty^ AreColumnSplittersHitTestVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.AreColumnSplittersHitTestVisiblePropertyKey Field

TreeViewExAreColumnSplittersHitTestVisiblePropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey AreColumnSplittersHitTestVisiblePropertyKey
public:
static initonly DependencyPropertyKey^ AreColumnSplittersHitTestVisiblePropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

TreeViewEx Class


TreeViewEx.CanCopyProperty Field

TreeViewExCanCopyProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanCopyProperty
public:
static initonly DependencyProperty^ CanCopyProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.CanCutProperty Field

TreeViewExCanCutProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanCutProperty
public:
static initonly DependencyProperty^ CanCutProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.CanDeleteProperty Field

TreeViewExCanDeleteProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanDeleteProperty
public:
static initonly DependencyProperty^ CanDeleteProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.CanDragExpandProperty Field

TreeViewExCanDragExpandProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanDragExpandProperty
public:
static initonly DependencyProperty^ CanDragExpandProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.CanPasteProperty Field

TreeViewExCanPasteProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanPasteProperty
public:
static initonly DependencyProperty^ CanPasteProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ColumnsProperty Field

TreeViewExColumnsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ColumnsProperty
public:
static initonly DependencyProperty^ ColumnsProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ComputedHeaderContentOffsetProperty Field

TreeViewExComputedHeaderContentOffsetProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ComputedHeaderContentOffsetProperty
public:
static initonly DependencyProperty^ ComputedHeaderContentOffsetProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ComputedHeaderContentOffsetPropertyKey Field

TreeViewExComputedHeaderContentOffsetPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey ComputedHeaderContentOffsetPropertyKey
public:
static initonly DependencyPropertyKey^ ComputedHeaderContentOffsetPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

TreeViewEx Class


TreeViewEx.DragExpandingDelayProperty Field

TreeViewExDragExpandingDelayProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DragExpandingDelayProperty
public:
static initonly DependencyProperty^ DragExpandingDelayProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.DragExpandInvalidNodesProperty Field

TreeViewExDragExpandInvalidNodesProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DragExpandInvalidNodesProperty
public:
static initonly DependencyProperty^ DragExpandInvalidNodesProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.EnableColumnSplittersInteractionProperty Field

TreeViewExEnableColumnSplittersInteractionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty EnableColumnSplittersInteractionProperty
public:
static initonly DependencyProperty^ EnableColumnSplittersInteractionProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.FilterOptionsContentProperty Field

TreeViewExFilterOptionsContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FilterOptionsContentProperty
public:
static initonly DependencyProperty^ FilterOptionsContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.HeaderBackgroundProperty Field

TreeViewExHeaderBackgroundProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HeaderBackgroundProperty
public:
static initonly DependencyProperty^ HeaderBackgroundProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.HeaderBorderBrushProperty Field

TreeViewExHeaderBorderBrushProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HeaderBorderBrushProperty
public:
static initonly DependencyProperty^ HeaderBorderBrushProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.HeaderBorderThicknessProperty Field

TreeViewExHeaderBorderThicknessProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HeaderBorderThicknessProperty
public:
static initonly DependencyProperty^ HeaderBorderThicknessProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.HeaderForegroundProperty Field

TreeViewExHeaderForegroundProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HeaderForegroundProperty
public:
static initonly DependencyProperty^ HeaderForegroundProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.IndentProperty Field

TreeViewExIndentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IndentProperty
public:
static initonly DependencyProperty^ IndentProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.IsDataOperationInProgressProperty Field

TreeViewExIsDataOperationInProgressProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsDataOperationInProgressProperty
public:
static initonly DependencyProperty^ IsDataOperationInProgressProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.IsDefaultSearchBoxInUseProperty Field

TreeViewExIsDefaultSearchBoxInUseProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsDefaultSearchBoxInUseProperty
public:
static initonly DependencyProperty^ IsDefaultSearchBoxInUseProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.IsDefaultSearchBoxInUsePropertyKey Field

TreeViewExIsDefaultSearchBoxInUsePropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey IsDefaultSearchBoxInUsePropertyKey
public:
static initonly DependencyPropertyKey^ IsDefaultSearchBoxInUsePropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

TreeViewEx Class


TreeViewEx.IsEditingProperty Field

TreeViewExIsEditingProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsEditingProperty
public:
static initonly DependencyProperty^ IsEditingProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.IsEditingPropertyKey Field

TreeViewExIsEditingPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey IsEditingPropertyKey
public:
static initonly DependencyPropertyKey^ IsEditingPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

TreeViewEx Class


TreeViewEx.IsGeneratingDragVisualProperty Field

TreeViewExIsGeneratingDragVisualProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsGeneratingDragVisualProperty
public:
static initonly DependencyProperty^ IsGeneratingDragVisualProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.IsGeneratingDragVisualPropertyKey Field

TreeViewExIsGeneratingDragVisualPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey IsGeneratingDragVisualPropertyKey
public:
static initonly DependencyPropertyKey^ IsGeneratingDragVisualPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

TreeViewEx Class


TreeViewEx.LineFillProperty Field

TreeViewExLineFillProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty LineFillProperty
public:
static initonly DependencyProperty^ LineFillProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.LineThicknessProperty Field

TreeViewExLineThicknessProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty LineThicknessProperty
public:
static initonly DependencyProperty^ LineThicknessProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.NodeExpansionModeProperty Field

TreeViewExNodeExpansionModeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty NodeExpansionModeProperty
public:
static initonly DependencyProperty^ NodeExpansionModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.PlaceholderPlacementProperty Field

TreeViewExPlaceholderPlacementProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PlaceholderPlacementProperty
public:
static initonly DependencyProperty^ PlaceholderPlacementProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.PlaceholderProperty Field

TreeViewExPlaceholderProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PlaceholderProperty
public:
static initonly DependencyProperty^ PlaceholderProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.RightClickPerformsExtendedNodeSelectionProperty Field

TreeViewExRightClickPerformsExtendedNodeSelectionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RightClickPerformsExtendedNodeSelectionProperty
public:
static initonly DependencyProperty^ RightClickPerformsExtendedNodeSelectionProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.RootProperty Field

TreeViewExRootProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RootProperty
public:
static initonly DependencyProperty^ RootProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.SearchBoxBackgroundProperty Field

TreeViewExSearchBoxBackgroundProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SearchBoxBackgroundProperty
public:
static initonly DependencyProperty^ SearchBoxBackgroundProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.SearchBoxCornerRadiusProperty Field

TreeViewExSearchBoxCornerRadiusProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SearchBoxCornerRadiusProperty
public:
static initonly DependencyProperty^ SearchBoxCornerRadiusProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.SearchBoxMarginProperty Field

TreeViewExSearchBoxMarginProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SearchBoxMarginProperty
public:
static initonly DependencyProperty^ SearchBoxMarginProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.SearchBoxProperty Field

TreeViewExSearchBoxProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SearchBoxProperty
public:
static initonly DependencyProperty^ SearchBoxProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowColumnHeadersProperty Field

TreeViewExShowColumnHeadersProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowColumnHeadersProperty
public:
static initonly DependencyProperty^ ShowColumnHeadersProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowColumnSplittersProperty Field

TreeViewExShowColumnSplittersProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowColumnSplittersProperty
public:
static initonly DependencyProperty^ ShowColumnSplittersProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowFilterOptionsProperty Field

TreeViewExShowFilterOptionsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowFilterOptionsProperty
public:
static initonly DependencyProperty^ ShowFilterOptionsProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowLinesProperty Field

TreeViewExShowLinesProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowLinesProperty
public:
static initonly DependencyProperty^ ShowLinesProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowRootExpanderProperty Field

TreeViewExShowRootExpanderProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowRootExpanderProperty
public:
static initonly DependencyProperty^ ShowRootExpanderProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowRootLinesProperty Field

TreeViewExShowRootLinesProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowRootLinesProperty
public:
static initonly DependencyProperty^ ShowRootLinesProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowRootProperty Field

TreeViewExShowRootProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowRootProperty
public:
static initonly DependencyProperty^ ShowRootProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.ShowSearchBoxProperty Field

TreeViewExShowSearchBoxProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ShowSearchBoxProperty
public:
static initonly DependencyProperty^ ShowSearchBoxProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewEx.TopDownSelectionOrderProperty Field

TreeViewExTopDownSelectionOrderProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TopDownSelectionOrderProperty
public:
static initonly DependencyProperty^ TopDownSelectionOrderProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewEx Class


TreeViewExCommandHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedTreeViewExCommandHandler

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TreeViewExCommandHandler : ICommand
public ref class TreeViewExCommandHandler : ICommand

The TreeViewExCommandHandler type exposes the following members.

Constructors
 | Name | Description
Public method | TreeViewExCommandHandler(Action) | Initializes a new instance of the TreeViewExCommandHandler class
Public method | TreeViewExCommandHandler(ActionObject) | Initializes a new instance of the TreeViewExCommandHandler class
Top
Methods
 | Name | Description
Public method | CanExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CanExecuteChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


TreeViewExCommandHandler Constructor

Overload List
 | Name | Description
Public method | TreeViewExCommandHandler(Action) | Initializes a new instance of the TreeViewExCommandHandler class
Public method | TreeViewExCommandHandler(ActionObject) | Initializes a new instance of the TreeViewExCommandHandler class
Top
See Also

Reference

TreeViewExCommandHandler Class


TreeViewExCommandHandler Constructor (Action)

Initializes a new instance of the TreeViewExCommandHandler class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewExCommandHandler(
    Action action
)
public:
TreeViewExCommandHandler(
    Action^ action
)

Parameters

action
Type: SystemAction
See Also

Reference

TreeViewExCommandHandler Class
TreeViewExCommandHandler Overload


TreeViewExCommandHandler Constructor (Action(Object))

TreeViewExCommandHandler Constructor (ActionObject)

Initializes a new instance of the TreeViewExCommandHandler class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewExCommandHandler(
    Action<Object> action
)
public:
TreeViewExCommandHandler(
    Action<Object^>^ action
)

Parameters

action
Type: SystemActionObject
See Also

Reference

TreeViewExCommandHandler Class
TreeViewExCommandHandler Overload


TreeViewExCommandHandler Methods

The TreeViewExCommandHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TreeViewExCommandHandler Class


TreeViewExCommandHandler.CanExecute Method

TreeViewExCommandHandlerCanExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanExecute(
    Object parameter
)
public:
virtual bool CanExecute(
    Object^ parameter
) sealed

Parameters

parameter
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TreeViewExCommandHandler.CanExecute(System.Object)"]

Implements

ICommandCanExecute(Object)
See Also

Reference

TreeViewExCommandHandler Class


TreeViewExCommandHandler.Execute Method

TreeViewExCommandHandlerExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    Object parameter
)
public:
virtual void Execute(
    Object^ parameter
) sealed

Parameters

parameter
Type: SystemObject

Implements

ICommandExecute(Object)
See Also

Reference

TreeViewExCommandHandler Class


TreeViewExCommandHandler Events

The TreeViewExCommandHandler type exposes the following members.

Events
 | Name | Description
Public event | CanExecuteChanged |
Top
See Also

Reference

TreeViewExCommandHandler Class


TreeViewExCommandHandler.CanExecuteChanged Event

TreeViewExCommandHandlerCanExecuteChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler CanExecuteChanged
public:
virtual  event EventHandler^ CanExecuteChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ICommandCanExecuteChanged
See Also

Reference

TreeViewExCommandHandler Class


TreeViewItemEx Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsListBoxItem
System.Windows.ControlsListViewItem
VisualComponents.UX.SharedTreeViewItemEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TreeViewItemEx : ListViewItem
public ref class TreeViewItemEx : public ListViewItem

The TreeViewItemEx type exposes the following members.

Constructors
 | Name | Description
Public method | TreeViewItemEx | Initializes a new instance of the TreeViewItemEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Node |
Public property | NodeView |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RowSelectionArea |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TreeView |
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | (Overrides FrameworkElementOnContextMenuOpening(ContextMenuEventArgs).)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | (Overrides UIElementOnLostMouseCapture(MouseEventArgs).)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | (Overrides ListBoxItemOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | (Overrides ListBoxItemOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | (Overrides UIElementOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | (Overrides ListBoxItemOnMouseRightButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseRightButtonUp | (Overrides UIElementOnMouseRightButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelected | Called when the ListBoxItem is selected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnselected | Called when the ListBoxItem is unselected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the visual parent of a list box item changes. (Inherited from ListBoxItem.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | Selected | Occurs when a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | Unselected | Occurs when a ListBoxItem is unselected. (Inherited from ListBoxItem.)
Top
Fields
Name | Description
NodeViewProperty |
TreeViewProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


TreeViewItemEx Constructor

Initializes a new instance of the TreeViewItemEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewItemEx()
public:
TreeViewItemEx()
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx Properties

The TreeViewItemEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Node |
Public property | NodeView |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RowSelectionArea |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TreeView |
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.Node Property

TreeViewItemExNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Node { get; }
public:
virtual property TreeNodeEx^ Node {
    TreeNodeEx^ get () sealed;
}

Property Value

Type: TreeNodeEx
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.NodeView Property

TreeViewItemExNodeView Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeViewEx NodeView { get; }
public:
virtual property TreeNodeViewEx^ NodeView {
    TreeNodeViewEx^ get () sealed;
}

Property Value

Type: TreeNodeViewEx
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.RowSelectionArea Property

TreeViewItemExRowSelectionArea Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameworkElement RowSelectionArea { get; }
public:
property FrameworkElement^ RowSelectionArea {
    FrameworkElement^ get ();
}

Property Value

Type: FrameworkElement
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.TreeView Property

TreeViewItemExTreeView Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewEx TreeView { get; }
public:
virtual property TreeViewEx^ TreeView {
    TreeViewEx^ get () sealed;
}

Property Value

Type: TreeViewEx
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx Methods

The TreeViewItemEx type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | (Overrides FrameworkElementOnContextMenuOpening(ContextMenuEventArgs).)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | (Overrides UIElementOnLostMouseCapture(MouseEventArgs).)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | (Overrides ListBoxItemOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | (Overrides ListBoxItemOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | (Overrides UIElementOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | (Overrides ListBoxItemOnMouseRightButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseRightButtonUp | (Overrides UIElementOnMouseRightButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelected | Called when the ListBoxItem is selected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnselected | Called when the ListBoxItem is unselected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the visual parent of a list box item changes. (Inherited from ListBoxItem.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnApplyTemplate Method

TreeViewItemExOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnContextMenuOpening Method

TreeViewItemExOnContextMenuOpening Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnContextMenuOpening(
    ContextMenuEventArgs e
)
protected:
virtual void OnContextMenuOpening(
    ContextMenuEventArgs^ e
) override

Parameters

e
Type: System.Windows.ControlsContextMenuEventArgs
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnKeyDown Method

TreeViewItemExOnKeyDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnLostMouseCapture Method

TreeViewItemExOnLostMouseCapture Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnLostMouseCapture(
    MouseEventArgs e
)
protected:
virtual void OnLostMouseCapture(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnMouseLeave Method

TreeViewItemExOnMouseLeave Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseLeave(
    MouseEventArgs e
)
protected:
virtual void OnMouseLeave(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnMouseLeftButtonDown Method

TreeViewItemExOnMouseLeftButtonDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnMouseLeftButtonUp Method

TreeViewItemExOnMouseLeftButtonUp Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
protected:
virtual void OnMouseLeftButtonUp(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnMouseMove Method

TreeViewItemExOnMouseMove Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnMouseRightButtonDown Method

TreeViewItemExOnMouseRightButtonDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseRightButtonDown(
    MouseButtonEventArgs e
)
protected:
virtual void OnMouseRightButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnMouseRightButtonUp Method

TreeViewItemExOnMouseRightButtonUp Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseRightButtonUp(
    MouseButtonEventArgs e
)
protected:
virtual void OnMouseRightButtonUp(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.OnPropertyChanged Method

TreeViewItemExOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx Events

The TreeViewItemEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | Selected | Occurs when a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | Unselected | Occurs when a ListBoxItem is unselected. (Inherited from ListBoxItem.)
Top
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx Fields

The TreeViewItemEx type exposes the following members.

Fields
Name | Description
NodeViewProperty |
TreeViewProperty |
Top
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.NodeViewProperty Field

TreeViewItemExNodeViewProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty NodeViewProperty
public:
static initonly DependencyProperty^ NodeViewProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewItemEx Class


TreeViewItemEx.TreeViewProperty Field

TreeViewItemExTreeViewProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TreeViewProperty
public:
static initonly DependencyProperty^ TreeViewProperty

Field Value

Type: DependencyProperty
See Also

Reference

TreeViewItemEx Class


TriggerActionTextChanged Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
TriggerAction
TriggerActionRichTextBox
VisualComponents.UX.SharedTriggerActionTextChanged

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TriggerActionTextChanged : TriggerAction<RichTextBox>
public ref class TriggerActionTextChanged : public TriggerAction<RichTextBox^>

The TriggerActionTextChanged type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerActionTextChanged | Initializes a new instance of the TriggerActionTextChanged class
Top
Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from TriggerActionRichTextBox.)
Protected property | AssociatedObjectTypeConstraint | (Inherited from TriggerActionRichTextBox.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
 | Functions |
 | GetSpecials |
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsEnabled | (Inherited from TriggerAction.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
 | Operators |
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from TriggerAction.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from TriggerAction.)
Public method | Detach | (Inherited from TriggerAction.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | Invoke | (Overrides TriggerAction.Invoke(Object).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides TriggerAction.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Inherited from TriggerAction.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


TriggerActionTextChanged Constructor

Initializes a new instance of the TriggerActionTextChanged class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TriggerActionTextChanged()
public:
TriggerActionTextChanged()
See Also

Reference

TriggerActionTextChanged Class


TriggerActionTextChanged Properties

The TriggerActionTextChanged type exposes the following members.

Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from TriggerActionRichTextBox.)
Protected property | AssociatedObjectTypeConstraint | (Inherited from TriggerActionRichTextBox.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
 | Functions |
 | GetSpecials |
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsEnabled | (Inherited from TriggerAction.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
 | Operators |
Top
See Also

Reference

TriggerActionTextChanged Class


TriggerActionTextChanged.Functions Property

TriggerActionTextChangedFunctions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IList<string> Functions { get; }
public:
static property IList<String^>^ Functions {
    IList<String^>^ get ();
}

Property Value

Type: IListString
See Also

Reference

TriggerActionTextChanged Class


TriggerActionTextChanged.GetSpecials Property

TriggerActionTextChangedGetSpecials Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IList<char> GetSpecials { get; }
public:
static property IList<wchar_t>^ GetSpecials {
    IList<wchar_t>^ get ();
}

Property Value

Type: IListChar
See Also

Reference

TriggerActionTextChanged Class


TriggerActionTextChanged.Operators Property

TriggerActionTextChangedOperators Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IList<string> Operators { get; }
public:
static property IList<String^>^ Operators {
    IList<String^>^ get ();
}

Property Value

Type: IListString
See Also

Reference

TriggerActionTextChanged Class


TriggerActionTextChanged Methods

The TriggerActionTextChanged type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from TriggerAction.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from TriggerAction.)
Public method | Detach | (Inherited from TriggerAction.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | Invoke | (Overrides TriggerAction.Invoke(Object).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides TriggerAction.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Inherited from TriggerAction.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TriggerActionTextChanged Class


TriggerActionTextChanged.Invoke Method

TriggerActionTextChangedInvoke Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Invoke(
    Object parameter
)
protected:
virtual void Invoke(
    Object^ parameter
) override

Parameters

parameter
Type: SystemObject
See Also

Reference

TriggerActionTextChanged Class


TriggerActionTextChanged.OnAttached Method

TriggerActionTextChangedOnAttached Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnAttached()
protected:
virtual void OnAttached() override
See Also

Reference

TriggerActionTextChanged Class


TriggerActionTextChanged Events

The TriggerActionTextChanged type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

TriggerActionTextChanged Class


TriggerTracing Class

Contains attached properties to activate Trigger Tracing on the specified Triggers. This file alone should be dropped into your app.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedTriggerTracing

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class TriggerTracing
public ref class TriggerTracing abstract sealed

The TriggerTracing type exposes the following members.

Methods
Name | Description
GetTraceEnabled | Gets a value indication whether trace is enabled for the specified trigger.
GetTriggerName | Gets the trigger name for the specified trigger. This will be used to identify the trigger in the debug output.
SetTraceEnabled | Sets a value specifying whether trace is enabled for the specified trigger
SetTriggerName | Sets the trigger name for the specified trigger. This will be used to identify the trigger in the debug output.
Top
Fields
Name | Description
TraceEnabledProperty |
TriggerNameProperty |
Top
Attached Properties
 | Name | Description
Public attached property | TraceEnabled |
Public attached property | TriggerName |
Top
See Also

Reference


TriggerTracing Methods

The TriggerTracing type exposes the following members.

Methods
Name | Description
GetTraceEnabled | Gets a value indication whether trace is enabled for the specified trigger.
GetTriggerName | Gets the trigger name for the specified trigger. This will be used to identify the trigger in the debug output.
SetTraceEnabled | Sets a value specifying whether trace is enabled for the specified trigger
SetTriggerName | Sets the trigger name for the specified trigger. This will be used to identify the trigger in the debug output.
Top
See Also

Reference

TriggerTracing Class


TriggerTracing.GetTraceEnabled Method

TriggerTracingGetTraceEnabled Method

Gets a value indication whether trace is enabled for the specified trigger.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetTraceEnabled(
    TriggerBase trigger
)
public:
static bool GetTraceEnabled(
    TriggerBase^ trigger
)

Parameters

trigger
Type: System.WindowsTriggerBase
The trigger.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TriggerTracing.GetTraceEnabled(System.Windows.TriggerBase)"]

See Also

Reference

TriggerTracing Class


TriggerTracing.GetTriggerName Method

TriggerTracingGetTriggerName Method

Gets the trigger name for the specified trigger. This will be used to identify the trigger in the debug output.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetTriggerName(
    TriggerBase trigger
)
public:
static String^ GetTriggerName(
    TriggerBase^ trigger
)

Parameters

trigger
Type: System.WindowsTriggerBase
The trigger.

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TriggerTracing.GetTriggerName(System.Windows.TriggerBase)"]

See Also

Reference

TriggerTracing Class


TriggerTracing.SetTraceEnabled Method

TriggerTracingSetTraceEnabled Method

Sets a value specifying whether trace is enabled for the specified trigger

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetTraceEnabled(
    TriggerBase trigger,
    bool value
)
public:
static void SetTraceEnabled(
    TriggerBase^ trigger,
    bool value
)

Parameters

trigger
Type: System.WindowsTriggerBase
value
Type: SystemBoolean
See Also

Reference

TriggerTracing Class


TriggerTracing.SetTriggerName Method

TriggerTracingSetTriggerName Method

Sets the trigger name for the specified trigger. This will be used to identify the trigger in the debug output.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetTriggerName(
    TriggerBase trigger,
    string value
)
public:
static void SetTriggerName(
    TriggerBase^ trigger,
    String^ value
)

Parameters

trigger
Type: System.WindowsTriggerBase
The trigger.
value
Type: SystemString
See Also

Reference

TriggerTracing Class


TriggerTracing Fields

The TriggerTracing type exposes the following members.

Fields
Name | Description
TraceEnabledProperty |
TriggerNameProperty |
Top
See Also

Reference

TriggerTracing Class


TriggerTracing.TraceEnabledProperty Field

TriggerTracingTraceEnabledProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TraceEnabledProperty
public:
static initonly DependencyProperty^ TraceEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

TriggerTracing Class


TriggerTracing.TriggerNameProperty Field

TriggerTracingTriggerNameProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TriggerNameProperty
public:
static initonly DependencyProperty^ TriggerNameProperty

Field Value

Type: DependencyProperty
See Also

Reference

TriggerTracing Class


TriggerTracing Attached Properties

The TriggerTracing type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | TraceEnabled |
Public attached property | TriggerName |
Top
See Also

Reference

TriggerTracing Class


TriggerTracing.TraceEnabled Attached Property

TriggerTracingTraceEnabled Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetTraceEnabled, SetTraceEnabled
See GetTraceEnabled, SetTraceEnabled

Property Value

Type: Boolean
See Also

Reference

TriggerTracing Class


TriggerTracing.TriggerName Attached Property

TriggerTracingTriggerName Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetTriggerName, SetTriggerName
See GetTriggerName, SetTriggerName

Property Value

Type: String
See Also

Reference

TriggerTracing Class


UiElementExtensions Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedUiElementExtensions

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class UiElementExtensions
[ExtensionAttribute]
public ref class UiElementExtensions abstract sealed

The UiElementExtensions type exposes the following members.

Methods
Name | Description
GetWindow |
Top
See Also

Reference


UiElementExtensions Methods

The UiElementExtensions type exposes the following members.

Methods
Name | Description
GetWindow |
Top
See Also

Reference

UiElementExtensions Class


UiElementExtensions.GetWindow Method

UiElementExtensionsGetWindow Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Window GetWindow(
    this FrameworkElement element
)
public:
[ExtensionAttribute]
static Window^ GetWindow(
    FrameworkElement^ element
)

Parameters

element
Type: System.WindowsFrameworkElement

Return Value

Type: Window

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UiElementExtensions.GetWindow(System.Windows.FrameworkElement)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type FrameworkElement. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UiElementExtensions Class


UndoableRichTextBox Class

Optionally overwrites the default Undo/Redo operations with VC commands.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsRichTextBox
RichTextBox
VisualComponents.UX.SharedUndoableRichTextBox
VisualComponents.UX.SharedRichTextBoxEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UndoableRichTextBox : RichTextBox
public ref class UndoableRichTextBox : public RichTextBox

The UndoableRichTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | UndoableRichTextBox | Initializes a new instance of the UndoableRichTextBox class
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretPosition | Gets or sets the position of the input caret. (Inherited from RichTextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Document | Gets or sets the FlowDocument that represents the contents of the RichTextBox. (Inherited from RichTextBox.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDocumentEnabled | Gets or sets a value that indicates whether the user can interact with UIElement and ContentElement objects within the RichTextBox. (Inherited from RichTextBox.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical children of the RichTextBox. (Inherited from RichTextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Selection | Gets a TextSelection object containing the current selection in the RichTextBox. (Inherited from RichTextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | (Inherited from RichTextBox.)
Public property | TextFormatter | (Inherited from RichTextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseCustomUndo |
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | (Inherited from RichTextBox.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | (Inherited from RichTextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | (Inherited from RichTextBox.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorPosition | Returns a TextPointer that points to the next spelling error in the contents of the RichTextBox. (Inherited from RichTextBox.)
Public method | GetPositionFromPoint | Returns a TextPointer that points to the insertion point closest to the specified position. (Inherited from RichTextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at a specified position in the contents of the RichTextBox. (Inherited from RichTextBox.)
Public method | GetSpellingErrorRange | Returns a TextRange object covering any misspelled word at a specified position in the contents of the RichTextBox. (Inherited from RichTextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to re-measure the RichTextBox. (Inherited from RichTextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for this RichTextBox. (Inherited from RichTextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this Rich Text Box is rendered changes. (Inherited from RichTextBox.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Overrides RichTextBox.OnTextChanged(TextChangedEventArgs).)
Protected method | OnTextFormatterPropertyChanged | (Inherited from RichTextBox.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeDocument | Returns a value that indicates whether or not the effective value of the Document property should be serialized during serialization of a RichTextBox object. (Inherited from RichTextBox.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
UseCustomUndoProperty | If true, replaces default Undo/Redo operations with VC Undo/Redo commands. Does not support changing this value after initialization.
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UndoableRichTextBox Constructor

Initializes a new instance of the UndoableRichTextBox class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UndoableRichTextBox()
public:
UndoableRichTextBox()
See Also

Reference

UndoableRichTextBox Class


UndoableRichTextBox Properties

The UndoableRichTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretPosition | Gets or sets the position of the input caret. (Inherited from RichTextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Document | Gets or sets the FlowDocument that represents the contents of the RichTextBox. (Inherited from RichTextBox.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDocumentEnabled | Gets or sets a value that indicates whether the user can interact with UIElement and ContentElement objects within the RichTextBox. (Inherited from RichTextBox.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical children of the RichTextBox. (Inherited from RichTextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Selection | Gets a TextSelection object containing the current selection in the RichTextBox. (Inherited from RichTextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | (Inherited from RichTextBox.)
Public property | TextFormatter | (Inherited from RichTextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseCustomUndo |
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

UndoableRichTextBox Class


UndoableRichTextBox.UseCustomUndo Property

UndoableRichTextBoxUseCustomUndo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UseCustomUndo { get; set; }
public:
property bool UseCustomUndo {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UndoableRichTextBox Class


UndoableRichTextBox Methods

The UndoableRichTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | (Inherited from RichTextBox.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | (Inherited from RichTextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | (Inherited from RichTextBox.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorPosition | Returns a TextPointer that points to the next spelling error in the contents of the RichTextBox. (Inherited from RichTextBox.)
Public method | GetPositionFromPoint | Returns a TextPointer that points to the insertion point closest to the specified position. (Inherited from RichTextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at a specified position in the contents of the RichTextBox. (Inherited from RichTextBox.)
Public method | GetSpellingErrorRange | Returns a TextRange object covering any misspelled word at a specified position in the contents of the RichTextBox. (Inherited from RichTextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to re-measure the RichTextBox. (Inherited from RichTextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for this RichTextBox. (Inherited from RichTextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this Rich Text Box is rendered changes. (Inherited from RichTextBox.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Overrides RichTextBox.OnTextChanged(TextChangedEventArgs).)
Protected method | OnTextFormatterPropertyChanged | (Inherited from RichTextBox.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeDocument | Returns a value that indicates whether or not the effective value of the Document property should be serialized during serialization of a RichTextBox object. (Inherited from RichTextBox.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UndoableRichTextBox Class


UndoableRichTextBox.OnTextChanged Method

UndoableRichTextBoxOnTextChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnTextChanged(
    TextChangedEventArgs e
)
protected:
virtual void OnTextChanged(
    TextChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.ControlsTextChangedEventArgs
See Also

Reference

UndoableRichTextBox Class


UndoableRichTextBox Events

The UndoableRichTextBox type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

UndoableRichTextBox Class


UndoableRichTextBox Fields

The UndoableRichTextBox type exposes the following members.

Fields
Name | Description
UseCustomUndoProperty | If true, replaces default Undo/Redo operations with VC Undo/Redo commands. Does not support changing this value after initialization.
Top
See Also

Reference

UndoableRichTextBox Class


UndoableRichTextBox.UseCustomUndoProperty Field

UndoableRichTextBoxUseCustomUndoProperty Field

If true, replaces default Undo/Redo operations with VC Undo/Redo commands. Does not support changing this value after initialization.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty UseCustomUndoProperty
public:
static initonly DependencyProperty^ UseCustomUndoProperty

Field Value

Type: DependencyProperty
See Also

Reference

UndoableRichTextBox Class


UndoableTextBox Class

Optionally overwrites the default Undo/Redo operations with VC commands.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsTextBox
VisualComponents.UX.SharedUndoableTextBox
VisualComponents.UX.SharedExtendedTextBox
VisualComponents.UX.SharedResetableTextBox

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UndoableTextBox : TextBox
public ref class UndoableTextBox : public TextBox

The UndoableTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | UndoableTextBox | Initializes a new instance of the UndoableTextBox class
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseCustomUndo |
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Overrides FrameworkElementOnInitialized(EventArgs).)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Overrides TextBoxBaseOnTextChanged(TextChangedEventArgs).)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
UseCustomUndoProperty | If true, replaces default Undo/Redo operations with VC Undo/Redo commands. Does not support changing this value after initialization.
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UndoableTextBox Constructor

Initializes a new instance of the UndoableTextBox class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UndoableTextBox()
public:
UndoableTextBox()
See Also

Reference

UndoableTextBox Class


UndoableTextBox Properties

The UndoableTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseCustomUndo |
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

UndoableTextBox Class


UndoableTextBox.UseCustomUndo Property

UndoableTextBoxUseCustomUndo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UseCustomUndo { get; set; }
public:
property bool UseCustomUndo {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UndoableTextBox Class


UndoableTextBox Methods

The UndoableTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Overrides FrameworkElementOnInitialized(EventArgs).)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Overrides TextBoxBaseOnTextChanged(TextChangedEventArgs).)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UndoableTextBox Class


UndoableTextBox.OnInitialized Method

UndoableTextBoxOnInitialized Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnInitialized(
    EventArgs e
)
protected:
virtual void OnInitialized(
    EventArgs^ e
) override

Parameters

e
Type: SystemEventArgs
See Also

Reference

UndoableTextBox Class


UndoableTextBox.OnTextChanged Method

UndoableTextBoxOnTextChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnTextChanged(
    TextChangedEventArgs e
)
protected:
virtual void OnTextChanged(
    TextChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.ControlsTextChangedEventArgs
See Also

Reference

UndoableTextBox Class


UndoableTextBox Events

The UndoableTextBox type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

UndoableTextBox Class


UndoableTextBox Fields

The UndoableTextBox type exposes the following members.

Fields
Name | Description
UseCustomUndoProperty | If true, replaces default Undo/Redo operations with VC Undo/Redo commands. Does not support changing this value after initialization.
Top
See Also

Reference

UndoableTextBox Class


UndoableTextBox.UseCustomUndoProperty Field

UndoableTextBoxUseCustomUndoProperty Field

If true, replaces default Undo/Redo operations with VC Undo/Redo commands. Does not support changing this value after initialization.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty UseCustomUndoProperty
public:
static initonly DependencyProperty^ UseCustomUndoProperty

Field Value

Type: DependencyProperty
See Also

Reference

UndoableTextBox Class


UniqueNameHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedUniqueNameHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UniqueNameHelper
public ref class UniqueNameHelper

The UniqueNameHelper type exposes the following members.

Constructors
 | Name | Description
Public method | UniqueNameHelper | Initializes a new instance of the UniqueNameHelper class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateUniqueName(IEnumerableString, String) |
 | GenerateUniqueName(IEnumerableIFrameworkInputElement, String) |
 | GenerateUniqueName(IEnumerableINamed, String) |
 | GenerateUniqueNameT(IEnumerableT, String) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UniqueNameHelper Constructor

Initializes a new instance of the UniqueNameHelper class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UniqueNameHelper()
public:
UniqueNameHelper()
See Also

Reference

UniqueNameHelper Class


UniqueNameHelper Methods

The UniqueNameHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateUniqueName(IEnumerableString, String) |
 | GenerateUniqueName(IEnumerableIFrameworkInputElement, String) |
 | GenerateUniqueName(IEnumerableINamed, String) |
 | GenerateUniqueNameT(IEnumerableT, String) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UniqueNameHelper Class


UniqueNameHelper.GenerateUniqueName Method

UniqueNameHelperGenerateUniqueName Method

Overload List
Name | Description
GenerateUniqueName(IEnumerableString, String) |
GenerateUniqueName(IEnumerableIFrameworkInputElement, String) |
GenerateUniqueNameT(IEnumerableT, String) |
GenerateUniqueName(IEnumerableINamed, String) |
Top
See Also

Reference

UniqueNameHelper Class


UniqueNameHelper.GenerateUniqueName Method (IEnumerable(String), String)

UniqueNameHelperGenerateUniqueName Method (IEnumerableString, String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GenerateUniqueName(
    IEnumerable<string> itemList,
    string prefix
)
public:
static String^ GenerateUniqueName(
    IEnumerable<String^>^ itemList,
    String^ prefix
)

Parameters

itemList
Type: System.Collections.GenericIEnumerableString
prefix
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UniqueNameHelper.GenerateUniqueName(System.Collections.Generic.IEnumerable{System.String},System.String)"]

See Also

Reference

UniqueNameHelper Class
GenerateUniqueName Overload


UniqueNameHelper.GenerateUniqueName Method (IEnumerable(IFrameworkInputElement), String)

UniqueNameHelperGenerateUniqueName Method (IEnumerableIFrameworkInputElement, String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GenerateUniqueName(
    IEnumerable<IFrameworkInputElement> itemList,
    string prefix
)
public:
static String^ GenerateUniqueName(
    IEnumerable<IFrameworkInputElement^>^ itemList,
    String^ prefix
)

Parameters

itemList
Type: System.Collections.GenericIEnumerableIFrameworkInputElement
prefix
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UniqueNameHelper.GenerateUniqueName(System.Collections.Generic.IEnumerable{System.Windows.IFrameworkInputElement},System.String)"]

See Also

Reference

UniqueNameHelper Class
GenerateUniqueName Overload


UniqueNameHelper.GenerateUniqueName(T) Method (IEnumerable(T), String)

UniqueNameHelperGenerateUniqueNameT Method (IEnumerableT, String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GenerateUniqueName<T>(
    IEnumerable<T> itemList,
    string prefix
)

public:
generic<typename T>
static String^ GenerateUniqueName(
    IEnumerable<T>^ itemList,
    String^ prefix
)

Parameters

itemList
Type: System.Collections.GenericIEnumerableT
prefix
Type: SystemString

Type Parameters

T

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UniqueNameHelper.GenerateUniqueName``1(System.Collections.Generic.IEnumerable{``0},System.String)"]

See Also

Reference

UniqueNameHelper Class
GenerateUniqueName Overload


UniqueNameHelper.GenerateUniqueName Method (IEnumerable(INamed), String)

UniqueNameHelperGenerateUniqueName Method (IEnumerableINamed, String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GenerateUniqueName(
    IEnumerable<INamed> itemList,
    string prefix
)
public:
static String^ GenerateUniqueName(
    IEnumerable<INamed^>^ itemList,
    String^ prefix
)

Parameters

itemList
Type: System.Collections.GenericIEnumerableINamed
prefix
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UniqueNameHelper.GenerateUniqueName(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.INamed},System.String)"]

See Also

Reference

UniqueNameHelper Class
GenerateUniqueName Overload


UnitFormat Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum UnitFormat
public enum class UnitFormat
Members
Member name | Value | Description
Any | 0 | Any of selected unit are displayed.
CanonicalOnly | 1 | Unit is converted to canonical formt before displaying
See Also

Reference


UriEditor Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedUriEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UriEditor : Control
public ref class UriEditor : public Control

The UriEditor type exposes the following members.

Constructors
 | Name | Description
Public method | UriEditor | Initializes a new instance of the UriEditor class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Description |
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogType |
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Filter |
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsResourceBrowsingCompleted |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ResourceType |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Source |
Public property | SourceFileName |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | (Overrides UIElementOnDrop(DragEventArgs).)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | ResourceBrowseCompleted |
Public event | ResourceBrowsingStarted |
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DescriptionProperty |
DialogTypeProperty |
FilterProperty |
IsResourceBrowsingCompletedProperty |
ResourceBrowseCompletedEvent |
ResourceBrowsingStartedEvent |
ResourceTypeProperty |
SourceFileNameProperty |
SourceProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UriEditor Constructor

Initializes a new instance of the UriEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UriEditor()
public:
UriEditor()
See Also

Reference

UriEditor Class


UriEditor Properties

The UriEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Description |
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogType |
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Filter |
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsResourceBrowsingCompleted |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ResourceType |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Source |
Public property | SourceFileName |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

UriEditor Class


UriEditor.Description Property

UriEditorDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UriEditor Class


UriEditor.DialogType Property

UriEditorDialogType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DialogType DialogType { get; set; }
public:
property DialogType DialogType {
    DialogType get ();
    void set (DialogType value);
}

Property Value

Type: DialogType
See Also

Reference

UriEditor Class


UriEditor.Filter Property

UriEditorFilter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Filter { get; set; }
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UriEditor Class


UriEditor.IsResourceBrowsingCompleted Property

UriEditorIsResourceBrowsingCompleted Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsResourceBrowsingCompleted { get; }
public:
property bool IsResourceBrowsingCompleted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

UriEditor Class


UriEditor.ResourceType Property

UriEditorResourceType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ResourceType ResourceType { get; set; }
public:
property ResourceType ResourceType {
    ResourceType get ();
    void set (ResourceType value);
}

Property Value

Type: ResourceType
See Also

Reference

UriEditor Class


UriEditor.Source Property

UriEditorSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Source { get; set; }
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UriEditor Class


UriEditor.SourceFileName Property

UriEditorSourceFileName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SourceFileName { get; set; }
public:
property String^ SourceFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UriEditor Class


UriEditor Methods

The UriEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | (Overrides UIElementOnDrop(DragEventArgs).)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UriEditor Class


UriEditor.OnApplyTemplate Method

UriEditorOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

UriEditor Class


UriEditor.OnDrop Method

UriEditorOnDrop Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnDrop(
    DragEventArgs e
)
protected:
virtual void OnDrop(
    DragEventArgs^ e
) override

Parameters

e
Type: System.WindowsDragEventArgs
See Also

Reference

UriEditor Class


UriEditor.ToString Method

UriEditorToString Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UriEditor.ToString"]

See Also

Reference

UriEditor Class


UriEditor Events

The UriEditor type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | ResourceBrowseCompleted |
Public event | ResourceBrowsingStarted |
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

UriEditor Class


UriEditor.ResourceBrowseCompleted Event

UriEditorResourceBrowseCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler ResourceBrowseCompleted
public:
 event RoutedEventHandler^ ResourceBrowseCompleted {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

UriEditor Class


UriEditor.ResourceBrowsingStarted Event

UriEditorResourceBrowsingStarted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler ResourceBrowsingStarted
public:
 event RoutedEventHandler^ ResourceBrowsingStarted {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

UriEditor Class


UriEditor Fields

The UriEditor type exposes the following members.

Fields
Name | Description
DescriptionProperty |
DialogTypeProperty |
FilterProperty |
IsResourceBrowsingCompletedProperty |
ResourceBrowseCompletedEvent |
ResourceBrowsingStartedEvent |
ResourceTypeProperty |
SourceFileNameProperty |
SourceProperty |
Top
See Also

Reference

UriEditor Class


UriEditor.DescriptionProperty Field

UriEditorDescriptionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty DescriptionProperty
public:
static DependencyProperty^ DescriptionProperty

Field Value

Type: DependencyProperty
See Also

Reference

UriEditor Class


UriEditor.DialogTypeProperty Field

UriEditorDialogTypeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty DialogTypeProperty
public:
static DependencyProperty^ DialogTypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

UriEditor Class


UriEditor.FilterProperty Field

UriEditorFilterProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty FilterProperty
public:
static DependencyProperty^ FilterProperty

Field Value

Type: DependencyProperty
See Also

Reference

UriEditor Class


UriEditor.IsResourceBrowsingCompletedProperty Field

UriEditorIsResourceBrowsingCompletedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsResourceBrowsingCompletedProperty
public:
static DependencyProperty^ IsResourceBrowsingCompletedProperty

Field Value

Type: DependencyProperty
See Also

Reference

UriEditor Class


UriEditor.ResourceBrowseCompletedEvent Field

UriEditorResourceBrowseCompletedEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent ResourceBrowseCompletedEvent
public:
static initonly RoutedEvent^ ResourceBrowseCompletedEvent

Field Value

Type: RoutedEvent
See Also

Reference

UriEditor Class


UriEditor.ResourceBrowsingStartedEvent Field

UriEditorResourceBrowsingStartedEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent ResourceBrowsingStartedEvent
public:
static initonly RoutedEvent^ ResourceBrowsingStartedEvent

Field Value

Type: RoutedEvent
See Also

Reference

UriEditor Class


UriEditor.ResourceTypeProperty Field

UriEditorResourceTypeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ResourceTypeProperty
public:
static DependencyProperty^ ResourceTypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

UriEditor Class


UriEditor.SourceFileNameProperty Field

UriEditorSourceFileNameProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty SourceFileNameProperty
public:
static DependencyProperty^ SourceFileNameProperty

Field Value

Type: DependencyProperty
See Also

Reference

UriEditor Class


UriEditor.SourceProperty Field

UriEditorSourceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty SourceProperty
public:
static DependencyProperty^ SourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

UriEditor Class


UriToBitmapImageConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedUriToBitmapImageConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UriToBitmapImageConverter : IValueConverter
public ref class UriToBitmapImageConverter : IValueConverter

The UriToBitmapImageConverter type exposes the following members.

Constructors
 | Name | Description
Public method | UriToBitmapImageConverter | Initializes a new instance of the UriToBitmapImageConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UriToBitmapImageConverter Constructor

Initializes a new instance of the UriToBitmapImageConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UriToBitmapImageConverter()
public:
UriToBitmapImageConverter()
See Also

Reference

UriToBitmapImageConverter Class


UriToBitmapImageConverter Methods

The UriToBitmapImageConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UriToBitmapImageConverter Class


UriToBitmapImageConverter.Convert Method

UriToBitmapImageConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UriToBitmapImageConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

UriToBitmapImageConverter Class


UriToBitmapImageConverter.ConvertBack Method

UriToBitmapImageConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UriToBitmapImageConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

UriToBitmapImageConverter Class


UserControlOptimizedView Class

Note: this class is needed only when ViewModel is using "CacheViews = false".
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedUserControlOptimizedView
More...

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UserControlOptimizedView : UserControl
public ref class UserControlOptimizedView : public UserControl

The UserControlOptimizedView type exposes the following members.

Constructors
 | Name | Description
Public method | UserControlOptimizedView | Initializes a new instance of the UserControlOptimizedView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Overrides FrameworkElementOnVisualParentChanged(DependencyObject).)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedUserControlOptimizedView
VisualComponents.UX.SharedActionConfigurationView
VisualComponents.UX.SharedPhysicsJointD6EditorView
VisualComponents.UX.SharedPropertyEditorView
VisualComponents.UX.SharedSimplePropertyEditorView
VisualComponents.UX.SharedSimulationControlView
VisualComponents.UX.SharedSimulationSettingView
VisualComponents.UX.SharedTransportLinkView


UserControlOptimizedView Constructor

Initializes a new instance of the UserControlOptimizedView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UserControlOptimizedView()
public:
UserControlOptimizedView()
See Also

Reference

UserControlOptimizedView Class


UserControlOptimizedView Properties

The UserControlOptimizedView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

UserControlOptimizedView Class


UserControlOptimizedView Methods

The UserControlOptimizedView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Overrides FrameworkElementOnVisualParentChanged(DependencyObject).)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UserControlOptimizedView Class


UserControlOptimizedView.OnVisualParentChanged Method

UserControlOptimizedViewOnVisualParentChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnVisualParentChanged(
    DependencyObject oldParent
)
protected:
virtual void OnVisualParentChanged(
    DependencyObject^ oldParent
) override

Parameters

oldParent
Type: System.WindowsDependencyObject
See Also

Reference

UserControlOptimizedView Class


UserControlOptimizedView Events

The UserControlOptimizedView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

UserControlOptimizedView Class


UXEntryAddedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedUXSiteChangedEventArgs
VisualComponents.UX.SharedUXEntryAddedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UXEntryAddedEventArgs : UXSiteChangedEventArgs
public ref class UXEntryAddedEventArgs sealed : public UXSiteChangedEventArgs

The UXEntryAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UXEntryAddedEventArgs(UXSiteSetup, UXSiteConfigElement, UXSiteEntryConfigElement) | Initializes a new instance of the UXEntryAddedEventArgs class
Public method | UXEntryAddedEventArgs(UXSiteSetup, UXSiteConfigElement, UXSiteEntryConfigElement, Int32) | Initializes a new instance of the UXEntryAddedEventArgs class
Public method | UXEntryAddedEventArgs(UXSiteSetup, UXSiteConfigElement, UXSiteEntryConfigElement, String, Int32, Int32) | Initializes a new instance of the UXEntryAddedEventArgs class
Top
Properties
 | Name | Description
Public property | Entry |
Public property | Index | Represent position new value is added.Value is Int32.MaxValue if it is added at the last.
Public property | OffSet | Represent offset position.
Public property | ReferenceId |
Public property | Site | (Inherited from UXSiteChangedEventArgs.)
Public property | SiteSetup | (Inherited from UXSiteChangedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXEntryAddedEventArgs Constructor

Overload List
 | Name | Description
Public method | UXEntryAddedEventArgs(UXSiteSetup, UXSiteConfigElement, UXSiteEntryConfigElement) | Initializes a new instance of the UXEntryAddedEventArgs class
Public method | UXEntryAddedEventArgs(UXSiteSetup, UXSiteConfigElement, UXSiteEntryConfigElement, Int32) | Initializes a new instance of the UXEntryAddedEventArgs class
Public method | UXEntryAddedEventArgs(UXSiteSetup, UXSiteConfigElement, UXSiteEntryConfigElement, String, Int32, Int32) | Initializes a new instance of the UXEntryAddedEventArgs class
Top
See Also

Reference

UXEntryAddedEventArgs Class


UXEntryAddedEventArgs Constructor (UXSiteSetup, UXSiteConfigElement, UXSiteEntryConfigElement)

Initializes a new instance of the UXEntryAddedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXEntryAddedEventArgs(
    UXSiteSetup siteSetup,
    UXSiteConfigElement site,
    UXSiteEntryConfigElement entry
)
public:
UXEntryAddedEventArgs(
    UXSiteSetup^ siteSetup,
    UXSiteConfigElement^ site,
    UXSiteEntryConfigElement^ entry
)

Parameters

siteSetup
Type: VisualComponents.UX.SharedUXSiteSetup
site
Type: VisualComponents.UX.SharedUXSiteConfigElement
entry
Type: VisualComponents.UX.SharedUXSiteEntryConfigElement
See Also

Reference

UXEntryAddedEventArgs Class
UXEntryAddedEventArgs Overload


UXEntryAddedEventArgs Constructor (UXSiteSetup, UXSiteConfigElement, UXSiteEntryConfigElement, Int32)

Initializes a new instance of the UXEntryAddedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXEntryAddedEventArgs(
    UXSiteSetup siteSetup,
    UXSiteConfigElement site,
    UXSiteEntryConfigElement entry,
    int index
)
public:
UXEntryAddedEventArgs(
    UXSiteSetup^ siteSetup,
    UXSiteConfigElement^ site,
    UXSiteEntryConfigElement^ entry,
    int index
)

Parameters

siteSetup
Type: VisualComponents.UX.SharedUXSiteSetup
site
Type: VisualComponents.UX.SharedUXSiteConfigElement
entry
Type: VisualComponents.UX.SharedUXSiteEntryConfigElement
index
Type: SystemInt32
See Also

Reference

UXEntryAddedEventArgs Class
UXEntryAddedEventArgs Overload


UXEntryAddedEventArgs Constructor (UXSiteSetup, UXSiteConfigElement, UXSiteEntryConfigElement, String, Int32, Int32)

Initializes a new instance of the UXEntryAddedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXEntryAddedEventArgs(
    UXSiteSetup siteSetup,
    UXSiteConfigElement site,
    UXSiteEntryConfigElement entry,
    string referenceId,
    int offSet,
    int index
)
public:
UXEntryAddedEventArgs(
    UXSiteSetup^ siteSetup,
    UXSiteConfigElement^ site,
    UXSiteEntryConfigElement^ entry,
    String^ referenceId,
    int offSet,
    int index
)

Parameters

siteSetup
Type: VisualComponents.UX.SharedUXSiteSetup
site
Type: VisualComponents.UX.SharedUXSiteConfigElement
entry
Type: VisualComponents.UX.SharedUXSiteEntryConfigElement
referenceId
Type: SystemString
offSet
Type: SystemInt32
index
Type: SystemInt32
See Also

Reference

UXEntryAddedEventArgs Class
UXEntryAddedEventArgs Overload


UXEntryAddedEventArgs Properties

The UXEntryAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Entry |
Public property | Index | Represent position new value is added.Value is Int32.MaxValue if it is added at the last.
Public property | OffSet | Represent offset position.
Public property | ReferenceId |
Public property | Site | (Inherited from UXSiteChangedEventArgs.)
Public property | SiteSetup | (Inherited from UXSiteChangedEventArgs.)
Top
See Also

Reference

UXEntryAddedEventArgs Class


UXEntryAddedEventArgs.Entry Property

UXEntryAddedEventArgsEntry Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteEntryConfigElement Entry { get; }
public:
property UXSiteEntryConfigElement^ Entry {
    UXSiteEntryConfigElement^ get ();
}

Property Value

Type: UXSiteEntryConfigElement
See Also

Reference

UXEntryAddedEventArgs Class


UXEntryAddedEventArgs.Index Property

UXEntryAddedEventArgsIndex Property

Represent position new value is added.Value is Int32.MaxValue if it is added at the last.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Index { get; }
public:
property int Index {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

UXEntryAddedEventArgs Class


UXEntryAddedEventArgs.OffSet Property

UXEntryAddedEventArgsOffSet Property

Represent offset position.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int OffSet { get; }
public:
property int OffSet {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

UXEntryAddedEventArgs Class


UXEntryAddedEventArgs.ReferenceId Property

UXEntryAddedEventArgsReferenceId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ReferenceId { get; }
public:
property String^ ReferenceId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UXEntryAddedEventArgs Class


UXEntryAddedEventArgs Methods

The UXEntryAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXEntryAddedEventArgs Class


UXEntryRemovedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedUXSiteChangedEventArgs
VisualComponents.UX.SharedUXEntryRemovedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UXEntryRemovedEventArgs : UXSiteChangedEventArgs
public ref class UXEntryRemovedEventArgs sealed : public UXSiteChangedEventArgs

The UXEntryRemovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UXEntryRemovedEventArgs | Initializes a new instance of the UXEntryRemovedEventArgs class
Top
Properties
 | Name | Description
Public property | Entry |
Public property | Parent |
Public property | Site | (Inherited from UXSiteChangedEventArgs.)
Public property | SiteSetup | (Inherited from UXSiteChangedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXEntryRemovedEventArgs Constructor

Initializes a new instance of the UXEntryRemovedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXEntryRemovedEventArgs(
    UXSiteSetup siteSetup,
    UXSiteConfigElement site,
    UXSiteEntryConfigElement entry,
    UXSiteConfigElement parent
)
public:
UXEntryRemovedEventArgs(
    UXSiteSetup^ siteSetup,
    UXSiteConfigElement^ site,
    UXSiteEntryConfigElement^ entry,
    UXSiteConfigElement^ parent
)

Parameters

siteSetup
Type: VisualComponents.UX.SharedUXSiteSetup
site
Type: VisualComponents.UX.SharedUXSiteConfigElement
entry
Type: VisualComponents.UX.SharedUXSiteEntryConfigElement
parent
Type: VisualComponents.UX.SharedUXSiteConfigElement
See Also

Reference

UXEntryRemovedEventArgs Class


UXEntryRemovedEventArgs Properties

The UXEntryRemovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Entry |
Public property | Parent |
Public property | Site | (Inherited from UXSiteChangedEventArgs.)
Public property | SiteSetup | (Inherited from UXSiteChangedEventArgs.)
Top
See Also

Reference

UXEntryRemovedEventArgs Class


UXEntryRemovedEventArgs.Entry Property

UXEntryRemovedEventArgsEntry Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteEntryConfigElement Entry { get; }
public:
property UXSiteEntryConfigElement^ Entry {
    UXSiteEntryConfigElement^ get ();
}

Property Value

Type: UXSiteEntryConfigElement
See Also

Reference

UXEntryRemovedEventArgs Class


UXEntryRemovedEventArgs.Parent Property

UXEntryRemovedEventArgsParent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteConfigElement Parent { get; }
public:
property UXSiteConfigElement^ Parent {
    UXSiteConfigElement^ get ();
}

Property Value

Type: UXSiteConfigElement
See Also

Reference

UXEntryRemovedEventArgs Class


UXEntryRemovedEventArgs Methods

The UXEntryRemovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXEntryRemovedEventArgs Class


UxListProperty(T) Class

UxListPropertyT Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedUxProperty T
VisualComponents.UX.SharedUxListPropertyT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UxListProperty<T> : UxProperty<T[]>,
    IListProperty, IProperty, INotifyPropertyChanged, IDisposable, INamed

generic<typename T>
public ref class UxListProperty : public UxProperty<array<T>^>,
    IListProperty, IProperty, INotifyPropertyChanged, IDisposable, INamed

Type Parameters

T

The UxListPropertyT type exposes the following members.

Constructors
 | Name | Description
Public method | UxListPropertyT | Initializes a new instance of the UxListPropertyT class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from UxPropertyT.)
Public property | AllowedMinimum | (Inherited from UxPropertyT.)
Public property | AllowedValues | (Overrides UxPropertyTAllowedValues.)
Public property | CanCreateNewValue | (Inherited from UxPropertyT.)
Public property | Category | (Inherited from UxPropertyT.)
Public property | ConstraintType | (Inherited from UxPropertyT.)
Public property | Container | (Inherited from UxPropertyT.)
Public property | CreationTypes | (Inherited from UxPropertyT.)
Public property | Description | (Inherited from UxPropertyT.)
Public property | DisabledStateToolTip | (Inherited from UxPropertyT.)
Public property | DistributionExpression | (Inherited from UxPropertyT.)
Public property | HasDistribution | (Inherited from UxPropertyT.)
Public property | History | (Inherited from UxPropertyT.)
Public property | IsDesignTime | (Inherited from UxPropertyT.)
Public property | IsInternal | (Inherited from UxPropertyT.)
Public property | IsLocked | (Inherited from UxPropertyT.)
Public property | IsPersistent | (Inherited from UxPropertyT.)
Public property | IsQuantityValue | (Inherited from UxPropertyT.)
Public property | IsReadOnly | (Inherited from UxPropertyT.)
Public property | IsVisible | (Inherited from UxPropertyT.)
Public property | IsVisibleDesignTime | (Inherited from UxPropertyT.)
Public property | List |
Public property | Name | (Inherited from UxPropertyT.)
Public property | NotifyOnChanges | (Inherited from UxPropertyT.)
Public property | Order | (Inherited from UxPropertyT.)
Public property | PropertyType | (Inherited from UxPropertyT.)
Public property | Quantity | (Inherited from UxPropertyT.)
Public property | SupportStringValue | (Inherited from UxPropertyT.)
Public property | TabHeader | (Inherited from UxPropertyT.)
Public property | Unit | (Inherited from UxPropertyT.)
Public property | Value | (Overrides UxPropertyTValue.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from UxPropertyT.)
Public method | CreateAndSetNewValue | (Inherited from UxPropertyT.)
Public method | Dispose | (Inherited from UxPropertyT.)
Public method | EndBatch | (Inherited from UxPropertyT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem |
Public method | NotifyAllowedValuesChanged | (Inherited from UxPropertyT.)
Public method | NotifyPropertyValueChanged | (Inherited from UxPropertyT.)
Public method | SetQuantity | (Inherited from UxPropertyT.)
Public method | SetUnitMagnitude | (Inherited from UxPropertyT.)
Public method | StartBatch | (Inherited from UxPropertyT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from UxPropertyT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UxListProperty(T) Constructor

UxListPropertyT Constructor

Initializes a new instance of the UxListPropertyT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UxListProperty()
public:
UxListProperty()
See Also

Reference

UxListPropertyT Class


UxListProperty(T) Properties

UxListPropertyT Properties

The UxListPropertyT generic type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from UxPropertyT.)
Public property | AllowedMinimum | (Inherited from UxPropertyT.)
Public property | AllowedValues | (Overrides UxPropertyTAllowedValues.)
Public property | CanCreateNewValue | (Inherited from UxPropertyT.)
Public property | Category | (Inherited from UxPropertyT.)
Public property | ConstraintType | (Inherited from UxPropertyT.)
Public property | Container | (Inherited from UxPropertyT.)
Public property | CreationTypes | (Inherited from UxPropertyT.)
Public property | Description | (Inherited from UxPropertyT.)
Public property | DisabledStateToolTip | (Inherited from UxPropertyT.)
Public property | DistributionExpression | (Inherited from UxPropertyT.)
Public property | HasDistribution | (Inherited from UxPropertyT.)
Public property | History | (Inherited from UxPropertyT.)
Public property | IsDesignTime | (Inherited from UxPropertyT.)
Public property | IsInternal | (Inherited from UxPropertyT.)
Public property | IsLocked | (Inherited from UxPropertyT.)
Public property | IsPersistent | (Inherited from UxPropertyT.)
Public property | IsQuantityValue | (Inherited from UxPropertyT.)
Public property | IsReadOnly | (Inherited from UxPropertyT.)
Public property | IsVisible | (Inherited from UxPropertyT.)
Public property | IsVisibleDesignTime | (Inherited from UxPropertyT.)
Public property | List |
Public property | Name | (Inherited from UxPropertyT.)
Public property | NotifyOnChanges | (Inherited from UxPropertyT.)
Public property | Order | (Inherited from UxPropertyT.)
Public property | PropertyType | (Inherited from UxPropertyT.)
Public property | Quantity | (Inherited from UxPropertyT.)
Public property | SupportStringValue | (Inherited from UxPropertyT.)
Public property | TabHeader | (Inherited from UxPropertyT.)
Public property | Unit | (Inherited from UxPropertyT.)
Public property | Value | (Overrides UxPropertyTValue.)
Top
See Also

Reference

UxListPropertyT Class


UxListProperty(T).AllowedValues Property

UxListPropertyTAllowedValues Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ICollection<PropertyAllowedValue> AllowedValues { get; set; }
public:
virtual property ICollection<PropertyAllowedValue>^ AllowedValues {
    ICollection<PropertyAllowedValue>^ get () override;
    void set (ICollection<PropertyAllowedValue>^ value) override;
}

Property Value

Type: ICollectionPropertyAllowedValue

Implements

IPropertyAllowedValues
IPropertyAllowedValues
See Also

Reference

UxListPropertyT Class


UxListProperty(T).List Property

UxListPropertyTList Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList List { get; }
public:
virtual property IList^ List {
    IList^ get () sealed;
}

Property Value

Type: IList

Implements

IListPropertyList
See Also

Reference

UxListPropertyT Class


UxListProperty(T).Value Property

UxListPropertyTValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override Object Value { get; set; }
public:
virtual property Object^ Value {
    Object^ get () override;
    void set (Object^ value) override;
}

Property Value

Type: Object

Implements

IPropertyValue
IPropertyValue
See Also

Reference

UxListPropertyT Class


UxListProperty(T) Methods

UxListPropertyT Methods

The UxListPropertyT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from UxPropertyT.)
Public method | CreateAndSetNewValue | (Inherited from UxPropertyT.)
Public method | Dispose | (Inherited from UxPropertyT.)
Public method | EndBatch | (Inherited from UxPropertyT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem |
Public method | NotifyAllowedValuesChanged | (Inherited from UxPropertyT.)
Public method | NotifyPropertyValueChanged | (Inherited from UxPropertyT.)
Public method | SetQuantity | (Inherited from UxPropertyT.)
Public method | SetUnitMagnitude | (Inherited from UxPropertyT.)
Public method | StartBatch | (Inherited from UxPropertyT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UxListPropertyT Class


UxListProperty(T).MoveItem Method

UxListPropertyTMoveItem Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool MoveItem(
    int from,
    int to
)
public:
virtual bool MoveItem(
    int from,
    int to
) sealed

Parameters

from
Type: SystemInt32
to
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UxListProperty`1.MoveItem(System.Int32,System.Int32)"]

Implements

IListPropertyMoveItem(Int32, Int32)
See Also

Reference

UxListPropertyT Class


UxListProperty(T) Events

UxListPropertyT Events

The UxListPropertyT generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from UxPropertyT.)
Top
See Also

Reference

UxListPropertyT Class


UxProperty(T) Class

UxPropertyT Class

Implements managed IProperty Note: no need to implement PropertyChanged, because we can use EditorProperty for that.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedUxPropertyT
VisualComponents.UX.SharedUxListPropertyT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UxProperty<T> : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

generic<typename T>
public ref class UxProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

Type Parameters

T
Type of the contained value.

The UxPropertyT type exposes the following members.

Constructors
 | Name | Description
Public method | UxPropertyT | Initializes a new instance of the UxPropertyT class
Public method | UxPropertyT(T) | Initializes a new instance of the UxPropertyT class
Public method | UxPropertyT(String, T) | Initializes a new instance of the UxPropertyT class
Top
Properties
 | Name | Description
Public property | AllowedMaximum |
Public property | AllowedMinimum |
Public property | AllowedValues |
Public property | CanCreateNewValue |
Public property | Category |
Public property | ConstraintType |
Public property | Container |
Public property | CreationTypes |
Public property | Description |
Public property | DisabledStateToolTip |
Public property | DistributionExpression |
Public property | HasDistribution |
Public property | History |
Public property | IsDesignTime |
Public property | IsInternal |
Public property | IsLocked |
Public property | IsPersistent |
Public property | IsQuantityValue |
Public property | IsReadOnly |
Public property | IsVisible |
Public property | IsVisibleDesignTime |
Public property | Name |
Public property | NotifyOnChanges |
Public property | Order |
Public property | PropertyType |
Public property | Quantity |
Public property | SupportStringValue |
Public property | TabHeader |
Public property | Unit |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | CreateAndSetNewValue |
Public method | Dispose | Releases all resources used by the UxPropertyT
Public method | EndBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAllowedValuesChanged |
Public method | NotifyPropertyValueChanged |
Public method | SetQuantity |
Public method | SetUnitMagnitude |
Public method | StartBatch |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UxProperty(T) Constructor

UxPropertyT Constructor

Overload List
 | Name | Description
Public method | UxPropertyT | Initializes a new instance of the UxPropertyT class
Public method | UxPropertyT(T) | Initializes a new instance of the UxPropertyT class
Public method | UxPropertyT(String, T) | Initializes a new instance of the UxPropertyT class
Top
See Also

Reference

UxPropertyT Class


UxProperty(T) Constructor

UxPropertyT Constructor

Initializes a new instance of the UxPropertyT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UxProperty()
public:
UxProperty()
See Also

Reference

UxPropertyT Class
UxPropertyT Overload


UxProperty(T) Constructor (T)

UxPropertyT Constructor (T)

Initializes a new instance of the UxPropertyT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UxProperty(
    T initialValue
)
public:
UxProperty(
    T initialValue
)

Parameters

initialValue
Type: T
See Also

Reference

UxPropertyT Class
UxPropertyT Overload


UxProperty(T) Constructor (String, T)

UxPropertyT Constructor (String, T)

Initializes a new instance of the UxPropertyT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UxProperty(
    string name,
    T initialValue
)
public:
UxProperty(
    String^ name,
    T initialValue
)

Parameters

name
Type: SystemString
initialValue
Type: T
See Also

Reference

UxPropertyT Class
UxPropertyT Overload


UxProperty(T) Properties

UxPropertyT Properties

The UxPropertyT generic type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum |
Public property | AllowedMinimum |
Public property | AllowedValues |
Public property | CanCreateNewValue |
Public property | Category |
Public property | ConstraintType |
Public property | Container |
Public property | CreationTypes |
Public property | Description |
Public property | DisabledStateToolTip |
Public property | DistributionExpression |
Public property | HasDistribution |
Public property | History |
Public property | IsDesignTime |
Public property | IsInternal |
Public property | IsLocked |
Public property | IsPersistent |
Public property | IsQuantityValue |
Public property | IsReadOnly |
Public property | IsVisible |
Public property | IsVisibleDesignTime |
Public property | Name |
Public property | NotifyOnChanges |
Public property | Order |
Public property | PropertyType |
Public property | Quantity |
Public property | SupportStringValue |
Public property | TabHeader |
Public property | Unit |
Public property | Value |
Top
See Also

Reference

UxPropertyT Class


UxProperty(T).AllowedMaximum Property

UxPropertyTAllowedMaximum Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IComparable AllowedMaximum { get; set; }
public:
virtual property IComparable^ AllowedMaximum {
    IComparable^ get () sealed;
    void set (IComparable^ value) sealed;
}

Property Value

Type: IComparable

Implements

IPropertyAllowedMaximum
See Also

Reference

UxPropertyT Class


UxProperty(T).AllowedMinimum Property

UxPropertyTAllowedMinimum Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IComparable AllowedMinimum { get; set; }
public:
virtual property IComparable^ AllowedMinimum {
    IComparable^ get () sealed;
    void set (IComparable^ value) sealed;
}

Property Value

Type: IComparable

Implements

IPropertyAllowedMinimum
See Also

Reference

UxPropertyT Class


UxProperty(T).AllowedValues Property

UxPropertyTAllowedValues Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual ICollection<PropertyAllowedValue> AllowedValues { get; set; }
public:
virtual property ICollection<PropertyAllowedValue>^ AllowedValues {
    ICollection<PropertyAllowedValue>^ get ();
    void set (ICollection<PropertyAllowedValue>^ value);
}

Property Value

Type: ICollectionPropertyAllowedValue

Implements

IPropertyAllowedValues
See Also

Reference

UxPropertyT Class


UxProperty(T).CanCreateNewValue Property

UxPropertyTCanCreateNewValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanCreateNewValue { get; }
public:
virtual property bool CanCreateNewValue {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyCanCreateNewValue
See Also

Reference

UxPropertyT Class


UxProperty(T).Category Property

UxPropertyTCategory Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Category { get; set; }
public:
virtual property String^ Category {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyCategory
See Also

Reference

UxPropertyT Class


UxProperty(T).ConstraintType Property

UxPropertyTConstraintType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyConstraintType ConstraintType { get; set; }
public:
virtual property PropertyConstraintType ConstraintType {
    PropertyConstraintType get () sealed;
    void set (PropertyConstraintType value) sealed;
}

Property Value

Type: PropertyConstraintType

Implements

IPropertyConstraintType
See Also

Reference

UxPropertyT Class


UxProperty(T).Container Property

UxPropertyTContainer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPropertyContainer Container { get; set; }
public:
virtual property IPropertyContainer^ Container {
    IPropertyContainer^ get () sealed;
    void set (IPropertyContainer^ value) sealed;
}

Property Value

Type: IPropertyContainer

Implements

IPropertyContainer
See Also

Reference

UxPropertyT Class


UxProperty(T).CreationTypes Property

UxPropertyTCreationTypes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<string> CreationTypes { get; }
public:
virtual property IList<String^>^ CreationTypes {
    IList<String^>^ get () sealed;
}

Property Value

Type: IListString

Implements

IPropertyCreationTypes
See Also

Reference

UxPropertyT Class


UxProperty(T).Description Property

UxPropertyTDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyDescription
See Also

Reference

UxPropertyT Class


UxProperty(T).DisabledStateToolTip Property

UxPropertyTDisabledStateToolTip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DisabledStateToolTip { get; set; }
public:
virtual property String^ DisabledStateToolTip {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyDisabledStateToolTip
See Also

Reference

UxPropertyT Class


UxProperty(T).DistributionExpression Property

UxPropertyTDistributionExpression Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DistributionExpression { get; set; }
public:
virtual property String^ DistributionExpression {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyDistributionExpression
See Also

Reference

UxPropertyT Class


UxProperty(T).HasDistribution Property

UxPropertyTHasDistribution Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasDistribution { get; set; }
public:
virtual property bool HasDistribution {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyHasDistribution
See Also

Reference

UxPropertyT Class


UxProperty(T).History Property

UxPropertyTHistory Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<HistoryItem> History { get; }
public:
virtual property ReadOnlyCollection<HistoryItem>^ History {
    ReadOnlyCollection<HistoryItem>^ get () sealed;
}

Property Value

Type: ReadOnlyCollectionHistoryItem

Implements

IPropertyHistory
See Also

Reference

UxPropertyT Class


UxProperty(T).IsDesignTime Property

UxPropertyTIsDesignTime Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDesignTime { get; }
public:
virtual property bool IsDesignTime {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsDesignTime
See Also

Reference

UxPropertyT Class


UxProperty(T).IsInternal Property

UxPropertyTIsInternal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInternal { get; set; }
public:
virtual property bool IsInternal {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsInternal
See Also

Reference

UxPropertyT Class


UxProperty(T).IsLocked Property

UxPropertyTIsLocked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLocked { get; set; }
public:
virtual property bool IsLocked {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsLocked
See Also

Reference

UxPropertyT Class


UxProperty(T).IsPersistent Property

UxPropertyTIsPersistent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPersistent { get; set; }
public:
virtual property bool IsPersistent {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsPersistent
See Also

Reference

UxPropertyT Class


UxProperty(T).IsQuantityValue Property

UxPropertyTIsQuantityValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsQuantityValue { get; }
public:
virtual property bool IsQuantityValue {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsQuantityValue
See Also

Reference

UxPropertyT Class


UxProperty(T).IsReadOnly Property

UxPropertyTIsReadOnly Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsReadOnly { get; set; }
public:
virtual property bool IsReadOnly {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsReadOnly
See Also

Reference

UxPropertyT Class


UxProperty(T).IsVisible Property

UxPropertyTIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsVisible
See Also

Reference

UxPropertyT Class


UxProperty(T).IsVisibleDesignTime Property

UxPropertyTIsVisibleDesignTime Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisibleDesignTime { get; }
public:
virtual property bool IsVisibleDesignTime {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsVisibleDesignTime
See Also

Reference

UxPropertyT Class


UxProperty(T).Name Property

UxPropertyTName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INamedName
See Also

Reference

UxPropertyT Class


UxProperty(T).NotifyOnChanges Property

UxPropertyTNotifyOnChanges Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool NotifyOnChanges { get; set; }
public:
property bool NotifyOnChanges {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UxPropertyT Class


UxProperty(T).Order Property

UxPropertyTOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Order { get; set; }
public:
virtual property int Order {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IPropertyOrder
See Also

Reference

UxPropertyT Class


UxProperty(T).PropertyType Property

UxPropertyTPropertyType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type PropertyType { get; set; }
public:
virtual property Type^ PropertyType {
    Type^ get () sealed;
    void set (Type^ value) sealed;
}

Property Value

Type: Type

Implements

IPropertyPropertyType
See Also

Reference

UxPropertyT Class


UxProperty(T).Quantity Property

UxPropertyTQuantity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IScalarQuantity Quantity { get; }
public:
virtual property IScalarQuantity^ Quantity {
    IScalarQuantity^ get () sealed;
}

Property Value

Type: IScalarQuantity

Implements

IPropertyQuantity
See Also

Reference

UxPropertyT Class


UxProperty(T).SupportStringValue Property

UxPropertyTSupportStringValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SupportStringValue { get; set; }
public:
property bool SupportStringValue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UxPropertyT Class


UxProperty(T).TabHeader Property

UxPropertyTTabHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TabHeader { get; set; }
public:
virtual property String^ TabHeader {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyTabHeader
See Also

Reference

UxPropertyT Class


UxProperty(T).Unit Property

UxPropertyTUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnit Unit { get; }
public:
virtual property IUnit^ Unit {
    IUnit^ get () sealed;
}

Property Value

Type: IUnit

Implements

IPropertyUnit
See Also

Reference

UxPropertyT Class


UxProperty(T).Value Property

UxPropertyTValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object Value { get; set; }
public:
virtual property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object

Implements

IPropertyValue
See Also

Reference

UxPropertyT Class


UxProperty(T) Methods

UxPropertyT Methods

The UxPropertyT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | CreateAndSetNewValue |
Public method | Dispose |
Public method | EndBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAllowedValuesChanged |
Public method | NotifyPropertyValueChanged |
Public method | SetQuantity |
Public method | SetUnitMagnitude |
Public method | StartBatch |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UxPropertyT Class


UxProperty(T).Clone Method

UxPropertyTClone Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Clone()
public:
virtual IProperty^ Clone() sealed

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UxProperty`1.Clone"]

Implements

IPropertyClone
See Also

Reference

UxPropertyT Class


UxProperty(T).CreateAndSetNewValue Method

UxPropertyTCreateAndSetNewValue Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object CreateAndSetNewValue(
    string creationType,
    bool setImmediately
)
public:
virtual Object^ CreateAndSetNewValue(
    String^ creationType,
    bool setImmediately
) sealed

Parameters

creationType
Type: SystemString
setImmediately
Type: SystemBoolean

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UxProperty`1.CreateAndSetNewValue(System.String,System.Boolean)"]

Implements

IPropertyCreateAndSetNewValue(String, Boolean)
See Also

Reference

UxPropertyT Class


UxProperty(T).Dispose Method

UxPropertyTDispose Method

Releases all resources used by the UxPropertyT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

UxPropertyT Class


UxProperty(T).EndBatch Method

UxPropertyTEndBatch Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EndBatch(
    bool cancel
)
public:
virtual void EndBatch(
    bool cancel
) sealed

Parameters

cancel
Type: SystemBoolean

Implements

IPropertyEndBatch(Boolean)
See Also

Reference

UxPropertyT Class


UxProperty(T).NotifyAllowedValuesChanged Method

UxPropertyTNotifyAllowedValuesChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NotifyAllowedValuesChanged()
public:
void NotifyAllowedValuesChanged()
See Also

Reference

UxPropertyT Class


UxProperty(T).NotifyPropertyValueChanged Method

UxPropertyTNotifyPropertyValueChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NotifyPropertyValueChanged()
public:
void NotifyPropertyValueChanged()
See Also

Reference

UxPropertyT Class


UxProperty(T).SetQuantity Method

UxPropertyTSetQuantity Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnitGroup SetQuantity(
    string value
)
public:
virtual IUnitGroup^ SetQuantity(
    String^ value
) sealed

Parameters

value
Type: SystemString

Return Value

Type: IUnitGroup

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UxProperty`1.SetQuantity(System.String)"]

Implements

IPropertySetQuantity(String)
See Also

Reference

UxPropertyT Class


UxProperty(T).SetUnitMagnitude Method

UxPropertyTSetUnitMagnitude Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetUnitMagnitude(
    double value
)
public:
virtual void SetUnitMagnitude(
    double value
) sealed

Parameters

value
Type: SystemDouble

Implements

IPropertySetUnitMagnitude(Double)
See Also

Reference

UxPropertyT Class


UxProperty(T).StartBatch Method

UxPropertyTStartBatch Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartBatch()
public:
virtual void StartBatch() sealed

Implements

IPropertyStartBatch
See Also

Reference

UxPropertyT Class


UxProperty(T) Events

UxPropertyT Events

The UxPropertyT generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

UxPropertyT Class


UxProperty(T).PropertyChanged Event

UxPropertyTPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

UxPropertyT Class


UXSiteAddedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedUXSiteChangedEventArgs
VisualComponents.UX.SharedUXSiteAddedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UXSiteAddedEventArgs : UXSiteChangedEventArgs
public ref class UXSiteAddedEventArgs sealed : public UXSiteChangedEventArgs

The UXSiteAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UXSiteAddedEventArgs | Initializes a new instance of the UXSiteAddedEventArgs class
Top
Properties
 | Name | Description
Public property | Site | (Inherited from UXSiteChangedEventArgs.)
Public property | SiteSetup | (Inherited from UXSiteChangedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXSiteAddedEventArgs Constructor

Initializes a new instance of the UXSiteAddedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteAddedEventArgs(
    UXSiteSetup siteSetup,
    UXSiteConfigElement site
)
public:
UXSiteAddedEventArgs(
    UXSiteSetup^ siteSetup,
    UXSiteConfigElement^ site
)

Parameters

siteSetup
Type: VisualComponents.UX.SharedUXSiteSetup
site
Type: VisualComponents.UX.SharedUXSiteConfigElement
See Also

Reference

UXSiteAddedEventArgs Class


UXSiteAddedEventArgs Properties

The UXSiteAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Site | (Inherited from UXSiteChangedEventArgs.)
Public property | SiteSetup | (Inherited from UXSiteChangedEventArgs.)
Top
See Also

Reference

UXSiteAddedEventArgs Class


UXSiteAddedEventArgs Methods

The UXSiteAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXSiteAddedEventArgs Class


UXSiteChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedUXSiteChangedEventArgs
VisualComponents.UX.SharedUXEntryAddedEventArgs
VisualComponents.UX.SharedUXEntryRemovedEventArgs
VisualComponents.UX.SharedUXSiteAddedEventArgs
VisualComponents.UX.SharedUXSiteRemovedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class UXSiteChangedEventArgs : EventArgs
public ref class UXSiteChangedEventArgs abstract : public EventArgs

The UXSiteChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Protected method | UXSiteChangedEventArgs | Initializes a new instance of the UXSiteChangedEventArgs class
Top
Properties
 | Name | Description
Public property | Site |
Public property | SiteSetup |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _site |
Protected field | _siteSetup |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXSiteChangedEventArgs Constructor

Initializes a new instance of the UXSiteChangedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected UXSiteChangedEventArgs()
protected:
UXSiteChangedEventArgs()
See Also

Reference

UXSiteChangedEventArgs Class


UXSiteChangedEventArgs Properties

The UXSiteChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Site |
Public property | SiteSetup |
Top
See Also

Reference

UXSiteChangedEventArgs Class


UXSiteChangedEventArgs.Site Property

UXSiteChangedEventArgsSite Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteConfigElement Site { get; }
public:
property UXSiteConfigElement^ Site {
    UXSiteConfigElement^ get ();
}

Property Value

Type: UXSiteConfigElement
See Also

Reference

UXSiteChangedEventArgs Class


UXSiteChangedEventArgs.SiteSetup Property

UXSiteChangedEventArgsSiteSetup Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteSetup SiteSetup { get; }
public:
property UXSiteSetup^ SiteSetup {
    UXSiteSetup^ get ();
}

Property Value

Type: UXSiteSetup
See Also

Reference

UXSiteChangedEventArgs Class


UXSiteChangedEventArgs Methods

The UXSiteChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXSiteChangedEventArgs Class


UXSiteChangedEventArgs Fields

The UXSiteChangedEventArgs type exposes the following members.

Fields
 | Name | Description
Protected field | _site |
Protected field | _siteSetup |
Top
See Also

Reference

UXSiteChangedEventArgs Class


UXSiteChangedEventArgs._site Field

UXSiteChangedEventArgs_site Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected UXSiteConfigElement _site
protected:
UXSiteConfigElement^ _site

Field Value

Type: UXSiteConfigElement
See Also

Reference

UXSiteChangedEventArgs Class


UXSiteChangedEventArgs._siteSetup Field

UXSiteChangedEventArgs_siteSetup Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected UXSiteSetup _siteSetup
protected:
UXSiteSetup^ _siteSetup

Field Value

Type: UXSiteSetup
See Also

Reference

UXSiteChangedEventArgs Class


UXSiteConfigElement Class

blocked item config element
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedUXSiteConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UXSiteConfigElement : ConfigurationElement
public ref class UXSiteConfigElement sealed : public ConfigurationElement

The UXSiteConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | UXSiteConfigElement | Initializes a new instance of the UXSiteConfigElement class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Excluded | Defines Excluded attribute. The section will not be loaded at all if it is true.
Public property | IconKey | Icon file name with out extenstion.
Public property | ItemId | Item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | TitleKey | Title Localization key
Public property | Type | Type
Public property | UXSiteEntries |
Public property | UXSites |
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXSiteConfigElement Constructor

Initializes a new instance of the UXSiteConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteConfigElement()
public:
UXSiteConfigElement()
See Also

Reference

UXSiteConfigElement Class


UXSiteConfigElement Properties

The UXSiteConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Excluded | Defines Excluded attribute. The section will not be loaded at all if it is true.
Public property | IconKey | Icon file name with out extenstion.
Public property | ItemId | Item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | TitleKey | Title Localization key
Public property | Type | Type
Public property | UXSiteEntries |
Public property | UXSites |
Top
See Also

Reference

UXSiteConfigElement Class


UXSiteConfigElement.Excluded Property

UXSiteConfigElementExcluded Property

Defines Excluded attribute. The section will not be loaded at all if it is true.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Excluded { get; set; }
public:
property bool Excluded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UXSiteConfigElement Class


UXSiteConfigElement.IconKey Property

UXSiteConfigElementIconKey Property

Icon file name with out extenstion.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconKey { get; set; }
public:
property String^ IconKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteConfigElement Class


UXSiteConfigElement.ItemId Property

UXSiteConfigElementItemId Property

Item ID

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ItemId { get; set; }
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteConfigElement Class


UXSiteConfigElement.TitleKey Property

UXSiteConfigElementTitleKey Property

Title Localization key

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TitleKey { get; set; }
public:
property String^ TitleKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteConfigElement Class


UXSiteConfigElement.Type Property

UXSiteConfigElementType Property

Type

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Type { get; set; }
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteConfigElement Class


UXSiteConfigElement.UXSiteEntries Property

UXSiteConfigElementUXSiteEntries Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSitesEntryConfigCollection UXSiteEntries { get; }
public:
property UXSitesEntryConfigCollection^ UXSiteEntries {
    UXSitesEntryConfigCollection^ get ();
}

Property Value

Type: UXSitesEntryConfigCollection
See Also

Reference

UXSiteConfigElement Class


UXSiteConfigElement.UXSites Property

UXSiteConfigElementUXSites Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSitesConfigCollection UXSites { get; }
public:
property UXSitesConfigCollection^ UXSites {
    UXSitesConfigCollection^ get ();
}

Property Value

Type: UXSitesConfigCollection
See Also

Reference

UXSiteConfigElement Class


UXSiteConfigElement Methods

The UXSiteConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXSiteConfigElement Class


UXSiteConfigElement.IsReadOnly Method

UXSiteConfigElementIsReadOnly Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool IsReadOnly()
public:
virtual bool IsReadOnly() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UXSiteConfigElement.IsReadOnly"]

See Also

Reference

UXSiteConfigElement Class


UXSiteEntryConfigElement Class

blocked item config element
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedUXSiteEntryConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UXSiteEntryConfigElement : ConfigurationElement
public ref class UXSiteEntryConfigElement sealed : public ConfigurationElement

The UXSiteEntryConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | UXSiteEntryConfigElement | Initializes a new instance of the UXSiteEntryConfigElement class
Top
Properties
 | Name | Description
Public property | CaptionKey | Localization key
Public property | ControlType | Defines UI item control type.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EntityName | Can be the name of a company, product, etc.
Public property | IconKey | Icon file name with out extenstion.
Public property | ItemId | Item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Priority | Defines importance level
Public property | RowStart | Row start
Public property | SubItemsKey | Define SubItem source
Public property | TitleKey | Title Localization key
Public property | ToolSize | Preferred size of the button (Large, Normal, ImageOnly).
Public property | ToolTipContentKey | Localization key for Tooltip Content
Public property | ToolTipHeaderKey | Localization key for Tooltip Header
Public property | Url | Url
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXSiteEntryConfigElement Constructor

Initializes a new instance of the UXSiteEntryConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteEntryConfigElement()
public:
UXSiteEntryConfigElement()
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement Properties

The UXSiteEntryConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CaptionKey | Localization key
Public property | ControlType | Defines UI item control type.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EntityName | Can be the name of a company, product, etc.
Public property | IconKey | Icon file name with out extenstion.
Public property | ItemId | Item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Priority | Defines importance level
Public property | RowStart | Row start
Public property | SubItemsKey | Define SubItem source
Public property | TitleKey | Title Localization key
Public property | ToolSize | Preferred size of the button (Large, Normal, ImageOnly).
Public property | ToolTipContentKey | Localization key for Tooltip Content
Public property | ToolTipHeaderKey | Localization key for Tooltip Header
Public property | Url | Url
Top
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.CaptionKey Property

UXSiteEntryConfigElementCaptionKey Property

Localization key

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CaptionKey { get; set; }
public:
property String^ CaptionKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.ControlType Property

UXSiteEntryConfigElementControlType Property

Defines UI item control type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ControlType { get; set; }
public:
property String^ ControlType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.EntityName Property

UXSiteEntryConfigElementEntityName Property

Can be the name of a company, product, etc.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string EntityName { get; set; }
public:
property String^ EntityName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.IconKey Property

UXSiteEntryConfigElementIconKey Property

Icon file name with out extenstion.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconKey { get; set; }
public:
property String^ IconKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.ItemId Property

UXSiteEntryConfigElementItemId Property

Item ID

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ItemId { get; set; }
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.Priority Property

UXSiteEntryConfigElementPriority Property

Defines importance level

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Priority { get; set; }
public:
property int Priority {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.RowStart Property

UXSiteEntryConfigElementRowStart Property

Row start

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool RowStart { get; set; }
public:
property bool RowStart {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.SubItemsKey Property

UXSiteEntryConfigElementSubItemsKey Property

Define SubItem source

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SubItemsKey { get; set; }
public:
property String^ SubItemsKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.TitleKey Property

UXSiteEntryConfigElementTitleKey Property

Title Localization key

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TitleKey { get; set; }
public:
property String^ TitleKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.ToolSize Property

UXSiteEntryConfigElementToolSize Property

Preferred size of the button (Large, Normal, ImageOnly).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolSize { get; set; }
public:
property String^ ToolSize {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.ToolTipContentKey Property

UXSiteEntryConfigElementToolTipContentKey Property

Localization key for Tooltip Content

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipContentKey { get; set; }
public:
property String^ ToolTipContentKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.ToolTipHeaderKey Property

UXSiteEntryConfigElementToolTipHeaderKey Property

Localization key for Tooltip Header

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipHeaderKey { get; set; }
public:
property String^ ToolTipHeaderKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement.Url Property

UXSiteEntryConfigElementUrl Property

Url

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Url { get; set; }
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteEntryConfigElement Methods

The UXSiteEntryConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXSiteEntryConfigElement Class


UXSiteRemovedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedUXSiteChangedEventArgs
VisualComponents.UX.SharedUXSiteRemovedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UXSiteRemovedEventArgs : UXSiteChangedEventArgs
public ref class UXSiteRemovedEventArgs sealed : public UXSiteChangedEventArgs

The UXSiteRemovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UXSiteRemovedEventArgs | Initializes a new instance of the UXSiteRemovedEventArgs class
Top
Properties
 | Name | Description
Public property | Site | (Inherited from UXSiteChangedEventArgs.)
Public property | SiteSetup | (Inherited from UXSiteChangedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXSiteRemovedEventArgs Constructor

Initializes a new instance of the UXSiteRemovedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteRemovedEventArgs(
    UXSiteSetup siteSetup,
    UXSiteConfigElement site
)
public:
UXSiteRemovedEventArgs(
    UXSiteSetup^ siteSetup,
    UXSiteConfigElement^ site
)

Parameters

siteSetup
Type: VisualComponents.UX.SharedUXSiteSetup
site
Type: VisualComponents.UX.SharedUXSiteConfigElement
See Also

Reference

UXSiteRemovedEventArgs Class


UXSiteRemovedEventArgs Properties

The UXSiteRemovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Site | (Inherited from UXSiteChangedEventArgs.)
Public property | SiteSetup | (Inherited from UXSiteChangedEventArgs.)
Top
See Also

Reference

UXSiteRemovedEventArgs Class


UXSiteRemovedEventArgs Methods

The UXSiteRemovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXSiteRemovedEventArgs Class


UXSites Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedUXSites

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class UXSites
public ref class UXSites abstract sealed

The UXSites type exposes the following members.

Fields
Name | Description
All |
Author3DContextMenu |
AuthorTreeViewBasesContextMenu |
AuthorTreeViewBehaviorsContextMenu |
AuthorTreeViewContextMenu |
AuthorTreeViewFeaturesContextMenu |
AuthorTreeViewNodesContextMenu |
AuthorTreeViewPropertiesContextMenu |
AuthorTreeViewRobotFramesContextMenu |
AuthorTreeViewToolContextMenu |
Configure3DContextMenu |
ConfigureQuickmenu |
ConfigureToolbar |
ContextMenuComponentMenu3D |
Drawing3DContextMenu |
ProcessStatementGallery |
ProcessStatements |
ProgramStatementContextMenu |
ProgramStatementToolbar |
QuickAccessToolbar |
Ribbon |
SnapOptions |
Teach3DContextMenu |
VcStatisticsDashboardToolbar |
Top
See Also

Reference


UXSites Fields

The UXSites type exposes the following members.

Fields
Name | Description
All |
Author3DContextMenu |
AuthorTreeViewBasesContextMenu |
AuthorTreeViewBehaviorsContextMenu |
AuthorTreeViewContextMenu |
AuthorTreeViewFeaturesContextMenu |
AuthorTreeViewNodesContextMenu |
AuthorTreeViewPropertiesContextMenu |
AuthorTreeViewRobotFramesContextMenu |
AuthorTreeViewToolContextMenu |
Configure3DContextMenu |
ConfigureQuickmenu |
ConfigureToolbar |
ContextMenuComponentMenu3D |
Drawing3DContextMenu |
ProcessStatementGallery |
ProcessStatements |
ProgramStatementContextMenu |
ProgramStatementToolbar |
QuickAccessToolbar |
Ribbon |
SnapOptions |
Teach3DContextMenu |
VcStatisticsDashboardToolbar |
Top
See Also

Reference

UXSites Class


UXSites.All Field

UXSitesAll Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string All = "All"
public:
literal String^ All = "All"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.Author3DContextMenu Field

UXSitesAuthor3DContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Author3DContextMenu = "VcAuthor3DContextMenu"
public:
literal String^ Author3DContextMenu = "VcAuthor3DContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.AuthorTreeViewBasesContextMenu Field

UXSitesAuthorTreeViewBasesContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string AuthorTreeViewBasesContextMenu = "VcAuthorTreeViewBasesContextMenu"
public:
literal String^ AuthorTreeViewBasesContextMenu = "VcAuthorTreeViewBasesContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.AuthorTreeViewBehaviorsContextMenu Field

UXSitesAuthorTreeViewBehaviorsContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string AuthorTreeViewBehaviorsContextMenu = "VcAuthorTreeViewBehaviorsContextMenu"
public:
literal String^ AuthorTreeViewBehaviorsContextMenu = "VcAuthorTreeViewBehaviorsContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.AuthorTreeViewContextMenu Field

UXSitesAuthorTreeViewContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string AuthorTreeViewContextMenu = "VcAuthorTreeViewContextMenu"
public:
literal String^ AuthorTreeViewContextMenu = "VcAuthorTreeViewContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.AuthorTreeViewFeaturesContextMenu Field

UXSitesAuthorTreeViewFeaturesContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string AuthorTreeViewFeaturesContextMenu = "VcAuthorTreeViewFeaturesContextMenu"
public:
literal String^ AuthorTreeViewFeaturesContextMenu = "VcAuthorTreeViewFeaturesContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.AuthorTreeViewNodesContextMenu Field

UXSitesAuthorTreeViewNodesContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string AuthorTreeViewNodesContextMenu = "VcAuthorTreeViewNodesContextMenu"
public:
literal String^ AuthorTreeViewNodesContextMenu = "VcAuthorTreeViewNodesContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.AuthorTreeViewPropertiesContextMenu Field

UXSitesAuthorTreeViewPropertiesContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string AuthorTreeViewPropertiesContextMenu = "VcAuthorTreeViewPropertiesContextMenu"
public:
literal String^ AuthorTreeViewPropertiesContextMenu = "VcAuthorTreeViewPropertiesContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.AuthorTreeViewRobotFramesContextMenu Field

UXSitesAuthorTreeViewRobotFramesContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string AuthorTreeViewRobotFramesContextMenu = "VcAuthorTreeViewRobotFramesContextMenu"
public:
literal String^ AuthorTreeViewRobotFramesContextMenu = "VcAuthorTreeViewRobotFramesContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.AuthorTreeViewToolContextMenu Field

UXSitesAuthorTreeViewToolContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string AuthorTreeViewToolContextMenu = "VcAuthorTreeViewToolContextMenu"
public:
literal String^ AuthorTreeViewToolContextMenu = "VcAuthorTreeViewToolContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.Configure3DContextMenu Field

UXSitesConfigure3DContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Configure3DContextMenu = "VcConfigure3DContextMenu"
public:
literal String^ Configure3DContextMenu = "VcConfigure3DContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.ConfigureQuickmenu Field

UXSitesConfigureQuickmenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ConfigureQuickmenu = "VcConfigureQuickmenu"
public:
literal String^ ConfigureQuickmenu = "VcConfigureQuickmenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.ConfigureToolbar Field

UXSitesConfigureToolbar Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ConfigureToolbar = "VcConfigureToolbar"
public:
literal String^ ConfigureToolbar = "VcConfigureToolbar"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.ContextMenuComponentMenu3D Field

UXSitesContextMenuComponentMenu3D Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ContextMenuComponentMenu3D = "ContextMenuComponentMenu3D"
public:
literal String^ ContextMenuComponentMenu3D = "ContextMenuComponentMenu3D"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.Drawing3DContextMenu Field

UXSitesDrawing3DContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Drawing3DContextMenu = "VcDrawing3DContextMenu"
public:
literal String^ Drawing3DContextMenu = "VcDrawing3DContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.ProcessStatementGallery Field

UXSitesProcessStatementGallery Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ProcessStatementGallery = "VcProcessStatements"
public:
literal String^ ProcessStatementGallery = "VcProcessStatements"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.ProcessStatements Field

UXSitesProcessStatements Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ProcessStatements = "ProcessStatements"
public:
literal String^ ProcessStatements = "ProcessStatements"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.ProgramStatementContextMenu Field

UXSitesProgramStatementContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ProgramStatementContextMenu = "ProgramStatementContextMenu"
public:
literal String^ ProgramStatementContextMenu = "ProgramStatementContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.ProgramStatementToolbar Field

UXSitesProgramStatementToolbar Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ProgramStatementToolbar = "VcProgramStatementToolbar"
public:
literal String^ ProgramStatementToolbar = "VcProgramStatementToolbar"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.QuickAccessToolbar Field

UXSitesQuickAccessToolbar Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string QuickAccessToolbar = "QAT"
public:
literal String^ QuickAccessToolbar = "QAT"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.Ribbon Field

UXSitesRibbon Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Ribbon = "Ribbon"
public:
literal String^ Ribbon = "Ribbon"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.SnapOptions Field

UXSitesSnapOptions Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string SnapOptions = "SnapOptions"
public:
literal String^ SnapOptions = "SnapOptions"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.Teach3DContextMenu Field

UXSitesTeach3DContextMenu Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Teach3DContextMenu = "VcTeach3DContextMenu"
public:
literal String^ Teach3DContextMenu = "VcTeach3DContextMenu"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSites.VcStatisticsDashboardToolbar Field

UXSitesVcStatisticsDashboardToolbar Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string VcStatisticsDashboardToolbar = "VcStatisticsDashboardToolbar"
public:
literal String^ VcStatisticsDashboardToolbar = "VcStatisticsDashboardToolbar"

Field Value

Type: String
See Also

Reference

UXSites Class


UXSitesConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollection UXSiteConfigElement
VisualComponents.UX.SharedUXSitesConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UXSitesConfigCollection : BaseConfigCollection<UXSiteConfigElement>
public ref class UXSitesConfigCollection sealed : public BaseConfigCollection<UXSiteConfigElement^>

The UXSitesConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | UXSitesConfigCollection | Initializes a new instance of the UXSitesConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | (Overrides ConfigurationElementCollectionIsReadOnly.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXSitesConfigCollection Constructor

Initializes a new instance of the UXSitesConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSitesConfigCollection()
public:
UXSitesConfigCollection()
See Also

Reference

UXSitesConfigCollection Class


UXSitesConfigCollection Properties

The UXSitesConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

UXSitesConfigCollection Class


UXSitesConfigCollection Methods

The UXSitesConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | (Overrides ConfigurationElementCollectionIsReadOnly.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXSitesConfigCollection Class


UXSitesConfigCollection.IsReadOnly Method

UXSitesConfigCollectionIsReadOnly Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool IsReadOnly()
public:
virtual bool IsReadOnly() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UXSitesConfigCollection.IsReadOnly"]

See Also

Reference

UXSitesConfigCollection Class


UXSitesEntryConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollection UXSiteEntryConfigElement
VisualComponents.UX.SharedUXSitesEntryConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UXSitesEntryConfigCollection : BaseConfigCollection<UXSiteEntryConfigElement>
public ref class UXSitesEntryConfigCollection sealed : public BaseConfigCollection<UXSiteEntryConfigElement^>

The UXSitesEntryConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | UXSitesEntryConfigCollection | Initializes a new instance of the UXSitesEntryConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | (Overrides ConfigurationElementCollectionIsReadOnly.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXSitesEntryConfigCollection Constructor

Initializes a new instance of the UXSitesEntryConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSitesEntryConfigCollection()
public:
UXSitesEntryConfigCollection()
See Also

Reference

UXSitesEntryConfigCollection Class


UXSitesEntryConfigCollection Properties

The UXSitesEntryConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

UXSitesEntryConfigCollection Class


UXSitesEntryConfigCollection Methods

The UXSitesEntryConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | (Overrides ConfigurationElementCollectionIsReadOnly.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXSitesEntryConfigCollection Class


UXSitesEntryConfigCollection.IsReadOnly Method

UXSitesEntryConfigCollectionIsReadOnly Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool IsReadOnly()
public:
virtual bool IsReadOnly() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UXSitesEntryConfigCollection.IsReadOnly"]

See Also

Reference

UXSitesEntryConfigCollection Class


UXSiteSetup Class

Setup information for the UXSite and UXEntries in it.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedUXSiteSetup

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UXSiteSetup
public ref class UXSiteSetup sealed

The UXSiteSetup type exposes the following members.

Constructors
 | Name | Description
Public method | UXSiteSetup | Initializes a new instance of the UXSiteSetup class
Top
Properties
 | Name | Description
Public property | EntryCaption |
Public property | EntryId |
Public property | EntryIndex |
Public property | IconRelativePath |
Public property | ToolTipContentKey |
Public property | UXSiteCaption |
Public property | UXSiteIdPath | Path to UxSite separated with '/' character. Leading/trailing '/' characters will be removed.
Public property | UXSiteType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXSiteSetup Constructor

Initializes a new instance of the UXSiteSetup class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteSetup()
public:
UXSiteSetup()
See Also

Reference

UXSiteSetup Class


UXSiteSetup Properties

The UXSiteSetup type exposes the following members.

Properties
 | Name | Description
Public property | EntryCaption |
Public property | EntryId |
Public property | EntryIndex |
Public property | IconRelativePath |
Public property | ToolTipContentKey |
Public property | UXSiteCaption |
Public property | UXSiteIdPath | Path to UxSite separated with '/' character. Leading/trailing '/' characters will be removed.
Public property | UXSiteType |
Top
See Also

Reference

UXSiteSetup Class


UXSiteSetup.EntryCaption Property

UXSiteSetupEntryCaption Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string EntryCaption { get; set; }
public:
property String^ EntryCaption {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteSetup Class


UXSiteSetup.EntryId Property

UXSiteSetupEntryId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string EntryId { get; set; }
public:
property String^ EntryId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteSetup Class


UXSiteSetup.EntryIndex Property

UXSiteSetupEntryIndex Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int EntryIndex { get; set; }
public:
property int EntryIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

UXSiteSetup Class


UXSiteSetup.IconRelativePath Property

UXSiteSetupIconRelativePath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconRelativePath { get; set; }
public:
property String^ IconRelativePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteSetup Class


UXSiteSetup.ToolTipContentKey Property

UXSiteSetupToolTipContentKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipContentKey { get; set; }
public:
property String^ ToolTipContentKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteSetup Class


UXSiteSetup.UXSiteCaption Property

UXSiteSetupUXSiteCaption Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string UXSiteCaption { get; set; }
public:
property String^ UXSiteCaption {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteSetup Class


UXSiteSetup.UXSiteIdPath Property

UXSiteSetupUXSiteIdPath Property

Path to UxSite separated with '/' character. Leading/trailing '/' characters will be removed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string UXSiteIdPath { get; set; }
public:
property String^ UXSiteIdPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UXSiteSetup Class


UXSiteSetup.UXSiteType Property

UXSiteSetupUXSiteType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSiteType UXSiteType { get; set; }
public:
property UXSiteType UXSiteType {
    UXSiteType get ();
    void set (UXSiteType value);
}

Property Value

Type: UXSiteType
See Also

Reference

UXSiteSetup Class


UXSiteSetup Methods

The UXSiteSetup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXSiteSetup Class


UXSitesSection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.UX.SharedUXSitesSection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UXSitesSection : ConfigurationSection,
    ISection
public ref class UXSitesSection sealed : public ConfigurationSection,
    ISection

The UXSitesSection type exposes the following members.

Constructors
 | Name | Description
Public method | UXSitesSection | Initializes a new instance of the UXSitesSection class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Public property | SiteOrder |
Public property | UXSites |
Top
Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


UXSitesSection Constructor

Initializes a new instance of the UXSitesSection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSitesSection()
public:
UXSitesSection()
See Also

Reference

UXSitesSection Class


UXSitesSection Properties

The UXSitesSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Public property | SiteOrder |
Public property | UXSites |
Top
See Also

Reference

UXSitesSection Class


UXSitesSection.SectionName Property

UXSitesSectionSectionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

UXSitesSection Class


UXSitesSection.SectionType Property

UXSitesSectionSectionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

UXSitesSection Class


UXSitesSection.SectionVersion Property

UXSitesSectionSectionVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

UXSitesSection Class


UXSitesSection.SiteOrder Property

UXSitesSectionSiteOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SiteOrder { get; }
public:
property String^ SiteOrder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UXSitesSection Class


UXSitesSection.UXSites Property

UXSitesSectionUXSites Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UXSitesConfigCollection UXSites { get; }
public:
property UXSitesConfigCollection^ UXSites {
    UXSitesConfigCollection^ get ();
}

Property Value

Type: UXSitesConfigCollection
See Also

Reference

UXSitesSection Class


UXSitesSection Methods

The UXSitesSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UXSitesSection Class


UXSitesSection.CheckVersion Method

UXSitesSectionCheckVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

UXSitesSection Class


UXSitesSection.GetSection Method

UXSitesSectionGetSection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.UXSitesSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

UXSitesSection Class


UXSiteType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum UXSiteType
public enum class UXSiteType
Members
Member name | Value | Description
Default | 0 |
Tab | 1 |
RibbonGroup | 2 |
Menu | 4 |
ParentMenu | 8 |
ContextTab | 16 |
See Also

Reference


ValidationErrorToErrorContentConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedValidationErrorToErrorContentConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ValidationErrorToErrorContentConverter : IValueConverter
public ref class ValidationErrorToErrorContentConverter : IValueConverter

The ValidationErrorToErrorContentConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationErrorToErrorContentConverter | Initializes a new instance of the ValidationErrorToErrorContentConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


ValidationErrorToErrorContentConverter Constructor

Initializes a new instance of the ValidationErrorToErrorContentConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ValidationErrorToErrorContentConverter()
public:
ValidationErrorToErrorContentConverter()
See Also

Reference

ValidationErrorToErrorContentConverter Class


ValidationErrorToErrorContentConverter Methods

The ValidationErrorToErrorContentConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ValidationErrorToErrorContentConverter Class


ValidationErrorToErrorContentConverter.Convert Method

ValidationErrorToErrorContentConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ValidationErrorToErrorContentConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ValidationErrorToErrorContentConverter Class


ValidationErrorToErrorContentConverter.ConvertBack Method

ValidationErrorToErrorContentConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ValidationErrorToErrorContentConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ValidationErrorToErrorContentConverter Class


ValueAndUnitToStringConverter Class

concatenate value and unit .
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedValueAndUnitToStringConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ValueAndUnitToStringConverter : IMultiValueConverter
public ref class ValueAndUnitToStringConverter : IMultiValueConverter

The ValueAndUnitToStringConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ValueAndUnitToStringConverter | Initializes a new instance of the ValueAndUnitToStringConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


ValueAndUnitToStringConverter Constructor

Initializes a new instance of the ValueAndUnitToStringConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ValueAndUnitToStringConverter()
public:
ValueAndUnitToStringConverter()
See Also

Reference

ValueAndUnitToStringConverter Class


ValueAndUnitToStringConverter Methods

The ValueAndUnitToStringConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ValueAndUnitToStringConverter Class


ValueAndUnitToStringConverter.Convert Method

ValueAndUnitToStringConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ValueAndUnitToStringConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ValueAndUnitToStringConverter Class


ValueAndUnitToStringConverter.ConvertBack Method

ValueAndUnitToStringConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ValueAndUnitToStringConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ValueAndUnitToStringConverter Class


VariableEditorView Class

Interaction logic for VariableEditorView.xaml
VariableEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedVariableEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VariableEditorView : UserControl,
    IComponentConnector
public ref class VariableEditorView : public UserControl,
    IComponentConnector

The VariableEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | VariableEditorView | Initializes a new instance of the VariableEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VariableEditorView Constructor

Initializes a new instance of the VariableEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VariableEditorView()
public:
VariableEditorView()
See Also

Reference

VariableEditorView Class


VariableEditorView Properties

The VariableEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

VariableEditorView Class


VariableEditorView Methods

The VariableEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VariableEditorView Class


VariableEditorView.InitializeComponent Method

VariableEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

VariableEditorView Class


VariableEditorView Events

The VariableEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

VariableEditorView Class


WarningMessageArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedWarningMessageArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class WarningMessageArgs : EventArgs
public ref class WarningMessageArgs : public EventArgs

The WarningMessageArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WarningMessageArgs | Initializes a new instance of the WarningMessageArgs class
Top
Properties
 | Name | Description
Public property | AdditionalInfo |
Public property | LocalizationMessage |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


WarningMessageArgs Constructor

Initializes a new instance of the WarningMessageArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WarningMessageArgs(
    string message,
    string addition
)
public:
WarningMessageArgs(
    String^ message,
    String^ addition
)

Parameters

message
Type: SystemString
addition
Type: SystemString
See Also

Reference

WarningMessageArgs Class


WarningMessageArgs Properties

The WarningMessageArgs type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo |
Public property | LocalizationMessage |
Top
See Also

Reference

WarningMessageArgs Class


WarningMessageArgs.AdditionalInfo Property

WarningMessageArgsAdditionalInfo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AdditionalInfo { get; set; }
public:
property String^ AdditionalInfo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

WarningMessageArgs Class


WarningMessageArgs.LocalizationMessage Property

WarningMessageArgsLocalizationMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LocalizationMessage { get; set; }
public:
property String^ LocalizationMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

WarningMessageArgs Class


WarningMessageArgs Methods

The WarningMessageArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

WarningMessageArgs Class


VcAttachProperty Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
VisualComponents.UX.SharedVcAttachProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VcAttachProperty : DependencyObject
public ref class VcAttachProperty : public DependencyObject

The VcAttachProperty type exposes the following members.

Constructors
 | Name | Description
Public method | VcAttachProperty | Initializes a new instance of the VcAttachProperty class
Top
Properties
 | Name | Description
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueId | Gets the UniqueIdProperty for a given DependencyObject, which provides an String Id for arbitrary WPF elements.
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
 | SetUniqueId | Sets the UniqueIdProperty for a given DependencyObject, which provides an String Id for arbitrary WPF elements.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
UniqueIdProperty | An attached dependency property which provides Unique Id for arbitrary WPF elements.
Top
Attached Properties
 | Name | Description
Public attached property | UniqueId |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VcAttachProperty Constructor

Initializes a new instance of the VcAttachProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VcAttachProperty()
public:
VcAttachProperty()
See Also

Reference

VcAttachProperty Class


VcAttachProperty Properties

The VcAttachProperty type exposes the following members.

Properties
 | Name | Description
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
See Also

Reference

VcAttachProperty Class


VcAttachProperty Methods

The VcAttachProperty type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueId | Gets the UniqueIdProperty for a given DependencyObject, which provides an String Id for arbitrary WPF elements.
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
 | SetUniqueId | Sets the UniqueIdProperty for a given DependencyObject, which provides an String Id for arbitrary WPF elements.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VcAttachProperty Class


VcAttachProperty.GetUniqueId Method

VcAttachPropertyGetUniqueId Method

Gets the UniqueIdProperty for a given DependencyObject, which provides an String Id for arbitrary WPF elements.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetUniqueId(
    UIElement uiElement
)
public:
static String^ GetUniqueId(
    UIElement^ uiElement
)

Parameters

uiElement
Type: System.WindowsUIElement

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcAttachProperty.GetUniqueId(System.Windows.UIElement)"]

See Also

Reference

VcAttachProperty Class


VcAttachProperty.SetUniqueId Method

VcAttachPropertySetUniqueId Method

Sets the UniqueIdProperty for a given DependencyObject, which provides an String Id for arbitrary WPF elements.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetUniqueId(
    UIElement uiElement,
    string value
)
public:
static void SetUniqueId(
    UIElement^ uiElement,
    String^ value
)

Parameters

uiElement
Type: System.WindowsUIElement
value
Type: SystemString
See Also

Reference

VcAttachProperty Class


VcAttachProperty Fields

The VcAttachProperty type exposes the following members.

Fields
Name | Description
UniqueIdProperty | An attached dependency property which provides Unique Id for arbitrary WPF elements.
Top
See Also

Reference

VcAttachProperty Class


VcAttachProperty.UniqueIdProperty Field

VcAttachPropertyUniqueIdProperty Field

An attached dependency property which provides Unique Id for arbitrary WPF elements.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty UniqueIdProperty
public:
static initonly DependencyProperty^ UniqueIdProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcAttachProperty Class


VcAttachProperty Attached Properties

The VcAttachProperty type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | UniqueId |
Top
See Also

Reference

VcAttachProperty Class


VcAttachProperty.UniqueId Attached Property

VcAttachPropertyUniqueId Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetUniqueId, SetUniqueId
See GetUniqueId, SetUniqueId

Property Value

Type: String
See Also

Reference

VcAttachProperty Class


VcEditableTextBox Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsTextBox
VisualComponents.UX.SharedVcEditableTextBox

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VcEditableTextBox : TextBox
public ref class VcEditableTextBox : public TextBox

The VcEditableTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | VcEditableTextBox | Initializes a new instance of the VcEditableTextBox class
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | (Overrides TextBoxBaseOnLostFocus(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | (Overrides ControlOnMouseDoubleClick(MouseButtonEventArgs).)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | (Overrides UIElementOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetEditingStyle |
Public method | SetReadonlyStyle |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VcEditableTextBox Constructor

Initializes a new instance of the VcEditableTextBox class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VcEditableTextBox()
public:
VcEditableTextBox()
See Also

Reference

VcEditableTextBox Class


VcEditableTextBox Properties

The VcEditableTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

VcEditableTextBox Class


VcEditableTextBox Methods

The VcEditableTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | (Overrides TextBoxBaseOnLostFocus(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | (Overrides ControlOnMouseDoubleClick(MouseButtonEventArgs).)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | (Overrides UIElementOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetEditingStyle |
Public method | SetReadonlyStyle |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VcEditableTextBox Class


VcEditableTextBox.OnLostFocus Method

VcEditableTextBoxOnLostFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
protected:
virtual void OnLostFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.WindowsRoutedEventArgs
See Also

Reference

VcEditableTextBox Class


VcEditableTextBox.OnMouseDoubleClick Method

VcEditableTextBoxOnMouseDoubleClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseDoubleClick(
    MouseButtonEventArgs e
)
protected:
virtual void OnMouseDoubleClick(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

VcEditableTextBox Class


VcEditableTextBox.OnMouseLeftButtonDown Method

VcEditableTextBoxOnMouseLeftButtonDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

VcEditableTextBox Class


VcEditableTextBox.SetEditingStyle Method

VcEditableTextBoxSetEditingStyle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetEditingStyle()
public:
void SetEditingStyle()
See Also

Reference

VcEditableTextBox Class


VcEditableTextBox.SetReadonlyStyle Method

VcEditableTextBoxSetReadonlyStyle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetReadonlyStyle()
public:
void SetReadonlyStyle()
See Also

Reference

VcEditableTextBox Class


VcEditableTextBox Events

The VcEditableTextBox type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

VcEditableTextBox Class


VcImageSize Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct VcImageSize
public value class VcImageSize

The VcImageSize type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Height |
Public property | Unit |
Public property | Width |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VcImageSize Properties

The VcImageSize type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Height |
Public property | Unit |
Public property | Width |
Top
See Also

Reference

VcImageSize Structure


VcImageSize.DisplayName Property

VcImageSizeDisplayName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DisplayName { get; set; }
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcImageSize Structure


VcImageSize.Height Property

VcImageSizeHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Height { get; set; }
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VcImageSize Structure


VcImageSize.Unit Property

VcImageSizeUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImageSizeUnits Unit { get; set; }
public:
property ImageSizeUnits Unit {
    ImageSizeUnits get ();
    void set (ImageSizeUnits value);
}

Property Value

Type: ImageSizeUnits
See Also

Reference

VcImageSize Structure


VcImageSize.Width Property

VcImageSizeWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Width { get; set; }
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VcImageSize Structure


VcImageSize Methods

The VcImageSize type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VcImageSize Structure


VcImageSizeUnit Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct VcImageSizeUnit
public value class VcImageSizeUnit

The VcImageSizeUnit type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Magnitude |
Public property | Suffix |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VcImageSizeUnit Properties

The VcImageSizeUnit type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Magnitude |
Public property | Suffix |
Public property | Value |
Top
See Also

Reference

VcImageSizeUnit Structure


VcImageSizeUnit.DisplayName Property

VcImageSizeUnitDisplayName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DisplayName { get; set; }
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcImageSizeUnit Structure


VcImageSizeUnit.Magnitude Property

VcImageSizeUnitMagnitude Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Magnitude { get; set; }
public:
property double Magnitude {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VcImageSizeUnit Structure


VcImageSizeUnit.Suffix Property

VcImageSizeUnitSuffix Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Suffix { get; set; }
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcImageSizeUnit Structure


VcImageSizeUnit.Value Property

VcImageSizeUnitValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImageSizeUnits Value { get; set; }
public:
property ImageSizeUnits Value {
    ImageSizeUnits get ();
    void set (ImageSizeUnits value);
}

Property Value

Type: ImageSizeUnits
See Also

Reference

VcImageSizeUnit Structure


VcImageSizeUnit Methods

The VcImageSizeUnit type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VcImageSizeUnit Structure


VcMessageBox Class

Interaction logic for VcMessageBox.xaml
VcMessageBox
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
VisualComponents.UX.SharedVcMessageBox

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VcMessageBox : Window,
    IComponentConnector
public ref class VcMessageBox : public Window,
    IComponentConnector

The VcMessageBox type exposes the following members.

Constructors
 | Name | Description
Public method | VcMessageBox | Initializes a new instance of the VcMessageBox class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CancelButtonContent |
Public property | Caption |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CloseCaptionButtonVisibility |
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultResult |
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Message |
Public property | MessageBoxButton |
Public property | MessageBoxIconPath |
Public property | MessageBoxImage |
Public property | MessageBoxResult |
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NoButtonContent |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | YesButtonContent |
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | (Overrides WindowOnClosing(CancelEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
 | Show(String, Boolean) |
 | Show(String, String, Boolean) |
 | Show(String, MessageBoxResult, Boolean) |
 | Show(Window, String, Boolean) |
 | Show(String, String, MessageBoxButton, Boolean) |
 | Show(String, String, MessageBoxResult, Boolean) |
 | Show(Window, String, String, Boolean) |
 | Show(Window, String, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxResult, Boolean) |
 | Show(Window, String, String, MessageBoxButton, Boolean) |
 | Show(Window, String, String, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxImage, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, String, String, String, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, String, String, String, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxResult, String, String, String, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean) |
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
 | ShowExceptionMessage |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
 | MessageBoxHidden | Raised after a message box has been hidden.
 | MessageBoxShowing | Raised before a message box is shown.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CancelButtonContentProperty |
CloseCaptionButtonVisibilityProperty |
DefaultResultProperty |
MessageBoxButtonProperty |
MessageBoxIconPathProperty |
MessageBoxImageProperty |
MessageProperty |
NoButtonContentProperty |
YesButtonContentProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VcMessageBox Constructor

Initializes a new instance of the VcMessageBox class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VcMessageBox()
public:
VcMessageBox()
See Also

Reference

VcMessageBox Class


VcMessageBox Properties

The VcMessageBox type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CancelButtonContent |
Public property | Caption |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CloseCaptionButtonVisibility |
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultResult |
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Message |
Public property | MessageBoxButton |
Public property | MessageBoxIconPath |
Public property | MessageBoxImage |
Public property | MessageBoxResult |
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NoButtonContent |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | YesButtonContent |
Top
See Also

Reference

VcMessageBox Class


VcMessageBox.CancelButtonContent Property

VcMessageBoxCancelButtonContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonContent { get; set; }
public:
property String^ CancelButtonContent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcMessageBox Class


VcMessageBox.Caption Property

VcMessageBoxCaption Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Caption { get; set; }
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcMessageBox Class


VcMessageBox.CloseCaptionButtonVisibility Property

VcMessageBoxCloseCaptionButtonVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CloseCaptionButtonVisibility { get; set; }
public:
property bool CloseCaptionButtonVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

VcMessageBox Class


VcMessageBox.DefaultResult Property

VcMessageBoxDefaultResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MessageBoxResult DefaultResult { get; set; }
public:
property MessageBoxResult DefaultResult {
    MessageBoxResult get ();
    void set (MessageBoxResult value);
}

Property Value

Type: MessageBoxResult
See Also

Reference

VcMessageBox Class


VcMessageBox.Message Property

VcMessageBoxMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Message { get; set; }
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcMessageBox Class


VcMessageBox.MessageBoxButton Property

VcMessageBoxMessageBoxButton Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MessageBoxButton MessageBoxButton { get; set; }
public:
property MessageBoxButton MessageBoxButton {
    MessageBoxButton get ();
    void set (MessageBoxButton value);
}

Property Value

Type: MessageBoxButton
See Also

Reference

VcMessageBox Class


VcMessageBox.MessageBoxIconPath Property

VcMessageBoxMessageBoxIconPath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string MessageBoxIconPath { get; set; }
public:
property String^ MessageBoxIconPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcMessageBox Class


VcMessageBox.MessageBoxImage Property

VcMessageBoxMessageBoxImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MessageBoxImage MessageBoxImage { get; set; }
public:
property MessageBoxImage MessageBoxImage {
    MessageBoxImage get ();
    void set (MessageBoxImage value);
}

Property Value

Type: MessageBoxImage
See Also

Reference

VcMessageBox Class


VcMessageBox.MessageBoxResult Property

VcMessageBoxMessageBoxResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MessageBoxResult MessageBoxResult { get; }
public:
property MessageBoxResult MessageBoxResult {
    MessageBoxResult get ();
}

Property Value

Type: MessageBoxResult
See Also

Reference

VcMessageBox Class


VcMessageBox.NoButtonContent Property

VcMessageBoxNoButtonContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NoButtonContent { get; set; }
public:
property String^ NoButtonContent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcMessageBox Class


VcMessageBox.YesButtonContent Property

VcMessageBoxYesButtonContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string YesButtonContent { get; set; }
public:
property String^ YesButtonContent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcMessageBox Class


VcMessageBox Methods

The VcMessageBox type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | (Overrides WindowOnClosing(CancelEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
 | Show(String, Boolean) |
 | Show(String, String, Boolean) |
 | Show(String, MessageBoxResult, Boolean) |
 | Show(Window, String, Boolean) |
 | Show(String, String, MessageBoxButton, Boolean) |
 | Show(String, String, MessageBoxResult, Boolean) |
 | Show(Window, String, String, Boolean) |
 | Show(Window, String, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxResult, Boolean) |
 | Show(Window, String, String, MessageBoxButton, Boolean) |
 | Show(Window, String, String, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxImage, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, String, String, String, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, String, String, String, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxResult, String, String, String, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean) |
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
 | ShowExceptionMessage |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VcMessageBox Class


VcMessageBox.InitializeComponent Method

VcMessageBoxInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

VcMessageBox Class


VcMessageBox.OnClosing Method

VcMessageBoxOnClosing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnClosing(
    CancelEventArgs e
)
protected:
virtual void OnClosing(
    CancelEventArgs^ e
) override

Parameters

e
Type: System.ComponentModelCancelEventArgs
See Also

Reference

VcMessageBox Class


VcMessageBox.Show Method

VcMessageBoxShow Method

Overload List
 | Name | Description
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
 | Show(String, Boolean) |
 | Show(String, String, Boolean) |
 | Show(String, MessageBoxResult, Boolean) |
 | Show(Window, String, Boolean) |
 | Show(String, String, MessageBoxButton, Boolean) |
 | Show(String, String, MessageBoxResult, Boolean) |
 | Show(Window, String, String, Boolean) |
 | Show(Window, String, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxResult, Boolean) |
 | Show(Window, String, String, MessageBoxButton, Boolean) |
 | Show(Window, String, String, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxImage, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, String, String, String, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, String, String, String, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxResult, String, String, String, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean) |
 | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean, Boolean) |
 | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean) |
Top
See Also

Reference

VcMessageBox Class


VcMessageBox.Show Method (String, Boolean)

VcMessageBoxShow Method (String, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, Boolean)

VcMessageBoxShow Method (String, String, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, MessageBoxResult, Boolean)

VcMessageBoxShow Method (String, MessageBoxResult, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.Windows.MessageBoxResult,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (Window, String, Boolean)

VcMessageBoxShow Method (Window, String, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    bool closeCaptionButtonVisibility = true
)

Parameters

owner
Type: System.WindowsWindow
messageBoxText
Type: SystemString
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.Windows.Window,System.String,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, MessageBoxButton, Boolean)

VcMessageBoxShow Method (String, String, MessageBoxButton, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Windows.MessageBoxButton,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, MessageBoxResult, Boolean)

VcMessageBoxShow Method (String, String, MessageBoxResult, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Windows.MessageBoxResult,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (Window, String, String, Boolean)

VcMessageBoxShow Method (Window, String, String, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    bool closeCaptionButtonVisibility = true
)

Parameters

owner
Type: System.WindowsWindow
messageBoxText
Type: SystemString
caption
Type: SystemString
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.Windows.Window,System.String,System.String,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (Window, String, MessageBoxResult, Boolean)

VcMessageBoxShow Method (Window, String, MessageBoxResult, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)

Parameters

owner
Type: System.WindowsWindow
messageBoxText
Type: SystemString
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.Windows.Window,System.String,System.Windows.MessageBoxResult,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, MessageBoxButton, MessageBoxImage, Boolean)

VcMessageBoxShow Method (String, String, MessageBoxButton, MessageBoxImage, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
icon
Type: System.WindowsMessageBoxImage
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxImage,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, MessageBoxButton, MessageBoxResult, Boolean)

VcMessageBoxShow Method (String, String, MessageBoxButton, MessageBoxResult, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxResult,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (Window, String, String, MessageBoxButton, Boolean)

VcMessageBoxShow Method (Window, String, String, MessageBoxButton, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    bool closeCaptionButtonVisibility = true
)

Parameters

owner
Type: System.WindowsWindow
messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.Windows.Window,System.String,System.String,System.Windows.MessageBoxButton,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (Window, String, String, MessageBoxResult, Boolean)

VcMessageBoxShow Method (Window, String, String, MessageBoxResult, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)

Parameters

owner
Type: System.WindowsWindow
messageBoxText
Type: SystemString
caption
Type: SystemString
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.Windows.Window,System.String,System.String,System.Windows.MessageBoxResult,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean)

VcMessageBoxShow Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage image,
    MessageBoxResult defaultResult,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage image,
    MessageBoxResult defaultResult,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
image
Type: System.WindowsMessageBoxImage
defaultResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxImage,System.Windows.MessageBoxResult,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage, Boolean)

VcMessageBoxShow Method (Window, String, String, MessageBoxButton, MessageBoxImage, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    bool closeCaptionButtonVisibility = true
)

Parameters

owner
Type: System.WindowsWindow
messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
icon
Type: System.WindowsMessageBoxImage
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.Windows.Window,System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxImage,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (Window, String, String, MessageBoxButton, MessageBoxResult, Boolean)

VcMessageBoxShow Method (Window, String, String, MessageBoxButton, MessageBoxResult, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)

Parameters

owner
Type: System.WindowsWindow
messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.Windows.Window,System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxResult,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, MessageBoxButton, String, String, String, Boolean)

VcMessageBoxShow Method (String, String, MessageBoxButton, String, String, String, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    string yesButtonContent,
    string noButtonConten,
    string cancelButtonContent = null,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    String^ yesButtonContent,
    String^ noButtonConten,
    String^ cancelButtonContent = nullptr,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
yesButtonContent
Type: SystemString
noButtonConten
Type: SystemString
cancelButtonContent (Optional)
Type: SystemString
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Windows.MessageBoxButton,System.String,System.String,System.String,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean)

VcMessageBoxShow Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility = true
)

Parameters

owner
Type: System.WindowsWindow
messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
icon
Type: System.WindowsMessageBoxImage
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.Windows.Window,System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxImage,System.Windows.MessageBoxResult,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, MessageBoxButton, MessageBoxImage, String, String, String, Boolean)

VcMessageBoxShow Method (String, String, MessageBoxButton, MessageBoxImage, String, String, String, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent = null,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent = nullptr,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
icon
Type: System.WindowsMessageBoxImage
yesButtonContent
Type: SystemString
noButtonContent
Type: SystemString
cancelButtonContent (Optional)
Type: SystemString
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxImage,System.String,System.String,System.String,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, MessageBoxButton, MessageBoxResult, String, String, String, Boolean)

VcMessageBoxShow Method (String, String, MessageBoxButton, MessageBoxResult, String, String, String, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonConten,
    string cancelButtonContent = null,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonConten,
    String^ cancelButtonContent = nullptr,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
noButtonConten
Type: SystemString
cancelButtonContent (Optional)
Type: SystemString
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxResult,System.String,System.String,System.String,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean)

VcMessageBoxShow Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent = null,
    bool closeCaptionButtonVisibility = true
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent = nullptr,
    bool closeCaptionButtonVisibility = true
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
icon
Type: System.WindowsMessageBoxImage
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
noButtonContent
Type: SystemString
cancelButtonContent (Optional)
Type: SystemString
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxImage,System.Windows.MessageBoxResult,System.String,System.String,System.String,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean, Boolean)

VcMessageBoxShow Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent = null,
    bool closeCaptionButtonVisibility = true,
    bool isRCButtonType = false,
    bool isARIButtonType = false
)
public:
static MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent = nullptr,
    bool closeCaptionButtonVisibility = true,
    bool isRCButtonType = false,
    bool isARIButtonType = false
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
icon
Type: System.WindowsMessageBoxImage
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
noButtonContent
Type: SystemString
cancelButtonContent (Optional)
Type: SystemString
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean
isRCButtonType (Optional)
Type: SystemBoolean
isARIButtonType (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxImage,System.Windows.MessageBoxResult,System.String,System.String,System.String,System.Boolean,System.Boolean,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean)

VcMessageBoxShow Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultResult,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent = null,
    bool closeCaptionButtonVisibility = true,
    bool topMost = false
)
public:
static MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultResult,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent = nullptr,
    bool closeCaptionButtonVisibility = true,
    bool topMost = false
)

Parameters

owner
Type: System.WindowsWindow
messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
icon
Type: System.WindowsMessageBoxImage
defaultResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
noButtonContent
Type: SystemString
cancelButtonContent (Optional)
Type: SystemString
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean
topMost (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.Show(System.Windows.Window,System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxImage,System.Windows.MessageBoxResult,System.String,System.String,System.String,System.Boolean,System.Boolean)"]

See Also

Reference

VcMessageBox Class
Show Overload


VcMessageBox.ShowExceptionMessage Method

VcMessageBoxShowExceptionMessage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResult ShowExceptionMessage(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage image,
    MessageBoxResult defaultResult,
    bool closeCaptionButtonVisibility = true,
    bool isExceptionMessageBox = false
)
public:
static MessageBoxResult ShowExceptionMessage(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage image,
    MessageBoxResult defaultResult,
    bool closeCaptionButtonVisibility = true,
    bool isExceptionMessageBox = false
)

Parameters

messageBoxText
Type: SystemString
caption
Type: SystemString
button
Type: System.WindowsMessageBoxButton
image
Type: System.WindowsMessageBoxImage
defaultResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility (Optional)
Type: SystemBoolean
isExceptionMessageBox (Optional)
Type: SystemBoolean

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBox.ShowExceptionMessage(System.String,System.String,System.Windows.MessageBoxButton,System.Windows.MessageBoxImage,System.Windows.MessageBoxResult,System.Boolean,System.Boolean)"]

See Also

Reference

VcMessageBox Class


VcMessageBox Events

The VcMessageBox type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
 | MessageBoxHidden | Raised after a message box has been hidden.
 | MessageBoxShowing | Raised before a message box is shown.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

VcMessageBox Class


VcMessageBox.MessageBoxHidden Event

VcMessageBoxMessageBoxHidden Event

Raised after a message box has been hidden.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event EventHandler MessageBoxHidden
public:
static  event EventHandler^ MessageBoxHidden {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

VcMessageBox Class


VcMessageBox.MessageBoxShowing Event

VcMessageBoxMessageBoxShowing Event

Raised before a message box is shown.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event EventHandler MessageBoxShowing
public:
static  event EventHandler^ MessageBoxShowing {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

VcMessageBox Class


VcMessageBox Fields

The VcMessageBox type exposes the following members.

Fields
Name | Description
CancelButtonContentProperty |
CloseCaptionButtonVisibilityProperty |
DefaultResultProperty |
MessageBoxButtonProperty |
MessageBoxIconPathProperty |
MessageBoxImageProperty |
MessageProperty |
NoButtonContentProperty |
YesButtonContentProperty |
Top
See Also

Reference

VcMessageBox Class


VcMessageBox.CancelButtonContentProperty Field

VcMessageBoxCancelButtonContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CancelButtonContentProperty
public:
static initonly DependencyProperty^ CancelButtonContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcMessageBox Class


VcMessageBox.CloseCaptionButtonVisibilityProperty Field

VcMessageBoxCloseCaptionButtonVisibilityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CloseCaptionButtonVisibilityProperty
public:
static initonly DependencyProperty^ CloseCaptionButtonVisibilityProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcMessageBox Class


VcMessageBox.DefaultResultProperty Field

VcMessageBoxDefaultResultProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DefaultResultProperty
public:
static initonly DependencyProperty^ DefaultResultProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcMessageBox Class


VcMessageBox.MessageBoxButtonProperty Field

VcMessageBoxMessageBoxButtonProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty MessageBoxButtonProperty
public:
static initonly DependencyProperty^ MessageBoxButtonProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcMessageBox Class


VcMessageBox.MessageBoxIconPathProperty Field

VcMessageBoxMessageBoxIconPathProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty MessageBoxIconPathProperty
public:
static initonly DependencyProperty^ MessageBoxIconPathProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcMessageBox Class


VcMessageBox.MessageBoxImageProperty Field

VcMessageBoxMessageBoxImageProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty MessageBoxImageProperty
public:
static initonly DependencyProperty^ MessageBoxImageProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcMessageBox Class


VcMessageBox.MessageProperty Field

VcMessageBoxMessageProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty MessageProperty
public:
static initonly DependencyProperty^ MessageProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcMessageBox Class


VcMessageBox.NoButtonContentProperty Field

VcMessageBoxNoButtonContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty NoButtonContentProperty
public:
static initonly DependencyProperty^ NoButtonContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcMessageBox Class


VcMessageBox.YesButtonContentProperty Field

VcMessageBoxYesButtonContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty YesButtonContentProperty
public:
static initonly DependencyProperty^ YesButtonContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcMessageBox Class


VcMessageBoxExtension Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedVcMessageBoxExtension

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VcMessageBoxExtension
public ref class VcMessageBoxExtension

The VcMessageBoxExtension type exposes the following members.

Constructors
 | Name | Description
Public method | VcMessageBoxExtension | Initializes a new instance of the VcMessageBoxExtension class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCloseCaptionButtonVisibility |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetCloseCaptionButtonVisibility |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
CloseCaptionButtonVisibilityProperty |
Top
Attached Properties
 | Name | Description
Public attached property | CloseCaptionButtonVisibility |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VcMessageBoxExtension Constructor

Initializes a new instance of the VcMessageBoxExtension class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VcMessageBoxExtension()
public:
VcMessageBoxExtension()
See Also

Reference

VcMessageBoxExtension Class


VcMessageBoxExtension Methods

The VcMessageBoxExtension type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCloseCaptionButtonVisibility |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetCloseCaptionButtonVisibility |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VcMessageBoxExtension Class


VcMessageBoxExtension.GetCloseCaptionButtonVisibility Method

VcMessageBoxExtensionGetCloseCaptionButtonVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Visibility GetCloseCaptionButtonVisibility(
    DependencyObject obj
)
public:
static Visibility GetCloseCaptionButtonVisibility(
    DependencyObject^ obj
)

Parameters

obj
Type: System.WindowsDependencyObject

Return Value

Type: Visibility

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VcMessageBoxExtension.GetCloseCaptionButtonVisibility(System.Windows.DependencyObject)"]

See Also

Reference

VcMessageBoxExtension Class


VcMessageBoxExtension.SetCloseCaptionButtonVisibility Method

VcMessageBoxExtensionSetCloseCaptionButtonVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetCloseCaptionButtonVisibility(
    DependencyObject obj,
    Visibility value
)
public:
static void SetCloseCaptionButtonVisibility(
    DependencyObject^ obj,
    Visibility value
)

Parameters

obj
Type: System.WindowsDependencyObject
value
Type: System.WindowsVisibility
See Also

Reference

VcMessageBoxExtension Class


VcMessageBoxExtension Fields

The VcMessageBoxExtension type exposes the following members.

Fields
Name | Description
CloseCaptionButtonVisibilityProperty |
Top
See Also

Reference

VcMessageBoxExtension Class


VcMessageBoxExtension.CloseCaptionButtonVisibilityProperty Field

VcMessageBoxExtensionCloseCaptionButtonVisibilityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CloseCaptionButtonVisibilityProperty
public:
static initonly DependencyProperty^ CloseCaptionButtonVisibilityProperty

Field Value

Type: DependencyProperty
See Also

Reference

VcMessageBoxExtension Class


VcMessageBoxExtension Attached Properties

The VcMessageBoxExtension type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | CloseCaptionButtonVisibility |
Top
See Also

Reference

VcMessageBoxExtension Class


VcMessageBoxExtension.CloseCaptionButtonVisibility Attached Property

VcMessageBoxExtensionCloseCaptionButtonVisibility Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetCloseCaptionButtonVisibility, SetCloseCaptionButtonVisibility
See GetCloseCaptionButtonVisibility, SetCloseCaptionButtonVisibility

Property Value

Type: Visibility
See Also

Reference

VcMessageBoxExtension Class


VcRasterEffect Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct VcRasterEffect
public value class VcRasterEffect

The VcRasterEffect type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VcRasterEffect Properties

The VcRasterEffect type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Value |
Top
See Also

Reference

VcRasterEffect Structure


VcRasterEffect.DisplayName Property

VcRasterEffectDisplayName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DisplayName { get; set; }
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcRasterEffect Structure


VcRasterEffect.Value Property

VcRasterEffectValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Value { get; set; }
public:
property int Value {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

VcRasterEffect Structure


VcRasterEffect Methods

The VcRasterEffect type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VcRasterEffect Structure


VcTime Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct VcTime
public value class VcTime

The VcTime type exposes the following members.

Properties
 | Name | Description
Public property | First |
Public property | Last |
Public property | Middle |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VcTime Properties

The VcTime type exposes the following members.

Properties
 | Name | Description
Public property | First |
Public property | Last |
Public property | Middle |
Top
See Also

Reference

VcTime Structure


VcTime.First Property

VcTimeFirst Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VcTimePart First { get; set; }
public:
property VcTimePart First {
    VcTimePart get ();
    void set (VcTimePart value);
}

Property Value

Type: VcTimePart
See Also

Reference

VcTime Structure


VcTime.Last Property

VcTimeLast Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VcTimePart Last { get; set; }
public:
property VcTimePart Last {
    VcTimePart get ();
    void set (VcTimePart value);
}

Property Value

Type: VcTimePart
See Also

Reference

VcTime Structure


VcTime.Middle Property

VcTimeMiddle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VcTimePart Middle { get; set; }
public:
property VcTimePart Middle {
    VcTimePart get ();
    void set (VcTimePart value);
}

Property Value

Type: VcTimePart
See Also

Reference

VcTime Structure


VcTime Methods

The VcTime type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VcTime Structure


VcTimePart Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct VcTimePart
public value class VcTimePart

The VcTimePart type exposes the following members.

Properties
 | Name | Description
Public property | Unit |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VcTimePart Properties

The VcTimePart type exposes the following members.

Properties
 | Name | Description
Public property | Unit |
Public property | Value |
Top
See Also

Reference

VcTimePart Structure


VcTimePart.Unit Property

VcTimePartUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Unit { get; set; }
public:
property String^ Unit {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VcTimePart Structure


VcTimePart.Value Property

VcTimePartValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Value { get; set; }
public:
property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VcTimePart Structure


VcTimePart Methods

The VcTimePart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VcTimePart Structure


VcWindow Class

Interaction logic for WindowBorderLess.xaml
VcWindow
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
VisualComponents.UX.SharedVcWindow

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VcWindow : Window, IComponentConnector
public ref class VcWindow : public Window,
    IComponentConnector

The VcWindow type exposes the following members.

Constructors
 | Name | Description
Public method | VcWindow | Initializes a new instance of the VcWindow class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | (Overrides WindowOnClosing(CancelEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VcWindow Constructor

Initializes a new instance of the VcWindow class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VcWindow()
public:
VcWindow()
See Also

Reference

VcWindow Class


VcWindow Properties

The VcWindow type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

VcWindow Class


VcWindow Methods

The VcWindow type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | (Overrides WindowOnClosing(CancelEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VcWindow Class


VcWindow.InitializeComponent Method

VcWindowInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

VcWindow Class


VcWindow.OnClosing Method

VcWindowOnClosing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnClosing(
    CancelEventArgs e
)
protected:
virtual void OnClosing(
    CancelEventArgs^ e
) override

Parameters

e
Type: System.ComponentModelCancelEventArgs
See Also

Reference

VcWindow Class


VcWindow Events

The VcWindow type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

VcWindow Class


WebBrowserBehavior Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedWebBrowserBehavior

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class WebBrowserBehavior
public ref class WebBrowserBehavior

The WebBrowserBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | WebBrowserBehavior | Initializes a new instance of the WebBrowserBehavior class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBody |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetBody |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
BodyProperty |
Top
Attached Properties
 | Name | Description
Public attached property | Body |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


WebBrowserBehavior Constructor

Initializes a new instance of the WebBrowserBehavior class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WebBrowserBehavior()
public:
WebBrowserBehavior()
See Also

Reference

WebBrowserBehavior Class


WebBrowserBehavior Methods

The WebBrowserBehavior type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBody |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetBody |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

WebBrowserBehavior Class


WebBrowserBehavior.GetBody Method

WebBrowserBehaviorGetBody Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetBody(
    DependencyObject dependencyObject
)
public:
static String^ GetBody(
    DependencyObject^ dependencyObject
)

Parameters

dependencyObject
Type: System.WindowsDependencyObject

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.WebBrowserBehavior.GetBody(System.Windows.DependencyObject)"]

See Also

Reference

WebBrowserBehavior Class


WebBrowserBehavior.SetBody Method

WebBrowserBehaviorSetBody Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetBody(
    DependencyObject dependencyObject,
    string body
)
public:
static void SetBody(
    DependencyObject^ dependencyObject,
    String^ body
)

Parameters

dependencyObject
Type: System.WindowsDependencyObject
body
Type: SystemString
See Also

Reference

WebBrowserBehavior Class


WebBrowserBehavior Fields

The WebBrowserBehavior type exposes the following members.

Fields
Name | Description
BodyProperty |
Top
See Also

Reference

WebBrowserBehavior Class


WebBrowserBehavior.BodyProperty Field

WebBrowserBehaviorBodyProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty BodyProperty
public:
static initonly DependencyProperty^ BodyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WebBrowserBehavior Class


WebBrowserBehavior Attached Properties

The WebBrowserBehavior type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | Body |
Top
See Also

Reference

WebBrowserBehavior Class


WebBrowserBehavior.Body Attached Property

WebBrowserBehaviorBody Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetBody, SetBody
See GetBody, SetBody

Property Value

Type: String
See Also

Reference

WebBrowserBehavior Class


VectorEditor Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedVectorEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VectorEditor : Control
public ref class VectorEditor : public Control

The VectorEditor type exposes the following members.

Constructors
 | Name | Description
Public method | VectorEditor | Initializes a new instance of the VectorEditor class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HeaderText |
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVectorHeaderVisible |
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | IsXValueEnabled |
Public property | IsYValueEnabled |
Public property | IsZValueEnabled |
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VectorOrentation |
Public property | VectorUnit |
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XLabelText |
Public property | XResetButtonColor |
Public property | XValue |
Public property | YLabelText |
Public property | YResetButtonColor |
Public property | YValue |
Public property | ZLabelText |
Public property | ZResetButtonColor |
Public property | ZValue |
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
HeaderTextProperty |
IsVectorHeaderVisibleProperty |
IsXValueEnabledProperty |
IsYValueEnabledProperty |
IsZValueEnabledProperty |
VectorOrentationProperty |
VectorUnitProperty |
XLabelTextProperty |
XResetButtonColorProperty |
XValueProperty |
YLabelTextProperty |
YResetButtonColorProperty |
YValueProperty |
ZLabelTextProperty |
ZResetButtonColorProperty |
ZValueProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VectorEditor Constructor

Initializes a new instance of the VectorEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VectorEditor()
public:
VectorEditor()
See Also

Reference

VectorEditor Class


VectorEditor Properties

The VectorEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HeaderText |
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVectorHeaderVisible |
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | IsXValueEnabled |
Public property | IsYValueEnabled |
Public property | IsZValueEnabled |
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VectorOrentation |
Public property | VectorUnit |
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XLabelText |
Public property | XResetButtonColor |
Public property | XValue |
Public property | YLabelText |
Public property | YResetButtonColor |
Public property | YValue |
Public property | ZLabelText |
Public property | ZResetButtonColor |
Public property | ZValue |
Top
See Also

Reference

VectorEditor Class


VectorEditor.HeaderText Property

VectorEditorHeaderText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string HeaderText { get; set; }
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VectorEditor Class


VectorEditor.IsVectorHeaderVisible Property

VectorEditorIsVectorHeaderVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVectorHeaderVisible { get; set; }
public:
property bool IsVectorHeaderVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

VectorEditor Class


VectorEditor.IsXValueEnabled Property

VectorEditorIsXValueEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsXValueEnabled { get; set; }
public:
property bool IsXValueEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

VectorEditor Class


VectorEditor.IsYValueEnabled Property

VectorEditorIsYValueEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsYValueEnabled { get; set; }
public:
property bool IsYValueEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

VectorEditor Class


VectorEditor.IsZValueEnabled Property

VectorEditorIsZValueEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsZValueEnabled { get; set; }
public:
property bool IsZValueEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

VectorEditor Class


VectorEditor.VectorOrentation Property

VectorEditorVectorOrentation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VectorOrentation VectorOrentation { get; set; }
public:
property VectorOrentation VectorOrentation {
    VectorOrentation get ();
    void set (VectorOrentation value);
}

Property Value

Type: VectorOrentation
See Also

Reference

VectorEditor Class


VectorEditor.VectorUnit Property

VectorEditorVectorUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string VectorUnit { get; set; }
public:
property String^ VectorUnit {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VectorEditor Class


VectorEditor.XLabelText Property

VectorEditorXLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string XLabelText { get; set; }
public:
property String^ XLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VectorEditor Class


VectorEditor.XResetButtonColor Property

VectorEditorXResetButtonColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush XResetButtonColor { get; set; }
public:
property SolidColorBrush^ XResetButtonColor {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

VectorEditor Class


VectorEditor.XValue Property

VectorEditorXValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double XValue { get; set; }
public:
property double XValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VectorEditor Class


VectorEditor.YLabelText Property

VectorEditorYLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string YLabelText { get; set; }
public:
property String^ YLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VectorEditor Class


VectorEditor.YResetButtonColor Property

VectorEditorYResetButtonColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush YResetButtonColor { get; set; }
public:
property SolidColorBrush^ YResetButtonColor {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

VectorEditor Class


VectorEditor.YValue Property

VectorEditorYValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double YValue { get; set; }
public:
property double YValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VectorEditor Class


VectorEditor.ZLabelText Property

VectorEditorZLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ZLabelText { get; set; }
public:
property String^ ZLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VectorEditor Class


VectorEditor.ZResetButtonColor Property

VectorEditorZResetButtonColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush ZResetButtonColor { get; set; }
public:
property SolidColorBrush^ ZResetButtonColor {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

VectorEditor Class


VectorEditor.ZValue Property

VectorEditorZValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ZValue { get; set; }
public:
property double ZValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VectorEditor Class


VectorEditor Methods

The VectorEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VectorEditor Class


VectorEditor Events

The VectorEditor type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

VectorEditor Class


VectorEditor Fields

The VectorEditor type exposes the following members.

Fields
Name | Description
HeaderTextProperty |
IsVectorHeaderVisibleProperty |
IsXValueEnabledProperty |
IsYValueEnabledProperty |
IsZValueEnabledProperty |
VectorOrentationProperty |
VectorUnitProperty |
XLabelTextProperty |
XResetButtonColorProperty |
XValueProperty |
YLabelTextProperty |
YResetButtonColorProperty |
YValueProperty |
ZLabelTextProperty |
ZResetButtonColorProperty |
ZValueProperty |
Top
See Also

Reference

VectorEditor Class


VectorEditor.HeaderTextProperty Field

VectorEditorHeaderTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty HeaderTextProperty
public:
static DependencyProperty^ HeaderTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.IsVectorHeaderVisibleProperty Field

VectorEditorIsVectorHeaderVisibleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsVectorHeaderVisibleProperty
public:
static DependencyProperty^ IsVectorHeaderVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.IsXValueEnabledProperty Field

VectorEditorIsXValueEnabledProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsXValueEnabledProperty
public:
static DependencyProperty^ IsXValueEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.IsYValueEnabledProperty Field

VectorEditorIsYValueEnabledProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsYValueEnabledProperty
public:
static DependencyProperty^ IsYValueEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.IsZValueEnabledProperty Field

VectorEditorIsZValueEnabledProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsZValueEnabledProperty
public:
static DependencyProperty^ IsZValueEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.VectorOrentationProperty Field

VectorEditorVectorOrentationProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty VectorOrentationProperty
public:
static DependencyProperty^ VectorOrentationProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.VectorUnitProperty Field

VectorEditorVectorUnitProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty VectorUnitProperty
public:
static DependencyProperty^ VectorUnitProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.XLabelTextProperty Field

VectorEditorXLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty XLabelTextProperty
public:
static DependencyProperty^ XLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.XResetButtonColorProperty Field

VectorEditorXResetButtonColorProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty XResetButtonColorProperty
public:
static initonly DependencyProperty^ XResetButtonColorProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.XValueProperty Field

VectorEditorXValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty XValueProperty
public:
static DependencyProperty^ XValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.YLabelTextProperty Field

VectorEditorYLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty YLabelTextProperty
public:
static DependencyProperty^ YLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.YResetButtonColorProperty Field

VectorEditorYResetButtonColorProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty YResetButtonColorProperty
public:
static initonly DependencyProperty^ YResetButtonColorProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.YValueProperty Field

VectorEditorYValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty YValueProperty
public:
static DependencyProperty^ YValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.ZLabelTextProperty Field

VectorEditorZLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ZLabelTextProperty
public:
static DependencyProperty^ ZLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.ZResetButtonColorProperty Field

VectorEditorZResetButtonColorProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ZResetButtonColorProperty
public:
static initonly DependencyProperty^ ZResetButtonColorProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditor.ZValueProperty Field

VectorEditorZValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ZValueProperty
public:
static DependencyProperty^ ZValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditor Class


VectorEditorComponent Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedVectorEditorComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VectorEditorComponent : Control
public ref class VectorEditorComponent : public Control

The VectorEditorComponent type exposes the following members.

Constructors
 | Name | Description
Public method | VectorEditorComponent | Initializes a new instance of the VectorEditorComponent class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ComponentLabelText |
Public property | ComponentUnit |
Public property | ComponentValue |
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ComponentLabelTextProperty |
ComponentUnitProperty |
ComponentValueProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VectorEditorComponent Constructor

Initializes a new instance of the VectorEditorComponent class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VectorEditorComponent()
public:
VectorEditorComponent()
See Also

Reference

VectorEditorComponent Class


VectorEditorComponent Properties

The VectorEditorComponent type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ComponentLabelText |
Public property | ComponentUnit |
Public property | ComponentValue |
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

VectorEditorComponent Class


VectorEditorComponent.ComponentLabelText Property

VectorEditorComponentComponentLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ComponentLabelText { get; set; }
public:
property String^ ComponentLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VectorEditorComponent Class


VectorEditorComponent.ComponentUnit Property

VectorEditorComponentComponentUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ComponentUnit { get; set; }
public:
property String^ ComponentUnit {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VectorEditorComponent Class


VectorEditorComponent.ComponentValue Property

VectorEditorComponentComponentValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ComponentValue { get; set; }
public:
property double ComponentValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VectorEditorComponent Class


VectorEditorComponent Methods

The VectorEditorComponent type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VectorEditorComponent Class


VectorEditorComponent Events

The VectorEditorComponent type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

VectorEditorComponent Class


VectorEditorComponent Fields

The VectorEditorComponent type exposes the following members.

Fields
Name | Description
ComponentLabelTextProperty |
ComponentUnitProperty |
ComponentValueProperty |
Top
See Also

Reference

VectorEditorComponent Class


VectorEditorComponent.ComponentLabelTextProperty Field

VectorEditorComponentComponentLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ComponentLabelTextProperty
public:
static DependencyProperty^ ComponentLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditorComponent Class


VectorEditorComponent.ComponentUnitProperty Field

VectorEditorComponentComponentUnitProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ComponentUnitProperty
public:
static DependencyProperty^ ComponentUnitProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditorComponent Class


VectorEditorComponent.ComponentValueProperty Field

VectorEditorComponentComponentValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ComponentValueProperty
public:
static DependencyProperty^ ComponentValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

VectorEditorComponent Class


VectorOrentation Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum VectorOrentation
public enum class VectorOrentation
Members
Member name | Value | Description
Horizontal | 0 |
Vertical | 1 |
See Also

Reference


VectorProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedVectorProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VectorProperty : EditorProperty
public ref class VectorProperty : public EditorProperty

The VectorProperty type exposes the following members.

Constructors
 | Name | Description
Public method | VectorProperty | Initializes a new instance of the VectorProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Public property | ValueX |
Public property | ValueY |
Public property | ValueZ |
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VectorProperty Constructor

Initializes a new instance of the VectorProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VectorProperty(
    IProperty property
)
public:
VectorProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

VectorProperty Class


VectorProperty Properties

The VectorProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Public property | ValueX |
Public property | ValueY |
Public property | ValueZ |
Top
See Also

Reference

VectorProperty Class


VectorProperty.ValueX Property

VectorPropertyValueX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ValueX { get; set; }
public:
property double ValueX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VectorProperty Class


VectorProperty.ValueY Property

VectorPropertyValueY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ValueY { get; set; }
public:
property double ValueY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VectorProperty Class


VectorProperty.ValueZ Property

VectorPropertyValueZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ValueZ { get; set; }
public:
property double ValueZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VectorProperty Class


VectorProperty Methods

The VectorProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VectorProperty Class


VectorProperty Events

The VectorProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

VectorProperty Class


VectorProperty Fields

The VectorProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

VectorProperty Class


VideoExporterItem Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedVideoExporterItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VideoExporterItem : IVideoRecordExporter,
    IRecordExporter, IScreenRecorder, IVideoRecorder, IRecorder, IDisposable
public ref class VideoExporterItem : IVideoRecordExporter,
    IRecordExporter, IScreenRecorder, IVideoRecorder, IRecorder, IDisposable

The VideoExporterItem type exposes the following members.

Constructors
 | Name | Description
Public method | VideoExporterItem | Initializes a new instance of the VideoExporterItem class
Top
Properties
 | Name | Description
Public property | Bitrate |
Public property | Codec |
Public property | EndTime |
Public property | Format |
Public property | FrameRate |
Public property | Header |
Public property | Height |
Public property | IsPaused |
Public property | IsRecording |
Public property | RecordingHeight |
Public property | RecordingType |
Public property | RecordingWidth |
Public property | ShowVideo |
Public property | Speed |
Public property | StartTime |
Public property | Width |
Top
Methods
 | Name | Description
Public method | Cancel |
Public method | Dispose | Releases all resources used by the VideoExporterItem
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start |
Public method | Start(Boolean) |
Public method | StartScreenRecording |
Public method | Stop |
Public method | StopScreenRecording |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | VideoCreationProgress |
Public event | VideoRecordingFrame |
Public event | VideoRecordingNotification |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VideoExporterItem Constructor

Initializes a new instance of the VideoExporterItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VideoExporterItem()
public:
VideoExporterItem()
See Also

Reference

VideoExporterItem Class


VideoExporterItem Properties

The VideoExporterItem type exposes the following members.

Properties
 | Name | Description
Public property | Bitrate |
Public property | Codec |
Public property | EndTime |
Public property | Format |
Public property | FrameRate |
Public property | Header |
Public property | Height |
Public property | IsPaused |
Public property | IsRecording |
Public property | RecordingHeight |
Public property | RecordingType |
Public property | RecordingWidth |
Public property | ShowVideo |
Public property | Speed |
Public property | StartTime |
Public property | Width |
Top
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Bitrate Property

VideoExporterItemBitrate Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Bitrate { get; set; }
public:
virtual property double Bitrate {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IVideoRecorderBitrate
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Codec Property

VideoExporterItemCodec Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VideoCodec Codec { get; set; }
public:
virtual property VideoCodec Codec {
    VideoCodec get () sealed;
    void set (VideoCodec value) sealed;
}

Property Value

Type: VideoCodec

Implements

IVideoRecorderCodec
See Also

Reference

VideoExporterItem Class


VideoExporterItem.EndTime Property

VideoExporterItemEndTime Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int EndTime { get; set; }
public:
virtual property int EndTime {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IVideoRecorderEndTime
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Format Property

VideoExporterItemFormat Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VideoFormat Format { get; set; }
public:
virtual property VideoFormat Format {
    VideoFormat get () sealed;
    void set (VideoFormat value) sealed;
}

Property Value

Type: VideoFormat

Implements

IVideoRecorderFormat
See Also

Reference

VideoExporterItem Class


VideoExporterItem.FrameRate Property

VideoExporterItemFrameRate Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int FrameRate { get; set; }
public:
virtual property int FrameRate {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IRecorderFrameRate
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Header Property

VideoExporterItemHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IHeaderModel Header { get; set; }
public:
virtual property IHeaderModel^ Header {
    IHeaderModel^ get () sealed;
    void set (IHeaderModel^ value) sealed;
}

Property Value

Type: IHeaderModel

Implements

IRecordExporterHeader
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Height Property

VideoExporterItemHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Height { get; set; }
public:
virtual property int Height {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IVideoRecorderHeight
See Also

Reference

VideoExporterItem Class


VideoExporterItem.IsPaused Property

VideoExporterItemIsPaused Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPaused { get; set; }
public:
virtual property bool IsPaused {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IVideoRecorderIsPaused
See Also

Reference

VideoExporterItem Class


VideoExporterItem.IsRecording Property

VideoExporterItemIsRecording Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsRecording { get; }
public:
virtual property bool IsRecording {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IRecorderIsRecording
See Also

Reference

VideoExporterItem Class


VideoExporterItem.RecordingHeight Property

VideoExporterItemRecordingHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RecordingHeight { get; }
public:
virtual property int RecordingHeight {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IVideoRecorderRecordingHeight
See Also

Reference

VideoExporterItem Class


VideoExporterItem.RecordingType Property

VideoExporterItemRecordingType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecordingType RecordingType { get; }
public:
virtual property RecordingType RecordingType {
    RecordingType get () sealed;
}

Property Value

Type: RecordingType

Implements

IRecordExporterRecordingType
See Also

Reference

VideoExporterItem Class


VideoExporterItem.RecordingWidth Property

VideoExporterItemRecordingWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RecordingWidth { get; }
public:
virtual property int RecordingWidth {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IVideoRecorderRecordingWidth
See Also

Reference

VideoExporterItem Class


VideoExporterItem.ShowVideo Property

VideoExporterItemShowVideo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowVideo { get; set; }
public:
virtual property bool ShowVideo {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IVideoRecorderShowVideo
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Speed Property

VideoExporterItemSpeed Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Speed { get; set; }
public:
virtual property double Speed {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IVideoRecorderSpeed
See Also

Reference

VideoExporterItem Class


VideoExporterItem.StartTime Property

VideoExporterItemStartTime Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int StartTime { get; set; }
public:
virtual property int StartTime {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IVideoRecorderStartTime
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Width Property

VideoExporterItemWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Width { get; set; }
public:
virtual property int Width {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IVideoRecorderWidth
See Also

Reference

VideoExporterItem Class


VideoExporterItem Methods

The VideoExporterItem type exposes the following members.

Methods
 | Name | Description
Public method | Cancel |
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start |
Public method | Start(Boolean) |
Public method | StartScreenRecording |
Public method | Stop |
Public method | StopScreenRecording |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Cancel Method

VideoExporterItemCancel Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Cancel()
public:
virtual void Cancel() sealed

Implements

IVideoRecorderCancel
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Dispose Method

VideoExporterItemDispose Method

Releases all resources used by the VideoExporterItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Start Method

VideoExporterItemStart Method

Overload List
 | Name | Description
Public method | Start |
Public method | Start(Boolean) |
Top
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Start Method

VideoExporterItemStart Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Start()
public:
virtual void Start() sealed

Implements

IRecorderStart
See Also

Reference

VideoExporterItem Class
Start Overload


VideoExporterItem.Start Method (Boolean)

VideoExporterItemStart Method (Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Start(
    bool paused
)
public:
virtual void Start(
    bool paused
) sealed

Parameters

paused
Type: SystemBoolean

Implements

IVideoRecorderStart(Boolean)
See Also

Reference

VideoExporterItem Class
Start Overload


VideoExporterItem.StartScreenRecording Method

VideoExporterItemStartScreenRecording Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartScreenRecording(
    bool desktop,
    Uri url,
    bool mouse
)
public:
virtual void StartScreenRecording(
    bool desktop,
    Uri^ url,
    bool mouse
) sealed

Parameters

desktop
Type: SystemBoolean
url
Type: SystemUri
mouse
Type: SystemBoolean

Implements

IScreenRecorderStartScreenRecording(Boolean, Uri, Boolean)
See Also

Reference

VideoExporterItem Class


VideoExporterItem.Stop Method

VideoExporterItemStop Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Stop(
    Uri uri
)
public:
virtual void Stop(
    Uri^ uri
) sealed

Parameters

uri
Type: SystemUri

Implements

IRecorderStop(Uri)
See Also

Reference

VideoExporterItem Class


VideoExporterItem.StopScreenRecording Method

VideoExporterItemStopScreenRecording Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StopScreenRecording()
public:
virtual void StopScreenRecording() sealed

Implements

IScreenRecorderStopScreenRecording
See Also

Reference

VideoExporterItem Class


VideoExporterItem Events

The VideoExporterItem type exposes the following members.

Events
 | Name | Description
Public event | VideoCreationProgress |
Public event | VideoRecordingFrame |
Public event | VideoRecordingNotification |
Top
See Also

Reference

VideoExporterItem Class


VideoExporterItem.VideoCreationProgress Event

VideoExporterItemVideoCreationProgress Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<VideoCreationProgressEventArgs> VideoCreationProgress
public:
virtual  event EventHandler<VideoCreationProgressEventArgs^>^ VideoCreationProgress {
    void add (EventHandler<VideoCreationProgressEventArgs^>^ value);
    void remove (EventHandler<VideoCreationProgressEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVideoCreationProgressEventArgs

Implements

IVideoRecorderVideoCreationProgress
See Also

Reference

VideoExporterItem Class


VideoExporterItem.VideoRecordingFrame Event

VideoExporterItemVideoRecordingFrame Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<VideoCreationFrameEventArgs> VideoRecordingFrame
public:
virtual  event EventHandler<VideoCreationFrameEventArgs^>^ VideoRecordingFrame {
    void add (EventHandler<VideoCreationFrameEventArgs^>^ value);
    void remove (EventHandler<VideoCreationFrameEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVideoCreationFrameEventArgs

Implements

IVideoRecorderVideoRecordingFrame
See Also

Reference

VideoExporterItem Class


VideoExporterItem.VideoRecordingNotification Event

VideoExporterItemVideoRecordingNotification Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<VideoCreationNotificationEventArgs> VideoRecordingNotification
public:
virtual  event EventHandler<VideoCreationNotificationEventArgs^>^ VideoRecordingNotification {
    void add (EventHandler<VideoCreationNotificationEventArgs^>^ value);
    void remove (EventHandler<VideoCreationNotificationEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVideoCreationNotificationEventArgs

Implements

IVideoRecorderVideoRecordingNotification
See Also

Reference

VideoExporterItem Class


ViewportSizeChangedMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedViewportSizeChangedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ViewportSizeChangedMessage
public ref class ViewportSizeChangedMessage

The ViewportSizeChangedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ViewportSizeChangedMessage | Initializes a new instance of the ViewportSizeChangedMessage class
Public method | ViewportSizeChangedMessage(SizeChangedEventArgs) | Initializes a new instance of the ViewportSizeChangedMessage class
Top
Properties
 | Name | Description
Public property | HeightChanged |
Public property | NewSize |
Public property | PreviousSize |
Public property | WidthChanged |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


ViewportSizeChangedMessage Constructor

Overload List
 | Name | Description
Public method | ViewportSizeChangedMessage | Initializes a new instance of the ViewportSizeChangedMessage class
Public method | ViewportSizeChangedMessage(SizeChangedEventArgs) | Initializes a new instance of the ViewportSizeChangedMessage class
Top
See Also

Reference

ViewportSizeChangedMessage Class


ViewportSizeChangedMessage Constructor

Initializes a new instance of the ViewportSizeChangedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ViewportSizeChangedMessage()
public:
ViewportSizeChangedMessage()
See Also

Reference

ViewportSizeChangedMessage Class
ViewportSizeChangedMessage Overload


ViewportSizeChangedMessage Constructor (SizeChangedEventArgs)

Initializes a new instance of the ViewportSizeChangedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ViewportSizeChangedMessage(
    SizeChangedEventArgs e
)
public:
ViewportSizeChangedMessage(
    SizeChangedEventArgs^ e
)

Parameters

e
Type: System.WindowsSizeChangedEventArgs
See Also

Reference

ViewportSizeChangedMessage Class
ViewportSizeChangedMessage Overload


ViewportSizeChangedMessage Properties

The ViewportSizeChangedMessage type exposes the following members.

Properties
 | Name | Description
Public property | HeightChanged |
Public property | NewSize |
Public property | PreviousSize |
Public property | WidthChanged |
Top
See Also

Reference

ViewportSizeChangedMessage Class


ViewportSizeChangedMessage.HeightChanged Property

ViewportSizeChangedMessageHeightChanged Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HeightChanged { get; set; }
public:
property bool HeightChanged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ViewportSizeChangedMessage Class


ViewportSizeChangedMessage.NewSize Property

ViewportSizeChangedMessageNewSize Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Size NewSize { get; set; }
public:
property Size NewSize {
    Size get ();
    void set (Size value);
}

Property Value

Type: Size
See Also

Reference

ViewportSizeChangedMessage Class


ViewportSizeChangedMessage.PreviousSize Property

ViewportSizeChangedMessagePreviousSize Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Size PreviousSize { get; set; }
public:
property Size PreviousSize {
    Size get ();
    void set (Size value);
}

Property Value

Type: Size
See Also

Reference

ViewportSizeChangedMessage Class


ViewportSizeChangedMessage.WidthChanged Property

ViewportSizeChangedMessageWidthChanged Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool WidthChanged { get; set; }
public:
property bool WidthChanged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ViewportSizeChangedMessage Class


ViewportSizeChangedMessage Methods

The ViewportSizeChangedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ViewportSizeChangedMessage Class


ViewPreviewImageSourceConverter Class

Converter class that's used for converting PreviewImage to image source.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedViewPreviewImageSourceConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ViewPreviewImageSourceConverter : IValueConverter
public ref class ViewPreviewImageSourceConverter : IValueConverter

The ViewPreviewImageSourceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ViewPreviewImageSourceConverter | Initializes a new instance of the ViewPreviewImageSourceConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


ViewPreviewImageSourceConverter Constructor

Initializes a new instance of the ViewPreviewImageSourceConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ViewPreviewImageSourceConverter()
public:
ViewPreviewImageSourceConverter()
See Also

Reference

ViewPreviewImageSourceConverter Class


ViewPreviewImageSourceConverter Methods

The ViewPreviewImageSourceConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ViewPreviewImageSourceConverter Class


ViewPreviewImageSourceConverter.Convert Method

ViewPreviewImageSourceConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ViewPreviewImageSourceConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ViewPreviewImageSourceConverter Class


ViewPreviewImageSourceConverter.ConvertBack Method

ViewPreviewImageSourceConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ViewPreviewImageSourceConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ViewPreviewImageSourceConverter Class


Win32Helper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedWin32Helper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Win32Helper
public ref class Win32Helper abstract sealed

The Win32Helper type exposes the following members.

Methods
Name | Description
BitBlt |
CopyIcon |
CreateCompatibleDC |
CreateCursor |
CreateIconIndirect |
DeleteDC |
DestroyIcon |
FindOpaqueArea |
GetCursorAsBitmap |
GetCursorInfo |
GetDesktopWindow |
GetIconInfo |
LoadCursor |
LoadCursorFromFile |
SelectObject |
SetCursor |
SetPixels |
SetSystemCursor |
Top
Fields
Name | Description
CURSOR_SHOWING |
Top
See Also

Reference


Win32Helper Methods

The Win32Helper type exposes the following members.

Methods
Name | Description
BitBlt |
CopyIcon |
CreateCompatibleDC |
CreateCursor |
CreateIconIndirect |
DeleteDC |
DestroyIcon |
FindOpaqueArea |
GetCursorAsBitmap |
GetCursorInfo |
GetDesktopWindow |
GetIconInfo |
LoadCursor |
LoadCursorFromFile |
SelectObject |
SetCursor |
SetPixels |
SetSystemCursor |
Top
See Also

Reference

Win32Helper Class


Win32Helper.BitBlt Method

Win32HelperBitBlt Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool BitBlt(
    IntPtr hdc,
    int nXDest,
    int nYDest,
    int nWidth,
    int nHeight,
    IntPtr hdcSrc,
    int nXSrc,
    int nYSrc,
    Win32HelperTernaryRasterOperations dwRop
)
public:
static bool BitBlt(
    [InAttribute] IntPtr hdc,
    int nXDest,
    int nYDest,
    int nWidth,
    int nHeight,
    [InAttribute] IntPtr hdcSrc,
    int nXSrc,
    int nYSrc,
    Win32HelperTernaryRasterOperations dwRop
)

Parameters

hdc
Type: SystemIntPtr
nXDest
Type: SystemInt32
nYDest
Type: SystemInt32
nWidth
Type: SystemInt32
nHeight
Type: SystemInt32
hdcSrc
Type: SystemIntPtr
nXSrc
Type: SystemInt32
nYSrc
Type: SystemInt32
dwRop
Type: VisualComponents.UX.SharedWin32HelperTernaryRasterOperations

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.BitBlt(System.IntPtr,System.Int32,System.Int32,System.Int32,System.Int32,System.IntPtr,System.Int32,System.Int32,VisualComponents.UX.Shared.Win32Helper.TernaryRasterOperations)"]

See Also

Reference

Win32Helper Class


Win32Helper.CopyIcon Method

Win32HelperCopyIcon Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr CopyIcon(
    IntPtr hIcon
)
public:
static IntPtr CopyIcon(
    IntPtr hIcon
)

Parameters

hIcon
Type: SystemIntPtr

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.CopyIcon(System.IntPtr)"]

See Also

Reference

Win32Helper Class


Win32Helper.CreateCompatibleDC Method

Win32HelperCreateCompatibleDC Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr CreateCompatibleDC(
    IntPtr hdc
)
public:
static IntPtr CreateCompatibleDC(
    [InAttribute] IntPtr hdc
)

Parameters

hdc
Type: SystemIntPtr

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.CreateCompatibleDC(System.IntPtr)"]

See Also

Reference

Win32Helper Class


Win32Helper.CreateCursor Method

Win32HelperCreateCursor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Cursor CreateCursor(
    Bitmap bmp,
    int hx,
    int hy
)
public:
static Cursor^ CreateCursor(
    Bitmap^ bmp,
    int hx,
    int hy
)

Parameters

bmp
Type: System.DrawingBitmap
hx
Type: SystemInt32
hy
Type: SystemInt32

Return Value

Type: Cursor

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.CreateCursor(System.Drawing.Bitmap,System.Int32,System.Int32)"]

See Also

Reference

Win32Helper Class


Win32Helper.CreateIconIndirect Method

Win32HelperCreateIconIndirect Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr CreateIconIndirect(
    ref Win32HelperICONINFO icon
)
public:
static IntPtr CreateIconIndirect(
    Win32HelperICONINFO% icon
)

Parameters

icon
Type: VisualComponents.UX.SharedWin32HelperICONINFO

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.CreateIconIndirect(VisualComponents.UX.Shared.Win32Helper.ICONINFO@)"]

See Also

Reference

Win32Helper Class


Win32Helper.DeleteDC Method

Win32HelperDeleteDC Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool DeleteDC(
    IntPtr hdc
)
public:
static bool DeleteDC(
    [InAttribute] IntPtr hdc
)

Parameters

hdc
Type: SystemIntPtr

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.DeleteDC(System.IntPtr)"]

See Also

Reference

Win32Helper Class


Win32Helper.DestroyIcon Method

Win32HelperDestroyIcon Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool DestroyIcon(
    IntPtr handle
)
public:
static bool DestroyIcon(
    IntPtr handle
)

Parameters

handle
Type: SystemIntPtr

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.DestroyIcon(System.IntPtr)"]

See Also

Reference

Win32Helper Class


Win32Helper.FindOpaqueArea Method

Win32HelperFindOpaqueArea Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int[] FindOpaqueArea(
    Bitmap bmp
)
public:
static array<int>^ FindOpaqueArea(
    Bitmap^ bmp
)

Parameters

bmp
Type: System.DrawingBitmap

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.FindOpaqueArea(System.Drawing.Bitmap)"]

See Also

Reference

Win32Helper Class


Win32Helper.GetCursorAsBitmap Method

Win32HelperGetCursorAsBitmap Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Bitmap GetCursorAsBitmap(
    int id,
    ref int hx,
    ref int hy
)
public:
static Bitmap^ GetCursorAsBitmap(
    int id,
    int% hx,
    int% hy
)

Parameters

id
Type: SystemInt32
hx
Type: SystemInt32
hy
Type: SystemInt32

Return Value

Type: Bitmap

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.GetCursorAsBitmap(System.Int32,System.Int32@,System.Int32@)"]

See Also

Reference

Win32Helper Class


Win32Helper.GetCursorInfo Method

Win32HelperGetCursorInfo Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetCursorInfo(
    out Win32HelperCURSORINFO pci
)
public:
static bool GetCursorInfo(
    [OutAttribute] Win32HelperCURSORINFO% pci
)

Parameters

pci
Type: VisualComponents.UX.SharedWin32HelperCURSORINFO

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.GetCursorInfo(VisualComponents.UX.Shared.Win32Helper.CURSORINFO@)"]

See Also

Reference

Win32Helper Class


Win32Helper.GetDesktopWindow Method

Win32HelperGetDesktopWindow Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr GetDesktopWindow()
public:
static IntPtr GetDesktopWindow()

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.GetDesktopWindow"]

See Also

Reference

Win32Helper Class


Win32Helper.GetIconInfo Method

Win32HelperGetIconInfo Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetIconInfo(
    IntPtr hIcon,
    out Win32HelperICONINFO piconinfo
)
public:
static bool GetIconInfo(
    IntPtr hIcon,
    [OutAttribute] Win32HelperICONINFO% piconinfo
)

Parameters

hIcon
Type: SystemIntPtr
piconinfo
Type: VisualComponents.UX.SharedWin32HelperICONINFO

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.GetIconInfo(System.IntPtr,VisualComponents.UX.Shared.Win32Helper.ICONINFO@)"]

See Also

Reference

Win32Helper Class


Win32Helper.LoadCursor Method

Win32HelperLoadCursor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr LoadCursor(
    IntPtr hInstance,
    int lpCursorName
)
public:
static IntPtr LoadCursor(
    IntPtr hInstance,
    int lpCursorName
)

Parameters

hInstance
Type: SystemIntPtr
lpCursorName
Type: SystemInt32

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.LoadCursor(System.IntPtr,System.Int32)"]

See Also

Reference

Win32Helper Class


Win32Helper.LoadCursorFromFile Method

Win32HelperLoadCursorFromFile Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr LoadCursorFromFile(
    string lpFileName
)
public:
static IntPtr LoadCursorFromFile(
    String^ lpFileName
)

Parameters

lpFileName
Type: SystemString

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.LoadCursorFromFile(System.String)"]

See Also

Reference

Win32Helper Class


Win32Helper.SelectObject Method

Win32HelperSelectObject Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr SelectObject(
    IntPtr hdc,
    IntPtr hgdiobj
)
public:
static IntPtr SelectObject(
    [InAttribute] IntPtr hdc,
    [InAttribute] IntPtr hgdiobj
)

Parameters

hdc
Type: SystemIntPtr
hgdiobj
Type: SystemIntPtr

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.SelectObject(System.IntPtr,System.IntPtr)"]

See Also

Reference

Win32Helper Class


Win32Helper.SetCursor Method

Win32HelperSetCursor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr SetCursor(
    IntPtr hCursor
)
public:
static IntPtr SetCursor(
    IntPtr hCursor
)

Parameters

hCursor
Type: SystemIntPtr

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.SetCursor(System.IntPtr)"]

See Also

Reference

Win32Helper Class


Win32Helper.SetPixels Method

Win32HelperSetPixels Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool SetPixels(
    Bitmap destImage,
    int destX,
    int destY,
    BitmapImage srcImage,
    Int32Rect srcRect
)
public:
static bool SetPixels(
    Bitmap^ destImage,
    int destX,
    int destY,
    BitmapImage^ srcImage,
    Int32Rect srcRect
)

Parameters

destImage
Type: System.DrawingBitmap
destX
Type: SystemInt32
destY
Type: SystemInt32
srcImage
Type: System.Windows.Media.ImagingBitmapImage
srcRect
Type: System.WindowsInt32Rect

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.SetPixels(System.Drawing.Bitmap,System.Int32,System.Int32,System.Windows.Media.Imaging.BitmapImage,System.Windows.Int32Rect)"]

See Also

Reference

Win32Helper Class


Win32Helper.SetSystemCursor Method

Win32HelperSetSystemCursor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool SetSystemCursor(
    IntPtr hcur,
    uint id
)
public:
static bool SetSystemCursor(
    IntPtr hcur,
    unsigned int id
)

Parameters

hcur
Type: SystemIntPtr
id
Type: SystemUInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Win32Helper.SetSystemCursor(System.IntPtr,System.UInt32)"]

See Also

Reference

Win32Helper Class


Win32Helper Fields

The Win32Helper type exposes the following members.

Fields
Name | Description
CURSOR_SHOWING |
Top
See Also

Reference

Win32Helper Class


Win32Helper.CURSOR_SHOWING Field

Win32HelperCURSOR_SHOWING Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int CURSOR_SHOWING = 1
public:
literal int CURSOR_SHOWING = 1

Field Value

Type: Int32
See Also

Reference

Win32Helper Class


Win32Helper.CURSORINFO Structure

Win32HelperCURSORINFO Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct CURSORINFO
public value class CURSORINFO

The Win32HelperCURSORINFO type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | cbSize |
Public field | flags |
Public field | hCursor |
Public field | ptScreenPos |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


CURSORINFO Methods

The Win32HelperCURSORINFO type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Win32HelperCURSORINFO Structure


CURSORINFO Fields

The Win32HelperCURSORINFO type exposes the following members.

Fields
 | Name | Description
Public field | cbSize |
Public field | flags |
Public field | hCursor |
Public field | ptScreenPos |
Top
See Also

Reference

Win32HelperCURSORINFO Structure


Win32Helper.CURSORINFO.cbSize Field

Win32HelperCURSORINFOcbSize Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int cbSize
public:
int cbSize

Field Value

Type: Int32
See Also

Reference

Win32HelperCURSORINFO Structure


Win32Helper.CURSORINFO.flags Field

Win32HelperCURSORINFOflags Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int flags
public:
int flags

Field Value

Type: Int32
See Also

Reference

Win32HelperCURSORINFO Structure


Win32Helper.CURSORINFO.hCursor Field

Win32HelperCURSORINFOhCursor Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr hCursor
public:
IntPtr hCursor

Field Value

Type: IntPtr
See Also

Reference

Win32HelperCURSORINFO Structure


Win32Helper.CURSORINFO.ptScreenPos Field

Win32HelperCURSORINFOptScreenPos Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Win32HelperPOINT ptScreenPos
public:
Win32HelperPOINT ptScreenPos

Field Value

Type: Win32HelperPOINT
See Also

Reference

Win32HelperCURSORINFO Structure


Win32Helper.ICONINFO Structure

Win32HelperICONINFO Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct ICONINFO
public value class ICONINFO

The Win32HelperICONINFO type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | fIcon |
Public field | hbmColor |
Public field | hbmMask |
Public field | xHotspot |
Public field | yHotspot |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


ICONINFO Methods

The Win32HelperICONINFO type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Win32HelperICONINFO Structure


ICONINFO Fields

The Win32HelperICONINFO type exposes the following members.

Fields
 | Name | Description
Public field | fIcon |
Public field | hbmColor |
Public field | hbmMask |
Public field | xHotspot |
Public field | yHotspot |
Top
See Also

Reference

Win32HelperICONINFO Structure


Win32Helper.ICONINFO.fIcon Field

Win32HelperICONINFOfIcon Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool fIcon
public:
bool fIcon

Field Value

Type: Boolean
See Also

Reference

Win32HelperICONINFO Structure


Win32Helper.ICONINFO.hbmColor Field

Win32HelperICONINFOhbmColor Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr hbmColor
public:
IntPtr hbmColor

Field Value

Type: IntPtr
See Also

Reference

Win32HelperICONINFO Structure


Win32Helper.ICONINFO.hbmMask Field

Win32HelperICONINFOhbmMask Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr hbmMask
public:
IntPtr hbmMask

Field Value

Type: IntPtr
See Also

Reference

Win32HelperICONINFO Structure


Win32Helper.ICONINFO.xHotspot Field

Win32HelperICONINFOxHotspot Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int xHotspot
public:
int xHotspot

Field Value

Type: Int32
See Also

Reference

Win32HelperICONINFO Structure


Win32Helper.ICONINFO.yHotspot Field

Win32HelperICONINFOyHotspot Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int yHotspot
public:
int yHotspot

Field Value

Type: Int32
See Also

Reference

Win32HelperICONINFO Structure


Win32Helper.POINT Structure

Win32HelperPOINT Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct POINT
public value class POINT

The Win32HelperPOINT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | x |
Public field | y |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


POINT Methods

The Win32HelperPOINT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Win32HelperPOINT Structure


POINT Fields

The Win32HelperPOINT type exposes the following members.

Fields
 | Name | Description
Public field | x |
Public field | y |
Top
See Also

Reference

Win32HelperPOINT Structure


Win32Helper.POINT.x Field

Win32HelperPOINTx Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int x
public:
int x

Field Value

Type: Int32
See Also

Reference

Win32HelperPOINT Structure


Win32Helper.POINT.y Field

Win32HelperPOINTy Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int y
public:
int y

Field Value

Type: Int32
See Also

Reference

Win32HelperPOINT Structure


Win32Helper.TernaryRasterOperations Enumeration

Win32HelperTernaryRasterOperations Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TernaryRasterOperations
public enum class TernaryRasterOperations
Members
Member name | Value | Description
SRCCOPY | 13369376 | dest = source
SRCPAINT | 15597702 | dest = source OR dest
SRCAND | 8913094 | dest = source AND dest
SRCINVERT | 6684742 | dest = source XOR dest
SRCERASE | 4457256 | dest = source AND (NOT dest)
NOTSRCCOPY | 3342344 | dest = (NOT source)
NOTSRCERASE | 1114278 | dest = (NOT src) AND (NOT dest)
MERGECOPY | 12583114 | dest = (source AND pattern)
MERGEPAINT | 12255782 | dest = (NOT source) OR dest
PATCOPY | 15728673 | dest = pattern
PATPAINT | 16452105 | dest = DPSnoo
PATINVERT | 5898313 | dest = pattern XOR dest
DSTINVERT | 5570569 | dest = (NOT dest)
BLACKNESS | 66 | dest = BLACK
WHITENESS | 16711778 | dest = WHITE
CAPTUREBLT | 1073741824 | Capture window as seen on screen. This includes layered windows such as WPF windows with AllowsTransparency="true"
See Also

Reference


Window3DExtensions Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedWindow3DExtensions

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Window3DExtensions
[ExtensionAttribute]
public ref class Window3DExtensions abstract sealed

The Window3DExtensions type exposes the following members.

Methods
Name | Description
MapXYCoordinatesToPlaneEx |
Top
See Also

Reference


Window3DExtensions Methods

The Window3DExtensions type exposes the following members.

Methods
Name | Description
MapXYCoordinatesToPlaneEx |
Top
See Also

Reference

Window3DExtensions Class


Window3DExtensions.MapXYCoordinatesToPlaneEx Method

Window3DExtensionsMapXYCoordinatesToPlaneEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 MapXYCoordinatesToPlaneEx(
    this IWindow3D window,
    int x,
    int y,
    Vector3 position,
    Vector3 normal,
    Nullable<Matrix> toLocalSpace
)
public:
[ExtensionAttribute]
static Vector3 MapXYCoordinatesToPlaneEx(
    IWindow3D^ window,
    int x,
    int y,
    Vector3 position,
    Vector3 normal,
    Nullable<Matrix> toLocalSpace
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
x
Type: SystemInt32
y
Type: SystemInt32
position
Type: VisualComponents.Create3DVector3
normal
Type: VisualComponents.Create3DVector3
toLocalSpace
Type: SystemNullableMatrix

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Window3DExtensions.MapXYCoordinatesToPlaneEx(VisualComponents.Create3D.IWindow3D,System.Int32,System.Int32,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3,System.Nullable{VisualComponents.Create3D.Matrix})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IWindow3D. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Window3DExtensions Class


WindowCaptionButtons Class

Interaction logic for WindowCaptionButtons.xaml
WindowCaptionButtons
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedWindowCaptionButtons

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class WindowCaptionButtons : UserControl,
    IComponentConnector
public ref class WindowCaptionButtons : public UserControl,
    IComponentConnector

The WindowCaptionButtons type exposes the following members.

Constructors
 | Name | Description
Public method | WindowCaptionButtons | Initializes a new instance of the WindowCaptionButtons class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MarginButton | Gets or sets the margin button.
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Type | Gets or sets the visibility of the buttons.
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
MarginButtonProperty | The dependency property for the Margin between the buttons.
TypeProperty | The dependency property for the Margin between the buttons.
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


WindowCaptionButtons Constructor

Initializes a new instance of the WindowCaptionButtons class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WindowCaptionButtons()
public:
WindowCaptionButtons()
See Also

Reference

WindowCaptionButtons Class


WindowCaptionButtons Properties

The WindowCaptionButtons type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MarginButton | Gets or sets the margin button.
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Type | Gets or sets the visibility of the buttons.
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WindowCaptionButtons Class


WindowCaptionButtons.MarginButton Property

WindowCaptionButtonsMarginButton Property

Gets or sets the margin button.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness MarginButton { get; set; }
public:
property Thickness MarginButton {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
The margin button.
See Also

Reference

WindowCaptionButtons Class


WindowCaptionButtons.Type Property

WindowCaptionButtonsType Property

Gets or sets the visibility of the buttons.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WindowCaptionButtonsCaptionType Type { get; set; }
public:
property WindowCaptionButtonsCaptionType Type {
    WindowCaptionButtonsCaptionType get ();
    void set (WindowCaptionButtonsCaptionType value);
}

Property Value

Type: WindowCaptionButtonsCaptionType
The visible buttons.
See Also

Reference

WindowCaptionButtons Class


WindowCaptionButtons Methods

The WindowCaptionButtons type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

WindowCaptionButtons Class


WindowCaptionButtons.InitializeComponent Method

WindowCaptionButtonsInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

WindowCaptionButtons Class


WindowCaptionButtons Events

The WindowCaptionButtons type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

WindowCaptionButtons Class


WindowCaptionButtons Fields

The WindowCaptionButtons type exposes the following members.

Fields
Name | Description
MarginButtonProperty | The dependency property for the Margin between the buttons.
TypeProperty | The dependency property for the Margin between the buttons.
Top
See Also

Reference

WindowCaptionButtons Class


WindowCaptionButtons.MarginButtonProperty Field

WindowCaptionButtonsMarginButtonProperty Field

The dependency property for the Margin between the buttons.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty MarginButtonProperty
public:
static DependencyProperty^ MarginButtonProperty

Field Value

Type: DependencyProperty
See Also

Reference

WindowCaptionButtons Class


WindowCaptionButtons.TypeProperty Field

WindowCaptionButtonsTypeProperty Field

The dependency property for the Margin between the buttons.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty TypeProperty
public:
static DependencyProperty^ TypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

WindowCaptionButtons Class


WindowCaptionButtons.CaptionType Enumeration

WindowCaptionButtonsCaptionType Enumeration

Enum of the types of caption buttons

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CaptionType
public enum class CaptionType
Members
Member name | Value | Description
Full | 0 | All the buttons
Close | 1 | Only the close button
ReduceClose | 2 | Reduce and close buttons
See Also

Reference


WindowHeightToWindowContentHeightConverter Class

This converter is used to calculate window content hieght from window Height.It is used when creating popup window.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedWindowHeightToWindowContentHeightConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class WindowHeightToWindowContentHeightConverter : IValueConverter
public ref class WindowHeightToWindowContentHeightConverter : IValueConverter

The WindowHeightToWindowContentHeightConverter type exposes the following members.

Constructors
 | Name | Description
Public method | WindowHeightToWindowContentHeightConverter | Initializes a new instance of the WindowHeightToWindowContentHeightConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


WindowHeightToWindowContentHeightConverter Constructor

Initializes a new instance of the WindowHeightToWindowContentHeightConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WindowHeightToWindowContentHeightConverter()
public:
WindowHeightToWindowContentHeightConverter()
See Also

Reference

WindowHeightToWindowContentHeightConverter Class


WindowHeightToWindowContentHeightConverter Methods

The WindowHeightToWindowContentHeightConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

WindowHeightToWindowContentHeightConverter Class


WindowHeightToWindowContentHeightConverter.Convert Method

WindowHeightToWindowContentHeightConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.WindowHeightToWindowContentHeightConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

WindowHeightToWindowContentHeightConverter Class


WindowHeightToWindowContentHeightConverter.ConvertBack Method

WindowHeightToWindowContentHeightConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.WindowHeightToWindowContentHeightConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

WindowHeightToWindowContentHeightConverter Class


VirtualizingCanvas Class

Canvas with support for virtualization, panning and zooming.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
System.Windows.ControlsVirtualizingPanel
VisualComponents.UX.SharedVirtualizingCanvas

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VirtualizingCanvas : VirtualizingPanel,
    IScrollInfo
public ref class VirtualizingCanvas : public VirtualizingPanel,
    IScrollInfo

The VirtualizingCanvas type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualizingCanvas | Initializes a new instance of the VirtualizingCanvas class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | ActualViewport |
Public property | AheadRealizationViewport | Stores the viewport inflated to its actual bounds divided by the value of AheadRealizationViewportFraction property.
Public property | AheadRealizationViewportFraction |
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | ApplyTransform |
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanHierarchicallyScrollAndVirtualize | Gets a value that indicates whether the VirtualizingPanel can virtualize items that are grouped or organized in a hierarchy. (Inherited from VirtualizingPanel.)
Protected property | CanHierarchicallyScrollAndVirtualizeCore | Gets a value that indicates whether the VirtualizingPanel can virtualize items that are grouped or organized in a hierarchy. (Inherited from VirtualizingPanel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InitialBounds | Defines collection of bounds which will be assigned to items initially so that canvas doesn't need to realize them for the first time. Warning: when all items are added to the store this property will be nullified.
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVirtualizing |
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Item | Gets or sets the Rect bounds of an item which allows canvas to realize it again after it was virtualized (it won't know that the item is back into visible area otherwise). Setting an item's bounds to Rect.Empty guarantees it to be realized immediately. Setting approximate bounds is fine as the canvas will correct them during the Arrange pass. Use with care.
Public property | ItemBoundsSizeMultiplier |
Public property | ItemContainerGenerator | Gets a value that identifies the ItemContainerGenerator for this VirtualizingPanel. (Inherited from VirtualizingPanel.)
Public property | ItemsOwner |
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Offset |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RealizationBatchSize |
Public property | RealizationPriority |
Public property | RealizedItemsCount |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scale |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Stretch |
Public property | StretchDirection |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SuppressArrangeInvalidation | Suppresses internal InvalidateArrange() calls. Should be used for batch-updating positions of items on this canvas (Canvas.Top/Canvas.Left).
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Viewport |
Public property | VirtualizationResetRequested | Indicates whether this canvas requested immediate call to ResetVirtualization().
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | VisibleItemsLimit |
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddInternalChild | Adds the specified UIElement to the InternalChildren collection of a VirtualizingPanel element. (Inherited from VirtualizingPanel.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides FrameworkElementArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Protected method | BringIndexIntoView | When implemented in a derived class, generates the item at the specified index location and makes it visible. (Inherited from VirtualizingPanel.)
Public method | BringIndexIntoViewPublic | Generates the item at the specified index location and makes it visible. (Inherited from VirtualizingPanel.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetExtent |
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetItemOffset | Returns the position of the specified item, relative to the VirtualizingPanel. (Inherited from VirtualizingPanel.)
Protected method | GetItemOffsetCore | Returns the position of the specified item, relative to the VirtualizingPanel. (Inherited from VirtualizingPanel.)
Protected method | GetLayoutClip | (Overrides FrameworkElementGetLayoutClip(Size).)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Protected method | InsertInternalChild | Adds the specified UIElement to the InternalChildren collection of a VirtualizingPanel element at the specified index position. (Inherited from VirtualizingPanel.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateExtent | Invalidates scrolling extent. This is needed when canvas is placed inside a ScrollViewer.
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClearChildren | Called when the collection of child elements is cleared by the base Panel class. (Inherited from VirtualizingPanel.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | (Overrides PanelOnIsItemsHostChanged(Boolean, Boolean).)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemsChanged | (Overrides VirtualizingPanelOnItemsChanged(Object, ItemsChangedEventArgs).)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | (Overrides PanelOnVisualChildrenChanged(DependencyObject, DependencyObject).)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromCanvas | Translates given point from canvas coordinates to visual coordinates.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToCanvas | Translates given point from visual coordinates to canvas coordinates.
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RebuildStore | Reconstructs virtualizing store.
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveInternalChildRange | Removes child elements from the InternalChildren collection. (Inherited from VirtualizingPanel.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetVirtualization | Virtualizes/realizes items based on their bounds and current position in the canvas.
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldItemsChangeAffectLayout | Returns a value that indicates whether a changed item in an ItemsControl affects the layout for this panel. (Inherited from VirtualizingPanel.)
Protected method | ShouldItemsChangeAffectLayoutCore | Returns a value that indicates whether a changed item in an ItemsControl affects the layout for this panel. (Inherited from VirtualizingPanel.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContainerAdded | Occurs when item container gets added to the visual tree.
Public event | ContainerRemoved | Occurs when item container gets removed from the visual tree.
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RealizationFinished | Occurs when realization of a single item has finished. Stores realized element in the ItemContainer property.
Public event | RealizationStarted | Occurs when one particular item is about to be realized by the canvas.
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | VirtualizationFinished | Occurs when virtualization pass finishes (= involved items were realized or recycled). Stores generated containers in RealizedContainers property and the count of recycled containers in RecycledContainersCount property.
Public event | VirtualizationStarted | Occurs when canvas is about to perform its virtualization pass. During the pass some of the items will be realized or recycled.
Top
Fields
Name | Description
ActualViewportProperty | Area of this canvas that is actually being displayed currently.
AheadRealizationViewportFractionProperty | Defines the fraction of viewport that will participate in the query, so that the items which intersect the bounds of the viewport AND its fraction will be realized (can be used for smoother panning, because items that are not yet in the viewport will be pre-loaded). Viewport Width and Height will first be divided by the value of this property and then the viewport will get inflated by result in all directions.
ApplyTransformProperty | Defines whether VirtualizingCanvas should handle panning and zooming automatically.
IsVirtualizingProperty | Defines whether items in this canvas can/should be virtualized. This property directly affects the underlying VirtualizingPanel.
ItemBoundsSizeMultiplierProperty | Defines the value which items bounds will be multiplied by (Width and Height). This is needed when scale transform is applied directly to the items so that the query is checked against item's real (rendered size after transform) bounds.
OffsetProperty | Defines vertical and horizontal offset of the viewport of this canvas from top left corner.
RealizationBatchSizeProperty | Defines the maximum realization batch size of items in this canvas. This property takes effect only when IsVirtualizing is set to true.
RealizationPriorityProperty | Defines the DispatcherPriority for virtualization. Warning: if you lower the priority, GUI will freeze for a longer period of time during virtualization.
ScaleProperty | Defines the scale (zoom) ov this canvas' viewport.
StretchDirectionProperty | Defines the direction in which stretch will be applied to contents of this canvas when the Viewport property is set.
StretchProperty | Defines how the content of this canvas gets stretched when the Viewport property is set.
ViewportProperty | Area of this canvas that it should (theoretically) attempt to display.
VisibleItemsLimitProperty | Defines the maximum number of items this canvas will try to realize.
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VirtualizingCanvas Constructor

Initializes a new instance of the VirtualizingCanvas class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VirtualizingCanvas()
public:
VirtualizingCanvas()
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas Properties

The VirtualizingCanvas type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | ActualViewport |
Public property | AheadRealizationViewport | Stores the viewport inflated to its actual bounds divided by the value of AheadRealizationViewportFraction property.
Public property | AheadRealizationViewportFraction |
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | ApplyTransform |
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanHierarchicallyScrollAndVirtualize | Gets a value that indicates whether the VirtualizingPanel can virtualize items that are grouped or organized in a hierarchy. (Inherited from VirtualizingPanel.)
Protected property | CanHierarchicallyScrollAndVirtualizeCore | Gets a value that indicates whether the VirtualizingPanel can virtualize items that are grouped or organized in a hierarchy. (Inherited from VirtualizingPanel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InitialBounds | Defines collection of bounds which will be assigned to items initially so that canvas doesn't need to realize them for the first time. Warning: when all items are added to the store this property will be nullified.
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVirtualizing |
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Item | Gets or sets the Rect bounds of an item which allows canvas to realize it again after it was virtualized (it won't know that the item is back into visible area otherwise). Setting an item's bounds to Rect.Empty guarantees it to be realized immediately. Setting approximate bounds is fine as the canvas will correct them during the Arrange pass. Use with care.
Public property | ItemBoundsSizeMultiplier |
Public property | ItemContainerGenerator | Gets a value that identifies the ItemContainerGenerator for this VirtualizingPanel. (Inherited from VirtualizingPanel.)
Public property | ItemsOwner |
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Offset |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RealizationBatchSize |
Public property | RealizationPriority |
Public property | RealizedItemsCount |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scale |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Stretch |
Public property | StretchDirection |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SuppressArrangeInvalidation | Suppresses internal InvalidateArrange() calls. Should be used for batch-updating positions of items on this canvas (Canvas.Top/Canvas.Left).
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Viewport |
Public property | VirtualizationResetRequested | Indicates whether this canvas requested immediate call to ResetVirtualization().
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | VisibleItemsLimit |
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ActualViewport Property

VirtualizingCanvasActualViewport Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Rect ActualViewport { get; }
public:
property Rect ActualViewport {
    Rect get ();
}

Property Value

Type: Rect
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.AheadRealizationViewport Property

VirtualizingCanvasAheadRealizationViewport Property

Stores the viewport inflated to its actual bounds divided by the value of AheadRealizationViewportFraction property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Rect AheadRealizationViewport { get; set; }
public:
property Rect AheadRealizationViewport {
    Rect get ();
    void set (Rect value);
}

Property Value

Type: Rect
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.AheadRealizationViewportFraction Property

VirtualizingCanvasAheadRealizationViewportFraction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AheadRealizationViewportFraction { get; set; }
public:
property double AheadRealizationViewportFraction {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ApplyTransform Property

VirtualizingCanvasApplyTransform Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyTransform { get; set; }
public:
property bool ApplyTransform {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.InitialBounds Property

VirtualizingCanvasInitialBounds Property

Defines collection of bounds which will be assigned to items initially so that canvas doesn't need to realize them for the first time. Warning: when all items are added to the store this property will be nullified.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<Rect> InitialBounds { get; set; }
public:
property IList<Rect>^ InitialBounds {
    IList<Rect>^ get ();
    void set (IList<Rect>^ value);
}

Property Value

Type: IListRect
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.IsVirtualizing Property

VirtualizingCanvasIsVirtualizing Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVirtualizing { get; set; }
public:
property bool IsVirtualizing {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.Item Property

VirtualizingCanvasItem Property

Gets or sets the Rect bounds of an item which allows canvas to realize it again after it was virtualized (it won't know that the item is back into visible area otherwise). Setting an item's bounds to Rect.Empty guarantees it to be realized immediately. Setting approximate bounds is fine as the canvas will correct them during the Arrange pass. Use with care.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Rect this[
    int index,
    bool resetVirtualization = false
] { get; set; }
public:
property Rect default[int index, bool resetVirtualization = false] {
    Rect get (int index, bool resetVirtualization = false);
    void set (int index, bool resetVirtualization = false, Rect value);
}

Parameters

index
Type: SystemInt32
resetVirtualization (Optional)
Type: SystemBoolean

Property Value

Type: Rect
Remarks
This is the main interface between data side and virtualization in this canvas.
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ItemBoundsSizeMultiplier Property

VirtualizingCanvasItemBoundsSizeMultiplier Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ItemBoundsSizeMultiplier { get; set; }
public:
property double ItemBoundsSizeMultiplier {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ItemsOwner Property

VirtualizingCanvasItemsOwner Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ItemsControl ItemsOwner { get; }
public:
property ItemsControl^ ItemsOwner {
    ItemsControl^ get ();
}

Property Value

Type: ItemsControl
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.Offset Property

VirtualizingCanvasOffset Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point Offset { get; set; }
public:
property Point Offset {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.RealizationBatchSize Property

VirtualizingCanvasRealizationBatchSize Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RealizationBatchSize { get; set; }
public:
property int RealizationBatchSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.RealizationPriority Property

VirtualizingCanvasRealizationPriority Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DispatcherPriority RealizationPriority { get; set; }
public:
property DispatcherPriority RealizationPriority {
    DispatcherPriority get ();
    void set (DispatcherPriority value);
}

Property Value

Type: DispatcherPriority
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.RealizedItemsCount Property

VirtualizingCanvasRealizedItemsCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RealizedItemsCount { get; }
public:
property int RealizedItemsCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.Scale Property

VirtualizingCanvasScale Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Scale { get; set; }
public:
property double Scale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.Stretch Property

VirtualizingCanvasStretch Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Stretch Stretch { get; set; }
public:
property Stretch Stretch {
    Stretch get ();
    void set (Stretch value);
}

Property Value

Type: Stretch
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.StretchDirection Property

VirtualizingCanvasStretchDirection Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StretchDirection StretchDirection { get; set; }
public:
property StretchDirection StretchDirection {
    StretchDirection get ();
    void set (StretchDirection value);
}

Property Value

Type: StretchDirection
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.SuppressArrangeInvalidation Property

VirtualizingCanvasSuppressArrangeInvalidation Property

Suppresses internal InvalidateArrange() calls. Should be used for batch-updating positions of items on this canvas (Canvas.Top/Canvas.Left).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SuppressArrangeInvalidation { get; set; }
public:
property bool SuppressArrangeInvalidation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.Viewport Property

VirtualizingCanvasViewport Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Rect Viewport { get; set; }
public:
property Rect Viewport {
    Rect get ();
    void set (Rect value);
}

Property Value

Type: Rect
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.VirtualizationResetRequested Property

VirtualizingCanvasVirtualizationResetRequested Property

Indicates whether this canvas requested immediate call to ResetVirtualization().

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool VirtualizationResetRequested { get; set; }
public:
property bool VirtualizationResetRequested {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This is only a flag, so canvas does not perform reset on its own. This property is used solely for optimization purpose.
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.VisibleItemsLimit Property

VirtualizingCanvasVisibleItemsLimit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int VisibleItemsLimit { get; set; }
public:
property int VisibleItemsLimit {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas Methods

The VirtualizingCanvas type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddInternalChild | Adds the specified UIElement to the InternalChildren collection of a VirtualizingPanel element. (Inherited from VirtualizingPanel.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides FrameworkElementArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Protected method | BringIndexIntoView | When implemented in a derived class, generates the item at the specified index location and makes it visible. (Inherited from VirtualizingPanel.)
Public method | BringIndexIntoViewPublic | Generates the item at the specified index location and makes it visible. (Inherited from VirtualizingPanel.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetExtent |
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetItemOffset | Returns the position of the specified item, relative to the VirtualizingPanel. (Inherited from VirtualizingPanel.)
Protected method | GetItemOffsetCore | Returns the position of the specified item, relative to the VirtualizingPanel. (Inherited from VirtualizingPanel.)
Protected method | GetLayoutClip | (Overrides FrameworkElementGetLayoutClip(Size).)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Protected method | InsertInternalChild | Adds the specified UIElement to the InternalChildren collection of a VirtualizingPanel element at the specified index position. (Inherited from VirtualizingPanel.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateExtent | Invalidates scrolling extent. This is needed when canvas is placed inside a ScrollViewer.
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClearChildren | Called when the collection of child elements is cleared by the base Panel class. (Inherited from VirtualizingPanel.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | (Overrides PanelOnIsItemsHostChanged(Boolean, Boolean).)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemsChanged | (Overrides VirtualizingPanelOnItemsChanged(Object, ItemsChangedEventArgs).)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | (Overrides PanelOnVisualChildrenChanged(DependencyObject, DependencyObject).)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromCanvas | Translates given point from canvas coordinates to visual coordinates.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToCanvas | Translates given point from visual coordinates to canvas coordinates.
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RebuildStore | Reconstructs virtualizing store.
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveInternalChildRange | Removes child elements from the InternalChildren collection. (Inherited from VirtualizingPanel.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetVirtualization | Virtualizes/realizes items based on their bounds and current position in the canvas.
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldItemsChangeAffectLayout | Returns a value that indicates whether a changed item in an ItemsControl affects the layout for this panel. (Inherited from VirtualizingPanel.)
Protected method | ShouldItemsChangeAffectLayoutCore | Returns a value that indicates whether a changed item in an ItemsControl affects the layout for this panel. (Inherited from VirtualizingPanel.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ArrangeOverride Method

VirtualizingCanvasArrangeOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
protected:
virtual Size ArrangeOverride(
    Size finalSize
) override

Parameters

finalSize
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VirtualizingCanvas.ArrangeOverride(System.Windows.Size)"]

See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.GetExtent Method

VirtualizingCanvasGetExtent Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Rect GetExtent()
public:
Rect GetExtent()

Return Value

Type: Rect

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VirtualizingCanvas.GetExtent"]

See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.GetLayoutClip Method

VirtualizingCanvasGetLayoutClip Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Geometry GetLayoutClip(
    Size layoutSlotSize
)
protected:
virtual Geometry^ GetLayoutClip(
    Size layoutSlotSize
) override

Parameters

layoutSlotSize
Type: System.WindowsSize

Return Value

Type: Geometry

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VirtualizingCanvas.GetLayoutClip(System.Windows.Size)"]

See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.InvalidateExtent Method

VirtualizingCanvasInvalidateExtent Method

Invalidates scrolling extent. This is needed when canvas is placed inside a ScrollViewer.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InvalidateExtent()
public:
void InvalidateExtent()
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.MeasureOverride Method

VirtualizingCanvasMeasureOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size MeasureOverride(
    Size availableSize
)
protected:
virtual Size MeasureOverride(
    Size availableSize
) override

Parameters

availableSize
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VirtualizingCanvas.MeasureOverride(System.Windows.Size)"]

See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.OnIsItemsHostChanged Method

VirtualizingCanvasOnIsItemsHostChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnIsItemsHostChanged(
    bool oldIsItemsHost,
    bool newIsItemsHost
)
protected:
virtual void OnIsItemsHostChanged(
    bool oldIsItemsHost,
    bool newIsItemsHost
) override

Parameters

oldIsItemsHost
Type: SystemBoolean
newIsItemsHost
Type: SystemBoolean
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.OnItemsChanged Method

VirtualizingCanvasOnItemsChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override sealed void OnItemsChanged(
    Object sender,
    ItemsChangedEventArgs e
)
protected:
virtual void OnItemsChanged(
    Object^ sender,
    ItemsChangedEventArgs^ e
) override sealed

Parameters

sender
Type: SystemObject
e
Type: System.Windows.Controls.PrimitivesItemsChangedEventArgs
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.OnRenderSizeChanged Method

VirtualizingCanvasOnRenderSizeChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnRenderSizeChanged(
    SizeChangedInfo sizeInfo
)
protected:
virtual void OnRenderSizeChanged(
    SizeChangedInfo^ sizeInfo
) override

Parameters

sizeInfo
Type: System.WindowsSizeChangedInfo
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.OnVisualChildrenChanged Method

VirtualizingCanvasOnVisualChildrenChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnVisualChildrenChanged(
    DependencyObject added,
    DependencyObject removed
)
protected:
virtual void OnVisualChildrenChanged(
    DependencyObject^ added,
    DependencyObject^ removed
) override

Parameters

added
Type: System.WindowsDependencyObject
removed
Type: System.WindowsDependencyObject
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.PointFromCanvas Method

VirtualizingCanvasPointFromCanvas Method

Translates given point from canvas coordinates to visual coordinates.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point PointFromCanvas(
    Point point
)
public:
Point PointFromCanvas(
    Point point
)

Parameters

point
Type: System.WindowsPoint

Return Value

Type: Point

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VirtualizingCanvas.PointFromCanvas(System.Windows.Point)"]

See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.PointToCanvas Method

VirtualizingCanvasPointToCanvas Method

Translates given point from visual coordinates to canvas coordinates.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point PointToCanvas(
    Point point
)
public:
Point PointToCanvas(
    Point point
)

Parameters

point
Type: System.WindowsPoint

Return Value

Type: Point

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.VirtualizingCanvas.PointToCanvas(System.Windows.Point)"]

See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.RebuildStore Method

VirtualizingCanvasRebuildStore Method

Reconstructs virtualizing store.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RebuildStore()
public:
void RebuildStore()
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ResetVirtualization Method

VirtualizingCanvasResetVirtualization Method

Virtualizes/realizes items based on their bounds and current position in the canvas.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ResetVirtualization()
public:
void ResetVirtualization()
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas Events

The VirtualizingCanvas type exposes the following members.

Events
 | Name | Description
Public event | ContainerAdded | Occurs when item container gets added to the visual tree.
Public event | ContainerRemoved | Occurs when item container gets removed from the visual tree.
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RealizationFinished | Occurs when realization of a single item has finished. Stores realized element in the ItemContainer property.
Public event | RealizationStarted | Occurs when one particular item is about to be realized by the canvas.
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | VirtualizationFinished | Occurs when virtualization pass finishes (= involved items were realized or recycled). Stores generated containers in RealizedContainers property and the count of recycled containers in RecycledContainersCount property.
Public event | VirtualizationStarted | Occurs when canvas is about to perform its virtualization pass. During the pass some of the items will be realized or recycled.
Top
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ContainerAdded Event

VirtualizingCanvasContainerAdded Event

Occurs when item container gets added to the visual tree.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<VirtualizingCanvasItemContainerEventArgs> ContainerAdded
public:
 event EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ ContainerAdded {
    void add (EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ value);
    void remove (EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVirtualizingCanvasItemContainerEventArgs
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ContainerRemoved Event

VirtualizingCanvasContainerRemoved Event

Occurs when item container gets removed from the visual tree.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<VirtualizingCanvasItemContainerEventArgs> ContainerRemoved
public:
 event EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ ContainerRemoved {
    void add (EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ value);
    void remove (EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVirtualizingCanvasItemContainerEventArgs
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.RealizationFinished Event

VirtualizingCanvasRealizationFinished Event

Occurs when realization of a single item has finished. Stores realized element in the ItemContainer property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<VirtualizingCanvasItemContainerEventArgs> RealizationFinished
public:
 event EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ RealizationFinished {
    void add (EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ value);
    void remove (EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVirtualizingCanvasItemContainerEventArgs
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.RealizationStarted Event

VirtualizingCanvasRealizationStarted Event

Occurs when one particular item is about to be realized by the canvas.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<VirtualizingCanvasItemContainerEventArgs> RealizationStarted
public:
 event EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ RealizationStarted {
    void add (EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ value);
    void remove (EventHandler<VirtualizingCanvasItemContainerEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVirtualizingCanvasItemContainerEventArgs
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.VirtualizationFinished Event

VirtualizingCanvasVirtualizationFinished Event

Occurs when virtualization pass finishes (= involved items were realized or recycled). Stores generated containers in RealizedContainers property and the count of recycled containers in RecycledContainersCount property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<VirtualizingCanvasVirtualizationEventArgs> VirtualizationFinished
public:
 event EventHandler<VirtualizingCanvasVirtualizationEventArgs^>^ VirtualizationFinished {
    void add (EventHandler<VirtualizingCanvasVirtualizationEventArgs^>^ value);
    void remove (EventHandler<VirtualizingCanvasVirtualizationEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVirtualizingCanvasVirtualizationEventArgs
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.VirtualizationStarted Event

VirtualizingCanvasVirtualizationStarted Event

Occurs when canvas is about to perform its virtualization pass. During the pass some of the items will be realized or recycled.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<VirtualizingCanvasVirtualizationEventArgs> VirtualizationStarted
public:
 event EventHandler<VirtualizingCanvasVirtualizationEventArgs^>^ VirtualizationStarted {
    void add (EventHandler<VirtualizingCanvasVirtualizationEventArgs^>^ value);
    void remove (EventHandler<VirtualizingCanvasVirtualizationEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVirtualizingCanvasVirtualizationEventArgs
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas Fields

The VirtualizingCanvas type exposes the following members.

Fields
Name | Description
ActualViewportProperty | Area of this canvas that is actually being displayed currently.
AheadRealizationViewportFractionProperty | Defines the fraction of viewport that will participate in the query, so that the items which intersect the bounds of the viewport AND its fraction will be realized (can be used for smoother panning, because items that are not yet in the viewport will be pre-loaded). Viewport Width and Height will first be divided by the value of this property and then the viewport will get inflated by result in all directions.
ApplyTransformProperty | Defines whether VirtualizingCanvas should handle panning and zooming automatically.
IsVirtualizingProperty | Defines whether items in this canvas can/should be virtualized. This property directly affects the underlying VirtualizingPanel.
ItemBoundsSizeMultiplierProperty | Defines the value which items bounds will be multiplied by (Width and Height). This is needed when scale transform is applied directly to the items so that the query is checked against item's real (rendered size after transform) bounds.
OffsetProperty | Defines vertical and horizontal offset of the viewport of this canvas from top left corner.
RealizationBatchSizeProperty | Defines the maximum realization batch size of items in this canvas. This property takes effect only when IsVirtualizing is set to true.
RealizationPriorityProperty | Defines the DispatcherPriority for virtualization. Warning: if you lower the priority, GUI will freeze for a longer period of time during virtualization.
ScaleProperty | Defines the scale (zoom) ov this canvas' viewport.
StretchDirectionProperty | Defines the direction in which stretch will be applied to contents of this canvas when the Viewport property is set.
StretchProperty | Defines how the content of this canvas gets stretched when the Viewport property is set.
ViewportProperty | Area of this canvas that it should (theoretically) attempt to display.
VisibleItemsLimitProperty | Defines the maximum number of items this canvas will try to realize.
Top
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ActualViewportProperty Field

VirtualizingCanvasActualViewportProperty Field

Area of this canvas that is actually being displayed currently.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ActualViewportProperty
public:
static initonly DependencyProperty^ ActualViewportProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.AheadRealizationViewportFractionProperty Field

VirtualizingCanvasAheadRealizationViewportFractionProperty Field

Defines the fraction of viewport that will participate in the query, so that the items which intersect the bounds of the viewport AND its fraction will be realized (can be used for smoother panning, because items that are not yet in the viewport will be pre-loaded). Viewport Width and Height will first be divided by the value of this property and then the viewport will get inflated by result in all directions.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AheadRealizationViewportFractionProperty
public:
static initonly DependencyProperty^ AheadRealizationViewportFractionProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ApplyTransformProperty Field

VirtualizingCanvasApplyTransformProperty Field

Defines whether VirtualizingCanvas should handle panning and zooming automatically.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ApplyTransformProperty
public:
static initonly DependencyProperty^ ApplyTransformProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.IsVirtualizingProperty Field

VirtualizingCanvasIsVirtualizingProperty Field

Defines whether items in this canvas can/should be virtualized. This property directly affects the underlying VirtualizingPanel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsVirtualizingProperty
public:
static initonly DependencyProperty^ IsVirtualizingProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ItemBoundsSizeMultiplierProperty Field

VirtualizingCanvasItemBoundsSizeMultiplierProperty Field

Defines the value which items bounds will be multiplied by (Width and Height). This is needed when scale transform is applied directly to the items so that the query is checked against item's real (rendered size after transform) bounds.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ItemBoundsSizeMultiplierProperty
public:
static initonly DependencyProperty^ ItemBoundsSizeMultiplierProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.OffsetProperty Field

VirtualizingCanvasOffsetProperty Field

Defines vertical and horizontal offset of the viewport of this canvas from top left corner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty OffsetProperty
public:
static initonly DependencyProperty^ OffsetProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.RealizationBatchSizeProperty Field

VirtualizingCanvasRealizationBatchSizeProperty Field

Defines the maximum realization batch size of items in this canvas. This property takes effect only when IsVirtualizing is set to true.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RealizationBatchSizeProperty
public:
static initonly DependencyProperty^ RealizationBatchSizeProperty

Field Value

Type: DependencyProperty
Remarks
Generally you would only want to change the value of this property if you need to process an operation of higher importance than UI responsiveness.
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.RealizationPriorityProperty Field

VirtualizingCanvasRealizationPriorityProperty Field

Defines the DispatcherPriority for virtualization. Warning: if you lower the priority, GUI will freeze for a longer period of time during virtualization.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RealizationPriorityProperty
public:
static initonly DependencyProperty^ RealizationPriorityProperty

Field Value

Type: DependencyProperty
Remarks
Generally you would only want to change the value of this property if you need to process an operation of higher importance than UI responsiveness.
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ScaleProperty Field

VirtualizingCanvasScaleProperty Field

Defines the scale (zoom) ov this canvas' viewport.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ScaleProperty
public:
static initonly DependencyProperty^ ScaleProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.StretchDirectionProperty Field

VirtualizingCanvasStretchDirectionProperty Field

Defines the direction in which stretch will be applied to contents of this canvas when the Viewport property is set.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty StretchDirectionProperty
public:
static initonly DependencyProperty^ StretchDirectionProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.StretchProperty Field

VirtualizingCanvasStretchProperty Field

Defines how the content of this canvas gets stretched when the Viewport property is set.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty StretchProperty
public:
static initonly DependencyProperty^ StretchProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ViewportProperty Field

VirtualizingCanvasViewportProperty Field

Area of this canvas that it should (theoretically) attempt to display.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ViewportProperty
public:
static initonly DependencyProperty^ ViewportProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.VisibleItemsLimitProperty Field

VirtualizingCanvasVisibleItemsLimitProperty Field

Defines the maximum number of items this canvas will try to realize.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty VisibleItemsLimitProperty
public:
static initonly DependencyProperty^ VisibleItemsLimitProperty

Field Value

Type: DependencyProperty
See Also

Reference

VirtualizingCanvas Class


VirtualizingCanvas.ItemContainerEventArgs Class

VirtualizingCanvasItemContainerEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedVirtualizingCanvasItemContainerEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ItemContainerEventArgs : EventArgs
public ref class ItemContainerEventArgs : public EventArgs

The VirtualizingCanvasItemContainerEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualizingCanvasItemContainerEventArgs | Initializes a new instance of the VirtualizingCanvasItemContainerEventArgs class
Top
Properties
 | Name | Description
Public property | ItemContainer |
Public property | ItemIndex |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VirtualizingCanvas.ItemContainerEventArgs Constructor

VirtualizingCanvasItemContainerEventArgs Constructor

Initializes a new instance of the VirtualizingCanvasItemContainerEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ItemContainerEventArgs(
    int index = -1,
    UIElement changedItemContainer = null
)
public:
ItemContainerEventArgs(
    int index = -1,
    UIElement^ changedItemContainer = nullptr
)

Parameters

index (Optional)
Type: SystemInt32
changedItemContainer (Optional)
Type: System.WindowsUIElement
See Also

Reference

VirtualizingCanvasItemContainerEventArgs Class


ItemContainerEventArgs Properties

The VirtualizingCanvasItemContainerEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ItemContainer |
Public property | ItemIndex |
Top
See Also

Reference

VirtualizingCanvasItemContainerEventArgs Class


VirtualizingCanvas.ItemContainerEventArgs.ItemContainer Property

VirtualizingCanvasItemContainerEventArgsItemContainer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UIElement ItemContainer { get; set; }
public:
property UIElement^ ItemContainer {
    UIElement^ get ();
    void set (UIElement^ value);
}

Property Value

Type: UIElement
See Also

Reference

VirtualizingCanvasItemContainerEventArgs Class


VirtualizingCanvas.ItemContainerEventArgs.ItemIndex Property

VirtualizingCanvasItemContainerEventArgsItemIndex Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ItemIndex { get; set; }
public:
property int ItemIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

VirtualizingCanvasItemContainerEventArgs Class


ItemContainerEventArgs Methods

The VirtualizingCanvasItemContainerEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VirtualizingCanvasItemContainerEventArgs Class


VirtualizingCanvas.VirtualizationEventArgs Class

VirtualizingCanvasVirtualizationEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedVirtualizingCanvasVirtualizationEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VirtualizationEventArgs : EventArgs
public ref class VirtualizationEventArgs : public EventArgs

The VirtualizingCanvasVirtualizationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualizingCanvasVirtualizationEventArgs | Initializes a new instance of the VirtualizingCanvasVirtualizationEventArgs class
Top
Properties
 | Name | Description
Public property | RealizedContainers |
Public property | RecycledContainersCount |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


VirtualizingCanvas.VirtualizationEventArgs Constructor

VirtualizingCanvasVirtualizationEventArgs Constructor

Initializes a new instance of the VirtualizingCanvasVirtualizationEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VirtualizationEventArgs(
    List<UIElement> realizedContainers = null,
    int recycledContainersCount = 0
)
public:
VirtualizationEventArgs(
    List<UIElement^>^ realizedContainers = nullptr,
    int recycledContainersCount = 0
)

Parameters

realizedContainers (Optional)
Type: System.Collections.GenericListUIElement
recycledContainersCount (Optional)
Type: SystemInt32
See Also

Reference

VirtualizingCanvasVirtualizationEventArgs Class


VirtualizationEventArgs Properties

The VirtualizingCanvasVirtualizationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | RealizedContainers |
Public property | RecycledContainersCount |
Top
See Also

Reference

VirtualizingCanvasVirtualizationEventArgs Class


VirtualizingCanvas.VirtualizationEventArgs.RealizedContainers Property

VirtualizingCanvasVirtualizationEventArgsRealizedContainers Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<UIElement> RealizedContainers { get; set; }
public:
property List<UIElement^>^ RealizedContainers {
    List<UIElement^>^ get ();
    void set (List<UIElement^>^ value);
}

Property Value

Type: ListUIElement
See Also

Reference

VirtualizingCanvasVirtualizationEventArgs Class


VirtualizingCanvas.VirtualizationEventArgs.RecycledContainersCount Property

VirtualizingCanvasVirtualizationEventArgsRecycledContainersCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RecycledContainersCount { get; set; }
public:
property int RecycledContainersCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

VirtualizingCanvasVirtualizationEventArgs Class


VirtualizationEventArgs Methods

The VirtualizingCanvasVirtualizationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VirtualizingCanvasVirtualizationEventArgs Class


XamDockWindowManagerLoader Class

Creates and registers instance of XamDockWindowManager
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedXamDockWindowManagerLoader

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class XamDockWindowManagerLoader
public ref class XamDockWindowManagerLoader abstract sealed

The XamDockWindowManagerLoader type exposes the following members.

Methods
Name | Description
CreateXamDockWindowManager | Creates and registers instance of XamDockWindowManager
Top
See Also

Reference


XamDockWindowManagerLoader Methods

The XamDockWindowManagerLoader type exposes the following members.

Methods
Name | Description
CreateXamDockWindowManager | Creates and registers instance of XamDockWindowManager
Top
See Also

Reference

XamDockWindowManagerLoader Class


XamDockWindowManagerLoader.CreateXamDockWindowManager Method

XamDockWindowManagerLoaderCreateXamDockWindowManager Method

Creates and registers instance of XamDockWindowManager

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void CreateXamDockWindowManager()
public:
static void CreateXamDockWindowManager()
See Also

Reference

XamDockWindowManagerLoader Class


XamReportPreviewEx Class

Extended (actually currently it has less functionality than the original) XamReportPreview that allows us to debug and catch internal exceptions. Cannot show the report progress.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
XamReportPreview
VisualComponents.UX.SharedXamReportPreviewEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class XamReportPreviewEx : XamReportPreview
public ref class XamReportPreviewEx : public XamReportPreview

The XamReportPreviewEx type exposes the following members.

Constructors
 | Name | Description
Public method | XamReportPreviewEx | Initializes a new instance of the XamReportPreviewEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DocumentViewer | (Inherited from XamReportPreview.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsContentVisible | (Inherited from XamReportPreview.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Report |
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearPreview |
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GeneratePreview |
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from XamReportPreview.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ReportProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference


XamReportPreviewEx Constructor

Initializes a new instance of the XamReportPreviewEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public XamReportPreviewEx()
public:
XamReportPreviewEx()
See Also

Reference

XamReportPreviewEx Class


XamReportPreviewEx Properties

The XamReportPreviewEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DocumentViewer | (Inherited from XamReportPreview.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsContentVisible | (Inherited from XamReportPreview.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Report |
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

XamReportPreviewEx Class


XamReportPreviewEx.Report Property

XamReportPreviewExReport Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Report Report { get; }
public:
property Report^ Report {
    Report^ get ();
}

Property Value

Type: Report
See Also

Reference

XamReportPreviewEx Class


XamReportPreviewEx Methods

The XamReportPreviewEx type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearPreview |
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GeneratePreview |
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from XamReportPreview.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

XamReportPreviewEx Class


XamReportPreviewEx.ClearPreview Method

XamReportPreviewExClearPreview Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ClearPreview()
public:
void ClearPreview()
See Also

Reference

XamReportPreviewEx Class


XamReportPreviewEx.GeneratePreview Method

XamReportPreviewExGeneratePreview Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void GeneratePreview(
    Report reportOriginal,
    bool showPrintDialog,
    bool stub
)
public:
void GeneratePreview(
    Report^ reportOriginal,
    bool showPrintDialog,
    bool stub
)

Parameters

reportOriginal
Type: Report
showPrintDialog
Type: SystemBoolean
stub
Type: SystemBoolean
See Also

Reference

XamReportPreviewEx Class


XamReportPreviewEx Events

The XamReportPreviewEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

XamReportPreviewEx Class


XamReportPreviewEx Fields

The XamReportPreviewEx type exposes the following members.

Fields
Name | Description
ReportProperty |
Top
See Also

Reference

XamReportPreviewEx Class


XamReportPreviewEx.ReportProperty Field

XamReportPreviewExReportProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ReportProperty
public:
static initonly DependencyProperty^ ReportProperty

Field Value

Type: DependencyProperty
See Also

Reference

XamReportPreviewEx Class


XElementExt Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedXElementExt

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class XElementExt
[ExtensionAttribute]
public ref class XElementExt abstract sealed

The XElementExt type exposes the following members.

Methods
Name | Description
FromXElementT |
ToXElementT |
Top
See Also

Reference


XElementExt Methods

The XElementExt type exposes the following members.

Methods
Name | Description
FromXElementT |
ToXElementT |
Top
See Also

Reference

XElementExt Class


XElementExt.FromXElement(T) Method

XElementExtFromXElementT Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T FromXElement<T>(
    this XElement xElement
)

public:
[ExtensionAttribute]
generic<typename T>
static T FromXElement(
    XElement^ xElement
)

Parameters

xElement
Type: System.Xml.LinqXElement

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.XElementExt.FromXElement``1(System.Xml.Linq.XElement)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type XElement. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XElementExt Class


XElementExt.ToXElement(T) Method

XElementExtToXElementT Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static XElement ToXElement<T>(
    this Object obj
)

public:
[ExtensionAttribute]
generic<typename T>
static XElement^ ToXElement(
    Object^ obj
)

Parameters

obj
Type: SystemObject

Type Parameters

T

Return Value

Type: XElement

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.XElementExt.ToXElement``1(System.Object)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XElementExt Class


XmlExtensions Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedXmlExtensions

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class XmlExtensions
[ExtensionAttribute]
public ref class XmlExtensions abstract sealed

The XmlExtensions type exposes the following members.

Methods
Name | Description
GetNodes |
LoadEnd |
LoadStart |
LoadStartEx |
LoadValue |
LoadValueEx(String, Int32, Boolean) |
LoadValueEx(String, String, Boolean) |
LoadValueEx(String, String, Object, Object) |
LoadValueEx(String, String, Object, Boolean, IEnumerable) |
LoadValueEx2 |
SaveEnd |
SaveStart |
SaveValue(String, Boolean) |
SaveValue(String, Double) |
SaveValue(String, Int32) |
SaveValue(String, String) |
SaveValueEx(String, IEnumerableNullableDouble) |
SaveValueEx(String, IEnumerableNullableInt32) |
SaveValueEx(String, IEnumerableNullableColor) |
SaveValueEx(String, IEnumerableISimComponent) |
SaveValueEx(String, IProperty) |
SaveValueEx(String, Int32, Object) |
Top
Fields
Name | Description
_application |
_currentChildNodes |
_currentNodes |
_saveLoadedValues |
ChildNodes |
Top
See Also

Reference


XmlExtensions Methods

The XmlExtensions type exposes the following members.

Methods
Name | Description
GetNodes |
LoadEnd |
LoadStart |
LoadStartEx |
LoadValue |
LoadValueEx(String, Int32, Boolean) |
LoadValueEx(String, String, Boolean) |
LoadValueEx(String, String, Object, Object) |
LoadValueEx(String, String, Object, Boolean, IEnumerable) |
LoadValueEx2 |
SaveEnd |
SaveStart |
SaveValue(String, Boolean) |
SaveValue(String, Double) |
SaveValue(String, Int32) |
SaveValue(String, String) |
SaveValueEx(String, IEnumerableNullableDouble) |
SaveValueEx(String, IEnumerableNullableInt32) |
SaveValueEx(String, IEnumerableNullableColor) |
SaveValueEx(String, IEnumerableISimComponent) |
SaveValueEx(String, IProperty) |
SaveValueEx(String, Int32, Object) |
Top
See Also

Reference

XmlExtensions Class


XmlExtensions.GetNodes Method

XmlExtensionsGetNodes Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<XmlNode> GetNodes(
    this XmlNode parent,
    string firstName,
    string secondName,
    string childrenNames
)
public:
[ExtensionAttribute]
static IEnumerable<XmlNode^>^ GetNodes(
    XmlNode^ parent,
    String^ firstName,
    String^ secondName,
    String^ childrenNames
)

Parameters

parent
Type: System.XmlXmlNode
firstName
Type: SystemString
secondName
Type: SystemString
childrenNames
Type: SystemString

Return Value

Type: IEnumerableXmlNode

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.XmlExtensions.GetNodes(System.Xml.XmlNode,System.String,System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type XmlNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlExtensions Class


XmlExtensions.LoadEnd Method

XmlExtensionsLoadEnd Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadEnd(
    string name
)
public:
static void LoadEnd(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

XmlExtensions Class


XmlExtensions.LoadStart Method

XmlExtensionsLoadStart Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadStart(
    string childName,
    string childrenNames = null
)
public:
static void LoadStart(
    String^ childName,
    String^ childrenNames = nullptr
)

Parameters

childName
Type: SystemString
childrenNames (Optional)
Type: SystemString
See Also

Reference

XmlExtensions Class


XmlExtensions.LoadStartEx Method

XmlExtensionsLoadStartEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadStartEx(
    string childName,
    XmlNode currentChild,
    string childrenNames = null
)
public:
static void LoadStartEx(
    String^ childName,
    XmlNode^ currentChild,
    String^ childrenNames = nullptr
)

Parameters

childName
Type: SystemString
currentChild
Type: System.XmlXmlNode
childrenNames (Optional)
Type: SystemString
See Also

Reference

XmlExtensions Class


XmlExtensions.LoadValue Method

XmlExtensionsLoadValue Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadValue(
    string fromAttrib,
    string toProperty,
    Object toObj,
    bool skipOnEmpty
)
public:
static void LoadValue(
    String^ fromAttrib,
    String^ toProperty,
    Object^ toObj,
    bool skipOnEmpty
)

Parameters

fromAttrib
Type: SystemString
toProperty
Type: SystemString
toObj
Type: SystemObject
skipOnEmpty
Type: SystemBoolean
See Also

Reference

XmlExtensions Class


XmlExtensions.LoadValueEx Method

XmlExtensionsLoadValueEx Method

Overload List
Name | Description
LoadValueEx(String, Int32, Boolean) |
LoadValueEx(String, String, Boolean) |
LoadValueEx(String, String, Object, Object) |
LoadValueEx(String, String, Object, Boolean, IEnumerable) |
Top
See Also

Reference

XmlExtensions Class


XmlExtensions.LoadValueEx Method (String, Int32, Boolean)

XmlExtensionsLoadValueEx Method (String, Int32, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadValueEx(
    string fromAttrib,
    ref int toInt,
    bool skipOnEmpty
)
public:
static void LoadValueEx(
    String^ fromAttrib,
    int% toInt,
    bool skipOnEmpty
)

Parameters

fromAttrib
Type: SystemString
toInt
Type: SystemInt32
skipOnEmpty
Type: SystemBoolean
See Also

Reference

XmlExtensions Class
LoadValueEx Overload


XmlExtensions.LoadValueEx Method (String, String, Boolean)

XmlExtensionsLoadValueEx Method (String, String, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadValueEx(
    string fromAttrib,
    ref string toStr,
    bool skipOnEmpty
)
public:
static void LoadValueEx(
    String^ fromAttrib,
    String^% toStr,
    bool skipOnEmpty
)

Parameters

fromAttrib
Type: SystemString
toStr
Type: SystemString
skipOnEmpty
Type: SystemBoolean
See Also

Reference

XmlExtensions Class
LoadValueEx Overload


XmlExtensions.LoadValueEx Method (String, String, Object, Object[])

XmlExtensionsLoadValueEx Method (String, String, Object, Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadValueEx(
    string fromAttrib,
    string toProperty,
    Object toObj,
    Object[] valueMapping
)
public:
static void LoadValueEx(
    String^ fromAttrib,
    String^ toProperty,
    Object^ toObj,
    array<Object^>^ valueMapping
)

Parameters

fromAttrib
Type: SystemString
toProperty
Type: SystemString
toObj
Type: SystemObject
valueMapping
Type: SystemObject
See Also

Reference

XmlExtensions Class
LoadValueEx Overload


XmlExtensions.LoadValueEx Method (String, String, Object, Boolean, IEnumerable)

XmlExtensionsLoadValueEx Method (String, String, Object, Boolean, IEnumerable)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadValueEx(
    string fromAttrib,
    string toProperty,
    Object toObj,
    bool skipOnEmpty,
    IEnumerable indexedValues
)
public:
static void LoadValueEx(
    String^ fromAttrib,
    String^ toProperty,
    Object^ toObj,
    bool skipOnEmpty,
    IEnumerable^ indexedValues
)

Parameters

fromAttrib
Type: SystemString
toProperty
Type: SystemString
toObj
Type: SystemObject
skipOnEmpty
Type: SystemBoolean
indexedValues
Type: System.CollectionsIEnumerable
See Also

Reference

XmlExtensions Class
LoadValueEx Overload


XmlExtensions.LoadValueEx2 Method

XmlExtensionsLoadValueEx2 Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadValueEx2(
    string fromAttrib,
    string toProperty,
    Object toObj
)
public:
static void LoadValueEx2(
    String^ fromAttrib,
    String^ toProperty,
    Object^ toObj
)

Parameters

fromAttrib
Type: SystemString
toProperty
Type: SystemString
toObj
Type: SystemObject
See Also

Reference

XmlExtensions Class


XmlExtensions.SaveEnd Method

XmlExtensionsSaveEnd Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveEnd(
    string name
)
public:
static void SaveEnd(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

XmlExtensions Class


XmlExtensions.SaveStart Method

XmlExtensionsSaveStart Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveStart(
    string name
)
public:
static void SaveStart(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

XmlExtensions Class


XmlExtensions.SaveValue Method

XmlExtensionsSaveValue Method

Overload List
Name | Description
SaveValue(String, Boolean) |
SaveValue(String, Double) |
SaveValue(String, Int32) |
SaveValue(String, String) |
Top
See Also

Reference

XmlExtensions Class


XmlExtensions.SaveValue Method (String, Boolean)

XmlExtensionsSaveValue Method (String, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveValue(
    string toAttrib,
    bool val
)
public:
static void SaveValue(
    String^ toAttrib,
    bool val
)

Parameters

toAttrib
Type: SystemString
val
Type: SystemBoolean
See Also

Reference

XmlExtensions Class
SaveValue Overload


XmlExtensions.SaveValue Method (String, Double)

XmlExtensionsSaveValue Method (String, Double)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveValue(
    string toAttrib,
    double val
)
public:
static void SaveValue(
    String^ toAttrib,
    double val
)

Parameters

toAttrib
Type: SystemString
val
Type: SystemDouble
See Also

Reference

XmlExtensions Class
SaveValue Overload


XmlExtensions.SaveValue Method (String, Int32)

XmlExtensionsSaveValue Method (String, Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveValue(
    string toAttrib,
    int val
)
public:
static void SaveValue(
    String^ toAttrib,
    int val
)

Parameters

toAttrib
Type: SystemString
val
Type: SystemInt32
See Also

Reference

XmlExtensions Class
SaveValue Overload


XmlExtensions.SaveValue Method (String, String)

XmlExtensionsSaveValue Method (String, String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveValue(
    string toAttrib,
    string val
)
public:
static void SaveValue(
    String^ toAttrib,
    String^ val
)

Parameters

toAttrib
Type: SystemString
val
Type: SystemString
See Also

Reference

XmlExtensions Class
SaveValue Overload


XmlExtensions.SaveValueEx Method

XmlExtensionsSaveValueEx Method

Overload List
Name | Description
SaveValueEx(String, IEnumerableNullableDouble) |
SaveValueEx(String, IEnumerableNullableInt32) |
SaveValueEx(String, IEnumerableNullableColor) |
SaveValueEx(String, IEnumerableISimComponent) |
SaveValueEx(String, IProperty) |
SaveValueEx(String, Int32, Object) |
Top
See Also

Reference

XmlExtensions Class


XmlExtensions.SaveValueEx Method (String, IEnumerable(Nullable(Double)))

XmlExtensionsSaveValueEx Method (String, IEnumerableNullableDouble)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveValueEx(
    string toAttrib,
    IEnumerable<Nullable<double>> values
)
public:
static void SaveValueEx(
    String^ toAttrib,
    IEnumerable<Nullable<double>>^ values
)

Parameters

toAttrib
Type: SystemString
values
Type: System.Collections.GenericIEnumerableNullableDouble
See Also

Reference

XmlExtensions Class
SaveValueEx Overload


XmlExtensions.SaveValueEx Method (String, IEnumerable(Nullable(Int32)))

XmlExtensionsSaveValueEx Method (String, IEnumerableNullableInt32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveValueEx(
    string toAttrib,
    IEnumerable<Nullable<int>> values
)
public:
static void SaveValueEx(
    String^ toAttrib,
    IEnumerable<Nullable<int>>^ values
)

Parameters

toAttrib
Type: SystemString
values
Type: System.Collections.GenericIEnumerableNullableInt32
See Also

Reference

XmlExtensions Class
SaveValueEx Overload


XmlExtensions.SaveValueEx Method (String, IEnumerable(Nullable(Color)))

XmlExtensionsSaveValueEx Method (String, IEnumerableNullableColor)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveValueEx(
    string toAttrib,
    IEnumerable<Nullable<Color>> values
)
public:
static void SaveValueEx(
    String^ toAttrib,
    IEnumerable<Nullable<Color>>^ values
)

Parameters

toAttrib
Type: SystemString
values
Type: System.Collections.GenericIEnumerableNullableColor
See Also

Reference

XmlExtensions Class
SaveValueEx Overload


XmlExtensions.SaveValueEx Method (String, IEnumerable(ISimComponent))

XmlExtensionsSaveValueEx Method (String, IEnumerableISimComponent)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveValueEx(
    string toAttrib,
    IEnumerable<ISimComponent> comps
)
public:
static void SaveValueEx(
    String^ toAttrib,
    IEnumerable<ISimComponent^>^ comps
)

Parameters

toAttrib
Type: SystemString
comps
Type: System.Collections.GenericIEnumerableISimComponent
See Also

Reference

XmlExtensions Class
SaveValueEx Overload


XmlExtensions.SaveValueEx Method (String, IProperty)

XmlExtensionsSaveValueEx Method (String, IProperty)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveValueEx(
    string toAttrib,
    IProperty prop
)
public:
static void SaveValueEx(
    String^ toAttrib,
    IProperty^ prop
)

Parameters

toAttrib
Type: SystemString
prop
Type: VisualComponents.Create3DIProperty
See Also

Reference

XmlExtensions Class
SaveValueEx Overload


XmlExtensions.SaveValueEx Method (String, Int32, Object[])

XmlExtensionsSaveValueEx Method (String, Int32, Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SaveValueEx(
    string toAttrib,
    int val,
    Object[] valueMapping
)
public:
static void SaveValueEx(
    String^ toAttrib,
    int val,
    array<Object^>^ valueMapping
)

Parameters

toAttrib
Type: SystemString
val
Type: SystemInt32
valueMapping
Type: SystemObject
See Also

Reference

XmlExtensions Class
SaveValueEx Overload


XmlExtensions Fields

The XmlExtensions type exposes the following members.

Fields
Name | Description
_application |
_currentChildNodes |
_currentNodes |
_saveLoadedValues |
ChildNodes |
Top
See Also

Reference

XmlExtensions Class


XmlExtensions._application Field

XmlExtensions_application Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IApplication _application
public:
static IApplication^ _application

Field Value

Type: IApplication
See Also

Reference

XmlExtensions Class


XmlExtensions._currentChildNodes Field

XmlExtensions_currentChildNodes Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static List<List<XmlNode>> _currentChildNodes
public:
static List<List<XmlNode^>^>^ _currentChildNodes

Field Value

Type: ListListXmlNode
See Also

Reference

XmlExtensions Class


XmlExtensions._currentNodes Field

XmlExtensions_currentNodes Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static List<XmlNode> _currentNodes
public:
static List<XmlNode^>^ _currentNodes

Field Value

Type: ListXmlNode
See Also

Reference

XmlExtensions Class


XmlExtensions._saveLoadedValues Field

XmlExtensions_saveLoadedValues Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Dictionary<string, bool> _saveLoadedValues
public:
static Dictionary<String^, bool>^ _saveLoadedValues

Field Value

Type: DictionaryString, Boolean
See Also

Reference

XmlExtensions Class


XmlExtensions.ChildNodes Field

XmlExtensionsChildNodes Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static List<XmlNode> ChildNodes
public:
static List<XmlNode^>^ ChildNodes

Field Value

Type: ListXmlNode
See Also

Reference

XmlExtensions Class


VisualComponents.UX.Shared.Actions Namespace

Classes
 | Class | Description
Public class | AddDecalAction |
Public class | ExportToPDFAction | Action for saving pdf file, with ICommandPanelAction interface Similar to actions/classes: PdfExportAction, PdfExportActionWithGroup, PdfRecordCommand, IPdfRecordExporter, IPdfReportBuilder, VCPDFReportBuilder, and IU3DRecorder. Note: see also recording logic like: ISimulation.IsVideoRecordingEnabled/ISimulationService.IsSimulationRecordingOn/Simulation.U3DRecorder.IsRecording. Note: IPdfRecordExporter is actually just calling VCPDFReportBuilder class with pdf filename. Note: this instance must be used with Get``1(String).
Public class | ExportToVideoAction | Action for saving video file. Similar to IVideoRecordExporter class, but also has ICommandPanelAction interface. Note: this instance must be used with Get``1(String).
Public class | GeoFeatureInvertAction |
Public class | GeoFeatureSplitAction |
Public class | JointLimitTestAction |
Public class | MaterialAssignAction |
Public class | MaterialEditAction |
Public class | MergeFacesAction |
Public class | TextureMappingAction |
Interfaces
 | Interface | Description
Public interface | IExportToPDFAction |
Public interface | IExportToVideoAction |
Public interface | IGeoFeatureInvertAction |
Public interface | IGeoFeatureSplitAction |
Public interface | IMaterialAssignAction |
Public interface | IMaterialEditAction |
Public interface | IMergeFacesAction |
Enumerations
 | Enumeration | Description
Public enumeration | MaterialAssignFor |
Public enumeration | MaterialAssignMode |
Public enumeration | QualityType |


AddDecalAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.ActionsAddDecalAction

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AddDecalAction : IAddDecalAction,
    INotAbortableCommand, ICommandPanelAction
public ref class AddDecalAction : IAddDecalAction,
    INotAbortableCommand, ICommandPanelAction

The AddDecalAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplicationStatusService |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | DoDecal |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateManipulatorSize |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


AddDecalAction Properties

The AddDecalAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplicationStatusService |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Title |
Top
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.ActionFinished Property

AddDecalActionActionFinished Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.ActionProperties Property

AddDecalActionActionProperties Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.ApplicationStatusService Property

AddDecalActionApplicationStatusService Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplicationStatusService ApplicationStatusService { get; }
public:
property IApplicationStatusService^ ApplicationStatusService {
    IApplicationStatusService^ get ();
}

Property Value

Type: IApplicationStatusService
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.ApplyButtonText Property

AddDecalActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.AssociatedModelId Property

AddDecalActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.AssociatedSiteId Property

AddDecalActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.CallingCommandName Property

AddDecalActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.CancelButtonText Property

AddDecalActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.Description Property

AddDecalActionDescription Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.ErrorMessage Property

AddDecalActionErrorMessage Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.IsActive Property

AddDecalActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; }
public:
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.Title Property

AddDecalActionTitle Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction Methods

The AddDecalAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | DoDecal |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateManipulatorSize |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.ApplyAction Method

AddDecalActionApplyAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.AddDecalAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.CancelAction Method

AddDecalActionCancelAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.DoDecal Method

AddDecalActionDoDecal Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DoDecal()
public:
virtual void DoDecal() sealed

Implements

IAddDecalActionDoDecal
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.StartAction Method

AddDecalActionStartAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


AddDecalAction.UpdateManipulatorSize Method

AddDecalActionUpdateManipulatorSize Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateManipulatorSize()
public:
virtual void UpdateManipulatorSize() sealed

Implements

IAddDecalActionUpdateManipulatorSize
See Also

Reference

AddDecalAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction Class

Action for saving pdf file, with ICommandPanelAction interface Similar to actions/classes: PdfExportAction, PdfExportActionWithGroup, PdfRecordCommand, IPdfRecordExporter, IPdfReportBuilder, VCPDFReportBuilder, and IU3DRecorder. Note: see also recording logic like: ISimulation.IsVideoRecordingEnabled/ISimulationService.IsSimulationRecordingOn/Simulation.U3DRecorder.IsRecording. Note: IPdfRecordExporter is actually just calling VCPDFReportBuilder class with pdf filename. Note: this instance must be used with Get``1(String).
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.ActionsExportToPDFAction

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExportToPDFAction : ICommandPanelAction,
    IExportToPDFAction, IPdfRecorder
public ref class ExportToPDFAction : ICommandPanelAction,
    IExportToPDFAction, IPdfRecorder

The ExportToPDFAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | IsRecording |
Public property | PdfReportBuilder |
Public property | ShowPdf |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | StartRecording(String, Int32, Uri) |
Public method | StartRecording(String, Int32, IPdfReportBuilder, Uri, Action) |
Public method | StopRecording(Boolean) |
Public method | StopRecording(Boolean, Boolean) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PDFCommandStarted |
Public event | PDFCommandStopped |
Top
Fields
 | Name | Description
 | BOMDESCRIPTION |
 | BOMNAME |
 | HASBOM |
Public field | PdfDescriptionTag |
Public field | PdfGroupDescriptionTag |
Public field | PdfGroupNameTag |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction Properties

The ExportToPDFAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | IsRecording |
Public property | PdfReportBuilder |
Public property | ShowPdf |
Public property | Title |
Top
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.ActionFinished Property

ExportToPDFActionActionFinished Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.ActionProperties Property

ExportToPDFActionActionProperties Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.ApplyButtonText Property

ExportToPDFActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.AssociatedModelId Property

ExportToPDFActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.AssociatedSiteId Property

ExportToPDFActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.CallingCommandName Property

ExportToPDFActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.CancelButtonText Property

ExportToPDFActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.Description Property

ExportToPDFActionDescription Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.ErrorMessage Property

ExportToPDFActionErrorMessage Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.IsActive Property

ExportToPDFActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; }
public:
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.IsRecording Property

ExportToPDFActionIsRecording Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsRecording { get; }
public:
virtual property bool IsRecording {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IExportToPDFActionIsRecording
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.PdfReportBuilder Property

ExportToPDFActionPdfReportBuilder Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPdfReportBuilder PdfReportBuilder { get; }
public:
virtual property IPdfReportBuilder^ PdfReportBuilder {
    IPdfReportBuilder^ get () sealed;
}

Property Value

Type: IPdfReportBuilder

Implements

IExportToPDFActionPdfReportBuilder
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.ShowPdf Property

ExportToPDFActionShowPdf Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowPdf { get; set; }
public:
virtual property bool ShowPdf {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPdfRecorderShowPdf
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.Title Property

ExportToPDFActionTitle Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction Methods

The ExportToPDFAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | StartRecording(String, Int32, Uri) |
Public method | StartRecording(String, Int32, IPdfReportBuilder, Uri, Action) |
Public method | StopRecording(Boolean) |
Public method | StopRecording(Boolean, Boolean) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.ApplyAction Method

ExportToPDFActionApplyAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.ExportToPDFAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.CancelAction Method

ExportToPDFActionCancelAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.StartAction Method

ExportToPDFActionStartAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.StartRecording Method

ExportToPDFActionStartRecording Method

Overload List
 | Name | Description
Public method | StartRecording(String, Int32, Uri) |
Public method | StartRecording(String, Int32, IPdfReportBuilder, Uri, Action) |
Top
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.StartRecording Method (String, Int32, Uri)

ExportToPDFActionStartRecording Method (String, Int32, Uri)

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool StartRecording(
    string file,
    int frameRate,
    Uri templatePath
)
public:
virtual bool StartRecording(
    String^ file,
    int frameRate,
    Uri^ templatePath
) sealed

Parameters

file
Type: SystemString
frameRate
Type: SystemInt32
templatePath
Type: SystemUri

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.ExportToPDFAction.StartRecording(System.String,System.Int32,System.Uri)"]

Implements

IPdfRecorderStartRecording(String, Int32, Uri)
See Also

Reference

ExportToPDFAction Class
StartRecording Overload
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.StartRecording Method (String, Int32, IPdfReportBuilder, Uri, Action)

ExportToPDFActionStartRecording Method (String, Int32, IPdfReportBuilder, Uri, Action)

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool StartRecording(
    string file,
    int frameRate,
    IPdfReportBuilder builder,
    Uri templatePath,
    Action simulationEnd
)
public:
virtual bool StartRecording(
    String^ file,
    int frameRate,
    IPdfReportBuilder^ builder,
    Uri^ templatePath,
    Action^ simulationEnd
) sealed

Parameters

file
Type: SystemString
frameRate
Type: SystemInt32
builder
Type: VisualComponents.Create3DIPdfReportBuilder
templatePath
Type: SystemUri
simulationEnd
Type: SystemAction

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.ExportToPDFAction.StartRecording(System.String,System.Int32,VisualComponents.Create3D.IPdfReportBuilder,System.Uri,System.Action)"]

Implements

IExportToPDFActionStartRecording(String, Int32, IPdfReportBuilder, Uri, Action)
See Also

Reference

ExportToPDFAction Class
StartRecording Overload
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.StopRecording Method

ExportToPDFActionStopRecording Method

Overload List
 | Name | Description
Public method | StopRecording(Boolean) |
Public method | StopRecording(Boolean, Boolean) |
Top
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.StopRecording Method (Boolean)

ExportToPDFActionStopRecording Method (Boolean)

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StopRecording(
    bool save
)
public:
virtual void StopRecording(
    bool save
) sealed

Parameters

save
Type: SystemBoolean

Implements

IPdfRecorderStopRecording(Boolean)
See Also

Reference

ExportToPDFAction Class
StopRecording Overload
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.StopRecording Method (Boolean, Boolean)

ExportToPDFActionStopRecording Method (Boolean, Boolean)

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StopRecording(
    bool save,
    bool endAction
)
public:
virtual void StopRecording(
    bool save,
    bool endAction
) sealed

Parameters

save
Type: SystemBoolean
endAction
Type: SystemBoolean

Implements

IExportToPDFActionStopRecording(Boolean, Boolean)
See Also

Reference

ExportToPDFAction Class
StopRecording Overload
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction Events

The ExportToPDFAction type exposes the following members.

Events
 | Name | Description
Public event | PDFCommandStarted |
Public event | PDFCommandStopped |
Top
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.PDFCommandStarted Event

ExportToPDFActionPDFCommandStarted Event

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler PDFCommandStarted
public:
virtual  event EventHandler^ PDFCommandStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IExportToPDFActionPDFCommandStarted
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.PDFCommandStopped Event

ExportToPDFActionPDFCommandStopped Event

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler PDFCommandStopped
public:
virtual  event EventHandler^ PDFCommandStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IExportToPDFActionPDFCommandStopped
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction Fields

The ExportToPDFAction type exposes the following members.

Fields
 | Name | Description
 | BOMDESCRIPTION |
 | BOMNAME |
 | HASBOM |
Public field | PdfDescriptionTag |
Public field | PdfGroupDescriptionTag |
Public field | PdfGroupNameTag |
Top
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.BOMDESCRIPTION Field

ExportToPDFActionBOMDESCRIPTION Field

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string BOMDESCRIPTION = "BOMdescription"
public:
literal String^ BOMDESCRIPTION = "BOMdescription"

Field Value

Type: String
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.BOMNAME Field

ExportToPDFActionBOMNAME Field

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string BOMNAME = "BOMname"
public:
literal String^ BOMNAME = "BOMname"

Field Value

Type: String
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.HASBOM Field

ExportToPDFActionHASBOM Field

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string HASBOM = "BOM"
public:
literal String^ HASBOM = "BOM"

Field Value

Type: String
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.PdfDescriptionTag Field

ExportToPDFActionPdfDescriptionTag Field

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PdfDescriptionTag
public:
String^ PdfDescriptionTag

Field Value

Type: String
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.PdfGroupDescriptionTag Field

ExportToPDFActionPdfGroupDescriptionTag Field

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PdfGroupDescriptionTag
public:
String^ PdfGroupDescriptionTag

Field Value

Type: String
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToPDFAction.PdfGroupNameTag Field

ExportToPDFActionPdfGroupNameTag Field

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PdfGroupNameTag
public:
String^ PdfGroupNameTag

Field Value

Type: String
See Also

Reference

ExportToPDFAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction Class

Action for saving video file. Similar to IVideoRecordExporter class, but also has ICommandPanelAction interface. Note: this instance must be used with Get``1(String).
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.ActionsExportToVideoAction

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExportToVideoAction : ICommandPanelAction,
    IExportToVideoAction
public ref class ExportToVideoAction : ICommandPanelAction,
    IExportToVideoAction

The ExportToVideoAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | IsRecording |
Public property | Title |
Public property | VideoRecorder |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetResolutionWidthHeight |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | StartRecording |
Public method | StopRecording |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | VideoCommandStarted |
Public event | VideoCommandStopped |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction Properties

The ExportToVideoAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | IsRecording |
Public property | Title |
Public property | VideoRecorder |
Top
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.ActionFinished Property

ExportToVideoActionActionFinished Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; protected set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    protected: void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.ActionProperties Property

ExportToVideoActionActionProperties Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.ApplyButtonText Property

ExportToVideoActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.AssociatedModelId Property

ExportToVideoActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.AssociatedSiteId Property

ExportToVideoActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.CallingCommandName Property

ExportToVideoActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.CancelButtonText Property

ExportToVideoActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.Description Property

ExportToVideoActionDescription Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.ErrorMessage Property

ExportToVideoActionErrorMessage Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.IsActive Property

ExportToVideoActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; }
public:
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.IsRecording Property

ExportToVideoActionIsRecording Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsRecording { get; }
public:
virtual property bool IsRecording {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IExportToVideoActionIsRecording
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.Title Property

ExportToVideoActionTitle Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.VideoRecorder Property

ExportToVideoActionVideoRecorder Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IVideoRecorder VideoRecorder { get; }
public:
virtual property IVideoRecorder^ VideoRecorder {
    IVideoRecorder^ get () sealed;
}

Property Value

Type: IVideoRecorder

Implements

IExportToVideoActionVideoRecorder
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction Methods

The ExportToVideoAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetResolutionWidthHeight |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | StartRecording |
Public method | StopRecording |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.ApplyAction Method

ExportToVideoActionApplyAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.ExportToVideoAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.CancelAction Method

ExportToVideoActionCancelAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.GetResolutionWidthHeight Method

ExportToVideoActionGetResolutionWidthHeight Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Tuple<int, int> GetResolutionWidthHeight(
    int pixels
)
public:
virtual Tuple<int, int>^ GetResolutionWidthHeight(
    int pixels
) sealed

Parameters

pixels
Type: SystemInt32

Return Value

Type: TupleInt32, Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.ExportToVideoAction.GetResolutionWidthHeight(System.Int32)"]

Implements

IExportToVideoActionGetResolutionWidthHeight(Int32)
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.StartAction Method

ExportToVideoActionStartAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.StartRecording Method

ExportToVideoActionStartRecording Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool StartRecording(
    string file,
    int startTime,
    int endTime,
    int resolution,
    int frameRate,
    VideoCodec codec,
    QualityType quality,
    Action simulationEnd
)
public:
virtual bool StartRecording(
    String^ file,
    int startTime,
    int endTime,
    int resolution,
    int frameRate,
    VideoCodec codec,
    QualityType quality,
    Action^ simulationEnd
) sealed

Parameters

file
Type: SystemString
startTime
Type: SystemInt32
endTime
Type: SystemInt32
resolution
Type: SystemInt32
frameRate
Type: SystemInt32
codec
Type: VisualComponents.Create3DVideoCodec
quality
Type: VisualComponents.UX.Shared.ActionsQualityType
simulationEnd
Type: SystemAction

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.ExportToVideoAction.StartRecording(System.String,System.Int32,System.Int32,System.Int32,System.Int32,VisualComponents.Create3D.VideoCodec,VisualComponents.UX.Shared.Actions.QualityType,System.Action)"]

Implements

IExportToVideoActionStartRecording(String, Int32, Int32, Int32, Int32, VideoCodec, QualityType, Action)
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.StopRecording Method

ExportToVideoActionStopRecording Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StopRecording(
    bool save,
    bool endAction
)
public:
virtual void StopRecording(
    bool save,
    bool endAction
) sealed

Parameters

save
Type: SystemBoolean
endAction
Type: SystemBoolean

Implements

IExportToVideoActionStopRecording(Boolean, Boolean)
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction Events

The ExportToVideoAction type exposes the following members.

Events
 | Name | Description
Public event | VideoCommandStarted |
Public event | VideoCommandStopped |
Top
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.VideoCommandStarted Event

ExportToVideoActionVideoCommandStarted Event

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler VideoCommandStarted
public:
virtual  event EventHandler^ VideoCommandStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IExportToVideoActionVideoCommandStarted
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


ExportToVideoAction.VideoCommandStopped Event

ExportToVideoActionVideoCommandStopped Event

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler VideoCommandStopped
public:
virtual  event EventHandler^ VideoCommandStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IExportToVideoActionVideoCommandStopped
See Also

Reference

ExportToVideoAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.ActionsGeoFeatureInvertAction

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GeoFeatureInvertAction : IGeoFeatureInvertAction,
    IGeoFeatureBaseOperationLevelAction, ICommandPanelAction
public ref class GeoFeatureInvertAction : IGeoFeatureInvertAction,
    IGeoFeatureBaseOperationLevelAction, ICommandPanelAction

The GeoFeatureInvertAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Level |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFaces |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction Properties

The GeoFeatureInvertAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Level |
Public property | Title |
Top
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.ActionFinished Property

GeoFeatureInvertActionActionFinished Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.ActionProperties Property

GeoFeatureInvertActionActionProperties Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.ApplyButtonText Property

GeoFeatureInvertActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.AssociatedModelId Property

GeoFeatureInvertActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.AssociatedSiteId Property

GeoFeatureInvertActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.CallingCommandName Property

GeoFeatureInvertActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.CancelButtonText Property

GeoFeatureInvertActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.Description Property

GeoFeatureInvertActionDescription Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.ErrorMessage Property

GeoFeatureInvertActionErrorMessage Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.IsActive Property

GeoFeatureInvertActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; }
public:
virtual property bool IsActive {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IGeoFeatureBaseOperationLevelActionIsActive
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.Level Property

GeoFeatureInvertActionLevel Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FeatureOperationLevel Level { get; set; }
public:
virtual property FeatureOperationLevel Level {
    FeatureOperationLevel get () sealed;
    void set (FeatureOperationLevel value) sealed;
}

Property Value

Type: FeatureOperationLevel

Implements

IGeoFeatureBaseOperationLevelActionLevel
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.Title Property

GeoFeatureInvertActionTitle Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction Methods

The GeoFeatureInvertAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFaces |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.ApplyAction Method

GeoFeatureInvertActionApplyAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.GeoFeatureInvertAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.CancelAction Method

GeoFeatureInvertActionCancelAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.FindFaces Method

GeoFeatureInvertActionFindFaces Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Tuple<ISimComponent, IEnumerable<IFace>> FindFaces(
    int x,
    int y
)
public:
virtual Tuple<ISimComponent^, IEnumerable<IFace^>^>^ FindFaces(
    int x,
    int y
) sealed

Parameters

x
Type: SystemInt32
y
Type: SystemInt32

Return Value

Type: TupleISimComponent, IEnumerableIFace

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.GeoFeatureInvertAction.FindFaces(System.Int32,System.Int32)"]

Implements

IGeoFeatureBaseOperationLevelActionFindFaces(Int32, Int32)
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureInvertAction.StartAction Method

GeoFeatureInvertActionStartAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

GeoFeatureInvertAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.ActionsGeoFeatureSplitAction

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GeoFeatureSplitAction : IGeoFeatureSplitAction,
    IGeoFeatureBaseOperationLevelAction, ICommandPanelAction
public ref class GeoFeatureSplitAction : IGeoFeatureSplitAction,
    IGeoFeatureBaseOperationLevelAction, ICommandPanelAction

The GeoFeatureSplitAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Level |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFaces |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction Properties

The GeoFeatureSplitAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Level |
Public property | Title |
Top
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.ActionFinished Property

GeoFeatureSplitActionActionFinished Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.ActionProperties Property

GeoFeatureSplitActionActionProperties Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.ApplyButtonText Property

GeoFeatureSplitActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.AssociatedModelId Property

GeoFeatureSplitActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.AssociatedSiteId Property

GeoFeatureSplitActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.CallingCommandName Property

GeoFeatureSplitActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.CancelButtonText Property

GeoFeatureSplitActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.Description Property

GeoFeatureSplitActionDescription Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.ErrorMessage Property

GeoFeatureSplitActionErrorMessage Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.IsActive Property

GeoFeatureSplitActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; }
public:
virtual property bool IsActive {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IGeoFeatureBaseOperationLevelActionIsActive
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.Level Property

GeoFeatureSplitActionLevel Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FeatureOperationLevel Level { get; set; }
public:
virtual property FeatureOperationLevel Level {
    FeatureOperationLevel get () sealed;
    void set (FeatureOperationLevel value) sealed;
}

Property Value

Type: FeatureOperationLevel

Implements

IGeoFeatureBaseOperationLevelActionLevel
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.Title Property

GeoFeatureSplitActionTitle Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction Methods

The GeoFeatureSplitAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFaces |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.ApplyAction Method

GeoFeatureSplitActionApplyAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.GeoFeatureSplitAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.CancelAction Method

GeoFeatureSplitActionCancelAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.FindFaces Method

GeoFeatureSplitActionFindFaces Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Tuple<ISimComponent, IEnumerable<IFace>> FindFaces(
    int x,
    int y
)
public:
virtual Tuple<ISimComponent^, IEnumerable<IFace^>^>^ FindFaces(
    int x,
    int y
) sealed

Parameters

x
Type: SystemInt32
y
Type: SystemInt32

Return Value

Type: TupleISimComponent, IEnumerableIFace

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.GeoFeatureSplitAction.FindFaces(System.Int32,System.Int32)"]

Implements

IGeoFeatureBaseOperationLevelActionFindFaces(Int32, Int32)
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


GeoFeatureSplitAction.StartAction Method

GeoFeatureSplitActionStartAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

GeoFeatureSplitAction Class
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction Interface

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExportToPDFAction : IPdfRecorder,
    ICommandPanelAction
public interface class IExportToPDFAction : IPdfRecorder,
    ICommandPanelAction

The IExportToPDFAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsRecording |
Public property | PdfReportBuilder | This property is set only when recording.
Public property | ShowPdf | Show or not Pdf after creation (Inherited from IPdfRecorder.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | StartRecording(String, Int32, Uri) | Starts the simulation recording to Pdf. (Inherited from IPdfRecorder.)
Public method | StartRecording(String, Int32, IPdfReportBuilder, Uri, Action) |
Public method | StopRecording(Boolean) | Stops pdf creation (Inherited from IPdfRecorder.)
Public method | StopRecording(Boolean, Boolean) |
Top
Events
 | Name | Description
Public event | PDFCommandStarted |
Public event | PDFCommandStopped |
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction Properties

The IExportToPDFAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsRecording |
Public property | PdfReportBuilder | This property is set only when recording.
Public property | ShowPdf | Show or not Pdf after creation (Inherited from IPdfRecorder.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IExportToPDFAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction.IsRecording Property

IExportToPDFActionIsRecording Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRecording { get; }
property bool IsRecording {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IExportToPDFAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction.PdfReportBuilder Property

IExportToPDFActionPdfReportBuilder Property

This property is set only when recording.

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPdfReportBuilder PdfReportBuilder { get; }
property IPdfReportBuilder^ PdfReportBuilder {
    IPdfReportBuilder^ get ();
}

Property Value

Type: IPdfReportBuilder
See Also

Reference

IExportToPDFAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction Methods

The IExportToPDFAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | StartRecording(String, Int32, Uri) | Starts the simulation recording to Pdf. (Inherited from IPdfRecorder.)
Public method | StartRecording(String, Int32, IPdfReportBuilder, Uri, Action) |
Public method | StopRecording(Boolean) | Stops pdf creation (Inherited from IPdfRecorder.)
Public method | StopRecording(Boolean, Boolean) |
Top
See Also

Reference

IExportToPDFAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction.StartRecording Method

IExportToPDFActionStartRecording Method

Overload List
 | Name | Description
Public method | StartRecording(String, Int32, Uri) | Starts the simulation recording to Pdf. (Inherited from IPdfRecorder.)
Public method | StartRecording(String, Int32, IPdfReportBuilder, Uri, Action) |
Top
See Also

Reference

IExportToPDFAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction.StartRecording Method (String, Int32, IPdfReportBuilder, Uri, Action)

IExportToPDFActionStartRecording Method (String, Int32, IPdfReportBuilder, Uri, Action)

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool StartRecording(
    string file,
    int frameRate,
    IPdfReportBuilder builder,
    Uri templatePath,
    Action simulationEnd
)
bool StartRecording(
    String^ file,
    int frameRate,
    IPdfReportBuilder^ builder,
    Uri^ templatePath,
    Action^ simulationEnd
)

Parameters

file
Type: SystemString
frameRate
Type: SystemInt32
builder
Type: VisualComponents.Create3DIPdfReportBuilder
templatePath
Type: SystemUri
simulationEnd
Type: SystemAction

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.IExportToPDFAction.StartRecording(System.String,System.Int32,VisualComponents.Create3D.IPdfReportBuilder,System.Uri,System.Action)"]

See Also

Reference

IExportToPDFAction Interface
StartRecording Overload
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction.StopRecording Method

IExportToPDFActionStopRecording Method

Overload List
 | Name | Description
Public method | StopRecording(Boolean) | Stops pdf creation (Inherited from IPdfRecorder.)
Public method | StopRecording(Boolean, Boolean) |
Top
See Also

Reference

IExportToPDFAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction.StopRecording Method (Boolean, Boolean)

IExportToPDFActionStopRecording Method (Boolean, Boolean)

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopRecording(
    bool save,
    bool endAction
)
void StopRecording(
    bool save,
    bool endAction
)

Parameters

save
Type: SystemBoolean
endAction
Type: SystemBoolean
See Also

Reference

IExportToPDFAction Interface
StopRecording Overload
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction Events

The IExportToPDFAction type exposes the following members.

Events
 | Name | Description
Public event | PDFCommandStarted |
Public event | PDFCommandStopped |
Top
See Also

Reference

IExportToPDFAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction.PDFCommandStarted Event

IExportToPDFActionPDFCommandStarted Event

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler PDFCommandStarted
 event EventHandler^ PDFCommandStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IExportToPDFAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToPDFAction.PDFCommandStopped Event

IExportToPDFActionPDFCommandStopped Event

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler PDFCommandStopped
 event EventHandler^ PDFCommandStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IExportToPDFAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction Interface

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExportToVideoAction : ICommandPanelAction
public interface class IExportToVideoAction : ICommandPanelAction

The IExportToVideoAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsRecording |
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Public property | VideoRecorder | This property is set only when recording.
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | GetResolutionWidthHeight |
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | StartRecording |
Public method | StopRecording |
Top
Events
 | Name | Description
Public event | VideoCommandStarted |
Public event | VideoCommandStopped |
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction Properties

The IExportToVideoAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsRecording |
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Public property | VideoRecorder | This property is set only when recording.
Top
See Also

Reference

IExportToVideoAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction.IsRecording Property

IExportToVideoActionIsRecording Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRecording { get; }
property bool IsRecording {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IExportToVideoAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction.VideoRecorder Property

IExportToVideoActionVideoRecorder Property

This property is set only when recording.

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IVideoRecorder VideoRecorder { get; }
property IVideoRecorder^ VideoRecorder {
    IVideoRecorder^ get ();
}

Property Value

Type: IVideoRecorder
See Also

Reference

IExportToVideoAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction Methods

The IExportToVideoAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | GetResolutionWidthHeight |
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | StartRecording |
Public method | StopRecording |
Top
See Also

Reference

IExportToVideoAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction.GetResolutionWidthHeight Method

IExportToVideoActionGetResolutionWidthHeight Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<int, int> GetResolutionWidthHeight(
    int pixels
)
Tuple<int, int>^ GetResolutionWidthHeight(
    int pixels
)

Parameters

pixels
Type: SystemInt32

Return Value

Type: TupleInt32, Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.IExportToVideoAction.GetResolutionWidthHeight(System.Int32)"]

See Also

Reference

IExportToVideoAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction.StartRecording Method

IExportToVideoActionStartRecording Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool StartRecording(
    string file,
    int startTime,
    int endTime,
    int resolution,
    int frameRate,
    VideoCodec codec,
    QualityType quality,
    Action simulationEnd
)
bool StartRecording(
    String^ file,
    int startTime,
    int endTime,
    int resolution,
    int frameRate,
    VideoCodec codec,
    QualityType quality,
    Action^ simulationEnd
)

Parameters

file
Type: SystemString
startTime
Type: SystemInt32
endTime
Type: SystemInt32
resolution
Type: SystemInt32
frameRate
Type: SystemInt32
codec
Type: VisualComponents.Create3DVideoCodec
quality
Type: VisualComponents.UX.Shared.ActionsQualityType
simulationEnd
Type: SystemAction

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.IExportToVideoAction.StartRecording(System.String,System.Int32,System.Int32,System.Int32,System.Int32,VisualComponents.Create3D.VideoCodec,VisualComponents.UX.Shared.Actions.QualityType,System.Action)"]

See Also

Reference

IExportToVideoAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction.StopRecording Method

IExportToVideoActionStopRecording Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopRecording(
    bool save,
    bool endAction
)
void StopRecording(
    bool save,
    bool endAction
)

Parameters

save
Type: SystemBoolean
endAction
Type: SystemBoolean
See Also

Reference

IExportToVideoAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction Events

The IExportToVideoAction type exposes the following members.

Events
 | Name | Description
Public event | VideoCommandStarted |
Public event | VideoCommandStopped |
Top
See Also

Reference

IExportToVideoAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction.VideoCommandStarted Event

IExportToVideoActionVideoCommandStarted Event

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler VideoCommandStarted
 event EventHandler^ VideoCommandStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IExportToVideoAction Interface
VisualComponents.UX.Shared.Actions Namespace


IExportToVideoAction.VideoCommandStopped Event

IExportToVideoActionVideoCommandStopped Event

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler VideoCommandStopped
 event EventHandler^ VideoCommandStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IExportToVideoAction Interface
VisualComponents.UX.Shared.Actions Namespace


IGeoFeatureInvertAction Interface

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGeoFeatureInvertAction : IGeoFeatureBaseOperationLevelAction,
    ICommandPanelAction
public interface class IGeoFeatureInvertAction : IGeoFeatureBaseOperationLevelAction,
    ICommandPanelAction

The IGeoFeatureInvertAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsActive | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Level | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | FindFaces | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


IGeoFeatureInvertAction Properties

The IGeoFeatureInvertAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsActive | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Level | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IGeoFeatureInvertAction Interface
VisualComponents.UX.Shared.Actions Namespace


IGeoFeatureInvertAction Methods

The IGeoFeatureInvertAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | FindFaces | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IGeoFeatureInvertAction Interface
VisualComponents.UX.Shared.Actions Namespace


IGeoFeatureSplitAction Interface

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGeoFeatureSplitAction : IGeoFeatureBaseOperationLevelAction,
    ICommandPanelAction
public interface class IGeoFeatureSplitAction : IGeoFeatureBaseOperationLevelAction,
    ICommandPanelAction

The IGeoFeatureSplitAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsActive | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Level | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | FindFaces | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


IGeoFeatureSplitAction Properties

The IGeoFeatureSplitAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsActive | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Level | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IGeoFeatureSplitAction Interface
VisualComponents.UX.Shared.Actions Namespace


IGeoFeatureSplitAction Methods

The IGeoFeatureSplitAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | FindFaces | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IGeoFeatureSplitAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction Interface

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMaterialAssignAction
public interface class IMaterialAssignAction

The IMaterialAssignAction type exposes the following members.

Properties
 | Name | Description
Public property | AssignFor |
Public property | AssignMode |
Public property | IsActive |
Top
Methods
 | Name | Description
Public method | DeleteMaterialFromLayout |
Public method | HandleClick |
Public method | ReplaceAllToNewMaterial |
Public method | SelectAllSetsWithMaterial |
Public method | SelectMaterial |
Public method | StartAction |
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction Properties

The IMaterialAssignAction type exposes the following members.

Properties
 | Name | Description
Public property | AssignFor |
Public property | AssignMode |
Public property | IsActive |
Top
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction.AssignFor Property

IMaterialAssignActionAssignFor Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MaterialAssignFor AssignFor { get; set; }
property MaterialAssignFor AssignFor {
    MaterialAssignFor get ();
    void set (MaterialAssignFor value);
}

Property Value

Type: MaterialAssignFor
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction.AssignMode Property

IMaterialAssignActionAssignMode Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MaterialAssignMode AssignMode { get; set; }
property MaterialAssignMode AssignMode {
    MaterialAssignMode get ();
    void set (MaterialAssignMode value);
}

Property Value

Type: MaterialAssignMode
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction.IsActive Property

IMaterialAssignActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; }
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction Methods

The IMaterialAssignAction type exposes the following members.

Methods
 | Name | Description
Public method | DeleteMaterialFromLayout |
Public method | HandleClick |
Public method | ReplaceAllToNewMaterial |
Public method | SelectAllSetsWithMaterial |
Public method | SelectMaterial |
Public method | StartAction |
Top
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction.DeleteMaterialFromLayout Method

IMaterialAssignActionDeleteMaterialFromLayout Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteMaterialFromLayout(
    IMaterial mat
)
void DeleteMaterialFromLayout(
    IMaterial^ mat
)

Parameters

mat
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction.HandleClick Method

IMaterialAssignActionHandleClick Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void HandleClick(
    int x,
    int y,
    bool multiselect
)
void HandleClick(
    int x,
    int y,
    bool multiselect
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
multiselect
Type: SystemBoolean
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction.ReplaceAllToNewMaterial Method

IMaterialAssignActionReplaceAllToNewMaterial Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReplaceAllToNewMaterial(
    IMaterial matPrev,
    IMaterial mat
)
void ReplaceAllToNewMaterial(
    IMaterial^ matPrev,
    IMaterial^ mat
)

Parameters

matPrev
Type: VisualComponents.Create3DIMaterial
mat
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction.SelectAllSetsWithMaterial Method

IMaterialAssignActionSelectAllSetsWithMaterial Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectAllSetsWithMaterial(
    IMaterial mat
)
void SelectAllSetsWithMaterial(
    IMaterial^ mat
)

Parameters

mat
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction.SelectMaterial Method

IMaterialAssignActionSelectMaterial Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectMaterial(
    IMaterial m
)
void SelectMaterial(
    IMaterial^ m
)

Parameters

m
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialAssignAction.StartAction Method

IMaterialAssignActionStartAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
)

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs
See Also

Reference

IMaterialAssignAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialEditAction Interface

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMaterialEditAction
public interface class IMaterialEditAction

The IMaterialEditAction type exposes the following members.

Properties
 | Name | Description
Public property | IsActive |
Top
Methods
 | Name | Description
Public method | StartAction |
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


IMaterialEditAction Properties

The IMaterialEditAction type exposes the following members.

Properties
 | Name | Description
Public property | IsActive |
Top
See Also

Reference

IMaterialEditAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialEditAction.IsActive Property

IMaterialEditActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; }
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterialEditAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialEditAction Methods

The IMaterialEditAction type exposes the following members.

Methods
 | Name | Description
Public method | StartAction |
Top
See Also

Reference

IMaterialEditAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMaterialEditAction.StartAction Method

IMaterialEditActionStartAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartAction(
    IMaterial material,
    EventHandler<ResultCompletionEventArgs> completed = null
)
void StartAction(
    IMaterial^ material,
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
)

Parameters

material
Type: VisualComponents.Create3DIMaterial
completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs
See Also

Reference

IMaterialEditAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMergeFacesAction Interface

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMergeFacesAction : IGeoFeatureBaseOperationLevelAction,
    ICommandPanelAction
public interface class IMergeFacesAction : IGeoFeatureBaseOperationLevelAction,
    ICommandPanelAction

The IMergeFacesAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsActive | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Level | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | OnlyBoundaries |
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Public property | Tolerance |
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | FindFaces | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


IMergeFacesAction Properties

The IMergeFacesAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsActive | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Level | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | OnlyBoundaries |
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Public property | Tolerance |
Top
See Also

Reference

IMergeFacesAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMergeFacesAction.OnlyBoundaries Property

IMergeFacesActionOnlyBoundaries Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool OnlyBoundaries { get; set; }
property bool OnlyBoundaries {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMergeFacesAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMergeFacesAction.Tolerance Property

IMergeFacesActionTolerance Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Tolerance { get; set; }
property double Tolerance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMergeFacesAction Interface
VisualComponents.UX.Shared.Actions Namespace


IMergeFacesAction Methods

The IMergeFacesAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | FindFaces | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IMergeFacesAction Interface
VisualComponents.UX.Shared.Actions Namespace


JointLimitTestAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.ActionsJointLimitTestAction

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class JointLimitTestAction : IResult
public ref class JointLimitTestAction sealed : IResult

The JointLimitTestAction type exposes the following members.

Constructors
 | Name | Description
Public method | JointLimitTestAction | Initializes a new instance of the JointLimitTestAction class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


JointLimitTestAction Constructor

Initializes a new instance of the JointLimitTestAction class

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public JointLimitTestAction()
public:
JointLimitTestAction()
See Also

Reference

JointLimitTestAction Class
VisualComponents.UX.Shared.Actions Namespace


JointLimitTestAction Methods

The JointLimitTestAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

JointLimitTestAction Class
VisualComponents.UX.Shared.Actions Namespace


JointLimitTestAction.Execute Method

JointLimitTestActionExecute Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

JointLimitTestAction Class
VisualComponents.UX.Shared.Actions Namespace


JointLimitTestAction Events

The JointLimitTestAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

JointLimitTestAction Class
VisualComponents.UX.Shared.Actions Namespace


JointLimitTestAction.Completed Event

JointLimitTestActionCompleted Event

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

JointLimitTestAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.ActionsMaterialAssignAction

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MaterialAssignAction : ICommandPanelAction,
    IMaterialAssignAction
public ref class MaterialAssignAction : ICommandPanelAction,
    IMaterialAssignAction

The MaterialAssignAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplicationStatusService |
Public property | ApplyButtonText |
Public property | AssignFor |
Public property | AssignMode |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | DeleteMaterialFromLayout |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleClick |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceAllToNewMaterial |
Public method | SelectAllSetsWithMaterial |
Public method | SelectMaterial |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction Properties

The MaterialAssignAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplicationStatusService |
Public property | ApplyButtonText |
Public property | AssignFor |
Public property | AssignMode |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Title |
Top
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.ActionFinished Property

MaterialAssignActionActionFinished Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.ActionProperties Property

MaterialAssignActionActionProperties Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.ApplicationStatusService Property

MaterialAssignActionApplicationStatusService Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplicationStatusService ApplicationStatusService { get; }
public:
property IApplicationStatusService^ ApplicationStatusService {
    IApplicationStatusService^ get ();
}

Property Value

Type: IApplicationStatusService
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.ApplyButtonText Property

MaterialAssignActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.AssignFor Property

MaterialAssignActionAssignFor Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MaterialAssignFor AssignFor { get; set; }
public:
virtual property MaterialAssignFor AssignFor {
    MaterialAssignFor get () sealed;
    void set (MaterialAssignFor value) sealed;
}

Property Value

Type: MaterialAssignFor

Implements

IMaterialAssignActionAssignFor
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.AssignMode Property

MaterialAssignActionAssignMode Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MaterialAssignMode AssignMode { get; set; }
public:
virtual property MaterialAssignMode AssignMode {
    MaterialAssignMode get () sealed;
    void set (MaterialAssignMode value) sealed;
}

Property Value

Type: MaterialAssignMode

Implements

IMaterialAssignActionAssignMode
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.AssociatedModelId Property

MaterialAssignActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.AssociatedSiteId Property

MaterialAssignActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.CallingCommandName Property

MaterialAssignActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.CancelButtonText Property

MaterialAssignActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.Description Property

MaterialAssignActionDescription Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.ErrorMessage Property

MaterialAssignActionErrorMessage Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.IsActive Property

MaterialAssignActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; }
public:
virtual property bool IsActive {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IMaterialAssignActionIsActive
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.Title Property

MaterialAssignActionTitle Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction Methods

The MaterialAssignAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | DeleteMaterialFromLayout |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleClick |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceAllToNewMaterial |
Public method | SelectAllSetsWithMaterial |
Public method | SelectMaterial |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.ApplyAction Method

MaterialAssignActionApplyAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.MaterialAssignAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.CancelAction Method

MaterialAssignActionCancelAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.DeleteMaterialFromLayout Method

MaterialAssignActionDeleteMaterialFromLayout Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteMaterialFromLayout(
    IMaterial mat
)
public:
virtual void DeleteMaterialFromLayout(
    IMaterial^ mat
) sealed

Parameters

mat
Type: VisualComponents.Create3DIMaterial

Implements

IMaterialAssignActionDeleteMaterialFromLayout(IMaterial)
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.HandleClick Method

MaterialAssignActionHandleClick Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void HandleClick(
    int x,
    int y,
    bool multiselect
)
public:
virtual void HandleClick(
    int x,
    int y,
    bool multiselect
) sealed

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
multiselect
Type: SystemBoolean

Implements

IMaterialAssignActionHandleClick(Int32, Int32, Boolean)
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.ReplaceAllToNewMaterial Method

MaterialAssignActionReplaceAllToNewMaterial Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReplaceAllToNewMaterial(
    IMaterial matPrev,
    IMaterial mat
)
public:
virtual void ReplaceAllToNewMaterial(
    IMaterial^ matPrev,
    IMaterial^ mat
) sealed

Parameters

matPrev
Type: VisualComponents.Create3DIMaterial
mat
Type: VisualComponents.Create3DIMaterial

Implements

IMaterialAssignActionReplaceAllToNewMaterial(IMaterial, IMaterial)
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.SelectAllSetsWithMaterial Method

MaterialAssignActionSelectAllSetsWithMaterial Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SelectAllSetsWithMaterial(
    IMaterial mat
)
public:
virtual void SelectAllSetsWithMaterial(
    IMaterial^ mat
) sealed

Parameters

mat
Type: VisualComponents.Create3DIMaterial

Implements

IMaterialAssignActionSelectAllSetsWithMaterial(IMaterial)
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.SelectMaterial Method

MaterialAssignActionSelectMaterial Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SelectMaterial(
    IMaterial m
)
public:
virtual void SelectMaterial(
    IMaterial^ m
) sealed

Parameters

m
Type: VisualComponents.Create3DIMaterial

Implements

IMaterialAssignActionSelectMaterial(IMaterial)
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignAction.StartAction Method

MaterialAssignActionStartAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
IMaterialAssignActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

MaterialAssignAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialAssignFor Enumeration

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MaterialAssignFor
public enum class MaterialAssignFor
Members
Member name | Value | Description
Set | 0 |
Feature | 1 |
Link | 2 |
Component | 3 |
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


MaterialAssignMode Enumeration

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MaterialAssignMode
public enum class MaterialAssignMode
Members
Member name | Value | Description
Set | 0 |
Clear | 1 |
Inspect | 2 |
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.ActionsMaterialEditAction

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MaterialEditAction : ICommandPanelAction,
    IMaterialEditAction
public ref class MaterialEditAction : ICommandPanelAction,
    IMaterialEditAction

The MaterialEditAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(IMaterial, EventHandlerResultCompletionEventArgs) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction Properties

The MaterialEditAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Title |
Top
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.ActionFinished Property

MaterialEditActionActionFinished Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.ActionProperties Property

MaterialEditActionActionProperties Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.ApplyButtonText Property

MaterialEditActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.AssociatedModelId Property

MaterialEditActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.AssociatedSiteId Property

MaterialEditActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.CallingCommandName Property

MaterialEditActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.CancelButtonText Property

MaterialEditActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.Description Property

MaterialEditActionDescription Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.ErrorMessage Property

MaterialEditActionErrorMessage Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.IsActive Property

MaterialEditActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; }
public:
virtual property bool IsActive {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IMaterialEditActionIsActive
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.Title Property

MaterialEditActionTitle Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction Methods

The MaterialEditAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(IMaterial, EventHandlerResultCompletionEventArgs) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.ApplyAction Method

MaterialEditActionApplyAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.MaterialEditAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.CancelAction Method

MaterialEditActionCancelAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.StartAction Method

MaterialEditActionStartAction Method

Overload List
 | Name | Description
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(IMaterial, EventHandlerResultCompletionEventArgs) |
Top
See Also

Reference

MaterialEditAction Class
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.StartAction Method (EventHandler(ResultCompletionEventArgs))

MaterialEditActionStartAction Method (EventHandlerResultCompletionEventArgs)

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

MaterialEditAction Class
StartAction Overload
VisualComponents.UX.Shared.Actions Namespace


MaterialEditAction.StartAction Method (IMaterial, EventHandler(ResultCompletionEventArgs))

MaterialEditActionStartAction Method (IMaterial, EventHandlerResultCompletionEventArgs)

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    IMaterial mat,
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    IMaterial^ mat,
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

mat
Type: VisualComponents.Create3DIMaterial
completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

IMaterialEditActionStartAction(IMaterial, EventHandlerResultCompletionEventArgs)
See Also

Reference

MaterialEditAction Class
StartAction Overload
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.ActionsMergeFacesAction

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MergeFacesAction : IMergeFacesAction,
    IGeoFeatureBaseOperationLevelAction, ICommandPanelAction
public ref class MergeFacesAction : IMergeFacesAction,
    IGeoFeatureBaseOperationLevelAction, ICommandPanelAction

The MergeFacesAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplicationStatusService |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Level |
Public property | OnlyBoundaries |
Public property | Title |
Public property | Tolerance |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFaces |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction Properties

The MergeFacesAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplicationStatusService |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Level |
Public property | OnlyBoundaries |
Public property | Title |
Public property | Tolerance |
Top
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.ActionFinished Property

MergeFacesActionActionFinished Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.ActionProperties Property

MergeFacesActionActionProperties Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.ApplicationStatusService Property

MergeFacesActionApplicationStatusService Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplicationStatusService ApplicationStatusService { get; }
public:
property IApplicationStatusService^ ApplicationStatusService {
    IApplicationStatusService^ get ();
}

Property Value

Type: IApplicationStatusService
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.ApplyButtonText Property

MergeFacesActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.AssociatedModelId Property

MergeFacesActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.AssociatedSiteId Property

MergeFacesActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.CallingCommandName Property

MergeFacesActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.CancelButtonText Property

MergeFacesActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.Description Property

MergeFacesActionDescription Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.ErrorMessage Property

MergeFacesActionErrorMessage Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.IsActive Property

MergeFacesActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; }
public:
virtual property bool IsActive {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IGeoFeatureBaseOperationLevelActionIsActive
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.Level Property

MergeFacesActionLevel Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FeatureOperationLevel Level { get; set; }
public:
virtual property FeatureOperationLevel Level {
    FeatureOperationLevel get () sealed;
    void set (FeatureOperationLevel value) sealed;
}

Property Value

Type: FeatureOperationLevel

Implements

IGeoFeatureBaseOperationLevelActionLevel
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.OnlyBoundaries Property

MergeFacesActionOnlyBoundaries Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool OnlyBoundaries { get; set; }
public:
virtual property bool OnlyBoundaries {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IMergeFacesActionOnlyBoundaries
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.Title Property

MergeFacesActionTitle Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.Tolerance Property

MergeFacesActionTolerance Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Tolerance { get; set; }
public:
virtual property double Tolerance {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IMergeFacesActionTolerance
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction Methods

The MergeFacesAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFaces |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.ApplyAction Method

MergeFacesActionApplyAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.MergeFacesAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.CancelAction Method

MergeFacesActionCancelAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.FindFaces Method

MergeFacesActionFindFaces Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Tuple<ISimComponent, IEnumerable<IFace>> FindFaces(
    int x,
    int y
)
public:
virtual Tuple<ISimComponent^, IEnumerable<IFace^>^>^ FindFaces(
    int x,
    int y
) sealed

Parameters

x
Type: SystemInt32
y
Type: SystemInt32

Return Value

Type: TupleISimComponent, IEnumerableIFace

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.MergeFacesAction.FindFaces(System.Int32,System.Int32)"]

Implements

IGeoFeatureBaseOperationLevelActionFindFaces(Int32, Int32)
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


MergeFacesAction.StartAction Method

MergeFacesActionStartAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

MergeFacesAction Class
VisualComponents.UX.Shared.Actions Namespace


QualityType Enumeration

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum QualityType
public enum class QualityType
Members
Member name | Value | Description
High | 0 |
Medium | 1 |
Low | 2 |
Uncompressed | 3 |
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.ActionsTextureMappingAction

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TextureMappingAction : ITextureMappingAction,
    INotAbortableCommand, ICommandPanelAction, IGeoFeatureBaseOperationLevelAction
public ref class TextureMappingAction : ITextureMappingAction,
    INotAbortableCommand, ICommandPanelAction, IGeoFeatureBaseOperationLevelAction

The TextureMappingAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplicationStatusService |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Level |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | DoAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFaces |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectionMode |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateManipulator |
Public method | UpdateTiling |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction Properties

The TextureMappingAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplicationStatusService |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Level |
Public property | Title |
Top
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.ActionFinished Property

TextureMappingActionActionFinished Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.ActionProperties Property

TextureMappingActionActionProperties Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.ApplicationStatusService Property

TextureMappingActionApplicationStatusService Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplicationStatusService ApplicationStatusService { get; }
public:
property IApplicationStatusService^ ApplicationStatusService {
    IApplicationStatusService^ get ();
}

Property Value

Type: IApplicationStatusService
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.ApplyButtonText Property

TextureMappingActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.AssociatedModelId Property

TextureMappingActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.AssociatedSiteId Property

TextureMappingActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.CallingCommandName Property

TextureMappingActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.CancelButtonText Property

TextureMappingActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.Description Property

TextureMappingActionDescription Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.ErrorMessage Property

TextureMappingActionErrorMessage Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.IsActive Property

TextureMappingActionIsActive Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; }
public:
virtual property bool IsActive {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IGeoFeatureBaseOperationLevelActionIsActive
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.Level Property

TextureMappingActionLevel Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FeatureOperationLevel Level { get; set; }
public:
virtual property FeatureOperationLevel Level {
    FeatureOperationLevel get () sealed;
    void set (FeatureOperationLevel value) sealed;
}

Property Value

Type: FeatureOperationLevel

Implements

IGeoFeatureBaseOperationLevelActionLevel
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.Title Property

TextureMappingActionTitle Property

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction Methods

The TextureMappingAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | DoAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFaces |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectionMode |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateManipulator |
Public method | UpdateTiling |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.ApplyAction Method

TextureMappingActionApplyAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.TextureMappingAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.CancelAction Method

TextureMappingActionCancelAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.DoAction Method

TextureMappingActionDoAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DoAction()
public:
virtual void DoAction() sealed

Implements

ITextureMappingActionDoAction
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.FindFaces Method

TextureMappingActionFindFaces Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Tuple<ISimComponent, IEnumerable<IFace>> FindFaces(
    int x,
    int y
)
public:
virtual Tuple<ISimComponent^, IEnumerable<IFace^>^>^ FindFaces(
    int x,
    int y
) sealed

Parameters

x
Type: SystemInt32
y
Type: SystemInt32

Return Value

Type: TupleISimComponent, IEnumerableIFace

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Actions.TextureMappingAction.FindFaces(System.Int32,System.Int32)"]

Implements

IGeoFeatureBaseOperationLevelActionFindFaces(Int32, Int32)
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.SelectionMode Method

TextureMappingActionSelectionMode Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SelectionMode(
    FeatureOperationLevel mode
)
public:
virtual void SelectionMode(
    FeatureOperationLevel mode
) sealed

Parameters

mode
Type: VisualComponents.Create3DFeatureOperationLevel

Implements

ITextureMappingActionSelectionMode(FeatureOperationLevel)
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.StartAction Method

TextureMappingActionStartAction Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.UpdateManipulator Method

TextureMappingActionUpdateManipulator Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateManipulator()
public:
virtual void UpdateManipulator() sealed

Implements

ITextureMappingActionUpdateManipulator
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


TextureMappingAction.UpdateTiling Method

TextureMappingActionUpdateTiling Method

Namespace: VisualComponents.UX.Shared.Actions
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateTiling()
public:
virtual void UpdateTiling() sealed

Implements

ITextureMappingActionUpdateTiling
See Also

Reference

TextureMappingAction Class
VisualComponents.UX.Shared.Actions Namespace


VisualComponents.UX.Shared.Controls Namespace

Classes
 | Class | Description
Public class | CollectionItemsChangedEventArgs | Arguments to the ItemsAdded and ItemsRemoved events.
Public class | FolderBrowserDialogEx | Extended (a bit) old WinForms FolderBrowserDialog. It's still ugly and barely usable. Implemented using support guide from Microsoft. MS Guide source: https://support.microsoft.com/en-us/help/306285/how-to-implement-a-managed-component-that-wraps-the-browse-for-folder
Public class | ObservableCollectionExT | Observable collection with ability to delay or suspend CollectionChanged notifications
Public class | OutlinedText | Class similar to TextBlock but with shadow/outline. Copy/pasted from the darkest depths of internet. Requires some cleanup.


CollectionItemsChangedEventArgs Class

Arguments to the ItemsAdded and ItemsRemoved events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.Shared.ControlsCollectionItemsChangedEventArgs

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CollectionItemsChangedEventArgs : EventArgs
public ref class CollectionItemsChangedEventArgs : public EventArgs

The CollectionItemsChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionItemsChangedEventArgs | Initializes a new instance of the CollectionItemsChangedEventArgs class
Top
Properties
 | Name | Description
Public property | Items | The collection of items that changed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls Namespace


CollectionItemsChangedEventArgs Constructor

Initializes a new instance of the CollectionItemsChangedEventArgs class

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollectionItemsChangedEventArgs(
    ICollection items
)
public:
CollectionItemsChangedEventArgs(
    ICollection^ items
)

Parameters

items
Type: System.CollectionsICollection
See Also

Reference

CollectionItemsChangedEventArgs Class
VisualComponents.UX.Shared.Controls Namespace


CollectionItemsChangedEventArgs Properties

The CollectionItemsChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Items | The collection of items that changed.
Top
See Also

Reference

CollectionItemsChangedEventArgs Class
VisualComponents.UX.Shared.Controls Namespace


CollectionItemsChangedEventArgs.Items Property

CollectionItemsChangedEventArgsItems Property

The collection of items that changed.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICollection Items { get; }
public:
property ICollection^ Items {
    ICollection^ get ();
}

Property Value

Type: ICollection
See Also

Reference

CollectionItemsChangedEventArgs Class
VisualComponents.UX.Shared.Controls Namespace


CollectionItemsChangedEventArgs Methods

The CollectionItemsChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CollectionItemsChangedEventArgs Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx Class

Extended (a bit) old WinForms FolderBrowserDialog. It's still ugly and barely usable. Implemented using support guide from Microsoft. MS Guide source: https://support.microsoft.com/en-us/help/306285/how-to-implement-a-managed-component-that-wraps-the-browse-for-folder
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsCommonDialog
VisualComponents.UX.Shared.ControlsFolderBrowserDialogEx

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FolderBrowserDialogEx : CommonDialog
public ref class FolderBrowserDialogEx : public CommonDialog

The FolderBrowserDialogEx type exposes the following members.

Constructors
 | Name | Description
Public method | FolderBrowserDialogEx | Creates a new instance of extended FolderBrowserDialog.
Top
Properties
 | Name | Description
Public property | AllowFileSelection | If 'true' the dialog shows and allows to select files.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Description | Short text at the top of the dialog window.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMakeNewFolder | Enable or disable the "New Folder" button in the browser dialog.
Public property | DisplayPath | If 'true' shows a TextBox with path pointing to current selection at the bottom of the dialog.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | SelectedPath | Path of the currently selected entity.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookProc | Defines the common dialog box hook procedure that is overridden to add specific functionality to a common dialog box. (Inherited from CommonDialog.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnHelpRequest | Raises the HelpRequest event. (Inherited from CommonDialog.)
Protected method | OwnerWndProc | Defines the owner window procedure that is overridden to add specific functionality to a common dialog box. (Inherited from CommonDialog.)
Public method | Reset | Reset all properties of a dialog box to their default values. (Overrides CommonDialogReset.)
Protected method | RunDialog | Gets called from ShowDialog() and initializes dialog box. (Overrides CommonDialogRunDialog(IntPtr).)
Public method | ShowDialog | Runs a common dialog box with a default owner. (Inherited from CommonDialog.)
Public method | ShowDialog(IWin32Window) | Runs a common dialog box with the specified owner. (Inherited from CommonDialog.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx Constructor

Creates a new instance of extended FolderBrowserDialog.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FolderBrowserDialogEx()
public:
FolderBrowserDialogEx()
See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx Properties

The FolderBrowserDialogEx type exposes the following members.

Properties
 | Name | Description
Public property | AllowFileSelection | If 'true' the dialog shows and allows to select files.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Description | Short text at the top of the dialog window.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMakeNewFolder | Enable or disable the "New Folder" button in the browser dialog.
Public property | DisplayPath | If 'true' shows a TextBox with path pointing to current selection at the bottom of the dialog.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | SelectedPath | Path of the currently selected entity.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog.)
Top
See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx.AllowFileSelection Property

FolderBrowserDialogExAllowFileSelection Property

If 'true' the dialog shows and allows to select files.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AllowFileSelection { get; set; }
public:
property bool AllowFileSelection {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx.Description Property

FolderBrowserDialogExDescription Property

Short text at the top of the dialog window.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx.DisplayMakeNewFolder Property

FolderBrowserDialogExDisplayMakeNewFolder Property

Enable or disable the "New Folder" button in the browser dialog.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DisplayMakeNewFolder { get; set; }
public:
property bool DisplayMakeNewFolder {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx.DisplayPath Property

FolderBrowserDialogExDisplayPath Property

If 'true' shows a TextBox with path pointing to current selection at the bottom of the dialog.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DisplayPath { get; set; }
public:
property bool DisplayPath {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx.SelectedPath Property

FolderBrowserDialogExSelectedPath Property

Path of the currently selected entity.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SelectedPath { get; set; }
public:
property String^ SelectedPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx Methods

The FolderBrowserDialogEx type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookProc | Defines the common dialog box hook procedure that is overridden to add specific functionality to a common dialog box. (Inherited from CommonDialog.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnHelpRequest | Raises the HelpRequest event. (Inherited from CommonDialog.)
Protected method | OwnerWndProc | Defines the owner window procedure that is overridden to add specific functionality to a common dialog box. (Inherited from CommonDialog.)
Public method | Reset | Reset all properties of a dialog box to their default values. (Overrides CommonDialogReset.)
Protected method | RunDialog | Gets called from ShowDialog() and initializes dialog box. (Overrides CommonDialogRunDialog(IntPtr).)
Public method | ShowDialog | Runs a common dialog box with a default owner. (Inherited from CommonDialog.)
Public method | ShowDialog(IWin32Window) | Runs a common dialog box with the specified owner. (Inherited from CommonDialog.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx.Reset Method

FolderBrowserDialogExReset Method

Reset all properties of a dialog box to their default values.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Reset()
public:
virtual void Reset() override
See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx.RunDialog Method

FolderBrowserDialogExRunDialog Method

Gets called from ShowDialog() and initializes dialog box.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override bool RunDialog(
    IntPtr hWndOwner
)
protected:
virtual bool RunDialog(
    IntPtr hWndOwner
) override

Parameters

hWndOwner
Type: SystemIntPtr

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.FolderBrowserDialogEx.RunDialog(System.IntPtr)"]

See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


FolderBrowserDialogEx Events

The FolderBrowserDialogEx type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog.)
Top
See Also

Reference

FolderBrowserDialogEx Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T) Class

ObservableCollectionExT Class

Observable collection with ability to delay or suspend CollectionChanged notifications
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollectionT
VisualComponents.UX.Shared.ControlsObservableCollectionExT

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ObservableCollectionEx<T> : Collection<T>,
    INotifyCollectionChanged, INotifyPropertyChanged, IDisposable

generic<typename T>
public ref class ObservableCollectionEx : public Collection<T>,
    INotifyCollectionChanged, INotifyPropertyChanged, IDisposable

Type Parameters

T

The ObservableCollectionExT type exposes the following members.

Constructors
 | Name | Description
Public method | ObservableCollectionExT | Initializes a new instance of ObservableCollectionEx that is empty and has default initial capacity.
Public method | ObservableCollectionExT(IEnumerableT) | Initializes a new instance of the ObservableCollection class that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.
Public method | ObservableCollectionExT(ListT) | Initializes a new instance of the ObservableCollectionEx class that contains elements copied from the specified list
Public method | ObservableCollectionExT(ObservableCollectionExT, Boolean) | Constructor that configures the container to delay or disable notifications.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from CollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from CollectionT.)
Top
Methods
Name Description
Public method Add
Adds an object to the end of the CollectionT.
(Inherited from CollectionT.)
Protected method BlockReentrancy
Disallow reentrant attempts to change this collection. E.g. a event handler of the CollectionChanged event is not allowed to make changes to this collection.
Protected method CheckReentrancy
Check and assert for reentrant attempts to change this collection.
Public method Clear
Removes all elements from the CollectionT.
(Inherited from CollectionT.)
Protected method ClearItems
Called by base class Collection when the list is being cleared; raises a CollectionChanged event to any listeners.
(Overrides CollectionTClearItems.)
Public method Contains
Determines whether an element is in the CollectionT.
(Inherited from CollectionT.)
Public method CopyTo
Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array.
(Inherited from CollectionT.)
Public method DelayNotifications
Returns an instance of ObservableCollectionEx class which manipulates original collection but suppresses notifications untill this instance has been released and Dispose() method has been called. To supress notifications it is recommended to use this instance inside using() statement:
Copy
using (var iSuppressed = collection.DelayNotifications())
{
    iSuppressed.Add(x);
    iSuppressed.Add(y);
    iSuppressed.Add(z);
}
Each delayed interface is bound to only one type of operation such as Add, Remove, etc. Different types of operation on the same delayed interface are not allowed. In order to do other type of opertaion you can allocate another wrapper by calling .DelayNotifications() on either original object or any delayed instances.
Public method DisableNotifications
Returns a wrapper instance of an ObservableCollectionEx class. Calling methods of this instance will modify original collection but will not generate any notifications.
Public method Dispose
Called by the application code to fire all delayed notifications.
Protected method Dispose(Boolean)
Fires notification with all accumulated events
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Destructor
(Overrides ObjectFinalize.)
Public method GetEnumerator
Returns an enumerator that iterates through the CollectionT.
(Inherited from CollectionT.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IndexOf
Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT.
(Inherited from CollectionT.)
Public method Insert
Inserts an element into the CollectionT at the specified index.
(Inherited from CollectionT.)
Protected method InsertItem
Called by base class Collection when an item is added to list; raises a CollectionChanged event to any listeners.
(Overrides CollectionTInsertItem(Int32, T).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Move
Move item at oldIndex to newIndex.
Protected method MoveItem
Called by base class ObservableCollection when an item is to be moved within the list; raises a CollectionChanged event to any listeners.
Protected method OnCollectionChanged
Raise CollectionChanged event to any listeners. Properties/methods modifying this ObservableCollection will raise a collection changed event through this virtual method.
Protected method OnPropertyChanged
Raises a PropertyChanged event (per INotifyPropertyChanged).
Public method Refresh
Notifies subscribers that the whole collection was affected by changes of an unknown nature. This will cause all Bindings/Triggers to refresh, basically leading to performance overhead.
Public method Remove
Removes the first occurrence of a specific object from the CollectionT.
(Inherited from CollectionT.)
Public method RemoveAt
Removes the element at the specified index of the CollectionT.
(Inherited from CollectionT.)
Protected method RemoveItem
Called by base class Collection when an item is removed from list; raises a CollectionChanged event to any listeners.
(Overrides CollectionTRemoveItem(Int32).)
Public method RemoveRange
Removes a range of items from the collection.
Protected method SetItem
Called by base class Collection when an item is set in list; raises a CollectionChanged event to any listeners.
(Overrides CollectionTSetItem(Int32, T).)
Public method Swap
Exchanges 2 items of the collection.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
Events
 | Name | Description
Protected event | CollectionChanged | Occurs when the collection changes, either by adding or removing an item.
Public event | ItemsAdded | Event raised when items have been added.
Public event | ItemsRemoved | Event raised when items have been removed.
Public event | ItemsRemoving | Event raised when items are about to be removed.
Protected event | PropertyChanged | PropertyChanged event INotifyPropertyChanged.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | SortNaturallyT | Overloaded. Sorts the list naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | SortNaturallyT(Int32, Int32) | Overloaded. Sorts the ObservableCollectionT naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T) Constructor

ObservableCollectionExT Constructor

Overload List
 | Name | Description
Public method | ObservableCollectionExT | Initializes a new instance of ObservableCollectionEx that is empty and has default initial capacity.
Public method | ObservableCollectionExT(IEnumerableT) | Initializes a new instance of the ObservableCollection class that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.
Public method | ObservableCollectionExT(ListT) | Initializes a new instance of the ObservableCollectionEx class that contains elements copied from the specified list
Public method | ObservableCollectionExT(ObservableCollectionExT, Boolean) | Constructor that configures the container to delay or disable notifications.
Top
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T) Constructor

ObservableCollectionExT Constructor

Initializes a new instance of ObservableCollectionEx that is empty and has default initial capacity.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollectionEx()
public:
ObservableCollectionEx()
See Also

Reference

ObservableCollectionExT Class
ObservableCollectionExT Overload
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T) Constructor (IEnumerable(T))

ObservableCollectionExT Constructor (IEnumerableT)

Initializes a new instance of the ObservableCollection class that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollectionEx(
    IEnumerable<T> collection
)
public:
ObservableCollectionEx(
    IEnumerable<T>^ collection
)

Parameters

collection
Type: System.Collections.GenericIEnumerableT
The collection whose elements are copied to the new list.
Exceptions
Exception | Condition
ArgumentNullException | collection is a null reference
Remarks
The elements are copied onto the ObservableCollection in the same order they are read by the enumerator of the collection.
See Also

Reference

ObservableCollectionExT Class
ObservableCollectionExT Overload
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T) Constructor (List(T))

ObservableCollectionExT Constructor (ListT)

Initializes a new instance of the ObservableCollectionEx class that contains elements copied from the specified list

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollectionEx(
    List<T> list
)
public:
ObservableCollectionEx(
    List<T>^ list
)

Parameters

list
Type: System.Collections.GenericListT
The list whose elements are copied to the new list.
Exceptions
Exception | Condition
ArgumentNullException | list is a null reference
Remarks
The elements are copied onto the ObservableCollectionEx in the same order they are read by the enumerator of the list.
See Also

Reference

ObservableCollectionExT Class
ObservableCollectionExT Overload
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T) Constructor (ObservableCollectionEx(T), Boolean)

ObservableCollectionExT Constructor (ObservableCollectionExT, Boolean)

Constructor that configures the container to delay or disable notifications.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollectionEx(
    ObservableCollectionEx<T> parent,
    bool notify
)
public:
ObservableCollectionEx(
    ObservableCollectionEx<T>^ parent,
    bool notify
)

Parameters

parent
Type: VisualComponents.UX.Shared.ControlsObservableCollectionEx T
Reference to an original collection whos events are being postponed
notify
Type: SystemBoolean
Specifies if notifications needs to be delayed or disabled
See Also

Reference

ObservableCollectionExT Class
ObservableCollectionExT Overload
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T) Properties

ObservableCollectionExT Properties

The ObservableCollectionExT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionT .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from CollectionT .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from CollectionT .)
Top
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T) Methods

ObservableCollectionExT Methods

The ObservableCollectionExT generic type exposes the following members.

Methods
Name Description
Public method Add
Adds an object to the end of the CollectionT.
(Inherited from CollectionT .)
Protected method BlockReentrancy
Disallow reentrant attempts to change this collection. E.g. a event handler of the CollectionChanged event is not allowed to make changes to this collection.
Protected method CheckReentrancy
Check and assert for reentrant attempts to change this collection.
Public method Clear
Removes all elements from the CollectionT.
(Inherited from CollectionT .)
Protected method ClearItems
Called by base class Collection when the list is being cleared; raises a CollectionChanged event to any listeners.
(Overrides CollectionTClearItems.)
Public method Contains
Determines whether an element is in the CollectionT.
(Inherited from CollectionT .)
Public method CopyTo
Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array.
(Inherited from CollectionT .)
Public method DelayNotifications
Returns an instance of ObservableCollectionEx class which manipulates original collection but suppresses notifications untill this instance has been released and Dispose() method has been called. To supress notifications it is recommended to use this instance inside using() statement:
Copy
using (var iSuppressed = collection.DelayNotifications())
{
    iSuppressed.Add(x);
    iSuppressed.Add(y);
    iSuppressed.Add(z);
}
Each delayed interface is bound to only one type of operation such as Add, Remove, etc. Different types of operation on the same delayed interface are not allowed. In order to do other type of opertaion you can allocate another wrapper by calling .DelayNotifications() on either original object or any delayed instances.
Public method DisableNotifications
Returns a wrapper instance of an ObservableCollectionEx class. Calling methods of this instance will modify original collection but will not generate any notifications.
Public method Dispose
Called by the application code to fire all delayed notifications.
Protected method Dispose(Boolean)
Fires notification with all accumulated events
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Destructor
(Overrides ObjectFinalize.)
Public method GetEnumerator
Returns an enumerator that iterates through the CollectionT.
(Inherited from CollectionT .)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IndexOf
Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT.
(Inherited from CollectionT .)
Public method Insert
Inserts an element into the CollectionT at the specified index.
(Inherited from CollectionT .)
Protected method InsertItem
Called by base class Collection when an item is added to list; raises a CollectionChanged event to any listeners.
(Overrides CollectionTInsertItem(Int32, T).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Move
Move item at oldIndex to newIndex.
Protected method MoveItem
Called by base class ObservableCollection when an item is to be moved within the list; raises a CollectionChanged event to any listeners.
Protected method OnCollectionChanged
Raise CollectionChanged event to any listeners. Properties/methods modifying this ObservableCollection will raise a collection changed event through this virtual method.
Protected method OnPropertyChanged
Raises a PropertyChanged event (per INotifyPropertyChanged).
Public method Refresh
Notifies subscribers that the whole collection was affected by changes of an unknown nature. This will cause all Bindings/Triggers to refresh, basically leading to performance overhead.
Public method Remove
Removes the first occurrence of a specific object from the CollectionT.
(Inherited from CollectionT .)
Public method RemoveAt
Removes the element at the specified index of the CollectionT.
(Inherited from CollectionT .)
Protected method RemoveItem
Called by base class Collection when an item is removed from list; raises a CollectionChanged event to any listeners.
(Overrides CollectionTRemoveItem(Int32).)
Public method RemoveRange
Removes a range of items from the collection.
Protected method SetItem
Called by base class Collection when an item is set in list; raises a CollectionChanged event to any listeners.
(Overrides CollectionTSetItem(Int32, T).)
Public method Swap
Exchanges 2 items of the collection.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | SortNaturallyT | Overloaded. Sorts the list naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | SortNaturallyT(Int32, Int32) | Overloaded. Sorts the ObservableCollectionT naturally (alpha-numerically) by string representations of its items. (Defined by StringHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).BlockReentrancy Method

ObservableCollectionExTBlockReentrancy Method

Disallow reentrant attempts to change this collection. E.g. a event handler of the CollectionChanged event is not allowed to make changes to this collection.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IDisposable BlockReentrancy()
protected:
IDisposable^ BlockReentrancy()

Return Value

Type: IDisposable

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.ObservableCollectionEx`1.BlockReentrancy"]

Remarks
typical usage is to wrap e.g. a OnCollectionChanged call with a using() scope:
Copy
using (BlockReentrancy())
{
    CollectionChanged(this, new NotifyCollectionChangedEventArgs(action, item, index));
}
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).CheckReentrancy Method

ObservableCollectionExTCheckReentrancy Method

Check and assert for reentrant attempts to change this collection.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void CheckReentrancy()
protected:
void CheckReentrancy()
Exceptions
Exception | Condition
InvalidOperationException | raised when changing the collection while another collection change is still being notified to other listeners
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).ClearItems Method

ObservableCollectionExTClearItems Method

Called by base class Collection when the list is being cleared; raises a CollectionChanged event to any listeners.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void ClearItems()
protected:
virtual void ClearItems() override
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).DelayNotifications Method

ObservableCollectionExTDelayNotifications Method

Returns an instance of ObservableCollectionEx class which manipulates original collection but suppresses notifications untill this instance has been released and Dispose() method has been called. To supress notifications it is recommended to use this instance inside using() statement:
Copy
using (var iSuppressed = collection.DelayNotifications())
{
    iSuppressed.Add(x);
    iSuppressed.Add(y);
    iSuppressed.Add(z);
}
Each delayed interface is bound to only one type of operation such as Add, Remove, etc. Different types of operation on the same delayed interface are not allowed. In order to do other type of opertaion you can allocate another wrapper by calling .DelayNotifications() on either original object or any delayed instances.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollectionEx<T> DelayNotifications()
public:
ObservableCollectionEx<T>^ DelayNotifications()

Return Value

Type: ObservableCollectionEx T
ObservableCollectionEx
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).DisableNotifications Method

ObservableCollectionExTDisableNotifications Method

Returns a wrapper instance of an ObservableCollectionEx class. Calling methods of this instance will modify original collection but will not generate any notifications.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollectionEx<T> DisableNotifications()
public:
ObservableCollectionEx<T>^ DisableNotifications()

Return Value

Type: ObservableCollectionEx T
ObservableCollectionEx
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).Dispose Method

ObservableCollectionExTDispose Method

Overload List
 | Name | Description
Public method | Dispose | Called by the application code to fire all delayed notifications.
Protected method | Dispose(Boolean) | Fires notification with all accumulated events
Top
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).Dispose Method

ObservableCollectionExTDispose Method

Called by the application code to fire all delayed notifications.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ObservableCollectionExT Class
Dispose Overload
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).Dispose Method (Boolean)

ObservableCollectionExTDispose Method (Boolean)

Fires notification with all accumulated events

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Dispose(
    bool reason
)
protected:
virtual void Dispose(
    bool reason
)

Parameters

reason
Type: SystemBoolean
True is called by App code. False if called from GC.
See Also

Reference

ObservableCollectionExT Class
Dispose Overload
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).Finalize Method

ObservableCollectionExTFinalize Method

Destructor

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Finalize()
protected:
virtual void Finalize() override

Implements

ObjectFinalize
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).InsertItem Method

ObservableCollectionExTInsertItem Method

Called by base class Collection when an item is added to list; raises a CollectionChanged event to any listeners.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void InsertItem(
    int index,
    T item
)
protected:
virtual void InsertItem(
    int index,
    T item
) override

Parameters

index
Type: SystemInt32
item
Type: T
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).Move Method

ObservableCollectionExTMove Method

Move item at oldIndex to newIndex.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Move(
    int oldIndex,
    int newIndex
)
public:
void Move(
    int oldIndex,
    int newIndex
)

Parameters

oldIndex
Type: SystemInt32
newIndex
Type: SystemInt32
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).MoveItem Method

ObservableCollectionExTMoveItem Method

Called by base class ObservableCollection when an item is to be moved within the list; raises a CollectionChanged event to any listeners.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void MoveItem(
    int oldIndex,
    int newIndex
)
protected:
virtual void MoveItem(
    int oldIndex,
    int newIndex
)

Parameters

oldIndex
Type: SystemInt32
newIndex
Type: SystemInt32
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).OnCollectionChanged Method

ObservableCollectionExTOnCollectionChanged Method

Raise CollectionChanged event to any listeners. Properties/methods modifying this ObservableCollection will raise a collection changed event through this virtual method.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
protected:
virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs^ e
)

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
Remarks
When overriding this method, either call its base implementation or call BlockReentrancy to guard against reentrant collection changes.
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).OnPropertyChanged Method

ObservableCollectionExTOnPropertyChanged Method

Raises a PropertyChanged event (per INotifyPropertyChanged).

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ e
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).Refresh Method

ObservableCollectionExTRefresh Method

Notifies subscribers that the whole collection was affected by changes of an unknown nature. This will cause all Bindings/Triggers to refresh, basically leading to performance overhead.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Refresh()
public:
void Refresh()
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).RemoveItem Method

ObservableCollectionExTRemoveItem Method

Called by base class Collection when an item is removed from list; raises a CollectionChanged event to any listeners.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void RemoveItem(
    int index
)
protected:
virtual void RemoveItem(
    int index
) override

Parameters

index
Type: SystemInt32
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).RemoveRange Method

ObservableCollectionExTRemoveRange Method

Removes a range of items from the collection.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveRange(
    ICollection<T> range
)
public:
void RemoveRange(
    ICollection<T>^ range
)

Parameters

range
Type: System.Collections.GenericICollectionT
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).SetItem Method

ObservableCollectionExTSetItem Method

Called by base class Collection when an item is set in list; raises a CollectionChanged event to any listeners.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void SetItem(
    int index,
    T item
)
protected:
virtual void SetItem(
    int index,
    T item
) override

Parameters

index
Type: SystemInt32
item
Type: T
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).Swap Method

ObservableCollectionExTSwap Method

Exchanges 2 items of the collection.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Swap(
    int sourceIndex,
    int targetIndex
)
public:
void Swap(
    int sourceIndex,
    int targetIndex
)

Parameters

sourceIndex
Type: SystemInt32
targetIndex
Type: SystemInt32
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T) Events

ObservableCollectionExT Events

The ObservableCollectionExT generic type exposes the following members.

Events
 | Name | Description
Protected event | CollectionChanged | Occurs when the collection changes, either by adding or removing an item.
Public event | ItemsAdded | Event raised when items have been added.
Public event | ItemsRemoved | Event raised when items have been removed.
Public event | ItemsRemoving | Event raised when items are about to be removed.
Protected event | PropertyChanged | PropertyChanged event INotifyPropertyChanged.
Top
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).CollectionChanged Event

ObservableCollectionExTCollectionChanged Event

Occurs when the collection changes, either by adding or removing an item.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual event NotifyCollectionChangedEventHandler CollectionChanged
protected:
virtual  event NotifyCollectionChangedEventHandler^ CollectionChanged {
    void add (NotifyCollectionChangedEventHandler^ value);
    void remove (NotifyCollectionChangedEventHandler^ value);
}

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler
Remarks
See
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace
System.Collections.SpecializedINotifyCollectionChanged


ObservableCollectionEx(T).ItemsAdded Event

ObservableCollectionExTItemsAdded Event

Event raised when items have been added.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<CollectionItemsChangedEventArgs> ItemsAdded
public:
 event EventHandler<CollectionItemsChangedEventArgs^>^ ItemsAdded {
    void add (EventHandler<CollectionItemsChangedEventArgs^>^ value);
    void remove (EventHandler<CollectionItemsChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCollectionItemsChangedEventArgs
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).ItemsRemoved Event

ObservableCollectionExTItemsRemoved Event

Event raised when items have been removed.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<CollectionItemsChangedEventArgs> ItemsRemoved
public:
 event EventHandler<CollectionItemsChangedEventArgs^>^ ItemsRemoved {
    void add (EventHandler<CollectionItemsChangedEventArgs^>^ value);
    void remove (EventHandler<CollectionItemsChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCollectionItemsChangedEventArgs
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).ItemsRemoving Event

ObservableCollectionExTItemsRemoving Event

Event raised when items are about to be removed.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<CollectionItemsChangedEventArgs> ItemsRemoving
public:
 event EventHandler<CollectionItemsChangedEventArgs^>^ ItemsRemoving {
    void add (EventHandler<CollectionItemsChangedEventArgs^>^ value);
    void remove (EventHandler<CollectionItemsChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCollectionItemsChangedEventArgs
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


ObservableCollectionEx(T).PropertyChanged Event

ObservableCollectionExTPropertyChanged Event

PropertyChanged event INotifyPropertyChanged.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual event PropertyChangedEventHandler PropertyChanged
protected:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

ObservableCollectionExT Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText Class

Class similar to TextBlock but with shadow/outline. Copy/pasted from the darkest depths of internet. Requires some cleanup.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
VisualComponents.UX.Shared.ControlsOutlinedText

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class OutlinedText : FrameworkElement,
    IAddChild
public ref class OutlinedText : public FrameworkElement,
    IAddChild

The OutlinedText type exposes the following members.

Constructors
 | Name | Description
Public method | OutlinedText | Initializes a new instance of the OutlinedText class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | The font to use for the displayed formatted text.
Public property | FontSize | The current font size.
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Specifies the brush to use for the fill of the formatted text.
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Stroke | Specifies the brush to use for the stroke and optional hightlight of the formatted text.
Public property | StrokeThickness | The stroke thickness of the font.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Specifies the text string to display.
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddChild |
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddText |
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateText | Create the outline geometry based on the formatted text.
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | OnRender override draws the geometry of the text and optional highlight. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
 | Name | Description
 | FontFamilyProperty | Identifies the FontFamily dependency property.
 | FontSizeProperty | Identifies the FontSize dependency property.
Public field | FontStretch |
Public field | FontStyle |
Public field | FontWeight |
 | ForegroundProperty | Identifies the Foreground dependency property.
 | StrokeProperty | Identifies the Stroke dependency property.
 | StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
 | TextProperty | Identifies the Text dependency property.
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls Namespace


OutlinedText Constructor

Initializes a new instance of the OutlinedText class

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public OutlinedText()
public:
OutlinedText()
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText Properties

The OutlinedText type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | The font to use for the displayed formatted text.
Public property | FontSize | The current font size.
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Specifies the brush to use for the fill of the formatted text.
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Stroke | Specifies the brush to use for the stroke and optional hightlight of the formatted text.
Public property | StrokeThickness | The stroke thickness of the font.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Specifies the text string to display.
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.FontFamily Property

OutlinedTextFontFamily Property

The font to use for the displayed formatted text.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FontFamily FontFamily { get; set; }
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}

Property Value

Type: FontFamily
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.FontSize Property

OutlinedTextFontSize Property

The current font size.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double FontSize { get; set; }
public:
property double FontSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.Foreground Property

OutlinedTextForeground Property

Specifies the brush to use for the fill of the formatted text.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush Foreground { get; set; }
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.Stroke Property

OutlinedTextStroke Property

Specifies the brush to use for the stroke and optional hightlight of the formatted text.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush Stroke { get; set; }
public:
property Brush^ Stroke {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.StrokeThickness Property

OutlinedTextStrokeThickness Property

The stroke thickness of the font.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double StrokeThickness { get; set; }
public:
property double StrokeThickness {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.Text Property

OutlinedTextText Property

Specifies the text string to display.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText Methods

The OutlinedText type exposes the following members.

Methods
 | Name | Description
Public method | AddChild |
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddText |
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateText | Create the outline geometry based on the formatted text.
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | OnRender override draws the geometry of the text and optional highlight. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.AddChild Method

OutlinedTextAddChild Method

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddChild(
    Object value
)
public:
virtual void AddChild(
    Object^ value
) sealed

Parameters

value
Type: SystemObject

Implements

IAddChildAddChild(Object)
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.AddText Method

OutlinedTextAddText Method

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddText(
    string value
)
public:
virtual void AddText(
    String^ value
) sealed

Parameters

value
Type: SystemString

Implements

IAddChildAddText(String)
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.CreateText Method

OutlinedTextCreateText Method

Create the outline geometry based on the formatted text.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CreateText()
public:
void CreateText()
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.OnRender Method

OutlinedTextOnRender Method

OnRender override draws the geometry of the text and optional highlight.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
Drawing context of the OutlineText control.
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText Events

The OutlinedText type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText Fields

The OutlinedText type exposes the following members.

Fields
 | Name | Description
 | FontFamilyProperty | Identifies the FontFamily dependency property.
 | FontSizeProperty | Identifies the FontSize dependency property.
Public field | FontStretch |
Public field | FontStyle |
Public field | FontWeight |
 | ForegroundProperty | Identifies the Foreground dependency property.
 | StrokeProperty | Identifies the Stroke dependency property.
 | StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
 | TextProperty | Identifies the Text dependency property.
Top
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.FontFamilyProperty Field

OutlinedTextFontFamilyProperty Field

Identifies the FontFamily dependency property.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FontFamilyProperty
public:
static initonly DependencyProperty^ FontFamilyProperty

Field Value

Type: DependencyProperty
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.FontSizeProperty Field

OutlinedTextFontSizeProperty Field

Identifies the FontSize dependency property.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FontSizeProperty
public:
static initonly DependencyProperty^ FontSizeProperty

Field Value

Type: DependencyProperty
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.FontStretch Field

OutlinedTextFontStretch Field

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FontStretch FontStretch
public:
FontStretch FontStretch

Field Value

Type: FontStretch
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.FontStyle Field

OutlinedTextFontStyle Field

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FontStyle FontStyle
public:
FontStyle FontStyle

Field Value

Type: FontStyle
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.FontWeight Field

OutlinedTextFontWeight Field

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FontWeight FontWeight
public:
FontWeight FontWeight

Field Value

Type: FontWeight
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.ForegroundProperty Field

OutlinedTextForegroundProperty Field

Identifies the Foreground dependency property.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ForegroundProperty
public:
static initonly DependencyProperty^ ForegroundProperty

Field Value

Type: DependencyProperty
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.StrokeProperty Field

OutlinedTextStrokeProperty Field

Identifies the Stroke dependency property.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty StrokeProperty
public:
static initonly DependencyProperty^ StrokeProperty

Field Value

Type: DependencyProperty
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.StrokeThicknessProperty Field

OutlinedTextStrokeThicknessProperty Field

Identifies the StrokeThickness dependency property.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty StrokeThicknessProperty
public:
static initonly DependencyProperty^ StrokeThicknessProperty

Field Value

Type: DependencyProperty
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


OutlinedText.TextProperty Field

OutlinedTextTextProperty Field

Identifies the Text dependency property.

Namespace: VisualComponents.UX.Shared.Controls
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TextProperty
public:
static initonly DependencyProperty^ TextProperty

Field Value

Type: DependencyProperty
See Also

Reference

OutlinedText Class
VisualComponents.UX.Shared.Controls Namespace


VisualComponents.UX.Shared.Controls.Converters Namespace

Classes
 | Class | Description
Public class | BetterBooleanToVisibilityConverter | Boolean to visibility converter, except this one is better.
Public class | BooleanToOppositeVisibilityConverter |
Public class | BooleanToVisibilityConverter |
Public class | BoolToColorConverter | this is created to test color picker
Public class | BoolToOppositeConverter | Negates the boolean value. Needed in XAML.
Public class | BoolToParameterValueConverter | If parameter is an array, returns its first elemenet if the value is true and its second element if the value is false. Otherwise returns paramater itself if the value is true and null if the value is false.
Public class | BoolTypeConverter |
Public class | CameraAnimationTimeToBoolConverter |
Public class | ColorToSolidColorBrushColorConverter |
Public class | DoubleTypeConverter |
Public class | DoubleTypeConverterEx |
Public class | DoubleTypeConverterWithUnits |
Public class | DoubleTypeConverterWithUnitsEx |
Public class | DoubleWithUnitTypeConverter |
Public class | EnumTypeConverter |
Public class | IntTypeConverterWithUnits |
Public class | IsTrimmedToVisibilityConverter |
 | LanguageConverter | Returns localization string
Public class | ListToStringConverter |
Public class | ListToVisibilityConverter |
Public class | MediaColorToSolidColorBrushColorConverter |
Public class | MultipleBoolValueToIsEnabledConverter | This converter is used in checkbox. if two or more objects are selected, then there common property name is displayed on property grid. If Selected objects have value of different bool type then using this converter the checkbox control IsEnabled property will be false.
Public class | NewLineToSpaceConverter |
Public class | NullToBooleanConverter |
Public class | NullToHiddenVisibilityConverter |
Public class | NullToOppositeVisibilityConverter |
Public class | NullToVisibilityConverter |
Public class | ObjectToStringConverter |
Public class | ParameterEqualityToVisibilityConverter |
Public class | SecondToTimeSpanConverter |
Public class | SimulationTimeConverterForCameraEditor | This converter formats time to a setting set in clock display setting.
Public class | StringToBooleanConverter |
Public class | StringToDoubleWithUnitConverter |
Public class | StringToVisibilityConverter |
Public class | TextInputTypeConverter | This converter is used to select the TextInputType for double type property based on UseAsInteger property.
Public class | TwoStringsEqualityConverter |
Public class | TwoValuesEqualityConverter |
Public class | UnitConverter | This converter is used to select the right unit(for displaying in UI) suffix for the selected unit family .
Public class | UnitTypeConverter |
Public class | UnprecisedDoubleTypeConverterWithUnits |
Public class | UTCToLocalDateTimeConverter |
Public class | VectorOrientationToOrientationConverter |
Public class | VectorToColorConverter |
Public class | VisibilityToBooleanConverter |
Public class | VisibilityToOppositeConverter |


BetterBooleanToVisibilityConverter Class

Boolean to visibility converter, except this one is better.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersBetterBooleanToVisibilityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BetterBooleanToVisibilityConverter : IValueConverter
public ref class BetterBooleanToVisibilityConverter : IValueConverter

The BetterBooleanToVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BetterBooleanToVisibilityConverter | Default constructor.
Top
Properties
 | Name | Description
Public property | VisibilityWhenFalse | Visibility value when the value is false.
Public property | VisibilityWhenNull | Visibility value when the value is null.
Public property | VisibilityWhenTrue | Visibility value when the value is true.
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


BetterBooleanToVisibilityConverter Constructor

Default constructor.

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BetterBooleanToVisibilityConverter()
public:
BetterBooleanToVisibilityConverter()
See Also

Reference

BetterBooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BetterBooleanToVisibilityConverter Properties

The BetterBooleanToVisibilityConverter type exposes the following members.

Properties
 | Name | Description
Public property | VisibilityWhenFalse | Visibility value when the value is false.
Public property | VisibilityWhenNull | Visibility value when the value is null.
Public property | VisibilityWhenTrue | Visibility value when the value is true.
Top
See Also

Reference

BetterBooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BetterBooleanToVisibilityConverter.VisibilityWhenFalse Property

BetterBooleanToVisibilityConverterVisibilityWhenFalse Property

Visibility value when the value is false.

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility VisibilityWhenFalse { get; set; }
public:
property Visibility VisibilityWhenFalse {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

BetterBooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BetterBooleanToVisibilityConverter.VisibilityWhenNull Property

BetterBooleanToVisibilityConverterVisibilityWhenNull Property

Visibility value when the value is null.

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility VisibilityWhenNull { get; set; }
public:
property Visibility VisibilityWhenNull {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
Remarks
This property is only used if the type is nullable.
See Also

Reference

BetterBooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BetterBooleanToVisibilityConverter.VisibilityWhenTrue Property

BetterBooleanToVisibilityConverterVisibilityWhenTrue Property

Visibility value when the value is true.

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility VisibilityWhenTrue { get; set; }
public:
property Visibility VisibilityWhenTrue {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

BetterBooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BetterBooleanToVisibilityConverter Methods

The BetterBooleanToVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BetterBooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BetterBooleanToVisibilityConverter.Convert Method

BetterBooleanToVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BetterBooleanToVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

BetterBooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BetterBooleanToVisibilityConverter.ConvertBack Method

BetterBooleanToVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BetterBooleanToVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

BetterBooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BooleanToOppositeVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersBooleanToOppositeVisibilityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BooleanToOppositeVisibilityConverter : IValueConverter
public ref class BooleanToOppositeVisibilityConverter : IValueConverter

The BooleanToOppositeVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanToOppositeVisibilityConverter | Initializes a new instance of the BooleanToOppositeVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


BooleanToOppositeVisibilityConverter Constructor

Initializes a new instance of the BooleanToOppositeVisibilityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BooleanToOppositeVisibilityConverter()
public:
BooleanToOppositeVisibilityConverter()
See Also

Reference

BooleanToOppositeVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BooleanToOppositeVisibilityConverter Methods

The BooleanToOppositeVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BooleanToOppositeVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BooleanToOppositeVisibilityConverter.Convert Method

BooleanToOppositeVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BooleanToOppositeVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

BooleanToOppositeVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BooleanToOppositeVisibilityConverter.ConvertBack Method

BooleanToOppositeVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BooleanToOppositeVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

BooleanToOppositeVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BooleanToVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersBooleanToVisibilityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BooleanToVisibilityConverter : IValueConverter
public ref class BooleanToVisibilityConverter : IValueConverter

The BooleanToVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanToVisibilityConverter | Initializes a new instance of the BooleanToVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


BooleanToVisibilityConverter Constructor

Initializes a new instance of the BooleanToVisibilityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BooleanToVisibilityConverter()
public:
BooleanToVisibilityConverter()
See Also

Reference

BooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BooleanToVisibilityConverter Methods

The BooleanToVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BooleanToVisibilityConverter.Convert Method

BooleanToVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BooleanToVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

BooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BooleanToVisibilityConverter.ConvertBack Method

BooleanToVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BooleanToVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

BooleanToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToColorConverter Class

this is created to test color picker
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersBoolToColorConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BoolToColorConverter : IValueConverter
public ref class BoolToColorConverter : IValueConverter

The BoolToColorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BoolToColorConverter | Initializes a new instance of the BoolToColorConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToColorConverter Constructor

Initializes a new instance of the BoolToColorConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BoolToColorConverter()
public:
BoolToColorConverter()
See Also

Reference

BoolToColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToColorConverter Methods

The BoolToColorConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BoolToColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToColorConverter.Convert Method

BoolToColorConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BoolToColorConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

BoolToColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToColorConverter.ConvertBack Method

BoolToColorConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BoolToColorConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

BoolToColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToOppositeConverter Class

Negates the boolean value. Needed in XAML.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersBoolToOppositeConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BoolToOppositeConverter : IValueConverter
public ref class BoolToOppositeConverter : IValueConverter

The BoolToOppositeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BoolToOppositeConverter | Initializes a new instance of the BoolToOppositeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToOppositeConverter Constructor

Initializes a new instance of the BoolToOppositeConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BoolToOppositeConverter()
public:
BoolToOppositeConverter()
See Also

Reference

BoolToOppositeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToOppositeConverter Methods

The BoolToOppositeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BoolToOppositeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToOppositeConverter.Convert Method

BoolToOppositeConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BoolToOppositeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

BoolToOppositeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToOppositeConverter.ConvertBack Method

BoolToOppositeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BoolToOppositeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

BoolToOppositeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToParameterValueConverter Class

If parameter is an array, returns its first elemenet if the value is true and its second element if the value is false. Otherwise returns paramater itself if the value is true and null if the value is false.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersBoolToParameterValueConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BoolToParameterValueConverter : IValueConverter
public ref class BoolToParameterValueConverter : IValueConverter

The BoolToParameterValueConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BoolToParameterValueConverter | Initializes a new instance of the BoolToParameterValueConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToParameterValueConverter Constructor

Initializes a new instance of the BoolToParameterValueConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BoolToParameterValueConverter()
public:
BoolToParameterValueConverter()
See Also

Reference

BoolToParameterValueConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToParameterValueConverter Methods

The BoolToParameterValueConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BoolToParameterValueConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToParameterValueConverter.Convert Method

BoolToParameterValueConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BoolToParameterValueConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

BoolToParameterValueConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolToParameterValueConverter.ConvertBack Method

BoolToParameterValueConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BoolToParameterValueConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

BoolToParameterValueConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolTypeConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersBoolTypeConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BoolTypeConverter : IValueConverter
public ref class BoolTypeConverter : IValueConverter

The BoolTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BoolTypeConverter | Initializes a new instance of the BoolTypeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


BoolTypeConverter Constructor

Initializes a new instance of the BoolTypeConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BoolTypeConverter()
public:
BoolTypeConverter()
See Also

Reference

BoolTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolTypeConverter Methods

The BoolTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BoolTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolTypeConverter.Convert Method

BoolTypeConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BoolTypeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

BoolTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


BoolTypeConverter.ConvertBack Method

BoolTypeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.BoolTypeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

BoolTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


CameraAnimationTimeToBoolConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersCameraAnimationTimeToBoolConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CameraAnimationTimeToBoolConverter : IValueConverter
public ref class CameraAnimationTimeToBoolConverter : IValueConverter

The CameraAnimationTimeToBoolConverter type exposes the following members.

Constructors
 | Name | Description
Public method | CameraAnimationTimeToBoolConverter | Initializes a new instance of the CameraAnimationTimeToBoolConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


CameraAnimationTimeToBoolConverter Constructor

Initializes a new instance of the CameraAnimationTimeToBoolConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CameraAnimationTimeToBoolConverter()
public:
CameraAnimationTimeToBoolConverter()
See Also

Reference

CameraAnimationTimeToBoolConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


CameraAnimationTimeToBoolConverter Methods

The CameraAnimationTimeToBoolConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CameraAnimationTimeToBoolConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


CameraAnimationTimeToBoolConverter.Convert Method

CameraAnimationTimeToBoolConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.CameraAnimationTimeToBoolConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

CameraAnimationTimeToBoolConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


CameraAnimationTimeToBoolConverter.ConvertBack Method

CameraAnimationTimeToBoolConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.CameraAnimationTimeToBoolConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

CameraAnimationTimeToBoolConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ColorToSolidColorBrushColorConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersColorToSolidColorBrushColorConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ColorToSolidColorBrushColorConverter : IValueConverter
public ref class ColorToSolidColorBrushColorConverter : IValueConverter

The ColorToSolidColorBrushColorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ColorToSolidColorBrushColorConverter | Initializes a new instance of the ColorToSolidColorBrushColorConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


ColorToSolidColorBrushColorConverter Constructor

Initializes a new instance of the ColorToSolidColorBrushColorConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ColorToSolidColorBrushColorConverter()
public:
ColorToSolidColorBrushColorConverter()
See Also

Reference

ColorToSolidColorBrushColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ColorToSolidColorBrushColorConverter Methods

The ColorToSolidColorBrushColorConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ColorToSolidColorBrushColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ColorToSolidColorBrushColorConverter.Convert Method

ColorToSolidColorBrushColorConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.ColorToSolidColorBrushColorConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ColorToSolidColorBrushColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ColorToSolidColorBrushColorConverter.ConvertBack Method

ColorToSolidColorBrushColorConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.ColorToSolidColorBrushColorConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ColorToSolidColorBrushColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
VisualComponents.UX.Shared.Controls.ConvertersDoubleTypeConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DoubleTypeConverter : FrameworkElement,
    IValueConverter
public ref class DoubleTypeConverter : public FrameworkElement,
    IValueConverter

The DoubleTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleTypeConverter | Initializes a new instance of the DoubleTypeConverter class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UnitConversion | If property has a unit defained, we will use that to convert displayed value.
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Convert |
Public method | ConvertBack |
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnitChanged |
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReadSettings |
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
UnitConversionProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter Constructor

Initializes a new instance of the DoubleTypeConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DoubleTypeConverter()
public:
DoubleTypeConverter()
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter Properties

The DoubleTypeConverter type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UnitConversion | If property has a unit defained, we will use that to convert displayed value.
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter.UnitConversion Property

DoubleTypeConverterUnitConversion Property

If property has a unit defained, we will use that to convert displayed value.

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnit UnitConversion { get; set; }
public:
property IUnit^ UnitConversion {
    IUnit^ get ();
    void set (IUnit^ value);
}

Property Value

Type: IUnit
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter Methods

The DoubleTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Convert |
Public method | ConvertBack |
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnitChanged |
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReadSettings |
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter.Convert Method

DoubleTypeConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleTypeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter.ConvertBack Method

DoubleTypeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleTypeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter.OnUnitChanged Method

DoubleTypeConverterOnUnitChanged Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnUnitChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnUnitChanged(
    DependencyPropertyChangedEventArgs e
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter.ReadSettings Method

DoubleTypeConverterReadSettings Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadSettings()
public:
void ReadSettings()
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter Events

The DoubleTypeConverter type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter Fields

The DoubleTypeConverter type exposes the following members.

Fields
Name | Description
UnitConversionProperty |
Top
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverter.UnitConversionProperty Field

DoubleTypeConverterUnitConversionProperty Field

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty UnitConversionProperty
public:
static initonly DependencyProperty^ UnitConversionProperty

Field Value

Type: DependencyProperty
See Also

Reference

DoubleTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
VisualComponents.UX.Shared.Controls.ConvertersDoubleTypeConverterEx

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DoubleTypeConverterEx : FrameworkElement,
    IValueConverter
public ref class DoubleTypeConverterEx : public FrameworkElement,
    IValueConverter

The DoubleTypeConverterEx type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleTypeConverterEx | Initializes a new instance of the DoubleTypeConverterEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UnitConversion | If property has a unit defained, we will use that to convert displayed value.
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Convert |
Public method | ConvertBack |
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnitChanged |
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReadSettings |
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
UnitConversionProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx Constructor

Initializes a new instance of the DoubleTypeConverterEx class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DoubleTypeConverterEx()
public:
DoubleTypeConverterEx()
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx Properties

The DoubleTypeConverterEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UnitConversion | If property has a unit defained, we will use that to convert displayed value.
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx.UnitConversion Property

DoubleTypeConverterExUnitConversion Property

If property has a unit defained, we will use that to convert displayed value.

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnit UnitConversion { get; set; }
public:
property IUnit^ UnitConversion {
    IUnit^ get ();
    void set (IUnit^ value);
}

Property Value

Type: IUnit
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx Methods

The DoubleTypeConverterEx type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Convert |
Public method | ConvertBack |
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnitChanged |
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReadSettings |
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx.Convert Method

DoubleTypeConverterExConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleTypeConverterEx.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx.ConvertBack Method

DoubleTypeConverterExConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleTypeConverterEx.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx.OnUnitChanged Method

DoubleTypeConverterExOnUnitChanged Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnUnitChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnUnitChanged(
    DependencyPropertyChangedEventArgs e
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx.ReadSettings Method

DoubleTypeConverterExReadSettings Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadSettings()
public:
void ReadSettings()
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx Events

The DoubleTypeConverterEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx Fields

The DoubleTypeConverterEx type exposes the following members.

Fields
Name | Description
UnitConversionProperty |
Top
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterEx.UnitConversionProperty Field

DoubleTypeConverterExUnitConversionProperty Field

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty UnitConversionProperty
public:
static initonly DependencyProperty^ UnitConversionProperty

Field Value

Type: DependencyProperty
See Also

Reference

DoubleTypeConverterEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnits Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersDoubleTypeConverterWithUnits

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DoubleTypeConverterWithUnits : IMultiValueConverter
public ref class DoubleTypeConverterWithUnits : IMultiValueConverter

The DoubleTypeConverterWithUnits type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleTypeConverterWithUnits | Initializes a new instance of the DoubleTypeConverterWithUnits class
Top
Properties
Name | Description
ExpressionEvaluator |
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | EvaluateIfNeeded |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnits Constructor

Initializes a new instance of the DoubleTypeConverterWithUnits class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DoubleTypeConverterWithUnits()
public:
DoubleTypeConverterWithUnits()
See Also

Reference

DoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnits Properties

The DoubleTypeConverterWithUnits type exposes the following members.

Properties
Name | Description
ExpressionEvaluator |
Top
See Also

Reference

DoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnits.ExpressionEvaluator Property

DoubleTypeConverterWithUnitsExpressionEvaluator Property

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IExpressionEvaluator ExpressionEvaluator { get; }
public:
static property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get ();
}

Property Value

Type: IExpressionEvaluator
See Also

Reference

DoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnits Methods

The DoubleTypeConverterWithUnits type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | EvaluateIfNeeded |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnits.Convert Method

DoubleTypeConverterWithUnitsConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleTypeConverterWithUnits.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnits.ConvertBack Method

DoubleTypeConverterWithUnitsConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleTypeConverterWithUnits.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnits.EvaluateIfNeeded Method

DoubleTypeConverterWithUnitsEvaluateIfNeeded Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool EvaluateIfNeeded(
    ref string value,
    TextInputType TextInputType,
    IExpressionContext ExpressionContext
)
public:
static bool EvaluateIfNeeded(
    String^% value,
    TextInputType TextInputType,
    IExpressionContext^ ExpressionContext
)

Parameters

value
Type: SystemString
TextInputType
Type: VisualComponents.UX.SharedTextInputType
ExpressionContext
Type: VisualComponents.Create3DIExpressionContext

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleTypeConverterWithUnits.EvaluateIfNeeded(System.String@,VisualComponents.UX.Shared.TextInputType,VisualComponents.Create3D.IExpressionContext)"]

See Also

Reference

DoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnits.ReadSettings Method

DoubleTypeConverterWithUnitsReadSettings Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadSettings()
public:
void ReadSettings()
See Also

Reference

DoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnitsEx Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersDoubleTypeConverterWithUnitsEx

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DoubleTypeConverterWithUnitsEx : IMultiValueConverter
public ref class DoubleTypeConverterWithUnitsEx : IMultiValueConverter

The DoubleTypeConverterWithUnitsEx type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleTypeConverterWithUnitsEx | Initializes a new instance of the DoubleTypeConverterWithUnitsEx class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnitsEx Constructor

Initializes a new instance of the DoubleTypeConverterWithUnitsEx class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DoubleTypeConverterWithUnitsEx()
public:
DoubleTypeConverterWithUnitsEx()
See Also

Reference

DoubleTypeConverterWithUnitsEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnitsEx Methods

The DoubleTypeConverterWithUnitsEx type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DoubleTypeConverterWithUnitsEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnitsEx.Convert Method

DoubleTypeConverterWithUnitsExConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleTypeConverterWithUnitsEx.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleTypeConverterWithUnitsEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnitsEx.ConvertBack Method

DoubleTypeConverterWithUnitsExConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleTypeConverterWithUnitsEx.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleTypeConverterWithUnitsEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleTypeConverterWithUnitsEx.ReadSettings Method

DoubleTypeConverterWithUnitsExReadSettings Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadSettings()
public:
void ReadSettings()
See Also

Reference

DoubleTypeConverterWithUnitsEx Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleWithUnitTypeConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersDoubleWithUnitTypeConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DoubleWithUnitTypeConverter : IMultiValueConverter
public ref class DoubleWithUnitTypeConverter : IMultiValueConverter

The DoubleWithUnitTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleWithUnitTypeConverter | Initializes a new instance of the DoubleWithUnitTypeConverter class
Top
Properties
 | Name | Description
Public property | UxUnit |
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleWithUnitTypeConverter Constructor

Initializes a new instance of the DoubleWithUnitTypeConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DoubleWithUnitTypeConverter()
public:
DoubleWithUnitTypeConverter()
See Also

Reference

DoubleWithUnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleWithUnitTypeConverter Properties

The DoubleWithUnitTypeConverter type exposes the following members.

Properties
 | Name | Description
Public property | UxUnit |
Top
See Also

Reference

DoubleWithUnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleWithUnitTypeConverter.UxUnit Property

DoubleWithUnitTypeConverterUxUnit Property

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnit UxUnit { get; }
public:
property IUnit^ UxUnit {
    IUnit^ get ();
}

Property Value

Type: IUnit
See Also

Reference

DoubleWithUnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleWithUnitTypeConverter Methods

The DoubleWithUnitTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DoubleWithUnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleWithUnitTypeConverter.Convert Method

DoubleWithUnitTypeConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleWithUnitTypeConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleWithUnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleWithUnitTypeConverter.ConvertBack Method

DoubleWithUnitTypeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.DoubleWithUnitTypeConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleWithUnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


DoubleWithUnitTypeConverter.ReadSettings Method

DoubleWithUnitTypeConverterReadSettings Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadSettings()
public:
void ReadSettings()
See Also

Reference

DoubleWithUnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


EnumTypeConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersEnumTypeConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EnumTypeConverter : IValueConverter
public ref class EnumTypeConverter : IValueConverter

The EnumTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | EnumTypeConverter | Initializes a new instance of the EnumTypeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


EnumTypeConverter Constructor

Initializes a new instance of the EnumTypeConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EnumTypeConverter()
public:
EnumTypeConverter()
See Also

Reference

EnumTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


EnumTypeConverter Methods

The EnumTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EnumTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


EnumTypeConverter.Convert Method

EnumTypeConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.EnumTypeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

EnumTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


EnumTypeConverter.ConvertBack Method

EnumTypeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.EnumTypeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

EnumTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


IntTypeConverterWithUnits Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersIntTypeConverterWithUnits

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class IntTypeConverterWithUnits : IMultiValueConverter
public ref class IntTypeConverterWithUnits : IMultiValueConverter

The IntTypeConverterWithUnits type exposes the following members.

Constructors
 | Name | Description
Public method | IntTypeConverterWithUnits | Initializes a new instance of the IntTypeConverterWithUnits class
Public method | IntTypeConverterWithUnits(IProperty) | Initializes a new instance of the IntTypeConverterWithUnits class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


IntTypeConverterWithUnits Constructor

Overload List
 | Name | Description
Public method | IntTypeConverterWithUnits | Initializes a new instance of the IntTypeConverterWithUnits class
Public method | IntTypeConverterWithUnits(IProperty) | Initializes a new instance of the IntTypeConverterWithUnits class
Top
See Also

Reference

IntTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


IntTypeConverterWithUnits Constructor

Initializes a new instance of the IntTypeConverterWithUnits class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntTypeConverterWithUnits()
public:
IntTypeConverterWithUnits()
See Also

Reference

IntTypeConverterWithUnits Class
IntTypeConverterWithUnits Overload
VisualComponents.UX.Shared.Controls.Converters Namespace


IntTypeConverterWithUnits Constructor (IProperty)

Initializes a new instance of the IntTypeConverterWithUnits class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntTypeConverterWithUnits(
    IProperty property
)
public:
IntTypeConverterWithUnits(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

IntTypeConverterWithUnits Class
IntTypeConverterWithUnits Overload
VisualComponents.UX.Shared.Controls.Converters Namespace


IntTypeConverterWithUnits Methods

The IntTypeConverterWithUnits type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

IntTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


IntTypeConverterWithUnits.Convert Method

IntTypeConverterWithUnitsConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.IntTypeConverterWithUnits.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

IntTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


IntTypeConverterWithUnits.ConvertBack Method

IntTypeConverterWithUnitsConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.IntTypeConverterWithUnits.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

IntTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


IsTrimmedToVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersIsTrimmedToVisibilityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class IsTrimmedToVisibilityConverter : IValueConverter
public ref class IsTrimmedToVisibilityConverter : IValueConverter

The IsTrimmedToVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | IsTrimmedToVisibilityConverter | Initializes a new instance of the IsTrimmedToVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


IsTrimmedToVisibilityConverter Constructor

Initializes a new instance of the IsTrimmedToVisibilityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IsTrimmedToVisibilityConverter()
public:
IsTrimmedToVisibilityConverter()
See Also

Reference

IsTrimmedToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


IsTrimmedToVisibilityConverter Methods

The IsTrimmedToVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

IsTrimmedToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


IsTrimmedToVisibilityConverter.Convert Method

IsTrimmedToVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.IsTrimmedToVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

IsTrimmedToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


IsTrimmedToVisibilityConverter.ConvertBack Method

IsTrimmedToVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.IsTrimmedToVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

IsTrimmedToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


LanguageConverter Class

Returns localization string
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersLanguageConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class LanguageConverter : IValueConverter
public ref class LanguageConverter sealed : IValueConverter

The LanguageConverter type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageConverter | default constructor
Top
Methods
 | Name | Description
Public method | Convert | Converts a value.
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Examples
Copy
// in xaml file
<igRibbon:XamRibbon x:Class="class_name"
    ...
    xmlns:converters="clr-namespace:VisualComponents.UX.Shared.Controls.Converters;assembly=UX.Shared"
    ...
    >
    <igRibbon:XamRibbon.Resources>
        <ResourceDictionary>
            ...
            <converters:LanguageConverter x:Key="LangConverter" />
            ...
        </ResourceDictionary>
    </igRibbon:XamRibbon.Resources>
    ...
    <Label Content="{Binding Converter={StaticResource LangConverter}, ConverterParameter=ResourceKey}"/>
Copy
<UserControl x:Class="class_name"
    ...
    xmlns:converters="clr-namespace:VisualComponents.UX.Shared.Controls.Converters;assembly=UX.Shared"
    ...
>
    <UserControl.Resources>
        <ResourceDictionary>
            ...
            <converters:LanguageConverter x:Key="LangConverter" />
            ...
        </ResourceDictionary>
    </UserControl.Resources>
    ...
    <ToolTip Style="{DynamicResource VCToolTipStyle}"
             Content="{Binding Converter={StaticResource LangConverter}, ConverterParameter=NameOfStringID}"/>
    ...
</UserControl>
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


LanguageConverter Constructor

default constructor

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LanguageConverter()
public:
LanguageConverter()
See Also

Reference

LanguageConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


LanguageConverter Methods

The LanguageConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value.
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LanguageConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


LanguageConverter.Convert Method

LanguageConverterConvert Method

Converts a value.

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value. If the method returns null, the valid null value is used.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

LanguageConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


LanguageConverter.ConvertBack Method

LanguageConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.LanguageConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

LanguageConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ListToStringConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersListToStringConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ListToStringConverter : IValueConverter
public ref class ListToStringConverter : IValueConverter

The ListToStringConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ListToStringConverter | Initializes a new instance of the ListToStringConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


ListToStringConverter Constructor

Initializes a new instance of the ListToStringConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ListToStringConverter()
public:
ListToStringConverter()
See Also

Reference

ListToStringConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ListToStringConverter Methods

The ListToStringConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ListToStringConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ListToStringConverter.Convert Method

ListToStringConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.ListToStringConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ListToStringConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ListToStringConverter.ConvertBack Method

ListToStringConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.ListToStringConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ListToStringConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ListToVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersListToVisibilityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ListToVisibilityConverter : IValueConverter
public ref class ListToVisibilityConverter : IValueConverter

The ListToVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ListToVisibilityConverter | Initializes a new instance of the ListToVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


ListToVisibilityConverter Constructor

Initializes a new instance of the ListToVisibilityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ListToVisibilityConverter()
public:
ListToVisibilityConverter()
See Also

Reference

ListToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ListToVisibilityConverter Methods

The ListToVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ListToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ListToVisibilityConverter.Convert Method

ListToVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.ListToVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ListToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ListToVisibilityConverter.ConvertBack Method

ListToVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.ListToVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ListToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


MediaColorToSolidColorBrushColorConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersMediaColorToSolidColorBrushColorConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MediaColorToSolidColorBrushColorConverter : IValueConverter
public ref class MediaColorToSolidColorBrushColorConverter : IValueConverter

The MediaColorToSolidColorBrushColorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MediaColorToSolidColorBrushColorConverter | Initializes a new instance of the MediaColorToSolidColorBrushColorConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


MediaColorToSolidColorBrushColorConverter Constructor

Initializes a new instance of the MediaColorToSolidColorBrushColorConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MediaColorToSolidColorBrushColorConverter()
public:
MediaColorToSolidColorBrushColorConverter()
See Also

Reference

MediaColorToSolidColorBrushColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


MediaColorToSolidColorBrushColorConverter Methods

The MediaColorToSolidColorBrushColorConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MediaColorToSolidColorBrushColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


MediaColorToSolidColorBrushColorConverter.Convert Method

MediaColorToSolidColorBrushColorConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.MediaColorToSolidColorBrushColorConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

MediaColorToSolidColorBrushColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


MediaColorToSolidColorBrushColorConverter.ConvertBack Method

MediaColorToSolidColorBrushColorConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.MediaColorToSolidColorBrushColorConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

MediaColorToSolidColorBrushColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


MultipleBoolValueToIsEnabledConverter Class

This converter is used in checkbox. if two or more objects are selected, then there common property name is displayed on property grid. If Selected objects have value of different bool type then using this converter the checkbox control IsEnabled property will be false.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersMultipleBoolValueToIsEnabledConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MultipleBoolValueToIsEnabledConverter : IValueConverter
public ref class MultipleBoolValueToIsEnabledConverter : IValueConverter

The MultipleBoolValueToIsEnabledConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MultipleBoolValueToIsEnabledConverter | Initializes a new instance of the MultipleBoolValueToIsEnabledConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


MultipleBoolValueToIsEnabledConverter Constructor

Initializes a new instance of the MultipleBoolValueToIsEnabledConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MultipleBoolValueToIsEnabledConverter()
public:
MultipleBoolValueToIsEnabledConverter()
See Also

Reference

MultipleBoolValueToIsEnabledConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


MultipleBoolValueToIsEnabledConverter Methods

The MultipleBoolValueToIsEnabledConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MultipleBoolValueToIsEnabledConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


MultipleBoolValueToIsEnabledConverter.Convert Method

MultipleBoolValueToIsEnabledConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.MultipleBoolValueToIsEnabledConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

MultipleBoolValueToIsEnabledConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


MultipleBoolValueToIsEnabledConverter.ConvertBack Method

MultipleBoolValueToIsEnabledConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.MultipleBoolValueToIsEnabledConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

MultipleBoolValueToIsEnabledConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NewLineToSpaceConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersNewLineToSpaceConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NewLineToSpaceConverter : IValueConverter
public ref class NewLineToSpaceConverter : IValueConverter

The NewLineToSpaceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NewLineToSpaceConverter | Initializes a new instance of the NewLineToSpaceConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


NewLineToSpaceConverter Constructor

Initializes a new instance of the NewLineToSpaceConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NewLineToSpaceConverter()
public:
NewLineToSpaceConverter()
See Also

Reference

NewLineToSpaceConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NewLineToSpaceConverter Methods

The NewLineToSpaceConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NewLineToSpaceConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NewLineToSpaceConverter.Convert Method

NewLineToSpaceConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.NewLineToSpaceConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

NewLineToSpaceConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NewLineToSpaceConverter.ConvertBack Method

NewLineToSpaceConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.NewLineToSpaceConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

NewLineToSpaceConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToBooleanConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersNullToBooleanConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NullToBooleanConverter : IValueConverter
public ref class NullToBooleanConverter : IValueConverter

The NullToBooleanConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NullToBooleanConverter | Initializes a new instance of the NullToBooleanConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


NullToBooleanConverter Constructor

Initializes a new instance of the NullToBooleanConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NullToBooleanConverter()
public:
NullToBooleanConverter()
See Also

Reference

NullToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToBooleanConverter Methods

The NullToBooleanConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NullToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToBooleanConverter.Convert Method

NullToBooleanConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.NullToBooleanConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

NullToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToBooleanConverter.ConvertBack Method

NullToBooleanConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.NullToBooleanConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

NullToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToHiddenVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersNullToHiddenVisibilityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NullToHiddenVisibilityConverter : IValueConverter
public ref class NullToHiddenVisibilityConverter : IValueConverter

The NullToHiddenVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NullToHiddenVisibilityConverter | Initializes a new instance of the NullToHiddenVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


NullToHiddenVisibilityConverter Constructor

Initializes a new instance of the NullToHiddenVisibilityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NullToHiddenVisibilityConverter()
public:
NullToHiddenVisibilityConverter()
See Also

Reference

NullToHiddenVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToHiddenVisibilityConverter Methods

The NullToHiddenVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NullToHiddenVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToHiddenVisibilityConverter.Convert Method

NullToHiddenVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.NullToHiddenVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

NullToHiddenVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToHiddenVisibilityConverter.ConvertBack Method

NullToHiddenVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.NullToHiddenVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

NullToHiddenVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToOppositeVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersNullToOppositeVisibilityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NullToOppositeVisibilityConverter : IValueConverter
public ref class NullToOppositeVisibilityConverter : IValueConverter

The NullToOppositeVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NullToOppositeVisibilityConverter | Initializes a new instance of the NullToOppositeVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


NullToOppositeVisibilityConverter Constructor

Initializes a new instance of the NullToOppositeVisibilityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NullToOppositeVisibilityConverter()
public:
NullToOppositeVisibilityConverter()
See Also

Reference

NullToOppositeVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToOppositeVisibilityConverter Methods

The NullToOppositeVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NullToOppositeVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToOppositeVisibilityConverter.Convert Method

NullToOppositeVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.NullToOppositeVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

NullToOppositeVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToOppositeVisibilityConverter.ConvertBack Method

NullToOppositeVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.NullToOppositeVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

NullToOppositeVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersNullToVisibilityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NullToVisibilityConverter : IValueConverter
public ref class NullToVisibilityConverter : IValueConverter

The NullToVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NullToVisibilityConverter | Initializes a new instance of the NullToVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


NullToVisibilityConverter Constructor

Initializes a new instance of the NullToVisibilityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NullToVisibilityConverter()
public:
NullToVisibilityConverter()
See Also

Reference

NullToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToVisibilityConverter Methods

The NullToVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NullToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToVisibilityConverter.Convert Method

NullToVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.NullToVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

NullToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


NullToVisibilityConverter.ConvertBack Method

NullToVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.NullToVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

NullToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ObjectToStringConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersObjectToStringConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ObjectToStringConverter : IValueConverter
public ref class ObjectToStringConverter : IValueConverter

The ObjectToStringConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectToStringConverter | Initializes a new instance of the ObjectToStringConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


ObjectToStringConverter Constructor

Initializes a new instance of the ObjectToStringConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObjectToStringConverter()
public:
ObjectToStringConverter()
See Also

Reference

ObjectToStringConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ObjectToStringConverter Methods

The ObjectToStringConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ObjectToStringConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ObjectToStringConverter.Convert Method

ObjectToStringConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.ObjectToStringConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ObjectToStringConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ObjectToStringConverter.ConvertBack Method

ObjectToStringConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.ObjectToStringConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ObjectToStringConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ParameterEqualityToVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersParameterEqualityToVisibilityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ParameterEqualityToVisibilityConverter : IValueConverter
public ref class ParameterEqualityToVisibilityConverter : IValueConverter

The ParameterEqualityToVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterEqualityToVisibilityConverter | Initializes a new instance of the ParameterEqualityToVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


ParameterEqualityToVisibilityConverter Constructor

Initializes a new instance of the ParameterEqualityToVisibilityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ParameterEqualityToVisibilityConverter()
public:
ParameterEqualityToVisibilityConverter()
See Also

Reference

ParameterEqualityToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ParameterEqualityToVisibilityConverter Methods

The ParameterEqualityToVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ParameterEqualityToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ParameterEqualityToVisibilityConverter.Convert Method

ParameterEqualityToVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.ParameterEqualityToVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ParameterEqualityToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


ParameterEqualityToVisibilityConverter.ConvertBack Method

ParameterEqualityToVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.ParameterEqualityToVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ParameterEqualityToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


SecondToTimeSpanConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersSecondToTimeSpanConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SecondToTimeSpanConverter : IValueConverter
public ref class SecondToTimeSpanConverter : IValueConverter

The SecondToTimeSpanConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SecondToTimeSpanConverter | Initializes a new instance of the SecondToTimeSpanConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


SecondToTimeSpanConverter Constructor

Initializes a new instance of the SecondToTimeSpanConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SecondToTimeSpanConverter()
public:
SecondToTimeSpanConverter()
See Also

Reference

SecondToTimeSpanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


SecondToTimeSpanConverter Methods

The SecondToTimeSpanConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SecondToTimeSpanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


SecondToTimeSpanConverter.Convert Method

SecondToTimeSpanConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.SecondToTimeSpanConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

SecondToTimeSpanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


SecondToTimeSpanConverter.ConvertBack Method

SecondToTimeSpanConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.SecondToTimeSpanConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

SecondToTimeSpanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


SimulationTimeConverterForCameraEditor Class

This converter formats time to a setting set in clock display setting.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersSimulationTimeConverterForCameraEditor

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationTimeConverterForCameraEditor : IValueConverter
public ref class SimulationTimeConverterForCameraEditor : IValueConverter

The SimulationTimeConverterForCameraEditor type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationTimeConverterForCameraEditor | Initializes a new instance of the SimulationTimeConverterForCameraEditor class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ObjectToEnumT |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


SimulationTimeConverterForCameraEditor Constructor

Initializes a new instance of the SimulationTimeConverterForCameraEditor class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationTimeConverterForCameraEditor()
public:
SimulationTimeConverterForCameraEditor()
See Also

Reference

SimulationTimeConverterForCameraEditor Class
VisualComponents.UX.Shared.Controls.Converters Namespace


SimulationTimeConverterForCameraEditor Methods

The SimulationTimeConverterForCameraEditor type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ObjectToEnumT |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationTimeConverterForCameraEditor Class
VisualComponents.UX.Shared.Controls.Converters Namespace


SimulationTimeConverterForCameraEditor.Convert Method

SimulationTimeConverterForCameraEditorConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.SimulationTimeConverterForCameraEditor.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

SimulationTimeConverterForCameraEditor Class
VisualComponents.UX.Shared.Controls.Converters Namespace


SimulationTimeConverterForCameraEditor.ConvertBack Method

SimulationTimeConverterForCameraEditorConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.SimulationTimeConverterForCameraEditor.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

SimulationTimeConverterForCameraEditor Class
VisualComponents.UX.Shared.Controls.Converters Namespace


SimulationTimeConverterForCameraEditor.ObjectToEnum(T) Method

SimulationTimeConverterForCameraEditorObjectToEnumT Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T ObjectToEnum<T>(
    Object o
)

public:
generic<typename T>
T ObjectToEnum(
    Object^ o
)

Parameters

o
Type: SystemObject

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.SimulationTimeConverterForCameraEditor.ObjectToEnum``1(System.Object)"]

See Also

Reference

SimulationTimeConverterForCameraEditor Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToBooleanConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersStringToBooleanConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StringToBooleanConverter : IValueConverter
public ref class StringToBooleanConverter : IValueConverter

The StringToBooleanConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StringToBooleanConverter | Initializes a new instance of the StringToBooleanConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


StringToBooleanConverter Constructor

Initializes a new instance of the StringToBooleanConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StringToBooleanConverter()
public:
StringToBooleanConverter()
See Also

Reference

StringToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToBooleanConverter Methods

The StringToBooleanConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StringToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToBooleanConverter.Convert Method

StringToBooleanConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.StringToBooleanConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

StringToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToBooleanConverter.ConvertBack Method

StringToBooleanConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.StringToBooleanConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

StringToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToDoubleWithUnitConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersStringToDoubleWithUnitConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StringToDoubleWithUnitConverter : IMultiValueConverter
public ref class StringToDoubleWithUnitConverter : IMultiValueConverter

The StringToDoubleWithUnitConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StringToDoubleWithUnitConverter | Initializes a new instance of the StringToDoubleWithUnitConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


StringToDoubleWithUnitConverter Constructor

Initializes a new instance of the StringToDoubleWithUnitConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StringToDoubleWithUnitConverter()
public:
StringToDoubleWithUnitConverter()
See Also

Reference

StringToDoubleWithUnitConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToDoubleWithUnitConverter Methods

The StringToDoubleWithUnitConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StringToDoubleWithUnitConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToDoubleWithUnitConverter.Convert Method

StringToDoubleWithUnitConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.StringToDoubleWithUnitConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

StringToDoubleWithUnitConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToDoubleWithUnitConverter.ConvertBack Method

StringToDoubleWithUnitConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.StringToDoubleWithUnitConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

StringToDoubleWithUnitConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToDoubleWithUnitConverter.ReadSettings Method

StringToDoubleWithUnitConverterReadSettings Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadSettings()
public:
void ReadSettings()
See Also

Reference

StringToDoubleWithUnitConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersStringToVisibilityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StringToVisibilityConverter : IValueConverter
public ref class StringToVisibilityConverter : IValueConverter

The StringToVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StringToVisibilityConverter | Initializes a new instance of the StringToVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


StringToVisibilityConverter Constructor

Initializes a new instance of the StringToVisibilityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StringToVisibilityConverter()
public:
StringToVisibilityConverter()
See Also

Reference

StringToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToVisibilityConverter Methods

The StringToVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StringToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToVisibilityConverter.Convert Method

StringToVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.StringToVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

StringToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


StringToVisibilityConverter.ConvertBack Method

StringToVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.StringToVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

StringToVisibilityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TextInputTypeConverter Class

This converter is used to select the TextInputType for double type property based on UseAsInteger property.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersTextInputTypeConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TextInputTypeConverter : IValueConverter
public ref class TextInputTypeConverter : IValueConverter

The TextInputTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TextInputTypeConverter | Initializes a new instance of the TextInputTypeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


TextInputTypeConverter Constructor

Initializes a new instance of the TextInputTypeConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TextInputTypeConverter()
public:
TextInputTypeConverter()
See Also

Reference

TextInputTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TextInputTypeConverter Methods

The TextInputTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TextInputTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TextInputTypeConverter.Convert Method

TextInputTypeConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.TextInputTypeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

TextInputTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TextInputTypeConverter.ConvertBack Method

TextInputTypeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.TextInputTypeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

TextInputTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TwoStringsEqualityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersTwoStringsEqualityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TwoStringsEqualityConverter : IMultiValueConverter
public ref class TwoStringsEqualityConverter : IMultiValueConverter

The TwoStringsEqualityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TwoStringsEqualityConverter | Initializes a new instance of the TwoStringsEqualityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


TwoStringsEqualityConverter Constructor

Initializes a new instance of the TwoStringsEqualityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TwoStringsEqualityConverter()
public:
TwoStringsEqualityConverter()
See Also

Reference

TwoStringsEqualityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TwoStringsEqualityConverter Methods

The TwoStringsEqualityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TwoStringsEqualityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TwoStringsEqualityConverter.Convert Method

TwoStringsEqualityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.TwoStringsEqualityConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

TwoStringsEqualityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TwoStringsEqualityConverter.ConvertBack Method

TwoStringsEqualityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.TwoStringsEqualityConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

TwoStringsEqualityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TwoValuesEqualityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersTwoValuesEqualityConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TwoValuesEqualityConverter : IMultiValueConverter
public ref class TwoValuesEqualityConverter : IMultiValueConverter

The TwoValuesEqualityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TwoValuesEqualityConverter | Initializes a new instance of the TwoValuesEqualityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


TwoValuesEqualityConverter Constructor

Initializes a new instance of the TwoValuesEqualityConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TwoValuesEqualityConverter()
public:
TwoValuesEqualityConverter()
See Also

Reference

TwoValuesEqualityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TwoValuesEqualityConverter Methods

The TwoValuesEqualityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TwoValuesEqualityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TwoValuesEqualityConverter.Convert Method

TwoValuesEqualityConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.TwoValuesEqualityConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

TwoValuesEqualityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


TwoValuesEqualityConverter.ConvertBack Method

TwoValuesEqualityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.TwoValuesEqualityConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

TwoValuesEqualityConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnitConverter Class

This converter is used to select the right unit(for displaying in UI) suffix for the selected unit family .
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersUnitConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UnitConverter : IValueConverter
public ref class UnitConverter : IValueConverter

The UnitConverter type exposes the following members.

Constructors
 | Name | Description
Public method | UnitConverter | Initializes a new instance of the UnitConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


UnitConverter Constructor

Initializes a new instance of the UnitConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UnitConverter()
public:
UnitConverter()
See Also

Reference

UnitConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnitConverter Methods

The UnitConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UnitConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnitConverter.Convert Method

UnitConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.UnitConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

UnitConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnitConverter.ConvertBack Method

UnitConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.UnitConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

UnitConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnitTypeConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersUnitTypeConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UnitTypeConverter : IValueConverter
public ref class UnitTypeConverter : IValueConverter

The UnitTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | UnitTypeConverter | Initializes a new instance of the UnitTypeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


UnitTypeConverter Constructor

Initializes a new instance of the UnitTypeConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UnitTypeConverter()
public:
UnitTypeConverter()
See Also

Reference

UnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnitTypeConverter Methods

The UnitTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnitTypeConverter.Convert Method

UnitTypeConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.UnitTypeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

UnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnitTypeConverter.ConvertBack Method

UnitTypeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.UnitTypeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

UnitTypeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnprecisedDoubleTypeConverterWithUnits Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersUnprecisedDoubleTypeConverterWithUnits

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UnprecisedDoubleTypeConverterWithUnits : IMultiValueConverter
public ref class UnprecisedDoubleTypeConverterWithUnits : IMultiValueConverter

The UnprecisedDoubleTypeConverterWithUnits type exposes the following members.

Constructors
 | Name | Description
Public method | UnprecisedDoubleTypeConverterWithUnits | Initializes a new instance of the UnprecisedDoubleTypeConverterWithUnits class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


UnprecisedDoubleTypeConverterWithUnits Constructor

Initializes a new instance of the UnprecisedDoubleTypeConverterWithUnits class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UnprecisedDoubleTypeConverterWithUnits()
public:
UnprecisedDoubleTypeConverterWithUnits()
See Also

Reference

UnprecisedDoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnprecisedDoubleTypeConverterWithUnits Methods

The UnprecisedDoubleTypeConverterWithUnits type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UnprecisedDoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnprecisedDoubleTypeConverterWithUnits.Convert Method

UnprecisedDoubleTypeConverterWithUnitsConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.UnprecisedDoubleTypeConverterWithUnits.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

UnprecisedDoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UnprecisedDoubleTypeConverterWithUnits.ConvertBack Method

UnprecisedDoubleTypeConverterWithUnitsConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.UnprecisedDoubleTypeConverterWithUnits.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

UnprecisedDoubleTypeConverterWithUnits Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UTCToLocalDateTimeConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersUTCToLocalDateTimeConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UTCToLocalDateTimeConverter : IValueConverter
public ref class UTCToLocalDateTimeConverter : IValueConverter

The UTCToLocalDateTimeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | UTCToLocalDateTimeConverter | Initializes a new instance of the UTCToLocalDateTimeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


UTCToLocalDateTimeConverter Constructor

Initializes a new instance of the UTCToLocalDateTimeConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UTCToLocalDateTimeConverter()
public:
UTCToLocalDateTimeConverter()
See Also

Reference

UTCToLocalDateTimeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UTCToLocalDateTimeConverter Methods

The UTCToLocalDateTimeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UTCToLocalDateTimeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UTCToLocalDateTimeConverter.Convert Method

UTCToLocalDateTimeConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.UTCToLocalDateTimeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

UTCToLocalDateTimeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


UTCToLocalDateTimeConverter.ConvertBack Method

UTCToLocalDateTimeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.UTCToLocalDateTimeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

UTCToLocalDateTimeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VectorOrientationToOrientationConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersVectorOrientationToOrientationConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VectorOrientationToOrientationConverter : IValueConverter
public ref class VectorOrientationToOrientationConverter : IValueConverter

The VectorOrientationToOrientationConverter type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOrientationToOrientationConverter | Initializes a new instance of the VectorOrientationToOrientationConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


VectorOrientationToOrientationConverter Constructor

Initializes a new instance of the VectorOrientationToOrientationConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VectorOrientationToOrientationConverter()
public:
VectorOrientationToOrientationConverter()
See Also

Reference

VectorOrientationToOrientationConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VectorOrientationToOrientationConverter Methods

The VectorOrientationToOrientationConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VectorOrientationToOrientationConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VectorOrientationToOrientationConverter.Convert Method

VectorOrientationToOrientationConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.VectorOrientationToOrientationConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

VectorOrientationToOrientationConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VectorOrientationToOrientationConverter.ConvertBack Method

VectorOrientationToOrientationConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.VectorOrientationToOrientationConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

VectorOrientationToOrientationConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VectorToColorConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersVectorToColorConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VectorToColorConverter : IValueConverter
public ref class VectorToColorConverter : IValueConverter

The VectorToColorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | VectorToColorConverter | Initializes a new instance of the VectorToColorConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


VectorToColorConverter Constructor

Initializes a new instance of the VectorToColorConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VectorToColorConverter()
public:
VectorToColorConverter()
See Also

Reference

VectorToColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VectorToColorConverter Methods

The VectorToColorConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VectorToColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VectorToColorConverter.Convert Method

VectorToColorConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.VectorToColorConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

VectorToColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VectorToColorConverter.ConvertBack Method

VectorToColorConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.VectorToColorConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

VectorToColorConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VisibilityToBooleanConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersVisibilityToBooleanConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VisibilityToBooleanConverter : IValueConverter
public ref class VisibilityToBooleanConverter : IValueConverter

The VisibilityToBooleanConverter type exposes the following members.

Constructors
 | Name | Description
Public method | VisibilityToBooleanConverter | Initializes a new instance of the VisibilityToBooleanConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


VisibilityToBooleanConverter Constructor

Initializes a new instance of the VisibilityToBooleanConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VisibilityToBooleanConverter()
public:
VisibilityToBooleanConverter()
See Also

Reference

VisibilityToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VisibilityToBooleanConverter Methods

The VisibilityToBooleanConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisibilityToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VisibilityToBooleanConverter.Convert Method

VisibilityToBooleanConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.VisibilityToBooleanConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

VisibilityToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VisibilityToBooleanConverter.ConvertBack Method

VisibilityToBooleanConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.VisibilityToBooleanConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

VisibilityToBooleanConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VisibilityToOppositeConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.Controls.ConvertersVisibilityToOppositeConverter

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VisibilityToOppositeConverter : IValueConverter
public ref class VisibilityToOppositeConverter : IValueConverter

The VisibilityToOppositeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | VisibilityToOppositeConverter | Initializes a new instance of the VisibilityToOppositeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Controls.Converters Namespace


VisibilityToOppositeConverter Constructor

Initializes a new instance of the VisibilityToOppositeConverter class

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VisibilityToOppositeConverter()
public:
VisibilityToOppositeConverter()
See Also

Reference

VisibilityToOppositeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VisibilityToOppositeConverter Methods

The VisibilityToOppositeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisibilityToOppositeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VisibilityToOppositeConverter.Convert Method

VisibilityToOppositeConverterConvert Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.VisibilityToOppositeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

VisibilityToOppositeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VisibilityToOppositeConverter.ConvertBack Method

VisibilityToOppositeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared.Controls.Converters
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Controls.Converters.VisibilityToOppositeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

VisibilityToOppositeConverter Class
VisualComponents.UX.Shared.Controls.Converters Namespace


VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace

Classes
 | Class | Description
Public class | CollisionOwnConfiguration |
Interfaces
 | Interface | Description
Public interface | IDetectorManager |
Enumerations
 | Enumeration | Description
Public enumeration | DetectorManagerBuildType |


CollisionOwnConfiguration Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.MenuCommands.CollisionDetectionCollisionOwnConfiguration

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CollisionOwnConfiguration
public ref class CollisionOwnConfiguration

The CollisionOwnConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | CollisionOwnConfiguration | Initializes a new instance of the CollisionOwnConfiguration class
Top
Properties
 | Name | Description
Public property | Component |
Public property | Config |
Public property | Tool |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


CollisionOwnConfiguration Constructor

Initializes a new instance of the CollisionOwnConfiguration class

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionOwnConfiguration()
public:
CollisionOwnConfiguration()
See Also

Reference

CollisionOwnConfiguration Class
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


CollisionOwnConfiguration Properties

The CollisionOwnConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Component |
Public property | Config |
Public property | Tool |
Top
See Also

Reference

CollisionOwnConfiguration Class
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


CollisionOwnConfiguration.Component Property

CollisionOwnConfigurationComponent Property

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimComponent Component { get; set; }
public:
property ISimComponent^ Component {
    ISimComponent^ get ();
    void set (ISimComponent^ value);
}

Property Value

Type: ISimComponent
See Also

Reference

CollisionOwnConfiguration Class
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


CollisionOwnConfiguration.Config Property

CollisionOwnConfigurationConfig Property

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionDetectionConfigElement Config { get; set; }
public:
property CollisionDetectionConfigElement^ Config {
    CollisionDetectionConfigElement^ get ();
    void set (CollisionDetectionConfigElement^ value);
}

Property Value

Type: CollisionDetectionConfigElement
See Also

Reference

CollisionOwnConfiguration Class
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


CollisionOwnConfiguration.Tool Property

CollisionOwnConfigurationTool Property

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimComponent Tool { get; set; }
public:
property ISimComponent^ Tool {
    ISimComponent^ get ();
    void set (ISimComponent^ value);
}

Property Value

Type: ISimComponent
See Also

Reference

CollisionOwnConfiguration Class
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


CollisionOwnConfiguration Methods

The CollisionOwnConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CollisionOwnConfiguration Class
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


DetectorManagerBuildType Enumeration

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DetectorManagerBuildType
public enum class DetectorManagerBuildType
Members
Member name | Value | Description
Automatically | 0 |
FromConfiguration | 1 |
Manual | 2 |
See Also

Reference

VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager Interface

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDetectorManager
public interface class IDetectorManager

The IDetectorManager type exposes the following members.

Properties
 | Name | Description
Public property | AllDetectors | Return all collision detectors in the world
Public property | BuildType | How detector manager should behave when creating collision detectors
Public property | IsActive | Overall setting indicating if system should check for collision
Public property | SelectionDetector | Returns an special collision detector (Selection vs World)
Top
Methods
 | Name | Description
Public method | AddOwnConfiguration | In case of DetectorManagerBuildType.Automatically this option will override component collision settings
Public method | ClearAllCollisionHighlighting | Calls ClearCollisionHighlighting for every detector manager
Public method | CreateDetector | Adds new detector to the world
Public method | DeleteOwnConfiguration | In case of DetectorManagerBuildType.Automatically this option will delete a component specific collision setting
Public method | GetGlobalConfiguration | In case of DetectorManagerBuildType.Automatically this option will return the current settings
Public method | GetOwnConfiguration | In case of DetectorManagerBuildType.Automatically this option will return a component collision setting
Public method | ReConfigureDetectors | Reconfigure collision detectors
Public method | RemoveDetector | Removes the given detector from the world
Top
See Also

Reference

VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager Properties

The IDetectorManager type exposes the following members.

Properties
 | Name | Description
Public property | AllDetectors | Return all collision detectors in the world
Public property | BuildType | How detector manager should behave when creating collision detectors
Public property | IsActive | Overall setting indicating if system should check for collision
Public property | SelectionDetector | Returns an special collision detector (Selection vs World)
Top
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.AllDetectors Property

IDetectorManagerAllDetectors Property

Return all collision detectors in the world

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<ICollisionDetector> AllDetectors { get; }
property List<ICollisionDetector^>^ AllDetectors {
    List<ICollisionDetector^>^ get ();
}

Property Value

Type: ListICollisionDetector
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.BuildType Property

IDetectorManagerBuildType Property

How detector manager should behave when creating collision detectors

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DetectorManagerBuildType BuildType { get; set; }
property DetectorManagerBuildType BuildType {
    DetectorManagerBuildType get ();
    void set (DetectorManagerBuildType value);
}

Property Value

Type: DetectorManagerBuildType
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.IsActive Property

IDetectorManagerIsActive Property

Overall setting indicating if system should check for collision

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; set; }
property bool IsActive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.SelectionDetector Property

IDetectorManagerSelectionDetector Property

Returns an special collision detector (Selection vs World)

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICollisionDetector SelectionDetector { get; }
property ICollisionDetector^ SelectionDetector {
    ICollisionDetector^ get ();
}

Property Value

Type: ICollisionDetector
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager Methods

The IDetectorManager type exposes the following members.

Methods
 | Name | Description
Public method | AddOwnConfiguration | In case of DetectorManagerBuildType.Automatically this option will override component collision settings
Public method | ClearAllCollisionHighlighting | Calls ClearCollisionHighlighting for every detector manager
Public method | CreateDetector | Adds new detector to the world
Public method | DeleteOwnConfiguration | In case of DetectorManagerBuildType.Automatically this option will delete a component specific collision setting
Public method | GetGlobalConfiguration | In case of DetectorManagerBuildType.Automatically this option will return the current settings
Public method | GetOwnConfiguration | In case of DetectorManagerBuildType.Automatically this option will return a component collision setting
Public method | ReConfigureDetectors | Reconfigure collision detectors
Public method | RemoveDetector | Removes the given detector from the world
Top
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.AddOwnConfiguration Method

IDetectorManagerAddOwnConfiguration Method

In case of DetectorManagerBuildType.Automatically this option will override component collision settings

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddOwnConfiguration(
    CollisionOwnConfiguration config
)
void AddOwnConfiguration(
    CollisionOwnConfiguration^ config
)

Parameters

config
Type: VisualComponents.UX.Shared.MenuCommands.CollisionDetectionCollisionOwnConfiguration
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.ClearAllCollisionHighlighting Method

IDetectorManagerClearAllCollisionHighlighting Method

Calls ClearCollisionHighlighting for every detector manager

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearAllCollisionHighlighting(
    bool onlyActive
)
void ClearAllCollisionHighlighting(
    bool onlyActive
)

Parameters

onlyActive
Type: SystemBoolean
If True, it will ignore non-active detectors
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.CreateDetector Method

IDetectorManagerCreateDetector Method

Adds new detector to the world

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICollisionDetector CreateDetector(
    string name,
    List<ISimComponent> components
)
ICollisionDetector^ CreateDetector(
    String^ name,
    List<ISimComponent^>^ components
)

Parameters

name
Type: SystemString
name of detector
components
Type: System.Collections.GenericListISimComponent
selected components

Return Value

Type: ICollisionDetector

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MenuCommands.CollisionDetection.IDetectorManager.CreateDetector(System.String,System.Collections.Generic.List{VisualComponents.Create3D.ISimComponent})"]

See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.DeleteOwnConfiguration Method

IDetectorManagerDeleteOwnConfiguration Method

In case of DetectorManagerBuildType.Automatically this option will delete a component specific collision setting

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteOwnConfiguration(
    ISimComponent comp
)
void DeleteOwnConfiguration(
    ISimComponent^ comp
)

Parameters

comp
Type: VisualComponents.Create3DISimComponent
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.GetGlobalConfiguration Method

IDetectorManagerGetGlobalConfiguration Method

In case of DetectorManagerBuildType.Automatically this option will return the current settings

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
CollisionDetectionConfigElement GetGlobalConfiguration()
CollisionDetectionConfigElement^ GetGlobalConfiguration()

Return Value

Type: CollisionDetectionConfigElement

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MenuCommands.CollisionDetection.IDetectorManager.GetGlobalConfiguration"]

See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.GetOwnConfiguration Method

IDetectorManagerGetOwnConfiguration Method

In case of DetectorManagerBuildType.Automatically this option will return a component collision setting

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
CollisionOwnConfiguration GetOwnConfiguration(
    ISimComponent comp
)
CollisionOwnConfiguration^ GetOwnConfiguration(
    ISimComponent^ comp
)

Parameters

comp
Type: VisualComponents.Create3DISimComponent

Return Value

Type: CollisionOwnConfiguration

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MenuCommands.CollisionDetection.IDetectorManager.GetOwnConfiguration(VisualComponents.Create3D.ISimComponent)"]

See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.ReConfigureDetectors Method

IDetectorManagerReConfigureDetectors Method

Reconfigure collision detectors

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReConfigureDetectors()
void ReConfigureDetectors()
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


IDetectorManager.RemoveDetector Method

IDetectorManagerRemoveDetector Method

Removes the given detector from the world

Namespace: VisualComponents.UX.Shared.MenuCommands.CollisionDetection
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveDetector(
    ICollisionDetector detector
)
void RemoveDetector(
    ICollisionDetector^ detector
)

Parameters

detector
Type: VisualComponents.Create3DICollisionDetector
detector to be deleted
See Also

Reference

IDetectorManager Interface
VisualComponents.UX.Shared.MenuCommands.CollisionDetection Namespace


VisualComponents.UX.Shared.Messages Namespace

Classes
 | Class | Description
Public class | ExportAreaChangedMessage | Message used by ExportToBitmapViewModel to show currently selected area.


ExportAreaChangedMessage Class

Message used by ExportToBitmapViewModel to show currently selected area.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.Shared.MessagesExportAreaChangedMessage

Namespace: VisualComponents.UX.Shared.Messages
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExportAreaChangedMessage
public ref class ExportAreaChangedMessage

The ExportAreaChangedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ExportAreaChangedMessage | Initializes a new instance of the ExportAreaChangedMessage class
Top
Properties
 | Name | Description
Public property | AreaHeight |
Public property | AreaWidth |
Public property | ShowArea |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.Messages Namespace


ExportAreaChangedMessage Constructor

Initializes a new instance of the ExportAreaChangedMessage class

Namespace: VisualComponents.UX.Shared.Messages
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExportAreaChangedMessage()
public:
ExportAreaChangedMessage()
See Also

Reference

ExportAreaChangedMessage Class
VisualComponents.UX.Shared.Messages Namespace


ExportAreaChangedMessage Properties

The ExportAreaChangedMessage type exposes the following members.

Properties
 | Name | Description
Public property | AreaHeight |
Public property | AreaWidth |
Public property | ShowArea |
Top
See Also

Reference

ExportAreaChangedMessage Class
VisualComponents.UX.Shared.Messages Namespace


ExportAreaChangedMessage.AreaHeight Property

ExportAreaChangedMessageAreaHeight Property

Namespace: VisualComponents.UX.Shared.Messages
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int AreaHeight { get; set; }
public:
property int AreaHeight {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ExportAreaChangedMessage Class
VisualComponents.UX.Shared.Messages Namespace


ExportAreaChangedMessage.AreaWidth Property

ExportAreaChangedMessageAreaWidth Property

Namespace: VisualComponents.UX.Shared.Messages
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int AreaWidth { get; set; }
public:
property int AreaWidth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ExportAreaChangedMessage Class
VisualComponents.UX.Shared.Messages Namespace


ExportAreaChangedMessage.ShowArea Property

ExportAreaChangedMessageShowArea Property

Namespace: VisualComponents.UX.Shared.Messages
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowArea { get; set; }
public:
property bool ShowArea {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ExportAreaChangedMessage Class
VisualComponents.UX.Shared.Messages Namespace


ExportAreaChangedMessage Methods

The ExportAreaChangedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExportAreaChangedMessage Class
VisualComponents.UX.Shared.Messages Namespace


VisualComponents.UX.Shared.NetworkMap Namespace

Classes
 | Class | Description
Public class | ConnectionViewModel |
Public class | ConnectorViewModel |
Public class | CurvedArrow |
Public class | GhostLineViewModel |
Public class | NetworkViewModel |
Public class | NodePositionInfo |
Public class | NodeViewModel |
Interfaces
 | Interface | Description
Public interface | INodeViewModelContainer |
Enumerations
 | Enumeration | Description
Public enumeration | ConnectorMode |
Public enumeration | MapType |
Public enumeration | NodeConnectorFamily |
Public enumeration | NodeConnectorType |


ConnectionViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.Shared.NetworkMapConnectionViewModel
VisualComponents.UX.Shared.NetworkMapGhostLineViewModel

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConnectionViewModel : PropertyChangedBase
public ref class ConnectionViewModel : public PropertyChangedBase

The ConnectionViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionViewModel | Initializes a new instance of the ConnectionViewModel class
Top
Properties
 | Name | Description
Public property | ArcCurvature | Applies only to connections where MidPointCount is 1. Defines the curvature of an arc between the endpoints. Values: 100 => no curvature (straight line), 99 to 50 => perfect circle between endpoints, 49 to 30 => high curvature, 29 to 1 => medium curvature, 0 => optimal curvature (default), -1 to -500 => low curvature, -501 to -2000 => very low curvature, less than -2000 => almost straight line.
Public property | DestConnector | The destination connector the connection is attached to.
Public property | DestConnectorHotspot |
Public property | DestConnectorMode | Determines whether the connection's destination connector is now representing Signal value or the connection status.
Public property | Hightlight |
Public property | IsActive |
Public property | IsContainerVisible |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsSelected |
Public property | IsVisible |
Public property | MidPointCount | Only 0, 1 and 2 are currently supported
Public property | Points | Points that make up the connection.
Public property | SourceConnector | The source connector the connection is attached to.
Public property | SourceConnectorHotspot | The source and dest hotspots used for generating connection points.
Public property | SourceConnectorMode | Determines whether the connection's source connector is now representing Signal value or the connection status.
Public property | Tag |
Top
Methods
 | Name | Description
Protected method | ComputeConnectionPoints | Rebuild connection points.
Public method | DestConnectorModeChanged |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightedLine |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NormalLine |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | SourceConnectorModeChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ConnectionChanged | Event fired when the connection has changed.
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel Constructor

Initializes a new instance of the ConnectionViewModel class

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionViewModel(
    int midPointsCount = 2,
    int arcCurvature = 0
)
public:
ConnectionViewModel(
    int midPointsCount = 2,
    int arcCurvature = 0
)

Parameters

midPointsCount (Optional)
Type: SystemInt32
arcCurvature (Optional)
Type: SystemInt32
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel Properties

The ConnectionViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ArcCurvature | Applies only to connections where MidPointCount is 1. Defines the curvature of an arc between the endpoints. Values: 100 => no curvature (straight line), 99 to 50 => perfect circle between endpoints, 49 to 30 => high curvature, 29 to 1 => medium curvature, 0 => optimal curvature (default), -1 to -500 => low curvature, -501 to -2000 => very low curvature, less than -2000 => almost straight line.
Public property | DestConnector | The destination connector the connection is attached to.
Public property | DestConnectorHotspot |
Public property | DestConnectorMode | Determines whether the connection's destination connector is now representing Signal value or the connection status.
Public property | Hightlight |
Public property | IsActive |
Public property | IsContainerVisible |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsSelected |
Public property | IsVisible |
Public property | MidPointCount | Only 0, 1 and 2 are currently supported
Public property | Points | Points that make up the connection.
Public property | SourceConnector | The source connector the connection is attached to.
Public property | SourceConnectorHotspot | The source and dest hotspots used for generating connection points.
Public property | SourceConnectorMode | Determines whether the connection's source connector is now representing Signal value or the connection status.
Public property | Tag |
Top
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.ArcCurvature Property

ConnectionViewModelArcCurvature Property

Applies only to connections where MidPointCount is 1. Defines the curvature of an arc between the endpoints. Values: 100 => no curvature (straight line), 99 to 50 => perfect circle between endpoints, 49 to 30 => high curvature, 29 to 1 => medium curvature, 0 => optimal curvature (default), -1 to -500 => low curvature, -501 to -2000 => very low curvature, less than -2000 => almost straight line.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ArcCurvature { get; set; }
public:
property int ArcCurvature {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.DestConnector Property

ConnectionViewModelDestConnector Property

The destination connector the connection is attached to.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorViewModel DestConnector { get; set; }
public:
property ConnectorViewModel^ DestConnector {
    ConnectorViewModel^ get ();
    void set (ConnectorViewModel^ value);
}

Property Value

Type: ConnectorViewModel
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.DestConnectorHotspot Property

ConnectionViewModelDestConnectorHotspot Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point DestConnectorHotspot { get; set; }
public:
property Point DestConnectorHotspot {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.DestConnectorMode Property

ConnectionViewModelDestConnectorMode Property

Determines whether the connection's destination connector is now representing Signal value or the connection status.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorMode DestConnectorMode { get; }
public:
property ConnectorMode DestConnectorMode {
    ConnectorMode get ();
}

Property Value

Type: ConnectorMode
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.Hightlight Property

ConnectionViewModelHightlight Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Hightlight { get; set; }
public:
property bool Hightlight {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.IsActive Property

ConnectionViewModelIsActive Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; set; }
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.IsContainerVisible Property

ConnectionViewModelIsContainerVisible Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsContainerVisible { get; set; }
public:
property bool IsContainerVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.IsSelected Property

ConnectionViewModelIsSelected Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSelected { get; set; }
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.IsVisible Property

ConnectionViewModelIsVisible Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.MidPointCount Property

ConnectionViewModelMidPointCount Property

Only 0, 1 and 2 are currently supported

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MidPointCount { get; set; }
public:
property int MidPointCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.Points Property

ConnectionViewModelPoints Property

Points that make up the connection.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PointCollection Points { get; set; }
public:
property PointCollection^ Points {
    PointCollection^ get ();
    void set (PointCollection^ value);
}

Property Value

Type: PointCollection
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.SourceConnector Property

ConnectionViewModelSourceConnector Property

The source connector the connection is attached to.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorViewModel SourceConnector { get; set; }
public:
property ConnectorViewModel^ SourceConnector {
    ConnectorViewModel^ get ();
    void set (ConnectorViewModel^ value);
}

Property Value

Type: ConnectorViewModel
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.SourceConnectorHotspot Property

ConnectionViewModelSourceConnectorHotspot Property

The source and dest hotspots used for generating connection points.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point SourceConnectorHotspot { get; set; }
public:
property Point SourceConnectorHotspot {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.SourceConnectorMode Property

ConnectionViewModelSourceConnectorMode Property

Determines whether the connection's source connector is now representing Signal value or the connection status.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorMode SourceConnectorMode { get; }
public:
property ConnectorMode SourceConnectorMode {
    ConnectorMode get ();
}

Property Value

Type: ConnectorMode
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.Tag Property

ConnectionViewModelTag Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Tag { get; set; }
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel Methods

The ConnectionViewModel type exposes the following members.

Methods
 | Name | Description
Protected method | ComputeConnectionPoints | Rebuild connection points.
Public method | DestConnectorModeChanged |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightedLine |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NormalLine |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | SourceConnectorModeChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.ComputeConnectionPoints Method

ConnectionViewModelComputeConnectionPoints Method

Rebuild connection points.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void ComputeConnectionPoints()
protected:
void ComputeConnectionPoints()
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.DestConnectorModeChanged Method

ConnectionViewModelDestConnectorModeChanged Method

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DestConnectorModeChanged()
public:
void DestConnectorModeChanged()
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.HighlightedLine Method

ConnectionViewModelHighlightedLine Method

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void HighlightedLine()
public:
void HighlightedLine()
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.NormalLine Method

ConnectionViewModelNormalLine Method

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NormalLine()
public:
void NormalLine()
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.SourceConnectorModeChanged Method

ConnectionViewModelSourceConnectorModeChanged Method

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SourceConnectorModeChanged()
public:
void SourceConnectorModeChanged()
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel Events

The ConnectionViewModel type exposes the following members.

Events
 | Name | Description
Public event | ConnectionChanged | Event fired when the connection has changed.
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectionViewModel.ConnectionChanged Event

ConnectionViewModelConnectionChanged Event

Event fired when the connection has changed.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<EventArgs> ConnectionChanged
public:
 event EventHandler<EventArgs^>^ ConnectionChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ConnectionViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorMode Enumeration

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ConnectorMode
public enum class ConnectorMode
Members
Member name | Value | Description
Status | 0 |
Value | 1 |
See Also

Reference

VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.Shared.NetworkMapConnectorViewModel

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConnectorViewModel : PropertyChangedBase
public ref class ConnectorViewModel : public PropertyChangedBase

The ConnectorViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectorViewModel(String) | Initializes a new instance of the ConnectorViewModel class
Public method | ConnectorViewModel(String, NodeConnectorType, Object, Boolean, Boolean) | Initializes a new instance of the ConnectorViewModel class
Top
Properties
 | Name | Description
Public property | AttachedConnections | The connections that are attached to this connector, or null if no connections are attached.
Public property | BoolValue |
Public property | CanBeToggled | Indicates whether the value of a Signal in this particular connector can be toggled (must be bool).
Public property | ConnectorInfo |
Public property | ConnectorItem | Reference to the connector's "ball" UI element.
Public property | Family |
Public property | HasValue |
Public property | Hotspot | The hotspot (or center) of the connector. This is pushed through from ConnectorItem in the UI.
Public property | IsBase | Determines if connector is a base connector for signals map
Public property | IsConnected | Returns 'true' if the connector connected to another node.
Public property | IsConnectedToMain | Returns 'true' if a connection to the main node's selected connector is attached to this connector. 'false' for selected connector itself.
Public property | IsConnectionAttached | Returns 'true' if a connection is attached to the connector. The other end of the connection may or may not be attached to a node.
Public property | IsConnectionHighlighted | Returns 'true' if a connection attached to this connector is currently highlighted.
Public property | IsConnectorInfoInvalid |
Public property | IsDragging | Determines if the connector is currently being dragged.
Public property | IsEditable |
Public property | IsEditing |
Public property | IsEnabled |
Public property | IsMatching | Determines if the connector is a valid candidate for main node's selected connector.
Public property | IsMouseIndirectlyOver | Indicates if the mouse is currently hovering on top of the connector item, but at the same time is directly over the corresponding connection line.
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsSelected | Determines if the connector is currently selected.
Public property | IsVisible | Determines if the connector is currently visible.
Public property | Mode | Determines whether the connector should be currently showing Signal value or the connection status.
Public property | Name | The name of the connector.
Public property | ParentNode | The parent node that the connector is attached to, or null if the connector is not attached to any node.
Public property | Tag |
Public property | Type | Defines the type of the connector.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateIsConnectedToMain |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | RefreshConnectorInfo | Publishes a notification of Name property change
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | HotspotUpdated | Event raised when the connector hotspot has been updated.
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel Constructor

Overload List
 | Name | Description
Public method | ConnectorViewModel(String) | Initializes a new instance of the ConnectorViewModel class
Public method | ConnectorViewModel(String, NodeConnectorType, Object, Boolean, Boolean) | Initializes a new instance of the ConnectorViewModel class
Top
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel Constructor (String)

Initializes a new instance of the ConnectorViewModel class

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorViewModel(
    string name
)
public:
ConnectorViewModel(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

ConnectorViewModel Class
ConnectorViewModel Overload
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel Constructor (String, NodeConnectorType, Object, Boolean, Boolean)

Initializes a new instance of the ConnectorViewModel class

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorViewModel(
    string name,
    NodeConnectorType type,
    Object tag,
    bool value = false,
    bool isBase = false
)
public:
ConnectorViewModel(
    String^ name,
    NodeConnectorType type,
    Object^ tag,
    bool value = false,
    bool isBase = false
)

Parameters

name
Type: SystemString
type
Type: VisualComponents.UX.Shared.NetworkMapNodeConnectorType
tag
Type: SystemObject
value (Optional)
Type: SystemBoolean
isBase (Optional)
Type: SystemBoolean
See Also

Reference

ConnectorViewModel Class
ConnectorViewModel Overload
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel Properties

The ConnectorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | AttachedConnections | The connections that are attached to this connector, or null if no connections are attached.
Public property | BoolValue |
Public property | CanBeToggled | Indicates whether the value of a Signal in this particular connector can be toggled (must be bool).
Public property | ConnectorInfo |
Public property | ConnectorItem | Reference to the connector's "ball" UI element.
Public property | Family |
Public property | HasValue |
Public property | Hotspot | The hotspot (or center) of the connector. This is pushed through from ConnectorItem in the UI.
Public property | IsBase | Determines if connector is a base connector for signals map
Public property | IsConnected | Returns 'true' if the connector connected to another node.
Public property | IsConnectedToMain | Returns 'true' if a connection to the main node's selected connector is attached to this connector. 'false' for selected connector itself.
Public property | IsConnectionAttached | Returns 'true' if a connection is attached to the connector. The other end of the connection may or may not be attached to a node.
Public property | IsConnectionHighlighted | Returns 'true' if a connection attached to this connector is currently highlighted.
Public property | IsConnectorInfoInvalid |
Public property | IsDragging | Determines if the connector is currently being dragged.
Public property | IsEditable |
Public property | IsEditing |
Public property | IsEnabled |
Public property | IsMatching | Determines if the connector is a valid candidate for main node's selected connector.
Public property | IsMouseIndirectlyOver | Indicates if the mouse is currently hovering on top of the connector item, but at the same time is directly over the corresponding connection line.
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsSelected | Determines if the connector is currently selected.
Public property | IsVisible | Determines if the connector is currently visible.
Public property | Mode | Determines whether the connector should be currently showing Signal value or the connection status.
Public property | Name | The name of the connector.
Public property | ParentNode | The parent node that the connector is attached to, or null if the connector is not attached to any node.
Public property | Tag |
Public property | Type | Defines the type of the connector.
Top
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.AttachedConnections Property

ConnectorViewModelAttachedConnections Property

The connections that are attached to this connector, or null if no connections are attached.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollectionEx<ConnectionViewModel> AttachedConnections { get; }
public:
property ObservableCollectionEx<ConnectionViewModel^>^ AttachedConnections {
    ObservableCollectionEx<ConnectionViewModel^>^ get ();
}

Property Value

Type: ObservableCollectionEx ConnectionViewModel
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.BoolValue Property

ConnectorViewModelBoolValue Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool BoolValue { get; set; }
public:
property bool BoolValue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.CanBeToggled Property

ConnectorViewModelCanBeToggled Property

Indicates whether the value of a Signal in this particular connector can be toggled (must be bool).

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanBeToggled { get; set; }
public:
property bool CanBeToggled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.ConnectorInfo Property

ConnectorViewModelConnectorInfo Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TextBox ConnectorInfo { get; set; }
public:
property TextBox^ ConnectorInfo {
    TextBox^ get ();
    void set (TextBox^ value);
}

Property Value

Type: TextBox
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.ConnectorItem Property

ConnectorViewModelConnectorItem Property

Reference to the connector's "ball" UI element.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorItem ConnectorItem { get; set; }
public:
property ConnectorItem^ ConnectorItem {
    ConnectorItem^ get ();
    void set (ConnectorItem^ value);
}

Property Value

Type: ConnectorItem
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.Family Property

ConnectorViewModelFamily Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeConnectorFamily Family { get; set; }
public:
property NodeConnectorFamily Family {
    NodeConnectorFamily get ();
    void set (NodeConnectorFamily value);
}

Property Value

Type: NodeConnectorFamily
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.HasValue Property

ConnectorViewModelHasValue Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasValue { get; set; }
public:
property bool HasValue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.Hotspot Property

ConnectorViewModelHotspot Property

The hotspot (or center) of the connector. This is pushed through from ConnectorItem in the UI.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point Hotspot { get; set; }
public:
property Point Hotspot {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsBase Property

ConnectorViewModelIsBase Property

Determines if connector is a base connector for signals map

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsBase { get; set; }
public:
property bool IsBase {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsConnected Property

ConnectorViewModelIsConnected Property

Returns 'true' if the connector connected to another node.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsConnected { get; }
public:
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsConnectedToMain Property

ConnectorViewModelIsConnectedToMain Property

Returns 'true' if a connection to the main node's selected connector is attached to this connector. 'false' for selected connector itself.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsConnectedToMain { get; set; }
public:
property bool IsConnectedToMain {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsConnectionAttached Property

ConnectorViewModelIsConnectionAttached Property

Returns 'true' if a connection is attached to the connector. The other end of the connection may or may not be attached to a node.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsConnectionAttached { get; }
public:
property bool IsConnectionAttached {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsConnectionHighlighted Property

ConnectorViewModelIsConnectionHighlighted Property

Returns 'true' if a connection attached to this connector is currently highlighted.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsConnectionHighlighted { get; set; }
public:
property bool IsConnectionHighlighted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsConnectorInfoInvalid Property

ConnectorViewModelIsConnectorInfoInvalid Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsConnectorInfoInvalid { get; set; }
public:
property bool IsConnectorInfoInvalid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsDragging Property

ConnectorViewModelIsDragging Property

Determines if the connector is currently being dragged.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDragging { get; set; }
public:
property bool IsDragging {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsEditable Property

ConnectorViewModelIsEditable Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEditable { get; set; }
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsEditing Property

ConnectorViewModelIsEditing Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEditing { get; set; }
public:
property bool IsEditing {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsEnabled Property

ConnectorViewModelIsEnabled Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEnabled { get; set; }
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsMatching Property

ConnectorViewModelIsMatching Property

Determines if the connector is a valid candidate for main node's selected connector.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsMatching { get; set; }
public:
property bool IsMatching {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsMouseIndirectlyOver Property

ConnectorViewModelIsMouseIndirectlyOver Property

Indicates if the mouse is currently hovering on top of the connector item, but at the same time is directly over the corresponding connection line.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsMouseIndirectlyOver { get; set; }
public:
property bool IsMouseIndirectlyOver {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsSelected Property

ConnectorViewModelIsSelected Property

Determines if the connector is currently selected.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSelected { get; set; }
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.IsVisible Property

ConnectorViewModelIsVisible Property

Determines if the connector is currently visible.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.Mode Property

ConnectorViewModelMode Property

Determines whether the connector should be currently showing Signal value or the connection status.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorMode Mode { get; set; }
public:
property ConnectorMode Mode {
    ConnectorMode get ();
    void set (ConnectorMode value);
}

Property Value

Type: ConnectorMode
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.Name Property

ConnectorViewModelName Property

The name of the connector.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.ParentNode Property

ConnectorViewModelParentNode Property

The parent node that the connector is attached to, or null if the connector is not attached to any node.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeViewModel ParentNode { get; set; }
public:
property NodeViewModel^ ParentNode {
    NodeViewModel^ get ();
    void set (NodeViewModel^ value);
}

Property Value

Type: NodeViewModel
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.Tag Property

ConnectorViewModelTag Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Tag { get; set; }
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.Type Property

ConnectorViewModelType Property

Defines the type of the connector.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeConnectorType Type { get; }
public:
property NodeConnectorType Type {
    NodeConnectorType get ();
}

Property Value

Type: NodeConnectorType
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel Methods

The ConnectorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateIsConnectedToMain |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | RefreshConnectorInfo | Publishes a notification of Name property change
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.EvaluateIsConnectedToMain Method

ConnectorViewModelEvaluateIsConnectedToMain Method

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EvaluateIsConnectedToMain()
public:
void EvaluateIsConnectedToMain()
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.RefreshConnectorInfo Method

ConnectorViewModelRefreshConnectorInfo Method

Publishes a notification of Name property change

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RefreshConnectorInfo()
public:
void RefreshConnectorInfo()
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.ToString Method

ConnectorViewModelToString Method

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel.ToString"]

See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel Events

The ConnectorViewModel type exposes the following members.

Events
 | Name | Description
Public event | HotspotUpdated | Event raised when the connector hotspot has been updated.
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


ConnectorViewModel.HotspotUpdated Event

ConnectorViewModelHotspotUpdated Event

Event raised when the connector hotspot has been updated.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<EventArgs> HotspotUpdated
public:
 event EventHandler<EventArgs^>^ HotspotUpdated {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ConnectorViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ShapesShape
VisualComponents.UX.Shared.NetworkMapCurvedArrow

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CurvedArrow : Shape
public ref class CurvedArrow : public Shape

The CurvedArrow type exposes the following members.

Constructors
 | Name | Description
Public method | CurvedArrow | Initializes a new instance of the CurvedArrow class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | ArrowHead | Geometry of the arrow head (line cap).
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Protected property | DefiningGeometry | Return the shape's geometry. (Overrides ShapeDefiningGeometry.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | EndOffset | Offset from the end of the line (does not modify original Points).
Public property | Fill | Gets or sets the Brush that specifies how the shape's interior is painted. (Inherited from Shape.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | GeometryTransform | Gets a value that represents a Transform that is applied to the geometry of a Shape prior to when it is drawn. (Inherited from Shape.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MidPoint |
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Points | The intermediate points that make up the line between the start and the end.
Public property | RenderedGeometry | Gets a value that represents the final rendered Geometry of a Shape. (Inherited from Shape.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StartOffset | Offset from the start of the line (does not modify original Points).
Public property | Stretch | Gets or sets a Stretch enumeration value that describes how the shape fills its allocated space. (Inherited from Shape.)
Public property | Stroke | Gets or sets the Brush that specifies how the Shape outline is painted. (Inherited from Shape.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline shapes. (Inherited from Shape.)
Public property | StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from Shape.)
Public property | StrokeDashOffset | Gets or sets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from Shape.)
Public property | StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from Shape.)
Public property | StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from Shape.)
Public property | StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from Shape.)
Public property | StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a Stroke. (Inherited from Shape.)
Public property | StrokeThickness | Gets or sets the width of the Shape outline. (Inherited from Shape.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges a Shape by evaluating its RenderedGeometry and Stretch properties. (Inherited from Shape.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Protected method | GenerateGeometry | Generate the shapes geometry.
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures a Shape during the first layout pass prior to arranging it. (Inherited from Shape.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Provides a means to change the default appearance of a Shape element. (Inherited from Shape.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ArrowHeadProperty |
EndOffsetProperty |
MidPointProperty |
MidPointPropertyKey |
PointsProperty |
StartOffsetProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow Constructor

Initializes a new instance of the CurvedArrow class

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CurvedArrow()
public:
CurvedArrow()
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow Properties

The CurvedArrow type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | ArrowHead | Geometry of the arrow head (line cap).
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Protected property | DefiningGeometry | Return the shape's geometry. (Overrides ShapeDefiningGeometry.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | EndOffset | Offset from the end of the line (does not modify original Points).
Public property | Fill | Gets or sets the Brush that specifies how the shape's interior is painted. (Inherited from Shape.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | GeometryTransform | Gets a value that represents a Transform that is applied to the geometry of a Shape prior to when it is drawn. (Inherited from Shape.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MidPoint |
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Points | The intermediate points that make up the line between the start and the end.
Public property | RenderedGeometry | Gets a value that represents the final rendered Geometry of a Shape. (Inherited from Shape.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StartOffset | Offset from the start of the line (does not modify original Points).
Public property | Stretch | Gets or sets a Stretch enumeration value that describes how the shape fills its allocated space. (Inherited from Shape.)
Public property | Stroke | Gets or sets the Brush that specifies how the Shape outline is painted. (Inherited from Shape.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline shapes. (Inherited from Shape.)
Public property | StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from Shape.)
Public property | StrokeDashOffset | Gets or sets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from Shape.)
Public property | StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from Shape.)
Public property | StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from Shape.)
Public property | StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from Shape.)
Public property | StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a Stroke. (Inherited from Shape.)
Public property | StrokeThickness | Gets or sets the width of the Shape outline. (Inherited from Shape.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.ArrowHead Property

CurvedArrowArrowHead Property

Geometry of the arrow head (line cap).

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Geometry ArrowHead { get; set; }
public:
property Geometry^ ArrowHead {
    Geometry^ get ();
    void set (Geometry^ value);
}

Property Value

Type: Geometry
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.DefiningGeometry Property

CurvedArrowDefiningGeometry Property

Return the shape's geometry.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Geometry DefiningGeometry { get; }
protected:
virtual property Geometry^ DefiningGeometry {
    Geometry^ get () override;
}

Property Value

Type: Geometry
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.EndOffset Property

CurvedArrowEndOffset Property

Offset from the end of the line (does not modify original Points).

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double EndOffset { get; set; }
public:
property double EndOffset {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.MidPoint Property

CurvedArrowMidPoint Property

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point MidPoint { get; }
public:
property Point MidPoint {
    Point get ();
}

Property Value

Type: Point
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.Points Property

CurvedArrowPoints Property

The intermediate points that make up the line between the start and the end.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PointCollection Points { get; set; }
public:
property PointCollection^ Points {
    PointCollection^ get ();
    void set (PointCollection^ value);
}

Property Value

Type: PointCollection
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.StartOffset Property

CurvedArrowStartOffset Property

Offset from the start of the line (does not modify original Points).

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double StartOffset { get; set; }
public:
property double StartOffset {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow Methods

The CurvedArrow type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges a Shape by evaluating its RenderedGeometry and Stretch properties. (Inherited from Shape.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Protected method | GenerateGeometry | Generate the shapes geometry.
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures a Shape during the first layout pass prior to arranging it. (Inherited from Shape.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Provides a means to change the default appearance of a Shape element. (Inherited from Shape.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.GenerateGeometry Method

CurvedArrowGenerateGeometry Method

Generate the shapes geometry.

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Geometry GenerateGeometry()
protected:
Geometry^ GenerateGeometry()

Return Value

Type: Geometry

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NetworkMap.CurvedArrow.GenerateGeometry"]

See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow Events

The CurvedArrow type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow Fields

The CurvedArrow type exposes the following members.

Fields
Name | Description
ArrowHeadProperty |
EndOffsetProperty |
MidPointProperty |
MidPointPropertyKey |
PointsProperty |
StartOffsetProperty |
Top
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.ArrowHeadProperty Field

CurvedArrowArrowHeadProperty Field

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ArrowHeadProperty
public:
static initonly DependencyProperty^ ArrowHeadProperty

Field Value

Type: DependencyProperty
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.EndOffsetProperty Field

CurvedArrowEndOffsetProperty Field

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty EndOffsetProperty
public:
static initonly DependencyProperty^ EndOffsetProperty

Field Value

Type: DependencyProperty
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.MidPointProperty Field

CurvedArrowMidPointProperty Field

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty MidPointProperty
public:
static initonly DependencyProperty^ MidPointProperty

Field Value

Type: DependencyProperty
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.MidPointPropertyKey Field

CurvedArrowMidPointPropertyKey Field

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey MidPointPropertyKey
public:
static initonly DependencyPropertyKey^ MidPointPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.PointsProperty Field

CurvedArrowPointsProperty Field

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PointsProperty
public:
static initonly DependencyProperty^ PointsProperty

Field Value

Type: DependencyProperty
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


CurvedArrow.StartOffsetProperty Field

CurvedArrowStartOffsetProperty Field

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty StartOffsetProperty
public:
static initonly DependencyProperty^ StartOffsetProperty

Field Value

Type: DependencyProperty
See Also

Reference

CurvedArrow Class
VisualComponents.UX.Shared.NetworkMap Namespace


GhostLineViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.Shared.NetworkMapConnectionViewModel
VisualComponents.UX.Shared.NetworkMapGhostLineViewModel

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GhostLineViewModel : ConnectionViewModel
public ref class GhostLineViewModel : public ConnectionViewModel

The GhostLineViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | GhostLineViewModel | Initializes a new instance of the GhostLineViewModel class
Top
Properties
 | Name | Description
Public property | ArcCurvature | Applies only to connections where MidPointCount is 1. Defines the curvature of an arc between the endpoints. Values: 100 => no curvature (straight line), 99 to 50 => perfect circle between endpoints, 49 to 30 => high curvature, 29 to 1 => medium curvature, 0 => optimal curvature (default), -1 to -500 => low curvature, -501 to -2000 => very low curvature, less than -2000 => almost straight line. (Inherited from ConnectionViewModel.)
Public property | DestConnector | The destination connector the connection is attached to. (Inherited from ConnectionViewModel.)
Public property | DestConnectorHotspot | (Inherited from ConnectionViewModel.)
Public property | DestConnectorMode | Determines whether the connection's destination connector is now representing Signal value or the connection status. (Inherited from ConnectionViewModel.)
Public property | Hightlight | (Inherited from ConnectionViewModel.)
Public property | IsActive | (Inherited from ConnectionViewModel.)
Public property | IsContainerVisible | (Inherited from ConnectionViewModel.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsSelected | (Inherited from ConnectionViewModel.)
Public property | IsVisible | (Inherited from ConnectionViewModel.)
Public property | MidPointCount | Only 0, 1 and 2 are currently supported (Inherited from ConnectionViewModel.)
Public property | Points | Points that make up the connection. (Inherited from ConnectionViewModel.)
Public property | SourceConnector | The source connector the connection is attached to. (Inherited from ConnectionViewModel.)
Public property | SourceConnectorHotspot | The source and dest hotspots used for generating connection points. (Inherited from ConnectionViewModel.)
Public property | SourceConnectorMode | Determines whether the connection's source connector is now representing Signal value or the connection status. (Inherited from ConnectionViewModel.)
Public property | Tag | (Inherited from ConnectionViewModel.)
Top
Methods
 | Name | Description
Protected method | ComputeConnectionPoints | Rebuild connection points. (Inherited from ConnectionViewModel.)
Public method | DestConnectorModeChanged | (Inherited from ConnectionViewModel.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightedLine | (Inherited from ConnectionViewModel.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NormalLine | (Inherited from ConnectionViewModel.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | SourceConnectorModeChanged | (Inherited from ConnectionViewModel.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ConnectionChanged | Event fired when the connection has changed. (Inherited from ConnectionViewModel.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.NetworkMap Namespace


GhostLineViewModel Constructor

Initializes a new instance of the GhostLineViewModel class

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GhostLineViewModel(
    int midPointsCount = 2,
    int arcCurvature = 0
)
public:
GhostLineViewModel(
    int midPointsCount = 2,
    int arcCurvature = 0
)

Parameters

midPointsCount (Optional)
Type: SystemInt32
arcCurvature (Optional)
Type: SystemInt32
See Also

Reference

GhostLineViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


GhostLineViewModel Properties

The GhostLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ArcCurvature | Applies only to connections where MidPointCount is 1. Defines the curvature of an arc between the endpoints. Values: 100 => no curvature (straight line), 99 to 50 => perfect circle between endpoints, 49 to 30 => high curvature, 29 to 1 => medium curvature, 0 => optimal curvature (default), -1 to -500 => low curvature, -501 to -2000 => very low curvature, less than -2000 => almost straight line. (Inherited from ConnectionViewModel.)
Public property | DestConnector | The destination connector the connection is attached to. (Inherited from ConnectionViewModel.)
Public property | DestConnectorHotspot | (Inherited from ConnectionViewModel.)
Public property | DestConnectorMode | Determines whether the connection's destination connector is now representing Signal value or the connection status. (Inherited from ConnectionViewModel.)
Public property | Hightlight | (Inherited from ConnectionViewModel.)
Public property | IsActive | (Inherited from ConnectionViewModel.)
Public property | IsContainerVisible | (Inherited from ConnectionViewModel.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsSelected | (Inherited from ConnectionViewModel.)
Public property | IsVisible | (Inherited from ConnectionViewModel.)
Public property | MidPointCount | Only 0, 1 and 2 are currently supported (Inherited from ConnectionViewModel.)
Public property | Points | Points that make up the connection. (Inherited from ConnectionViewModel.)
Public property | SourceConnector | The source connector the connection is attached to. (Inherited from ConnectionViewModel.)
Public property | SourceConnectorHotspot | The source and dest hotspots used for generating connection points. (Inherited from ConnectionViewModel.)
Public property | SourceConnectorMode | Determines whether the connection's source connector is now representing Signal value or the connection status. (Inherited from ConnectionViewModel.)
Public property | Tag | (Inherited from ConnectionViewModel.)
Top
See Also

Reference

GhostLineViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


GhostLineViewModel Methods

The GhostLineViewModel type exposes the following members.

Methods
 | Name | Description
Protected method | ComputeConnectionPoints | Rebuild connection points. (Inherited from ConnectionViewModel.)
Public method | DestConnectorModeChanged | (Inherited from ConnectionViewModel.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightedLine | (Inherited from ConnectionViewModel.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NormalLine | (Inherited from ConnectionViewModel.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | SourceConnectorModeChanged | (Inherited from ConnectionViewModel.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GhostLineViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


GhostLineViewModel Events

The GhostLineViewModel type exposes the following members.

Events
 | Name | Description
Public event | ConnectionChanged | Event fired when the connection has changed. (Inherited from ConnectionViewModel.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

GhostLineViewModel Class
VisualComponents.UX.Shared.NetworkMap Namespace


INodeViewModelContainer Interface

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INodeViewModelContainer
public interface class INodeViewModelContainer

The INodeViewModelContainer type exposes the following members.

Methods
 | Name | Description
Public method | IsPinned |
Public method | NodePinned |
Public method | NodeUnPinned |
Public method | SetPinnedPosition |
Top
See Also

Reference

VisualComponents.UX.Shared.NetworkMap Namespace


INodeViewModelContainer Methods

The INodeViewModelContainer type exposes the following members.

Methods
 | Name | Description
Public method | IsPinned |
Public method | NodePinned |
Public method | NodeUnPinned |
Public method | SetPinnedPosition |
Top
See Also

Reference

INodeViewModelContainer Interface
VisualComponents.UX.Shared.NetworkMap Namespace


INodeViewModelContainer.IsPinned Method

INodeViewModelContainerIsPinned Method

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPinned(
    NodeViewModel node
)
bool IsPinned(
    NodeViewModel^ node
)

Parameters

node
Type: VisualComponents.UX.Shared.NetworkMapNodeViewModel

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NetworkMap.INodeViewModelContainer.IsPinned(VisualComponents.UX.Shared.NetworkMap.NodeViewModel)"]

See Also

Reference

INodeViewModelContainer Interface
VisualComponents.UX.Shared.NetworkMap Namespace


INodeViewModelContainer.NodePinned Method

INodeViewModelContainerNodePinned Method

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NodePinned(
    NodeViewModel node,
    double x,
    double y
)
void NodePinned(
    NodeViewModel^ node,
    double x,
    double y
)

Parameters

node
Type: VisualComponents.UX.Shared.NetworkMapNodeViewModel
x
Type: SystemDouble
y
Type: SystemDouble
See Also

Reference

INodeViewModelContainer Interface
VisualComponents.UX.Shared.NetworkMap Namespace


INodeViewModelContainer.NodeUnPinned Method

INodeViewModelContainerNodeUnPinned Method

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NodeUnPinned(
    NodeViewModel node
)
void NodeUnPinned(
    NodeViewModel^ node
)

Parameters

node
Type: VisualComponents.UX.Shared.NetworkMapNodeViewModel
See Also

Reference

INodeViewModelContainer Interface
VisualComponents.UX.Shared.NetworkMap Namespace


INodeViewModelContainer.SetPinnedPosition Method

INodeViewModelContainerSetPinnedPosition Method

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetPinnedPosition(
    NodeViewModel node
)
void SetPinnedPosition(
    NodeViewModel^ node
)

Parameters

node
Type: VisualComponents.UX.Shared.NetworkMapNodeViewModel
See Also

Reference

INodeViewModelContainer Interface
VisualComponents.UX.Shared.NetworkMap Namespace


MapType Enumeration

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MapType
public enum class MapType
Members
Member name | Value | Description
Signals | 0 |
Interfaces | 1 |
Processes | 2 |
See Also

Reference

VisualComponents.UX.Shared.NetworkMap Namespace


NetworkViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.Shared.NetworkMapNetworkViewModel

Namespace: VisualComponents.UX.Shared.NetworkMap
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class NetworkViewModel : PropertyChangedBase
public ref class NetworkViewModel sealed : public PropertyChangedBase

The NetworkViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkViewModel | Initializes a new instance of the NetworkViewModel class
Top
Properties
 | Name | Description
Public property | Connections | The collection of connections in the network.
Public property | GhostLines | The collection of ghost lines in the network.
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Nodes | The collection of nodes in the network.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NotifyOfConnectionsCollectionChange |
Public method | NotifyOfGhostLinesCollectionChange |
Public method | NotifyOfNodesCollectionChange |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared.NetworkMap Namespace