How to use the works furnace in Works Library?

Hi all, I’m new here.

I’m aware that we can attached a work process component on a works lathe machine but I can’t seem to attached a work process component to the works furnace.

What I intend to do is to put in a tray of metal component for heat treatment and later to be taken out and put on a conveyor.

furnaceqn.vcmx (1.68 MB)

Have not see the layout, but from my understanding the furnace is just a visual. So you select the Works Process, and then use the Attach command to attach it to a node in Furnace. Afterward, move the Works Process where you want it and adjust height. Like you wrote, you know how to do that already with the lathe machine. The Works Furnace, though, doesn’t have moving parts, so I believe you just run a DummyProcess or Delay task to simulate the heat treatment.

Ahh I see, the furnace is just visual. Thank you.

Oh no, I faced a new problem.

My tray doesn’t seem to transport into the work process and is creating a bottleneck. it happens at 4min+

For your convenient.
#10 work process component

#13 work process component

#14 work process component

furnacebottleneck.vcmx (2 MB)

My friend, the issue is in #14. You know that the human will place a tray there. So what task do you think is creating the bottleneck in #14?

Yes, it is the TransportIn task. The TransportIn and TransportOut tasks are meant for material handling and flows. TransportIn requires a connection to Input port of Works Process and will allow a component to be transferred in and stopped. There is no feeder or conveyor line connected to the input port of #14, so the task is just waiting, waiting, waiting, and more waiting. TransportOut will do the exact same thing… waiting, waiting, you get the point because if there is no connection to the Output port of the Works Process then it has nowhere to transfer the component.

But I think the heart of darkness has revealed the true intention. If a component is placed in a Works Process, the component is contained there, so you do not need a TransportIn task for that component. A component is contained when you either transport it in, create it there, or it is placed there by a resource (robot, agv, human, etc).

So the Need task is all you need. You can test this on your own by connecting a conveyor to the end of #14 and changing the TransportIn to a TransportOut task.

Thank you for the detailed explanation about TransportIn and TransportOut task function.

I tried putting TransportOut task at #14 and connected it to a conveyor. But there is an output saying it’s not connected?
(I tried TransportOut TrayA instead of 888 too, it doesn’t solve the error)

image and vcmx file as attached

transportout.vcmx (1.83 MB)

You cannot connect a conveyor to any port and assume it is the beginning or end of the path.

A Works Process component has two One-to-One Interfaces for its path. The input port is used for TransportIn tasks. The output port is used for TransportOut tasks.

Basically, you have to connect the components in the right order. You have already done this in your layout, so might be time to take a break.

Ohhh. On closer look, I do see the little arrow on the work process component/conveyor to see the direction of material flow.

I have fixed the issue in my layout. Thank you.

And may I know where else can I find more educational resources on Work library other than VC website>Lessons>Layout configuration?

There are so many task like the If, Loop, ChangePathDirections, etcs are not covered in the lessons. And I would like to know more about them.

My friend, your request will be granted this week. Stay tuned and subscribe to the Academy. A new course on Works library will be published along with a Tasks reference guide and a learning pathway. Demos for each task and videos about those demos are being made. I will post a notification in forum as well as in the support site to let everyone know more.