Fog when zooming

I do not know if it is a VC bug or it might be my computer’s graphic card but when I zoom my simulation too much, there is a chance that "a fog " came accross the simulation and I couldn’t zoom any more. see below

No zoom

half zoom

Full zoom = entire grey screen

Right now , the only option I have is to quit the software and relaunch it.
any ideas?
do not hesite to move this topic if it’s not in the proper section.

Thanks in advance

This is working as intended, it has to do with near and far clipping planes for rendering and optimizing Z-buffer accuracy.

When zooming in or out lots, you need to set the COI (Center of interest) appropriately by either Ctrl + right click on the world, or using the command for it.

As TSy mentioned, it is related to camera. CTRL + Right click is a quick way to center the camera and work around this issue. There is no option backstage to control the clipping pane, but you can use API to change it.

hello zesty and thank you for your help.
Indeed it does help to zoom a bit but the issue prevails nevertheless.
Thank for the quick tips !