Why cannot I import sqlite3?

Forum Forums Visual Components 4.0 Python Programming in VC Why cannot I import sqlite3?

Be sure to read the Forum Rules and Guidelines before start using the Forum.


This topic contains 2 replies, has 3 voices, and was last updated by ImHolms ImHolms 1 year ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #4419


    As shown in the figure


    Report it as a bug.

    From the output and looking at directory in program files, this is what appears to happen:

    1. Imports sqlite3 module by calling dbapi2
    2. dbapi2 refers to _sqlite3 so the “_” underscore causes error
    3. Removing the “_” will still fail because dbapi2 is not importing everything nor using module name to call functions or constants, so the version constant will cause error
    4. The dbapi2 interface does not seem to work, so I tried modifying the __init__ file for the sqlite3 module to call the dbapi interface in the test/ directory. The import was successful, but useless because the expected functions were not imported nor recognized in Python Script

    Not going to debug further.


    Hey wangchengyang,

    Seems like there is an issue with that library. Probably the libraries were not recompiled correctly.

    Please send an email to support so this issue is corrected in a future version.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.