CAD components switching geometry

Forum Forums Visual Components 4.1 General Product Questions CAD components switching geometry

This topic contains 6 replies, has 7 voices, and was last updated by yelan123 yelan123 3 weeks, 1 day ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #15489
    Avatar
    CorentinM
    Participant

    Hi everyone,

    Me and several coworkers are facing the same issue with our layouts.

    Sometimes, for some random reason, when saving and re-opening a layout, one component has changed its geometry for another one present in the layout.

    It is extremey frustrating to have to re-import the model and replace it, it’s pretty tidious.

    I tried to check the “save component original path” and “include components” in the backstage, but it happened again, and I dont really know what those checkboxes do.

    Could you please share if any of you faced the same issue ? And if you fixed it ?

    We are using VC Essential 4.1

    Thank you all !

     

    Corentin

    #15510
    Avatar
    towag
    Participant

    Hi CorentinM,

    If you copy a component make the component unique!
    Modeling Tab -> right click on a component -> Tools -> Make component unique.

    #16195
    Avatar
    ahora339
    Participant

    <p style=”text-align: left;”>I have this problem too</p>

    #16222
    ccamilo
    ccamilo
    Participant

    Some side notes:

    – “save component original path” is just for debugging purposes. It does not really affect loading or saving.
    – “include components” is to include the components into the layout, instead of just reference them by vcid. This is useful when sharing layout with others that do not have those components in their eCats.

    #16226
    Avatar
    jouha
    Moderator

    Hi CorentinM,

    If you encounter such case where a geometry is replaced with another after reopening, I’d suggest you to send that layout to the support along with the scenario description for further investigation.

    #16499
    Avatar
    stransky
    Participant

    Hello,

    I noticed same issue – my theory is that the reason is the same name in Node Feature tree inside two and more components. Typically name “Geometry” – which is automatically assign after split operation. When this name of feature (name Geometry) is used inside two components, I think after closing and reopen Visual Components are these geometries sometimes replaced by one of them.

    I can not to prove it, but from time when i every feature named “Geometry” rename into different unique name i have not faced this issue any more.

    #16574
    yelan123
    yelan123
    Participant

    Hi Corentin

    I met this issue before. As far as I know , It may be caused by the model file name you entered. Such as letters other than English.

    I suggest u to save imported model as *.vcmx, then drag it into layout from your ecats.

    So far, I haven’t met this issue again.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.