How to solve very slow simulation speed?

Forum Forums Visual Components 4.0 General Product Questions How to solve very slow simulation speed?

Be sure to read the Forum Rules and Guidelines before start using the Forum.

Tagged: ,

This topic contains 5 replies, has 3 voices, and was last updated by  felix 7 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #4507

    acaki
    Participant

    I’m using VISUAL COMPONENTS PROFESSIONAL 4.0.5.

    And I mainly carry out logistics simulation throughout the factory. By the way, simulating the whole plant is much slower than real time. (I simulate the simulation mode as virtual time.)

    By the way, is it possible  to run the simulation without any animation effect in 3D world, but just collecting and showing data I want?

    Or is there another way to speed up? The speed is too slow to proceed.

    #4509

    felix
    Participant

    Is there a reason why you are using the mode virtual time?

    What is the used simulation factor (the number which get’s affected if you change the simulation speed with the slider) in virtual time?

    When you change from virtual time to real time what does the simulation factor show then?

    Anyway, if you have set up your virtual layout/components with the same parameters e.g. velocity and acceleration and if your simulation world’s speed is equal to real time – meaning when you are using real time with factor 1.0, then everything should be close to the real layout.

    What could also be the problem is if the layout and the included components are rather complex. In that case you could experience performance issues if your computer isn’t fast enough.

    By the way, is it possible to run the simulation without any animation effect in 3D world, but just collecting and showing data I want?

    As far as I know there is a possibility in the Python API to disable the animation of components in the 3D world within the vcApplication object. The property which needs to be set is “Animate”. Unfortunately it seems that there is something wrong. I get an error if I try to set the property. Therefore I wrote a support ticket for that issue.

    #4535

    acaki
    Participant

    The reason for using virtual time is to shorten the simulation time.
    My main analysis is LeadTime more than one month, and the process is more than about 100 including repetition.
    If you are analyzing more than a month and  analyzing it with realtime, is it meaningless to do simulation?

    And I tried the test using other tools(automod). When I analyzed the same situation, automod took 30 minutes but VC took 2 days.

    plus, my computer is much better than VC Recommended Specifications.

    Anyway, I want to know other specific speed improvement methods?

    I wonder that VC can not do complex simulations on a large scale?

    #4543

    felix
    Participant

    You can also adjust the simulation speed in real time mode, but it will only be “real time” if the simulation speed factor equals 1. Anything else is either slower or faster. Meaning you can also simulate a month of production in real time mode.

    What I actually wanted to find out with this question is, if the simulation layout when set to real time with simulation speed factor of 1 will perform as fast as the real layout. In your first post it thought you had a general issue with the speed of the layout to not match what it should be capable of in the real world.

    But maybe I got that wrong and you meant that you would like to simulate the time frame e.g. a month faster then it does in the current state. If that’s the case then it could be possible that the visualization is bottlenecking the maximum simulation speed. If I were you I would set the “Simulation Run Time” to the wanted time frame and then drag the simulation speed slider to the rightmost position and start the simulation.

    Simplifying or removing geometry might help, but unfortunately I don’t know any other method than that in speeding the simulation up. Disabling the animation might help – but as I said this isn’t implemented yet.

    Hopefully someone from VC has some tips? 🙂

    Edit:
    Just got a reply from VC which has something to do with simulation speed. Other options to speed up the simulations are:

    • Make components invisible
    • Set the property “Simulation Level” of the components to “Fast”
    #4627

    MichaelW
    Participant

    I’m facing here some similar issues. My scenario in real time (factor 1.0) gets very slow. When I switch to simulation time, the factor changes to 0.04. In simulation time it runs much smoother.

    However, if I speed up simulation time factor to 1.00, which should be equal to real time, its getting laggy again. :<

     

    #4660

    felix
    Participant

    I assume that you mean the “Virtual Time” mode in this phrase

    When I switch to simulation time, the factor changes to 0.04.

    Actually using “Virtual Time” mode with factor 1.0 will not be real time.

    You can check this in the help document under “Simulation Controls”

    Short Summary:

    Real Time

    “Real Time” mode with a time factor of 1.0 is real time. Any other factor will let the simulation run slower or faster than real time.

    Virtual Time

    When using this mode the simulation speed depends on the computer.

    The factor represents the step size between frames being taken from the simulation which get rendered. Therefore a factor of 0.04 will lead to that each frame in an interval of 0.04 seconds will get rendered and if the factor was 1.0 then each frame in an interval of 1.0 seconds will get rendered.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.